Ayuda con Problema de latencia

#1 por coreym el 26/01/2010
Hola, puess este es mi primer mensaje aqui (espero no el ultimo XD) y espero hacerlo bien XD

Veran, mi problema esta muy discutido en el foro, no es mas que latencia XD tengo una bateria electronica y al tratar de grabar via midi (mediante cable USB-Midi) tengo una latencia aberrante XD no se cuanto, pero es mucha jeje

He probado con los drivers asio4all pero no mejora nada, por lo que leyendo en internet y eso, he leido que quizas podria solucionarlo, cambiando mi tarjeta de sonido (es integrada) por una de mejor calidad, que soporte ASIO 2.0

Entonces, aqui las preguntas...

1) es esto cierto? mejorara la latencia con una una buena placa de sonido?
2) para que mejore, es necesario que dicha tarjeta tenga entrada Midi, y conectar mi bateria a esTa entrada?
3) Que tarjeta de presupuesto moderado, me recomendais para esta labor XD ?

Muchas gracias por cualquier informacion :)
Subir
#2 por Tio Harpo Molon el 26/01/2010
La placa de sonido no es el factor que mas influye en la latencia, en realidad no influye en nada.

La latencia es consecuencia de la manera en que el software se comunica con el hardware, en otras palabras es en los drivers en donde la latencia comienza a existir. Las tarjetas integradas no tienen drivers propietiaros que te permitan alcanzar bajas latencias, entonces tienes que tirar de soluciones tipo Asio4all, pero no basta con instalarlo, si no que tambien hay que configurarlo, si cambias el valor del parametro buffer, cambiaras la cantidad de latencia, entre mas grande el tamaño del buffer mayor sera la latencia, tienes que poner el valor mas bajo que puedas sin que comiencen a aparecer chasquidos.

Ahora lo que necesito que me expliques es donde tienes la latencia, segun entiendo estas grabando tu bateria electronica via MIDI, es decir que lo que estas enviando al ordenador no es sonido, son solo datos para ser interpretados por un instrumento virtual, cual instrumento virtual es el que estas usando? es el sintetizador por tabla de ondas por software que viene por defecto con windows? si es asi, este sintetizador no trabaja directamente en ASIO, por tanto no lo tendras sincronizado con lo que suene dentro de tu secuenciador, para eso al interior del secuenciador (ya sea cubase, reaper, live, etc) hay una opcion, que dependera de que software se trate, que te permite manualmente agregar un offset para lograr sincronizar el MIDI, con los datos me imagino que ese sera tu problema, pero si no, ya te queda claro que nos faltan datos para saber cual es la situacion real.
Subir
#3 por ggobbo el 26/01/2010
Hola ! soy nuevo aqui, pero tengo el mismo problema. Grabo con Sonar 6 y Edirol HQ Orchestral, y no sé cómo reducirla y me tiene loco. Qué tengo que configurar (aparte quiero cambiar la tarjeta de sonido) pero si puedo solucionarlo mas o menos, estaría bien.

Gracias!
Subir
#4 por coreym el 27/01/2010
harpocrates666 escribió:
La placa de sonido no es el factor que mas influye en la latencia, en realidad no influye en nada.

La latencia es consecuencia de la manera en que el software se comunica con el hardware, en otras palabras es en los drivers en donde la latencia comienza a existir. Las tarjetas integradas no tienen drivers propietiaros que te permitan alcanzar bajas latencias, entonces tienes que tirar de soluciones tipo Asio4all, pero no basta con instalarlo, si no que tambien hay que configurarlo, si cambias el valor del parametro buffer, cambiaras la cantidad de latencia, entre mas grande el tamaño del buffer mayor sera la latencia, tienes que poner el valor mas bajo que puedas sin que comiencen a aparecer chasquidos.

Ahora lo que necesito que me expliques es donde tienes la latencia, segun entiendo estas grabando tu bateria electronica via MIDI, es decir que lo que estas enviando al ordenador no es sonido, son solo datos para ser interpretados por un instrumento virtual, cual instrumento virtual es el que estas usando? es el sintetizador por tabla de ondas por software que viene por defecto con windows? si es asi, este sintetizador no trabaja directamente en ASIO, por tanto no lo tendras sincronizado con lo que suene dentro de tu secuenciador, para eso al interior del secuenciador (ya sea cubase, reaper, live, etc) hay una opcion, que dependera de que software se trate, que te permite manualmente agregar un offset para lograr sincronizar el MIDI, con los datos me imagino que ese sera tu problema, pero si no, ya te queda claro que nos faltan datos para saber cual es la situacion real.


Pues... muchisimas gracias por esa respuesta :D me aclaro y soluciono todo el problema XD

Pues en efecto, basto un poco de ajuste con el asio4all y problema solucionado, hice lo que me dijiste de bajar el buffer y bueno lo baje hasta un punto aleatorio XD donde ya no habia latencia y de momento, tampoco chasquidos... asi que solucionado !...

Muchisimas gracias...

ggobbo escribió:
Hola ! soy nuevo aqui, pero tengo el mismo problema. Grabo con Sonar 6 y Edirol HQ Orchestral, y no sé cómo reducirla y me tiene loco. Qué tengo que configurar (aparte quiero cambiar la tarjeta de sonido) pero si puedo solucionarlo mas o menos, estaría bien.

Gracias!


Pues yo me descargue el asio4all, y ajuste el buffer lo menos posible y solucionado... no se como sera con esos programas que mencionas ya que yo uso cubase, pero en cubase fue muy sencillo...
Subir
#5 por LuDoLuST el 27/01/2010
Instala el programa asio4all, reduce las latencias de la entrada de sonido, casi a nada

Si pueden me gustaria me comentaran sobre mis composiciones...Gracias
http://luisesp.hispasonic.com/

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo