Un clásico: problema con Behringher FCA-202 bajo AvLinux

#1 el 05/08/2012
Publicidad
Ya que me estoy manejando de sobra en casa con la Creative X-Fi, le he dejado la FCA202 a un colega novatillo en Linux para que vaya aprendiendo a usar Ardour. El tema es que funciona perfectamente durante un buen rato, pero llega un momento que se desconecta de JACK y, en ocasiones, este se inutiliza totalmente: lo relanzo, abro Guitarix, la señal entra, pero no hay sonido, y las conexiones están ruteadas perfectamente.

Llevo un buen rato revisando el ya irrelevante (o no) usuario en grupo audio, que el procesador esté en "rendimiento" y todo esto... me gustaría revisar esto desde el principio, pero ya me duele la cabeza. A ver si se os ocurre algo.

* Aquí está el ffado-diag. Pedid lo que queráis y lo iré poniendo ;)

http://dl.dropbox.com/u/48848367/ffado-diag

* Por lo que he leído, hoy en día no hace falta el 'libraw1394' así que omito esta sugerencia del foro de AvLinux... ¿o no? :_D

http://www.remastersys.com/forums/index.php?PHPSESSID=qat26s5ou4ks514v74jhehqnj5&topic=516.0

* Aquí el limits.conf

Alguien escribió:
@audio - rtprio 99
@audio - memlock unlimited
#@audio - nice -19


*Aquí el 'rtirq'

Alguien escribió:
http://dl.dropbox.com/u/48848367/rtirq


La FCA se conecta mediante una tarjeta firewire PCI... por si estuviera aquí el problema:
Alguien escribió:

"If your firewire card is handled by an external controller (e.g. a PC-Card), you need to code the name of the card controller module (e.g. yenta)"!


* Como ya he leído a pablo en algún post, el siguiente link es importante. Prometo releerlo, pero si alguno ya ve el posible problema en los datos anteriores, que me diga. :D

Alguien escribió:
https://help.ubuntu.com/community/FireWire


Reiniciaré después de actualizar el sistema y, en cuanto JACK pete, pongo el mensaje. ;) Perdón por el lío en la redacción, pero la sobredosis de café... ejem... xD

ME OLVIDABA LO MÁS IMPORTANTE!!!! AvLinux trae un script de comprobación, aquí la salida donde seguro está el problema que no veo yo, torpe de mí... xD
Archivos adjuntos:
realTimeConfigQuickScan.pl_001.png

"Si la facilidad de uso fuera el único requisito, todos estaríamos moviéndonos en triciclos".

-Douglas Engelbart

Subir
#2 el 05/08/2012
P.D: he incluído el 'noatime' en fstab... vamos a reiniciar... :D

"Si la facilidad de uso fuera el único requisito, todos estaríamos moviéndonos en triciclos".

-Douglas Engelbart

Subir
#3 el 05/08/2012
El inicio de JACK es así. Luego pongo el log cuando rompa.

Alguien escribió:
00:54:07.817 Patchbay desactivada.
00:54:07.844 Reiniciar estadísticas.
00:54:07.901 Cambios en las conexiones ALSA.
00:54:08.043 Cambió el gráfico de conexiones ALSA.
00:54:47.944 Registro iniciado --- dom ago 5 00:54:47 2012 ---
00:54:49.034 JACK está iniciándose...
00:54:49.038 /usr/bin/jackd -P70 -t2000 -dfirewire -r44100 -p1024 -n3
jackd 0.121.3
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
00:54:49.069 JACK se inició con PID=2597.
JACK compiled with System V SHM support.
loading driver ..
libffado 2.999.0- built Oct 6 2011 19:36:05
00:54:51.273 Cambios en las conexiones JACK.
00:54:51.274 Configuración del servidor salvada en "/home/berun/.jackdrc".
00:54:51.277 Reiniciar estadísticas.
00:54:51.676 Cliente activado.
00:54:51.684 Cambio en el tamaño de buffer (1024).

"Si la facilidad de uso fuera el único requisito, todos estaríamos moviéndonos en triciclos".

-Douglas Engelbart

Subir
#4 el 05/08/2012
Bueno, la tarjeta deja de sonar con el corte de JACK. Si la desconecto y reconecto del cable firewire vuelve a sonar, así que dos cosas:

* O el tema falla por culpa de la tarjeta.
* O el fallo en lo que sea relacionado con JACK la vuelve loca... xD

"Si la facilidad de uso fuera el único requisito, todos estaríamos moviéndonos en triciclos".

-Douglas Engelbart

Subir
#5 el 06/08/2012
baltardesign escribió:
* O el tema falla por culpa de la tarjeta.
* O el fallo en lo que sea relacionado con JACK la vuelve loca... xD


Hombre, cuando estas cosas sucede uno quiere agarrar a patadas la PC. Me considero un usuario pagmático y cuando esto sucede se me complica la existencia.

Aquí el maestro es Pablo_F, sin embargo leo por la web de FFADO que la tarjeta es totalmente soportada, pero que en ciertos casos algo aislados tiende a clavarse con JACK.

Los chicos de la comunidad dan opciones: Reinstalar/Actualiza FFADO o/y revisar que el modulo raw1394 es poseído unica y exclusivamente por el grupo root. Otra cosa que dicen es acerca de los chipsets IEEE1394. Como sabes hay algunos chipsets como los Intel que dan problemillas con las conexiones entre dispositivos. Esperemos que este no sea tu caso.

Algo más, una observación personal. Creo que desde hace varias versiones del Kernel se han venido suplantando los directorios reales por enlaces simbolicos a otros directorios. Quizá aqui puede que radique el problema. O puede que me equivoque. En todo caso, echale un revisada al link de FFADO (que me imagino ya has revisado) y a revisar por los pasos ya dados.

Nota aparte: Espero, rezo, le prendo candelas a San Isidoro de Sevilla (Santo patrono del Internet), que por favor Behringer saque al mercado la FirePower FCA1616 (Campo pagado :lol:), que esa me la compro aunque sea fea, mala o lo que quiera que digan.

¡Saludetes! thumb.gif

Fiat Caritas, Mi nuevo tema hecho en GNU/Linux: http://www.hispasonic.com/musica/fiat-caritas/96044

También soy Altiplane, esta es mi música

Subir
#6 el 07/08/2012
Gracias Irwin. Cuando vuelva por casa del colega y los dos tengamos ánimos bucearemos algo más en el problema, a ver que pasa. :D

"Si la facilidad de uso fuera el único requisito, todos estaríamos moviéndonos en triciclos".

-Douglas Engelbart

Subir
#7 el 19/08/2012
Parece que finalmente hemos solucionado el problema usando otra tarjeta pci-firewire, así que sí que deben de ir los tiros por el firmware de la otra. La FCA202 nos ha permitido estar un buen rato sin sustos, sólo en un intento de xrun se cerró Ardour pero no se colgó JACK ni nada: relanzamos Ardour y fiesta.

Me queda pendiente lanzar con 'jackd -s', que no me quería arrancar con él, e imagino así no volverá a cerrarse Ardour ante un posible xrun.

"Si la facilidad de uso fuera el único requisito, todos estaríamos moviéndonos en triciclos".

-Douglas Engelbart

Subir
Respuesta rápida
Identíficate o regístrate para poder responder en este hilo.