configuracion jack control

#1 por dinosauriojr el 05/09/2011
Alguien sabe de alguna página con instrucciones/tutorial/videodeyoutube para configurar el jack control sin volverse loco?

Gracias a todos!!
Subir
mod
#2 por Irwin J. Cespedes el 06/09/2011
@dinosauriojr, la configuración de Jack es muy sencilla si tienes la paciencia para entender como se mueven los dispositivos de audio en tu equipo. Pero, vamos por lo básico.

1. Necesitamos saber que tarjeta vas a controlar. Si es externa, nunca va a ser numerada hw:0,0, por la sencilla razón que es la que está por defecto instalada como interface o tarjeta de sonido nativa. Lo que hay que saber es cual hay que controlar, entonces abres un terminal y metes este código:

Terminal escribió:
cat /proc/asound/cards


Este comando te va a dar este resultado:

Screenshot-Terminal.png

Como ves la tarjeta de integrada a la tarjeta madre es la CMI 8738, y la externa es la Intel. En este caso vamos a usar la segunda con Jack, la cual es una interface USB, similar a tu caso.

2. Luego de saber que el número de la tarjeta Realtek AC 97 es 1, lo que vamos a hacer es abrir QJACKCTL, y antes de arrancar el servidor Jack vamos a ir a Settings e ir a este lugar:

Configuraci%2525C3%2525B3n%252520Tarjeta.png

Le das un click, y marcas la tarjeta que vas a usar. Aquí, no hay tanta confusión, ya que el mismo QJACKCTL te dice cual tarjeta es, solo es de tener cuidado a la hora de configurar.

3. Le das play, y ya debe de trabajar a la perfección.

JACK%252520%25255B%252528default%252529%25255D%252520Started..png

Con respecto a la configuración adicional, puedes variar los valores de los Frames y los Periods, aunque en mi caso los llevo hasta 1024 Frames y 2 Periods, para que la maquina trabaje descansada, aunque eso depende de la configuración de tu máquina. Toma también como referencia la configuración que aparece en el screenshot, y si tienes tiempo juega con la misma.

Espero te sirva esto. Y si te nace otra duda, puedes preguntar a todos los GNUsónicos de este foro.

¡Pura Vida! :-)

Ps. Echa un vistazo también a esta información más detallada acerca de los parámetros internos de QJACKCTL para configurar a Jack: http://www.soundebian.com.ar/2009/11/como-configurar-jack/

Ruta 27, Mi nuevo tema hecho en GNU/Linux: https://soundcloud.com/altiplane/ruta-27

También soy Altiplane, esta es mi música.

Subir
#3 por Pablo_F el 06/09/2011
Otro enlace;

http://semicorchux.blogspot.com/2010/12/configuracion-del-servidor-de-audio.html

Pero parece que tu problema está a un nivel más bajo que jack. Como te han comentado otros, es posible que tu tonesport UX1 no esté soportada por el kernel de Tango Studio. Es lo primero que tienes que mirar. Pega la salida de los comandos informativos que te proponen.

Saludos, Pablo
Subir
#4 por dinosauriojr el 07/09/2011
Muchas gracias por la respuesta, Irwin y Pablo!

Además de ser un negao para estas cosas veo que se me escapan algunas cosas. Introduciendo el comando que me indicas, Irwin, me pone lo siguiente:

0 [ICH5 ]: ICH4 - Intel ICH5
Intel ICH5 with ALC658D at irq 17
1 [UART ]: MPU-401 UART - MPU-401 UART
MPU-401 UART at 0x330, irq 10

O sea que además del toneport ux (el cual ya doy por perdido porque según creo no existen drivers para linux) tengo dos tarjetas de sonido. Opto por la primera (pues en sistema/preferencias/sonido me indica que la otra no tiene controles con lo cual deduzco que esta primera es más completa; corregidme si me equivoco). Luego abro jackcontrol, indico interfaz hw:0 y (por fin!!) consigo conectarme sin errores. Pero abro un WAV con audacity y al reproducirlo no se me escucha (cosa que sí sucede si estoy desconectado de jackcontrol). Alguna idea de lo que puedo estar haciendo mal?

Muchas gracias por vuestra ayuda!
Subir
mod
#5 por Irwin J. Cespedes el 07/09/2011
Como dice paraece que tu interfaz Toneport no esta soportada por GNU/Linux, por los momentos. Dale tiempo al tiempo y con seguridad alguien se dara cuenta de esto y resolverá el problema. Ahora por otro lado...

dinosauriojr escribió:
Pero abro un WAV con audacity y al reproducirlo no se me escucha


En ese caso tiene que ir a las opciones de Audacity y seleccionar como salida a Jack.

picture.php?albumid=266&pictureid=6979
No es screenshot mío, pero ahi sirve.

Donde dice "Host", selecciona la opción que dice Jack, y en channels, 2 (Stereo)

Por último:

dinosauriojr escribió:
1 [UART ]: MPU-401 UART - MPU-401 UART
MPU-401 UART at 0x330, irq 10


Estoy casi seguro que eso es una interfaz MIDI, ¿Verdad que es asi, Pablo_F?

Ruta 27, Mi nuevo tema hecho en GNU/Linux: https://soundcloud.com/altiplane/ruta-27

También soy Altiplane, esta es mi música.

Subir
#6 por dinosauriojr el 07/09/2011
Amigo, esto ya es otra cosa!

Supongo que hay que hacer lo mismo con el resto de programas pero... perdona que abuse de tu paciencia, en rosegarden tampoco se me escucha y en preferencias de audio parece estar correcto en editor externo de audio tengo puesto:
/usr/bin/rezound --audio-method=jack
Subir
mod
#7 por Irwin J. Cespedes el 07/09/2011
Con Rosegarden no estoy muy familiarizado, pero eso que escribes es el editor externo que utiliza RG, para la edición de samples. Con ese comando lo que quieres es que RG te lance Rezound para que edite un sample.

En todo caso, esto no tiene que ver con la configuración de Salida de RG, si no con un programa ajeno a él, el cual lanza forzando a que se monte on Jack (Si es que no esta bien configurado el Editor Externo)

Ruta 27, Mi nuevo tema hecho en GNU/Linux: https://soundcloud.com/altiplane/ruta-27

También soy Altiplane, esta es mi música.

Subir
#8 por dinosauriojr el 07/09/2011
Ok, muchas gracias por tu ayuda!

Un saludo!
Subir
#9 por veguita el 07/09/2011
Rosegarden no produce sonidos de forma interna, tienes que cargar un plugin dssi o conectarlo a un sintetizador externo. Hay varios tutoriales donde se explica el tema.

== Para cargar plugins DSSI (instrumentos virtuales) ==
- En el menú ver tienes que activar "Mostrar parámetros especiales"
- Te aparece un panel lateral con tres secciones, en la sección "Parámetros de reproducción" hay un cuadro de diálogo que dice dispositivo, ahí seleccionas "Plugin Sinte".
- Se activará otra sección llamada "Parámetros de instrumento"
- El primer botón te carga un plugin de instrumento, los siguientes te cargan plugins ladspa

== Para cargar sintetizadores externos ==
- Vas al menú Estudio > Gestionar dispositivos midi
- Seleccionas Nuevo, te creará un nuevo dispositivo midi.
- Seleccionas algún sintetizador para usar con ese dispositivo.

Rosegarden se conecta solo a las entradas y salidas de Jack tanto de audio como midi, no necesitas muchas configuraciones para hacerlo sonar, pero si deseas usar varios sintes a la vez puede ser algo poco intuitivo.

Espero haberte ayudado

Aquí hay un tutorial:
http://www.musix.org.ar/rosegarden-tutorial-es/chapter-1.html

"tengo una soledad tan concurrida que puedo organizarla como una procesión"
Mario Benedetti

Subir
#10 por dinosauriojr el 15/09/2011
Muchas gracias, Veguita, llevo unos días sin poderme conectar pero ahora que lo he visto lo he probado y funciona todo correctamente.

Muchas gracias!
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo