Consumo CPU de Maschine mk2 / Studio

  • 2
#16 por Ramon el 22/09/2016
Hola, un año mas tarde leo este hilo. me uno a este hilo porque quizás es el que mas toca con mi problema que es la sobrecarga de CPU... :(( os cuento,

-tengo un i3 con 4gB de RAM, algo muuuuy normalito de pc
- uso maschine 2.4 con una mikro, me he hecho con komplete11

Decir que ya no s que hacer para optimizar el pc, he seguido todos los pasos de optimizar el pc que da NI en sus videos,latency moon etc...según latency moon (para quien no lo conozc< es un programa que te detecta que drivers te funcionan mal ya sea cuando usas maschine o traktor ), yo uso ambos, pero bien el problema lo tengo cuando uso maschine 2.4.
Mientras cargo en maschine instrumentos tipo massive..etc.. no hay sobrecarga, cuando cargo otros como polyplex, flesh..la cpu se pone a reventar, evidentemente son muestras de sonidos muuucho mas pesadas, pero se entiende que esto debe quedar solucionado con los pasos a seguir que te dan los de NI, prosigo... cuando tengo un tema aunque solo sea 3 instrumentos en lo que hay uno de los antes mencionados , 1º tarda una eternidad en cargar, 2º a veces se queda en "no responde", y cuando lo reproduzco se entrecorta, chasquea y tocaría las maracas si se las diera!, la CPU marca a tope y latency moon indica que todos los drivers funcionan perfectamente. Es mas, cierro la canción en cuestión y me siguen sonando como unos chasquidos incluso con instrumentos que antes no me los hacían!

Estoy negro ya, y no se que mas hacer para optimizarlo todo, contemplo ampliar a 8gB la RAM, pero lo que no entiendo es que según latency moon todo funciona de maravilla, en el administrador de tareas mientras chasquea la canción compruebo el uso de RAM y no llega al 50%, y ya no se donde esta el fallo.


Alguien sabe/puede ayudarme? mil gracias!!!!!!!!!!!!!!!!!!!
Subir
#17 por Ramon el 22/09/2016
Ah...este problema no lo tengo funcionando en modo standalone, por lo que localizo el problema con la optimización o configuración del soft de maschine 2.4, pero según tutoriales lo tengo bien configurado, en latencias etc.... ;((
Subir
mod
#18 por walerandei el 26/09/2016
Ramon escribió:
cuando cargo otros como polyplex, flesh..la cpu se pone a reventar ...


Dejando de lado que tu portatil va justito de specs ... el problema no es el portatil ni la configuracion. El problema es el "Reaktor" (el Host de Flesh y Poliflex). El consumo de CPU de Reaktor es la leche ... desmedido ... arrasa con todo.

La unica solucion al respecto de Reaktor, es abrir un proyecto vacio ... cargar el plugin, hacer lo que quieras a nivel notas, etc. Y luego lo conviertes a Audio. Luego vuelve a tu proyecto donde tienes todo ... y carga en el sampler de Maschine la pista de audio ... veras que el audio es lo que menos consume CPU.
Es la unica manera de usar Reaktor (y sus plugins), sin morir en el intento.

Yo tengo un ordenador con 8 nucleos a 4ghz . Y aun asi es cargar Reaktor, y joder si se nota. :?
Convertir a audio y santas pascuas.

Y esta solucion tambien es util cuando metes muchas cosas y notas que ya alcanzas el techo de tu cpu. Conviertes varias pistas cargadiyas de plugins a audio y andando. La CPU volvera a ofrecer mas margen. 8)
Subir
#19 por tonovox el 26/09/2016
Que interface usas? Es USB1..USB2...Firewire?
Has probado los Asio4all???
Muchas veces van mejor que los nativos.

Escucha mi Música en: http://www.soundclick.com/bands/pagemus ... ndID=82540
https://tonovox.bandcamp.com/

Subir
#20 por Ramon el 26/09/2016
Hola! Gracias a los dos por vuestras respuestas deciros que utilizo los ASIO4ALL tanto en Maschine o Cubase, también he pensado en ampliar mi memoria RAM hasta las 8, pero por lo que decís con esto solamente parchearía un poco el problema ya que el alto consumo de reactor es el causante de todos mis dolores de cabeza, en fin, al menos tengo una solución, pero antes quisiera haceros una última pregunta a ver si esto te ha pasado a alguien... cómo se comentado hasta ahora cuando más chino utilizándolo en modo autónomo intentaba cargar algún instrumento tipo Poliflex la CPU se me ponía a tope y el sonido en mi tía chasquidos y cortes tanto es así que aún cerrando la canción e iniciando un proyecto nuevo me quedaba una distorsión residual que provenía del anterior proyecto haciendo qué sonidos muchos más simples me he me dieran también ese tipo de chasquidos y cortes....a alguien le ha pasado? Saludos a ambos!
Subir
mod
#21 por walerandei el 27/09/2016
Ramon escribió:
... cómo se comentado hasta ahora cuando más chino utilizándolo en modo autónomo intentaba cargar algún instrumento tipo Poliflex la CPU se me ponía a tope y el sonido en mi tía chasquidos y cortes tanto es así que aún cerrando la canción e iniciando un proyecto nuevo me quedaba una distorsión residual que provenía del anterior proyecto haciendo qué sonidos muchos más simples me he me dieran también ese tipo de chasquidos y cortes....a alguien le ha pasado? Saludos a ambos!


Los chasquidos y ruidos son porque el procesador que lleva tu portatil no es suficiente para mover Reaktor dentro del proyecto. Aunque conviertas el patron con Reaktor en audio ... durante el proceso de conversion, si el procesador del portatil no tiene suficiente chicha para que Reaktor trabaje con normalidad tambien tendras clicks, chasquidos y demas en el audio resultante. Eso quedara ahi ... lo mismo esto es lo que te esta pasando. Que importas el audio con chasquidos en otro proyecto ... y por eso escuchas lo que comentas.

Porque cambiando de proyectos, y cargando diferentes plugins a lo que genero el problema inicialmente ... nunca me paso que tuviera un ruido de audio residual o cosa similar. Esto habiendo usado Maschine en 2 portatiles diferentes y en un ordenador tocho fijo.
Subir
#22 por Ramon el 27/09/2016
Hola wanderlei!
eres un pozo de sabiduria.. ;) ! todo esto que me cuentas me parece super razonable, lo que no entiendo es que me pase también con maschine funcionando de modo autonomo...si recupero un proyecto muy simple, donde las pistas sea alguno de los instrumentos nombrados: flesh,polyplex,..me pasa lo mismo. Como te digo, ya sin usar reaktor, tarda media vida en cargar la cancion, a veces la pantallase queda unos segundos en "no responde". Y a partir de ahi los chasquidos y demas, salgo de ese proyecto , cargo otro y aun continua el chasquido residual... ;((
Subir
mod
#23 por walerandei el 28/09/2016
Ramon escribió:
a veces la pantallase queda unos segundos en "no responde".


Esto ... mientras carga los elementos de un proyecto, es normal. :)
Especialmente si hay mucho audio que cargar.

Ramon escribió:
lo que no entiendo es que me pase también con maschine funcionando de modo autonomo...


Es que todo se resume en la potencia de proceso que tenga tu ordenador.
Uses Maschine en modo vst o lo uses en modo Stand-alone (autonomo), en ambos casos Maschine tira de procesador para todo lo que tenga que ejecutar, cargar, etc. Quiero decir, es indiferente a como utilices Maschine. Si no hay margen de procesador ... en el audio tendras chasquidos y todo tipo de artefactos sonoros.

En mi caso, utilizo Maschine en modo Stand-alone. Asi no tengo ningun otro programa por debajo chupando cpu. Si usas Maschine como vst, el host (reaper, logic, cubase o lo que sea), chupara CPU y restara potencia de uso a Maschine. :)

Ramon escribió:
tarda media vida en cargar la cancion, a veces la pantallase queda unos segundos en "no responde". Y a partir de ahi los chasquidos y demas, salgo de ese proyecto , cargo otro y aun continua el chasquido residual... ;((


uhmmm ... es que lo mismo el problema no lo estas teniendo en Maschine como tal. Puede que estes experimentando algun problema con el driver de tu tarjeta o con la manera en que lo tienes configurado en el software de Maschine.
PREGUNTA:

Si coges y creas un proyecto nuevo en Maschine usandola Stand-alone ... sin ningun vst o sample cargado ... ¿continuas escuchando esos ruidos residuales? :?:
Subir
1
#24 por Ramon el 28/09/2016
Hola, teóricamente todos los drivers están ok, o eso me dice el ordenador, a tu pregunta....

Haciendo la prueba en modo standalone:

si primero cargo una canción que contiene uno de esos instrumentos,(flesh,polyplex..) la respuesta es si, aunque cargue uno proyecto nuevo ,tengo chasquidos residuales del proyecto anterior, he de cerrar el programa maschine y cargarlo de nuevo.

si cargo un proyecto que no contiene ninguno de esos instrumentos, no solo me carga mucho rápido (lógico), sino que no deja ningún chasquido,granulado ni nada, ni durante la reproducción del proyecto ni al cerrarlo y abrir otro.

No se, aumentar la RAM, crees que puede ser la solución? o ya seria lo suyo cambiar a un i5 o un i7?


muchas gracias
Subir
#25 por Miguel Angel Terriente hace 1 semana
Hola! Llevo buscando soluciones a mis problemas con los "chaquidos" en Maschine 2 semanas y semanas, y mira por donde, aquí habláis de este tema. Estupendo, porque necesito de vuestra ayuda.

Macbook Air 2013 1,3 GHz Intel Core i5 4 G de RAM

Tengo la Studio y estoy componiendo una sesion de música electrónica junto con un colega. Resulta que tengo 8 patrones metidos en una misma sesion (si, aun tengo que soltarme con como demonios ordenar todo esto de los patrones y sesiones...), y me aparecen los temidos chasquidos. He comprobado que subiendo latencia (la tengo a 512) hasta mas de 1000, dejan de escucharse.

En fin, podéis por favor ayudarme con este tema? Mil gracias de antemano.
Subir
mod
#26 por walerandei hace 1 semana
Miguel Angel Terriente escribió:
Hola! Llevo buscando soluciones a mis problemas con los "chaquidos" en Maschine 2 ...
Macbook Air 2013 1,3 GHz Intel Core i5 4 G de RAM ...


MAs datos, hombre! Mientras mas mejor ... asi podemos ayudarte adecuadamente!

Dime que Tarjeta de sonidos usas ... y que tipo de drivers tienes configurados en las preferencias para esta tarjeta. :) Comenta tambien la latencia y demas. Todo dato es bienvenido.

El software de Maschine lo usas en modo stand-alone (solo), o lo usas hosteado en otro Daw (como Logic, Cubase, Ableton, etc.) ???

¿Que instrumentos tienes cargados en las pistas de los patrones? Dentro de la sesion cuantos instrumentos suenan al mismo tiempo?

Y fundamental ... La barra de CPU que tal va? Ves si pega algun pico?
Subir
1
mod
#27 por walerandei hace 1 semana
Ramon escribió:
o ya seria lo suyo cambiar a un i5 o un i7?


Lo suyo seria tener un procesador con mas potencia. ESTO ES LO QUE TE ESTA AFECTANDO DIRECTAMENTE. Si te metes en cambios salta directo a i7, algo bien potente y mientras mas chicha mejor ... asi te queda margen para hacer cosas a gusto. Con respecto a la RAM, minimo 8gb ... no tanto por petarla de audio, sino tambien para que le quede resto al sistema operativo y al software que tengas en uso para funcionar olgadamente. Y tal como esta la ram ahora mismo (que no esta tan cara), si puedes saltar a 16gb mejor que mejor. La RAM mientras mas rapida sea, mejor ... aunque esto ultimo no es tan importante como el procesador.
Subir
1
Respuesta rápida

Regístrate o para poder postear en este hilo