gx_head, ampli virtual de guitarra descendiente de guitarix

#1 por Pablo_F el 15/01/2011
Hermann (aka brummer) acaba de anunciar en la lista de Linux Audio Users el ampli virtual gx_head, un simulador de amplificador de válvulas basado en guitarix.

Se pueden elegir 3 modelos de válvulas (12AX7, 12AU7, 6V6) y 8 modelos de tonestacks (Bassman, Twin Reverb, Princeton, JCM-800, JCM-2000, M-Lead, M2199, AC30).

Viene con un montón de efectos incluyendo distortion, crybaby, autowah, phaser, flanger, echo, delay, . . .

Los efectos se pueden ordenar en dos racks, uno para los efectos mono y otro para los estéreo. Los efectos mono se pueden usar en pre o post procesado. Los efectos estéreo sólo se pueden usar en post-procesado. Los efectos se pueden cargar desde el menú, menú desplegable desde los racks o desde una barra de plugins. Las configuraciones se pueden cargar como presets.

Todos los controladores accesibles desde la interfaz de usuario se pueden conectar con un controlador MIDI externo via MIDI learn.

En qjackctl / patchage aparecerán dos módulos, el cabezal y el módulo de efectos. De esta forma se puede combinar el ampli virtual con otros racks de efectos independientes de guitarix, por ejemplo con rakarrack.

Mantiene el módulo de reverb de convolución de guitarix.

Features:

* 8 tonestack models
* 3 tube models
* cabinet impulse response module
* bass boster
* easy Impulse Response file support via zita-convolver
* on the fly IR-file resampling via zita-resampler
* Oscilloscope and tuner
* multi band distortion model
* scalable EQ
* phaser, flanger, stereo delay, stereo echo,
* overdrive, compressor, freeverb, reverb,
* chorus, moog filter, low/high pass filter, . .
* MIDI learn
* Patch Info widget
* Preset File Load/Export option
* factory settings
* language support
* shining User Interface via GTK/gtkmm

Página de sourceforge:
http://sourceforge.net/projects/guitarix/

Noticias y pantallazos:
http://sourceforge.net/apps/wordpress/guitarix/

Foro:
http://sourceforge.net/apps/phpbb/guitarix/

Instalación:

Después de descomprimir las fuentes, desde el directorio gx_head:

./waf configure
./waf build
sudo ./waf install

Si alguien lo intenta y no se compila o algo va mal, que muestre la salida de ./waf configure para que le podamos ayudar.

Saludos, Pablo
Subir
#2 por the_rover el 03/02/2011
Compilado y funcionando.

Me ha gustado, sencillo de manejar y rápido para hacer presets. Mucho más agradable a la vista que Rakarrack.

Lo utilizaré únicamente para tocar de vez en cuando en mi portátil. Uso Tangerine (mi reproductor favorito) + Rackarrack/Gx Head y va de lujo. Puede que acabe añadiendo audacity para grabar ideas pero en principio es para ensayar sobre pistas exportadas o canciones.

Uso Ubuntu 10.10 + jack 0.118 (jack 1.9.x no me funciona aún no sé por qué). Ojo, yo utilizo una FCA202 (no soportada oficialmente por ffado, pero tira.

No uso kernel rt pero añado los cambios de cpu_freq que recomiendas en otro hilo y configuro prioridad y memlock en el grupo audio.

Latencia estimada jackd 23ms. Prácticamente inapreciable al tocar y sin xruns. Creo que podría bajarla pero en principio voy así.

Pablo, aprovecho para darte las gracias, ya que aunque soy usuario habitual de linux hay cosas en audio que no controlo (lo musical lo tengo todo en un mac) y me han servido de mucho los consejos que vas dejando por el foro.

Un saludo.
Subir
#3 por matv el 04/02/2011
Hola

Cuando compilo obtengo este error:

Checking for header boost/format.hpp : not found
/home/mat/Escritorio/gx_head/wscript:366: error: the configuration failed (see '/home/mat/Escritorio/gx_head/build/config.log')

agradeceria mucho que me pudieran ayudar

saludos, gracias
Subir
#4 por Pablo_F el 04/02/2011
Hola

Seguramente te faltará el paquete libboost-dev, pero no será el único... Te aconsejo el truco de instalar todos los paquetes de desarrollo necesarios para compilar ardour, lo cual permite compilar un montón de programas, no sólo ardour. En Debian / ubuntu se puede hacer con el comando:

sudo apt-get build-dep ardour

Si aún así "waf configure" te da algún error, es porque te falta algún otro paquete -dev, pero no creo que sea el caso.


... Me alegro, The Rover! viva gx_head!
Saludos, Pablo
Subir
#5 por matv el 04/02/2011
Gracias Pablo, compilo sin problemas.
Por cierto he leido tus guias en semicorchux, muy utilues para mi que vengo de hacer musica con Mac y windowds
Subir
#6 por igny el 04/02/2011
Gracias amigo Pablo por el post. Recibo este mensaje de error. Parece ser cosa del path con jack, puede ser?

Checking for g++ : ok
Checking for jack
Subir
#7 por igny el 04/02/2011
Solucionado el primer problema instalando los dev que faltaban. :)

Ahora el segundo problema es con la libreria esta

gtkmm-2.4 : not found

Y cuando voy al synaptic esta es la contestación:

ibgtkmm-2.4-dev:
Depende: libgtkmm-2.4-1c2a (=1:2.20.2-1) però s'instal·larà 1:2.20.3-0ubuntu1
Depende: libglibmm-2.4-dev però no s'instal·larà
Depende: libcairomm-1.0-dev però no s'instal·larà
Depende: libpangomm-1.4-dev però no s'instal·larà

con lo cual creo que esta dependencia me impide seguir con el proceso.

Saludos y gracias.
Subir
#8 por Pablo_F el 04/02/2011
Hola Xavi,

Mira a ver si tienes habilitado algún repositorio no oficial, desactívalo desde orígenes del software y recarga. Si eso no resulta, di distro y versión.

Un abrazo, Pablo
Subir
#9 por igny el 06/02/2011
Gracias por atender, como siempre amigo Pablo. Lliurex 10.09 (ubuntu 10.4)

Tengo los reppositorios oficiales de llliurex y tenía desactivados los de ubuntu. Activándolos y con esta orden: sudo apt-get build-dep ardour he conseguido ponerlo en marcha.

Muchísimas gracias por la ayuda.

Un fuerte abrazo y un saludo.

Salut.
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo