Hackintosh

#511 por Ed_Saxman el 28/09/2010
SuRGe escribió:
Buenas, os escribo desde mi Dellbook Pro :mrgreen:
El caso es que he instalado SL y lo tengo todo funcionando genial menos un pequeño problemilla. El teclado...
Solo si arranco con Empire EFI me funciona el teclado. Al iniciar desde bootloader, el teclado no funciona.
He probado a meter el VoodooPS2.Kext, pero me daba un kernel panic.
Alguno teneis idea de que puedo hacer?
El laptop es un Dell Latitude D820 y estoy actualizado a 10.6.4


Prueba con el AppleACPIPS2Nub.kext y el ApplePS2Controller.kext, poniendo ambos en S/L/E.

Si no los encuentras por ahí, puedes bajarte el pack que hice para mi anterior portátil, el HP DV3540es.

También podrías sacar el controlador de teclado PS2 que haya en el empireEFI ese.

.........

Yo me acabé cansando de no poder controlar el brillo de la pantalla en Snow leopard, y he acabado vendiendo el hackbook y pillando un MBP...

Me quedé al 98% con el Hakbook, que es mucho teniendo en cuenta que antes de mi tutorial no había nada para esa serie, pero ese pequeño 2% acabó jodiendome la experiencia.

Aunque no todos los portátiles tienen el control de brillo hardcoded in bios como el HP, ni una whitelist para el WIFI, etc, y hay algunos que si que llegan al 100% en funcionalidad, yo en general recomiendo los Hackintosh para PCs de sobremesa.

Aqui se puede leer la conclusión de mi odisea con el HP.

Workstations Hackintosh en AppleOSX86.com
No respondo dudas por privado. Utiliza los foros.

Subir
#512 por Real_Kcan el 28/09/2010
Hola surge prueba reparar los permisos yo lo hice y me funciono luego de instalar muchas veces los voodoops2.

bueno actualmente tengo un problema que aun con el voodootsc me esta funcionando el procesador a mitad de velocidad (dell inspiron 6400), si inicio con cpus=1 va bien, pero solo 1 nucleo funciona, esta semana no podre hacer mucho pero si alguien tiene alguna idea :?

salu2

-Lo peor de la ignorancia..es que.. a medida que se prolonga, adquiere confianza-

Subir
#513 por Sergio Jimenez el 28/09/2010
Gracias a ambos por vuestras respuestas.

@Ed_Saxman: Si uso kexthelper b7 me los instalará en el lugar adecuado? Aún no me siento muy seguro para instalarlos manualmente. Tendré que borrar/desactivar cualquier kext de PS2 que tuviera anteriormente, no?

@Real_Kcan: No se si será el mismo problema, pero cuando booteaba directamente con Chameleon, el ratón me iba a tirones y solo tenia un core activado. Lo solucioné con VoodooTSCSync.kext . Prueba, a lo mejor cae la breva...

The drum represents the heart beat; the bass is the thought, a line that flies. Walking bass, talking bass, comes from the brain. Boom Boom is from here, the heart"
Lee "Scratch" Perry

http://soundcloud.com/sergio-jimenez

Subir
#514 por Real_Kcan el 29/09/2010
asi es surge, yo al final use el sistema de tonymac, instale los kexts con el kexthelper y no me funciono si no hasta que repare los permisos, ahi perfecto teclado y mousepad.

por cierto he solucionado el problema boteando conn el flag de "cpus=2", y hasta el momento todo va ok, tengo que modificar el archivo de boot con dicho flag pero no recuerdo como se hace.

alguna pista? :P

-Lo peor de la ignorancia..es que.. a medida que se prolonga, adquiere confianza-

Subir
#515 por Ed_Saxman el 29/09/2010
Ya no es necesario usar el KextHelper...

Poneis lo que tengais que poner en System/Library/Extensions "a saco", y luego pasais el Kext Utility de cVad.
Es una buena herramienta. Se encarga de corregir permisos tanto en /S/L/E como en /Extra/Extensions, reconstruir cachés, y reconstruir el Extensions.mkext


Para lo que comenta Real_Kcan del flag Cpus=1, la mejor solución sería extraer y editar el DSDT para corregir los Alias.
Otra opción sería usar un Kernel alternativo con parcheo de cpu_ids.

Lo de los alias del DSDT no suele ser muy complicado:

[code]Scope (_PR)
{
Processor (P001, 0x01, 0x00000810, 0x06) {}
Processor (P002, 0x02, 0x00000000, 0x00) {}
Alias (P002, CPU2)

Workstations Hackintosh en AppleOSX86.com
No respondo dudas por privado. Utiliza los foros.

Subir
mod
#516 por Teo Tormo el 30/09/2010
Hey chicos,
Hace tiempo llevo rulando sin problemas el OSX 10.5.8 en mi portátil Acer y con muy buenos resultados, pero en mi ordenador de sobremesa ha sido totalmente imposible.
Es un HP modelo DC5700 (muy típico de oficinas, incluso hasta de hospitales) con procesador Core2Duo a 1,8 (o eso creo), gráfica Intel integrada y 2gb de Ram. Absolutamente ningún sistema para instalar el OSX me funciona, me arrancan los bootloaders, le digo que inicie el instalador de OSX y como mucho llego a tener la pantalla gris con la manzana gris oscuro encima. Ningún instalador pasa de ahí. He probado a meterle el Snow Leopard, el Leopard, rebel efi, empire efi, iatkos... su puta madre, nunca pasa de ahí. He probado todo tipo de opciones de instalación... nada de nada.

¿Alguien sabe si sencillamente con este ordenador puede que sea imposible o hay algún dato vital que puedo estar dejando pasar por alto?

Recuerda, el aspirante eres tú.

Subir
#517 por Aviaco el 30/09/2010
El culpable casi seguro que es tu gráfica integrada, una de esas primeras GMA de Intel, que no son soportadas por esas versiones parcheadas de OS X. Tal vez si le instalas una gráfica externa de las que funcionen con los OS X "trucados" tu fijo sea capaz de funcionar con el sistema de la manzana feliz.

Saludos
Subir
mod
#518 por Teo Tormo el 30/09/2010
Aviaco escribió:
El culpable casi seguro que es tu gráfica integrada, una de esas primeras GMA de Intel, que no son soportadas por esas versiones parcheadas de OS X. Tal vez si le instalas una gráfica externa de las que funcionen con los OS X "trucados" tu fijo sea capaz de funcionar con el sistema de la manzana feliz.

Saludos

Pues mira tu por donde que el portátil usa la misma gráfica y sí funciona.

Recuerda, el aspirante eres tú.

Subir
#519 por Aviaco el 30/09/2010
Pues igual no te funciona por algo de la BIOS del HP. En fin, mala suerte.

Saludos
Subir
Baneado
#520 por ediroll el 30/09/2010
Hola.aki esta todo.

http://www.kexts.com

Audio
Red
NVidia
Tarjetas de vídeo
ATI
Gestores de arranque
Herramientas
Chipset

Como Instalar un Driver .kext

1) Debemos copiar el archivo .kext navegando hasta la carpeta llamada Extensions, siguiendo la ruta:

Leopard/System/Library/Extensions/

Aquí si ya existe el Driver, nos preguntara si lo queremos reemplazar, y nos pedira nuestra contraseña.

2) Luego debemos abrir la Aplicación Terminal.

3) Ahora debemos borrar la caché de los .kext, en terminal escribimos lo siguiente:

sudo kextcache -k /System/Library/Extensions

4) Luego debemos reparar los permisos para poder utilizar el .kext, escribimos en Terminal lo siguiente:

sudo chmod -R 755 /Volumes/Leopard/System/Library/Extensions/gma950.kext

sudo chown -R root:wheel /Volumes/Leopard/System/Library/Extensions/gma950.kext

Nota: En donde dice Leopard es el nombre de la partición en donde tienes instalado Mac, y gma950.kext es en este caso el driver que se esta instalando, esto puede variar.

5) Reiniciamos y Listo.

P.D. Les recomiendo hacer una Copia de Seguridad del .kext que van a cambiar por si algo falla.

Saludos
Subir
mod
#521 por Teo Tormo el 30/09/2010
Aviaco escribió:
Pues igual no te funciona por algo de la BIOS del HP. En fin, mala suerte.

Saludos

No entiendo como me dices estas cosas por un foro cuando esta mañana hemos hablado por teléfono
:D :D :D :D :D :D

Recuerda, el aspirante eres tú.

Subir
#522 por Aviaco el 30/09/2010
Pues porque no habia leido tu post. De todas formas ya lo hablamos por telefono.

Saludos
Subir
#523 por solker el 30/09/2010
Weno, después de la mierda de indemnización que me han dado por el imac fundido, me planteo lo siguiente:

¿Alguien conoce alguna placa miniITX o cosas de estas pequeñas compatibles al estilo de las gigabyte con SL?

La idea sería montar algo tipo barebone o HTC, con SL, sin quebrarme demasiado la cabeza.

Visita La construcción de mi estudio
LMDL en Facbook
Move-sound studio

Subir
#524 por monarca el 30/09/2010
solker escribió:
Weno, después de la mierda de indemnización que me han dado por el imac fundido,


como que se fundio?? :shock:

Vendo Gibson SG Americana Faded con 3 pickups

Subir
#525 por solker el 30/09/2010
Subida de tensión ... estaba mayor ya de todas formas.

Visita La construcción de mi estudio
LMDL en Facbook
Move-sound studio

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo