Midi...todo problemas

  • 1
#1 por clavinord el 13/02/2015
Ahora de nuevo otro problema que ya me ocurrió en logic 9

Para empezar, decir que en la utilidad audio midi en utilidades he creado instrumentos con los puertos donde están conectados, ejemplo nord lead 2x-A..nord lead 2x-b..bass station -a , bass station B ...blofeld. Virus ti, nord lead 3 ...etc.

Pues bien, ya en logic creo una pista midi y elijo por ejemplo nord lead 2x canal 1... A partir de ahí...pincho dos veces debajo y me aparece una pista con ese instrumento y el canal siguiente....así hasta los cuatro partes muktitimbricas del nord....a continuación me voy a crear pista...elijo nord lead 2x B y me crea una pista con el canal 1... Y pulsando dos veces debajo me va creando pistas consecutivas...todo funciona genial...al día siguiente abro el proyecto y las 8 pistas (4 de cada nord) tienen el mismo puerto....y sí cambio el puerto de un nord al otro...se me cambian las 7 pistas restantes a ese puerto...pero que está pasando?...entre eso y los resets de los programas, imposible trabajar

Alguna idea?...es que acaso no va dijo logic con puertos midi?

Un saludo

it´s more fun to compute

Subir
1
#2 por finess7 el 13/02/2015
Buenas ClaviNord.

Lo que te esta pasando es muy simples de solucionar.

Tu estas a abrir una pista de cada vez? porexemplo abres una primera para el nord-A en el canal 1 midi y despues en el editor haces copypaste de la misma pista del nord-A? y solo le cambias el canal midi de la segunda pista que hiciste copypaste?

Para tudo dar cierto tienes que configurar todos los synths primero con los canales correspondientes y que neguno se cruse con el mismo canal midi, todos tiene que tener su puerto diferente.
Despues de configurares los synths porecxemplo: norde lead-A canal del 1 all 4 porque es un synth mulkti timbrial. despues el norde lead-B del 5 al 8, los bass-station-A al canal 9 y el B al canal 10, el Blofeld al canal 11, el virus ti basta abrires en el menu una pista de midi multitrack y aotomaticvamente el abrira 16 acanales solo para el virus ti y por fim el nord lead-3 se queda en el canal 12 al 16.

Y en principio está todo listo, despues para que te quedes simpre con el mis workflow sin tener que criar tudo de nuevo, vas al menu y crias un Tamplate solo con las pistas midi como un pojecto que siempre que lo abres ya esta prontito a trabajar y esta hecho.

Espero tener ayudado.

Saludos.
Subir
#3 por clavinord el 13/02/2015
Hola finess7... Muchas gracias por tu comentario...yo lo que hago es crear instrumentos en utilidades audio midi...y luego en logic creo una pista midi y asigno al instrumento que por ejemplo está en el puerto 1(ejemplo nord A)... Y a partir de ahí sí pulsas dos veces con ratón te crea una pista midi con el canal siguiente...así hasta el canal 4 con el puerto 1.... Pero luego no hago doble flickr..sino que pulso en la opción añadir pista midi,externa...y ahí elijo nord B que está en el puerto 2 del interfaces..y me crea una pista con el canal mid y el pueto 2...entonces reputo operación..doble click y me crea pista con el canal siguiente en el mismo puerto 2... Guardo proyecto para usarlo de plantilla y al,día,siguiente los 8 canales son el mismo...y sí cambió en una pista el puerto, me cambia en las siete restantes, cuando sólo 4 eran de un puerto y 4 del otro

Un abrazo

it´s more fun to compute

Subir
#4 por finess7 el 13/02/2015
Si tudo que haces esta corecto pero y en los sintes tienes condfigurado todas las puertas midi porexemplo en el nord lead-a el sonido 1 al canal midi 1 y el sonido 2 al canal midi 2 y asi sucesivamente?

Yo hace unos dias estava con un problema edentico con el virus ti2 desktop!
lo problema era que yo abria luego 16 pistas midi en external midi y despues los iva cambiando de canal uno a uno hasta el 16. pero salvava el projecto y despues quando volvia a abrirlo ya estaban todos los canales que tenia cambiado antes en el canal 1 todos.

yo solucione el problema en el menu onde abres las pistas audio/softoware instrumens/ external midi.

Lo que hice fue asi en ese mismo menu si reparaes en la parte onde diz: softoware instrumens al lado tiene una opcion onde puedes poner MULTITIMBRAL esa uso para el virus ti2 y para los otros synths que tengo uso pistas EXTERNAL MIDI.

Tenta desa forma a haver se te va biene.
despues hace un template para que no tengas que hacer simpre los mismo simpre que quieras trabajar un projecto.
Subir
#5 por clavinord el 13/02/2015
Ah, ósea que cuando,creo,una insta midi tengo,que poner muktitimbricas?...y así luego crear varias con doble click?, creo haberte entendid eso..es así?

Un abrazo y muchas gracias

it´s more fun to compute

Subir
#6 por finess7 el 13/02/2015
Si yo resolvi lo mio problema asi pero no se si hay otra forma de aregllkar este problema de los canales midi se cambiaren siempre que abres el projecto.

La manera que encontre para lo mio problema se resolveo de esa forma que te explique.

deja ver si apaece mas alguien a hablar del tema.

Porque como el virus ti tiene el suyo Vst proprio yo abro un multitrack en softoware instrumens y lo resto de los sintes los abro en external instrumens. pero no necesitas de hacer doble clique basta abrires luego el numero de pistas que vas a necesitar para todos los restantes sintes y en external instrumens degitas el numero de pistas que quieres y despues enumeras los canales midi a cada sinte.
Es la forma mas rapida y corecta para mi asi.

Saludos.
Subir
#7 por clavinord el 13/02/2015
La verdad es que me cuesta creer que tengamos estos problemas y se vayan cambiando los puertos,...cuando tuve dos virus ti tan pronto el usb1 era de un virus como de otro...con el bass station 2 me sea pasando lo mismo. Y eso que los he renombrado, uno left y otro Right, que los tengo a km derecha y a mi izquierda...pues, ...cambian también....y con lo de los nord lead...en fin. Igual...están en dos puertos y se duplican las pistas, ya que como dije,...aparecen las 8 pistas con el mismo puerto

A ti te pasa también que estás con un sonido, ejemplo banco 1 programa 37 y de repente el logic en stop te cambia al sonido 0?... Me da que va a estar relacionado con lo de las pistas,

it´s more fun to compute

Subir
#8 por finess7 el 13/02/2015
Puede ser un midi out de alguno sinte que este a enviar mensagens midi al logic.

Tenta ligar todos los synths en midi in y para lo patchbay todos en midi Out.

Y solo conectas el midi in e out al tuyo controlador midi tecalado.

Por exemplo yo tenia mi controlador M-audio axion pro con un problema en un fader y me estava siempore a enviar las mensagens midi al logic e me cambiava los parametros de de la pista que estuvese en el momento a trabajar.

Tire el cable midi in del controlador e tudo se resolveo pero es alguno boton o fader que esta malo y me hace ver en logic simpre las mensagens midi inestables simepre cambiando en numeros intrecalares...
Subir
#9 por clavinord el 13/02/2015
Ta bien lo he pensado, pero el bass station está por USB, y sí no tengo los midi out de sintes no puedo volcar sonidos por sysex etc..pufff que lío

it´s more fun to compute

Subir
mod
#10 por Jordi Torres el 13/02/2015
clavinord escribió:
Para empezar, decir que en la utilidad audio midi en utilidades he creado instrumentos con los puertos donde están conectados, ejemplo nord lead 2x-A..nord lead 2x-b..bass station -a , bass station B ...blofeld. Virus ti, nord lead 3 ...etc.


Es importante saber que esto solo sirve para que el nombre del puerto al que tienes conectado el sintetizador adopte el nombre del sintetizador (el nombre que le das al dispositivo virtual), facilitando la tarea de saber qué puerto desemboca en qué sintetizador. Esto es útil cuando se tiene cierto número de dispositivos, para no estar adivinando.

Dicho de otra manera, esto es opcional.

Saludos,

J.
Subir
mod
#11 por Jordi Torres el 13/02/2015
Hola,

clavinord escribió:
al día siguiente abro el proyecto y las 8 pistas (4 de cada nord) tienen el mismo puerto....y sí cambio el puerto de un nord al otro...se me cambian las 7 pistas restantes a ese puerto


Para evitar que esto ocurra, no uses el inspector. Asigna tus puertos y canales MIDI de tus dispositivos desde el panel de la biblioteca.

J.
Subir
#12 por clavinord el 13/02/2015
Ósea que creo una pista midi y luego en la biblioteca los asigno,....que mal, no?, si da la opción de duplicar con siguiente canal, no entiendo como hace lo que quiere con los puertos...un saludo

it´s more fun to compute

Subir
#13 por clavinord el 13/02/2015
#10 entonces incluso puedo omitir el paso de hacerlo en la utilidad audio midi no?, porque la verdad es que me da igual coger un puerto que ponga nord lead que puerto 4

Saludos

it´s more fun to compute

Subir
mod
#14 por Jordi Torres el 13/02/2015
#12 Al crear una pista de MIDI externo ocurre lo siguiente:

-Se crea una pista en el area de pistas.
-La pista estará asignada a un objeto multi-instrumento que se creará en la capa "MIDI Instr." de la ventana del entorno MIDI.
-El objeto en sí tendrá una asignación de puerto (el que elijas al crear la pista en la ventana de Nuevas Pistas)

Ahora, si decides ir al inspector y cambiar el puerto que figura allí, lo que estás haciendo es cambiarle la asignación de puerto al objeto multi-instrumento que está en la capa "MIDI Instr" de la ventana del entorno. La pista en sí sigue asignada al objeto que se creo originalmente. Si la finalidad es que la pista mande datos a un nuevo dispositivo, necesitas un nuevo objeto multi-instrumento. Esto se consigue cómodamente eligiéndolo desde la biblioteca (dispositivo/puerto > Canal MIDI).

Para que todo esté en orden, debes tener en la capa "MIDI Instr" (o en la que sea, si te pones a crear objetos manualmente) un objeto multi-instrumento por dispositivo (sinte externo). Cada uno te permitirá enviarle datos a cada sinte por hasta 16 canales MIDI.

Por cierto, nada de esto impide que crees nuevas pistas para el mismo dispositivo como ya has estado haciendo (doble click en el area de pistas).

Pero nuevamente, si quieres que una pista desemboque en un nuevo dispositivo, lo mejor que puedes hacer es abrir la biblioteca y elegir nuevo dispositivo/puerto y canal MIDI.

clavinord escribió:
entonces incluso puedo omitir el paso de hacerlo en la utilidad audio midi no?, porque la verdad es que me da igual coger un puerto que ponga nord lead que puerto 4


Sí, es opcional. Pero si tienes más de un sinte no es mala idea, para evitar hacerse un lío de puertos.

Saludos,

J.
Subir
#15 por clavinord el 13/02/2015
Ah...entiendo...pero una cosa..a ver sí he entendido...yo creo en añadir pista midi externo, una pista con el puerto 1. ..por ejemplo ..y se crea pista mid puerto 1 canal,1, ok?...a partir de ahí...doble click ..me va creando pistas consecutiva...canal 2,3 y 4....lo siguiente es crear nueva pista midi externo y ahí elijo puerto 2...(bueno con la utilidad midi audio ya elijo nord 2 que está asignado a puerto 2) me crea una pista concertó 2 y canal 1 y a partir de ahí ...doble click me crea pistas consecutivas ...eso es lo que hice al principio, no se sí es a lo que te refieres....pues al grabar el proyecto,..al día siguiente las ocho pistas iban al mismo puerto.....no se por que...

Un abrazo

it´s more fun to compute

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo