No arranco focusrite saffire pro 40

#76 por Splashman el 25/01/2011
Alguien escribió:
Haz un
ls -la /dev/raw1394

deberia salirte algo así ( permisos, propietario y grupo)

crw-rw---- 1 root audio 171, 0 2011-01-25 09:58 /dev/raw1394

Esto es para confirmar que raw1394 pertenece efectivamente al grupo audio y que el grupo tiene permisos de escritura y lectura en él.

Una vez hecho esto averiguamos si pertenecemos al grupo audio inquiriendo todos los grupos a los que pertenecemos
groups usuario | tr " " "\n" | grep audio

Todo esto está bien , responde afirmativamente
Alguien escribió:
¿Cuál es la salida del comando

cat /etc/security/limits.conf /etc/security/limits.d/audio.conf |grep -v "#"

Alguien escribió:
@audio - rtprio 99
@audio - memlock unlimited
@audio - nice -1

y de:
Alguien escribió:


ulimit -r -l

Alguien escribió:
real-time priority (-r) 99
max locked memory (kbytes, -l) unlimited

Y la salida del ffado diag
Alguien escribió:
FFADO diagnostic utility 2.999.0-1949M
============================
(C) 2008 Pieter Palmers
2009-2010 Arnold Krille


=== CHECK ===
Base system...
kernel version............ 2.6.32-24-generic
old 1394 stack present.... True
old 1394 stack loaded..... True
old 1394 stack active..... True
new 1394 stack present.... True
new 1394 stack loaded..... False
new 1394 stack active..... False
/dev/raw1394 node present. True
/dev/raw1394 permissions.. True
Prerequisites (dynamic at run-time)...
gcc ............... gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
g++ ............... g++ (Ubuntu 4.4.3-4ubuntu5) 4.4.3
PyQt4 (by pyuic4) . Python User Interface Compiler 4.7.2 for Qt version 4.6.2
jackd ............. jackd version 0.120.1 tmpdir /dev/shm protocol 24
path ............ /usr/bin/jackd
flags ........... -L/usr/lib64 -ljack -lpthread -lrt
libraw1394 ........ 2.0.4
flags ........... -lraw1394
libavc1394 ........ Package libavc1394 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libavc1394.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libavc1394' found
flags ........... Package libavc1394 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libavc1394.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libavc1394' found
libiec61883 ....... 1.2.0
flags ........... -liec61883 -lraw1394
libxml++-2.6 ...... 2.30.0
flags ........... -pthread -I/usr/include/libxml++-2.6 -I/usr/lib/libxml++-2.6/include -I/usr/include/libxml2 -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -pthread -lxml++-2.6 -lxml2 -lglibmm-2.4 -lgobject-2.0 -lsigc-2.0 -lgthread-2.0 -lrt -lglib-2.0
dbus-1 ............ 1.2.16
flags ........... -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -L/lib -ldbus-1 -lpthread -lrt
Prerequisites (static at compile-time)...
gcc ............... gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
g++ ............... g++ (Ubuntu 4.4.3-4ubuntu5) 4.4.3
PyQt4 (by pyuic4) . Python User Interface Compiler 4.7.2 for Qt version 4.6.2
jackd ............. jackd version 0.118.0 tmpdir /dev/shm protocol 24
path ............ /usr/bin/jackd
flags ........... Package jack was not found in the pkg-config search path.
libraw1394 ........ 2.0.4
flags ........... -lraw1394
libavc1394 ........ Package libavc1394 was not found in the pkg-config search path.
flags ........... Package libavc1394 was not found in the pkg-config search path.
libiec61883 ....... 1.2.0
flags ........... -liec61883 -lraw1394
libxml++-2.6 ...... 2.30.0
flags ........... -pthread -I/usr/include/libxml++-2.6 -I/usr/lib/libxml++-2.6/include -I/usr/include/libxml2 -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -pthread -lxml++-2.6 -lxml2 -lglibmm-2.4 -lgobject-2.0 -lsigc-2.0 -lgthread-2.0 -lrt -lglib-2.0
dbus-1 ............ 1.2.16
flags ........... -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -L/lib -ldbus-1 -lpthread -lrt
Hardware...
Host controllers:
01:07.0 FireWire (IEEE 1394) [0c00]: Agere Systems FW322/323 [11c1:5811] (rev 61) (prog-if 10)
Subsystem: Pinnacle Systems Inc. Device [11bd:000e]
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
Subir
#77 por Splashman el 25/01/2011
He conseguido que la tarjeta arranque obviando la parte de las sources de la pro24 referente a los firmwares ahora quiero ver las alertas estas del memlock, el ffado mixer que se ha freeze en:
Alguien escribió:
Bus reconfiguration progress, please wait...

y su log
Alguien escribió:
18:12:17 dbus: connecting to: Updated on /org/ffado/Control/DeviceManager (server: org.ffado.Control)
18:12:18 panelmanager: PanelManager::updatePanels()
18:12:18 panelmanager: going to add 00130e0402000dd1
18:12:18 panelmanager: Adding device 0: 00130e0402000dd1
18:12:18 panelmanager: Found (00130e0402000dd1, 130E, 8) Focusrite SAFFIRE_PRO_24DSP
18:12:18 registration: version/GUID combo already registered
18:12:18 matrixmixer: Mixer has 16 rows and 18 columns

Por cierto funcionan todas las salidas, entradas no lo he probado todavia y playback/recording tampoco he probado. y por supuesto el dsp y el vrm a no ser que focusrite publicase unos drivers no creo que funcione nunca (aunque estaria bien que linux tuviera un programa para ello con el que tener muchos mas plugins juas juaas)
Subir
#78 por igny el 12/06/2011
Problemas con el focusrite saffire pro 40. Saludos a todos los foreros. Ha conseguido alguien hacer funcionar este aparato con Lucid Lynx?
A mi, en concreto, después de compilar ffado y jack desde svn se llega a encender pero automàticamente me bloquea el macbook para tener que apagarlo porque no responde ni el ratón, vamos, cuelgue total.

La salida de ffado-diag muestra esto:

ffado-diag
fxavier@fxavier-laptop:~$ ffado-diag


FFADO diagnostic utility 2.999.0-1985
============================
(C) 2008 Pieter Palmers
2009-2010 Arnold Krille


=== CHECK ===
Base system...
kernel version............ 2.6.32-32-generic
old 1394 stack present.... True
old 1394 stack loaded..... True
old 1394 stack active..... True
new 1394 stack present.... True
new 1394 stack loaded..... False
new 1394 stack active..... False
/dev/raw1394 node present. True
/dev/raw1394 permissions.. True
Prerequisites (dynamic at run-time)...
gcc ............... gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
g++ ............... g++ (Ubuntu 4.4.3-4ubuntu5) 4.4.3
PyQt4 (by pyuic4) . Python User Interface Compiler 4.7.2 for Qt version 4.6.2
jackd ............. jackd version 0.120.2 tmpdir /dev/shm protocol 24
path ............ /usr/bin/jackd
flags ........... -ljack -lpthread -lrt
libraw1394 ........ 2.0.4
flags ........... -lraw1394
libavc1394 ........ 0.5.3
flags ........... -lavc1394 -lrom1394 -lraw1394
libiec61883 ....... 1.2.0
flags ........... -liec61883 -lraw1394
libxml++-2.6 ...... 2.30.0
flags ........... -pthread -I/usr/include/libxml++-2.6 -I/usr/lib/libxml++-2.6/include -I/usr/include/libxml2 -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -pthread -lxml++-2.6 -lxml2 -lglibmm-2.4 -lgobject-2.0 -lsigc-2.0 -lgthread-2.0 -lrt -lglib-2.0
dbus-1 ............ 1.2.16
flags ........... -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -L/lib -ldbus-1 -lpthread -lrt
Prerequisites (static at compile-time)...
gcc ............... gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
g++ ............... g++ (Ubuntu 4.4.3-4ubuntu5) 4.4.3
PyQt4 (by pyuic4) . Python User Interface Compiler 4.7.2 for Qt version 4.6.2
jackd ............. jackd version 0.118.0 tmpdir /dev/shm protocol 24
path ............ /usr/bin/jackd
flags ........... Package jack was not found in the pkg-config search path.
libraw1394 ........ 2.0.4
flags ........... -lraw1394
libavc1394 ........ 0.5.3
flags ........... -lavc1394 -lrom1394 -lraw1394
libiec61883 ....... 1.2.0
flags ........... -liec61883 -lraw1394
libxml++-2.6 ...... 2.30.0
flags ........... -pthread -I/usr/include/libxml++-2.6 -I/usr/lib/libxml++-2.6/include -I/usr/include/libxml2 -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -pthread -lxml++-2.6 -lxml2 -lglibmm-2.4 -lgobject-2.0 -lsigc-2.0 -lgthread-2.0 -lrt -lglib-2.0
dbus-1 ............ 1.2.16
flags ........... -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -L/lib -ldbus-1 -lpthread -lrt
Hardware...
Host controllers:
04:00.0 FireWire (IEEE 1394) [0c00]: Agere Systems FW643 PCI Express1394b Controller (PHY/Link) [11c1:5901] (rev 07) (prog-if 10)
Subsystem: Agere Systems Device [11c1:5900]
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort-
Subir
#79 por igny el 12/06/2011
Falta la respuesta de ffado-dbus-server con un archivo que parece que da conflicto

fxavier@fxavier-laptop:~$ ffado-dbus-server &
[1] 4651
fxavier@fxavier-laptop:~$ -----------------------------------------------
FFADO Control DBUS service
Part of the FFADO project -- http://www.ffado.org
Version: 2.0.0
(C) 2008, Pieter Palmers
This program comes with ABSOLUTELY NO WARRANTY.
-----------------------------------------------

Library version mismatch. (required: libffado 2.0.0, present: libffado 2.999.0-1985)
Please run this application against the exact corresponding library
it was compiled for. The most common cause for this is having more
than one version of libffado installed.

no message buffer overruns

Saludos y gracias por anticipado. Voy a probarlo en el sobremesa a ver si es cosa del mac
Subir
#80 por igny el 12/06/2011
Confirmado, debe ser cosa del mac. En el sobremesa probado y funcionando como siempre. Igual es el puertofirewire del mac que es a 800 en vez de 400.

Saludos.
Subir
#81 por chemisferio el 15/06/2011
¿Has mirado que no haya instalaciones paralelas de FFADO? El problema que propone el D-Bus service me parece bastante plausible. Borra todo lo relacionado con FFADO de donde esté instalado (/usr/bin y /usr/lib ó /usr/local/bin y /usr/local/lib normalmente) y reinstala. O si no prueba a sobreescribir la instalación anterior con el parámetro "prefix" indicando dónde estaba instalado anteriormente.

Para eliminar la versión compilada desde código fuente, en la carpeta de ffado-svn donde está alojado el código ejecuta:

#scons -c install

(para eliminar la versión de los repositorios usa apt o dpkg)

Para instalar sobreescribiendo archivos anteriores ejecuta, por ejemplo:

#scons prefix=/usr install

(sustituyendo "/usr" por el directorio padre de la instalación, si especificaste otro)

Imagino que todo esto ya lo sabrás, pero bueno, igual se te ha pasado algo.
Un saludo.
Subir
#82 por igny el 16/06/2011
Muchas gracias chemisferio, de verdad. No creas que sé tanto. Ojala¡ La ignorancia es muy grande y yo atesoro gran parte de ella. Siempre es de agradacer ayudas como la tuya.

Lo probaré, peró como soy un poco "ignorante" atajé por la tremenda y reinstalé nuevamente el sistema en el mac. He compilado el ffado dejando jack sin compilar, por si las moscas, y se sigue colgando. (dita sea :) El lunes tengo que usarlo para un proyecto de teatro escolar que no puede fallar. El martes le meto de nuevo a ver por qué leches se queda totalmente bloqueado el manzanita.

Tomo nota de tus "importantes" anotaciones para llevarlas a la pràctica.

Gracias de nuevo y ya informaré.

Salut a todos.
Subir
#83 por monon el 18/06/2011
Es muy probable que sea el FW-800

Los nuevos módulos de firewire (por defecto en Natty Narwhal) deberian funcionar y soportarlo.
Subir
#84 por igny el 19/06/2011
Comprobado monon. Con Natty ha funcionado sin compilar ni el ffado ni jack. Eso si, aparecen bastantes xruns. De todos modos me parece increíble que funcione así, a la primera. La verdad es que no estaba acostumbrado a eso. :)

Vale la pena compilar el ffado o el jack para ver si se solucionan los xruns? o lo dejo tal como està para salir del paso con el teatro y la grabación del lunes?

Muchas gracias a todos.

Salut
Subir
#85 por igny el 19/06/2011
También ha dejado de funcionar después de instalar los drivers para el wifi. Vuelta a la reinstalación y otra vez sin problemas. Por si alguien le pasa.

Salut
Subir
#86 por igny el 19/06/2011
Probando la salida del sonido, me doy cuenta de que no puedo escuchar nada. Seguimos probando

Salut
Subir
#87 por igny el 19/06/2011
Con natty, compilando ffado desde el svn y sin tocar jack se arregla el sonido.

Salut
Subir
#88 por monon el 21/06/2011
En Natty se instala jack2 cuando instalas Ardour y demás.
Así que si es jack2 lo que usas, en qjackctl debes añadir la opcion -S en la linea para lanzar jackd.
de modo que quede así.
/usr/bin/jackd -S

De todos modos aparte de eso, creo recordar haber hecho algo, y te juro que no me acuerdo de "que", para acabar completamente con los Xruns.
Cuando digo completamente, me refiero a que aguantaba con valores realmente bajos en los buffers, 2 a 32 muestras.
No sé, igual es una paranoia, un residuo en la memoria de tener siempre que hacer algo para que todo vaya fino. No sé , no sé. ¿¿Estaré perdiendo definitivamente la cordura??

Bueno lo de la opcion -S ( solo para jack2) si que funciona.
Subir
#89 por igny el 21/06/2011
Muchas gracias monon, ya has hecho demasiado amigo, no debes padecer.... :)

Tomaré nota de la -S, aunque después de probar algo natty, la cosa no parece que este muy bien afinada todavía. (ayer en el ensayo del teatro se me bloqueó una vez por la cara )

Lo que me ha desesperado un poco es que parece que el desarrollo del aparato no haya mejorado mucho, o al menos esa es mi sensación. Supongo que soy un maldito impaciente. :)
Anoche grabando el concierto de jazz tuve que recurrir al manzanita porque el portàtil con el que teniamos compilado el ffado perdió una vez la conexión con jack y nos dió miedo que pasara durante la actuación (y mira que nos jodió... :) )

Bueno amigo, sigo agradecido y mucho más....

Cuidate, i salut.

Gràcies.
Subir
#90 por monon el 21/06/2011
De todos modos, y sin saber cual fué el problema por el que jack perdío la conexion, cuando vayas a registrar y no necesites monitorizacion, date el margen de subir los buffers a 512 o mas si es conveniente.

Por cierto otra cosita que ya se ha hablado en algun otro hilo o foro, y es que, al menos con jack1 y a diferencia de "alsa", "ffado" funciona mejor con 3 buffers que con 2,
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo