No consigo activar el noatime en lion

#1 por edu28 el 10/10/2011
Hola a todos, despues de serios problemas para activar el trim consegui hacerlo a traves del terminal, despues se desactivaba el sonido que consegui corregir cambiando un parametro gracias aun compañero de otro foro pero no consigo que se active el noatime de ninguna de las maneras y no se que hacer he seguido el manual que aparece aqui de optimizar un ssd he realizado los pasos 1,2,3 (activar trim) he intente el paso 7 del manual pero no monta de ninguna manera el dichoso noatime ¿que puedo hacer? he seguido lo menos 6 manuales y ninguno ha funcionado
Subir
#2 por Ed_Saxman el 11/10/2011
Aqui tienes el script creado: http://www.mediafire.com/?l6n33sny6uldob9

Lo tienes que poner en /usr/local/bin/ además de tener el com.noatime.root.plist en la ruta /Library/LaunchDaemons/


EDITADO: Este script es solo para sistemas anteriores a lion

Ver "Uso óptimo de SSDs en sistemas OSX"

Workstations Hackintosh en AppleOSX86.com
No respondo dudas por privado. Utiliza los foros.

Subir
#3 por edu28 el 13/10/2011
no funciona no se activa
Subir
#4 por edu28 el 13/10/2011
tengo el noatime en SSD (HD) > /Library/LaunchDaemons/ con el nombre com.noatime.root.plist
el script en HD >usr/local/bin y cuando le doy a mount | grep "/" sale esto /dev/disk0s2 on / (hfs, local, journaled
lo he tratado de activar asi: (despues de poner el scrip)
sudo chmod +x /usr/local/bin/remount_noatime
sudo defaults write com.apple.loginwindow LoginHook /usr/local/bin/remount_noatime

y me dice algo como si no fueran las instrucciones correctas ya que salen muchas cosas entre corchetes

lo intente asi Crea el script /usr/local/bin/remount_noatime con el siguiente contenido:

#!/bin/bash
/sbin/mount -uwo noatime /Users/$1

Ahora abre la terminal y escribe:

sudo chmod +x /usr/local/bin/remount_noatime
sudo defaults write com.apple.loginwindow LoginHook /usr/local/bin/remount_noatime

lo intente asi:

sudo chown root:wheel /Library/LaunchDaemons/com.noatime.root.plist

mismo resultado como si la instruccion faltase algun parametro

¿se puede solucionar?
Subir
#5 por Ed_Saxman el 14/10/2011
bueno, vamos por partes.


1- Si tienes Lion, no necesitas el script para nada, solo el plist. (en /Library/LaunchDaemons/)

2- Este Plist (editado, ahora está mejor)

3- Tras reiniciar, el comando para comprobarlo es solo "mount".

Este será el resultado:

Capturadepantalla2011-10-14alas001814.png

Edito: punto 7 de la guia de uso óptimo de SSDs en sistema OSX simplificado y actualizado.

Gracias edu28 por tu persistencia. Sin testers las guias no sirven de nada.

Workstations Hackintosh en AppleOSX86.com
No respondo dudas por privado. Utiliza los foros.

Subir
#6 por edu28 el 14/10/2011
pues nada no vale sigue haciendo igual porque me sale esto:

capturadepantalla201110ma.png

y no me sale como a ti compañero....¿que pasa? tendra algo que ver con las lineas de carga del scrip?
Subir
#7 por edu28 el 14/10/2011
Se me olvidaba la version que uso es lion 10.7.2
Subir
#8 por edu28 el 14/10/2011
Otracosa por si sirve, cuando activo el trim por terminal se me inhabilita el sonido dejando el icono en gris lo arregle asi y gracias a lainformacion dada por el usuario havi de fans de apple

Edit /System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist, look for keepalive word and change the following to

para los que no me entiendan:









EnableTransactions



Label

com.apple.audio.coreaudiod

ProgramArguments



/usr/sbin/coreaudiod



KeepAlive
Subir
#9 por edu28 el 14/10/2011
EnableTransactions



Label

com.apple.audio.coreaudiod

ProgramArguments



/usr/sbin/coreaudiod



KeepAlive
Subir
#10 por Ed_Saxman el 14/10/2011
edu28 escribió:
pues nada no vale sigue haciendo igual porque me sale esto:

y no me sale como a ti compañero....¿que pasa?



No lo sé. He comprobado todo una vez más (Lion 10.7.2), y funciona corréctamente en mi equipo, el proceso es el correcto y el plist no tiene errores.

edu28 escribió:
tendra algo que ver con las lineas de carga del scrip?


El script te repito que no lo necesitas para nada en Lion. Los pasos son los que hay en el post #5 , no hay más secretos.

Gracias por lo que comentas del audio, aunque casi sería mejor que dejases el link al hilo original.

Salud.

Workstations Hackintosh en AppleOSX86.com
No respondo dudas por privado. Utiliza los foros.

Subir
#11 por edu28 el 14/10/2011
la reparacion de sionido mi compañero havi la saco de aqui: https://discussions.apple.com/thread/3203808?start=15&tstart=0
Subir
#12 por edu28 el 14/10/2011
no se si tiene algo que ver si tengo que concederle permisos al noatime ¿?
Subir
#13 por edu28 el 14/10/2011
Lo que hice despues de publicar el nuevo noatime borre el anterior que tenia en la carpeta HD (SSD en mi caso) >Lybrary > LaunchDaemons y borre la carpeta local/bin de usr donde estaba el script lo que si tengo en LaunchDaemons es un archivo que se llama com.apple.remotepairtool.plist ¿?que no se si es normal......
Subir
#14 por edu28 el 17/10/2011
Hola Ed_Saxman me prece que no me explique bien cuando me referia al script me referia al archivo com.noatime.root.plist en esta web tambien se abla del tema de gente que tampoco lo ha podido activar a ver s sacas algo en claro porque esta en ingles pero no se que dice http://forums.macrumors.com/showthread.php?t=1073640
Subir
#15 por edu28 el 17/10/2011
Me recomiendas hacer donwgrade? es decir volver a instalar la 10.6.8?
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo