Notas desordenadas en Yoshimi

#1 por ziz0u el 04/07/2011
Hola a todos,

soy muy nuevo en esto del sonido en Linux, por eso quiero disculparme de antemano por si mi pregunta es muy tonta. Tengo instalado Ubuntu Studio 11.04 y estoy probando Yoshimi, del que he leído muy buenas cosas. El caso es que estoy un poco mosqueado porque cuando pulso algunas notas en el teclado virtual que trae, estas suenan totalmente desordenadas. Por ejemplo, cuando pulso Do - Re - Mi suena Fa - Re - Lab. Así sucede a lo largo de todo el teclado.

He tocado muchas cosas y no lo he conseguido arreglar. He mirado por ejemplo en la ventana Scale > Show Scale Settings, desactivado el Microtonal, y cambiado la frecuencia del La a 440 y nada.

¿Alguien me ayuda? ¡Muchas gracias!

Néstor
Subir
#2 por Pablo_F el 04/07/2011
Hola,

¿Puedes mostrar un pantallazo de la ventana Scales?

Saludos, Pablo
Subir
#3 por ziz0u el 04/07/2011
Hola:

Esta es la ventana Scales:
ventana_scale.png

Y aquí una captura de las ventanas que estoy usando:
todas_las_ventanas.jpg

Gracias y un saludo!
Néstor
Subir
#4 por Pablo_F el 04/07/2011
Hola Néstor,

Yo lo tengo igual. No sé. Prueba a activar Microtonal y después le das a Retune.
Subir
#5 por Pablo_F el 04/07/2011
Asegúrate también, en la pestaña Alsa de Settings, que la frecuencia de muestreo en yoshimi coincide con la de jack (96000 en tu caso).
Subir
#6 por ziz0u el 04/07/2011
Gracias Pablo, pero no logro solucionarlo. El Retune no me funcionó, y la frecuencia de muestreo de Yoshimi coincide con la de jack. De hecho, he probado con varias frecuencias (44100, 96000, 48000) y Yoshimi detecta siempre cuál estoy utilizando en qjackctl y actualiza su propia configuración para ajustarla a la de éste. Sin embargo, creo que has dado en el clavo, porque cada vez que cambio la frecuencia, cambia el sonido de las teclas del Virtual Keyboard (?), pero siguen estando desordenados.

¿Es un poco extraño, no?

Gracias de nuevo y saludos,
Néstor

EDIT: Además, muchos de los sonidos están desafinados!
Subir
#7 por Pablo_F el 04/07/2011
Pues sí es extraño. A ver si algún usuario de Yoshimi te puede ayudar mejor.

Entretanto, podrías hacer la prueba con un teclado virtual independiente. Te recomiendo vmpk. No sé si te viene preinstalado pero estará en el centro de software. Lo único que no tiene puerto jack MIDI sino alsa MIDI. Entonces debes lanzar el comando "a2jmidid", y en la pestaña MIDI de las conexiones de qjackctl conectas la salida de a2j: vmpk a la entrada de yoshimi.

Saludos, Pablo

EDIT: ¿Has probado a cambiar el instrumento? ¿Has reseteado la rueda de tono que sale en el teclado virtual?
Subir
#8 por ziz0u el 04/07/2011
Pues sí, era el instrumento!! Algunos me funcionan bien y otros están desafinados y con las notas desordenadas, qué raro, no? Por ejemplo, el Sine Pad me va muy bien, pero el Resonance Pad1 desafina como antes (con las mismas notas).

Muchas gracias Pablo!

Néstor
Subir
--84263--
#9 por --84263-- el 08/07/2011
ziz0u tu pregunta no es tonta, pues acabo de enterarme de este software.A ver si puedo utilizarlo en vez del keyboard de solo dos octavas.
Acabo de verlo en el menu de tango studio.No se como va, pero a ver si me entero.
gracias i salud.
Subir
#10 por ziz0u el 08/07/2011
Hola,

ya me había olvidado de este post. Envié una pregunta sobre este error a la lista de correo de Yoshimi en Sourceforge. Si alguien quiere verla, está aquí: http://sourceforge.net/mailarchive/message.php?msg_id=27747821. Como podéis ver, me respondió uno de los desarrolladores, comentando que era un bug conocido de una anterior versión del programa. Puedo confirmar que con la versión 0.060.10 esto está totalmente arreglado y ahora el Yoshimi me va perfectamente :).

Gracias y un saludo,
Néstor
Subir
#11 por ziz0u el 08/07/2011
A Vivaldis: El programa pinta muy bien, a mí me está enganchando mucho! Pero no puedo jugar mucho que ahora estoy en exámenes :(.

Un saludo,
Néstor
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo