onda de sonido desplazada

  • 1
#1 por alt486 el 15/06/2015
Hola, a ver si podéis echarme una mano.

Estoy grabando sonido a través de la entrada de la tarjeta de sonido mi ordenador, utilizando Sound Forge.

Lo que ocurre es que en vez de ver la onda centrada sobre la línea que Sound Forge llama -Inf. la onda como por encima de esa línea. Pongo un enlace a un pantallazo para que se vea a lo que me refiero:

http://postimg.org/image/g5uy72f75/

Utilizo un micro de condensador conectado a un previo y de ahí envío la señal a la tarjeta de sonido del ordenador.

Por qué puede estar ocurriendo eso? Cuánto afecta a la calidad del sonido? Se os ocurre alguna forma de solucionarlo para que no pase?

Saludos y gracias.
Subir
#2 por SG-Bass el 15/06/2015
Pues desconozco cuál puede ser la causa, es una desviación bastante bestia, pero para solucionarlo puedes emplear un supresor de contínua (Remove DC offset, o algo así). O equivalentemente, emplea un filtro paso alto con una frecuencia de corte muy baja (alrededor de 20Hz). Eso centrará tu forma de onda.

No te fíes de las cosas correctas que se hacen por la razón equivocada. El porqué es la base.

Subir
#3 por alt486 el 15/06/2015
Gracias.

Sigo intentando descubrir si hay alguna manera de que se grabe sin ese desplazamiento.

Si no, intentaré utilizar lo que me propones para solucionarlo.
Subir
#4 por Tio Harpo Molon el 15/06/2015
No se ve el enlace a la foto, la puedes subir nuevamente?. Pero asumiendo que sea un DC offset lo que hay que revisar es como estas grabando. Un DC offset es cuando tu señal posee una corriente continua.

A que entrada de la tarjeta estas conectando el previo?
Subir
--589235--
#5 por --589235-- el 15/06/2015
Esta es la imágen:
inf.jpg
Subir
#6 por vagar el 15/06/2015
Aquí sí se ve el gráfico, tiene un desplazamiento DC positivo a unos -27 dBFS. Aunque luego le quite el desplazamiento, se le queda el margen dinámico hecho unos zorros.

¿Qué interfaz de audio usas, la integrada en la placa base o una de más calidad? Una interfaz con entradas balanceadas te quitaría la continua sin problemas.

Ars longa, vita brevis.
Mi colección de enlaces web en diigo.

Subir
#7 por Tio Harpo Molon el 15/06/2015
Dogbert escribió:
Esta es la imágen:


No, tampoco la veo, no se que pasará, pero si confirman que es un DC offset pues lo que tiene que hacer es explicar como lo está haciendo para poder identificar el punto en donde está ocurriendo.
Subir
#8 por alt486 el 15/06/2015
He subido la imagen a otro sitio, no sé qué ocurría para que no se viese:

http://subefotos.com/ver/?f418e8284a05db4dff565431667e2a94o.jpg
f418e8284a05db4dff565431667e2a94o.jpg
Igarrido, utilizo la tarjeta de sonido integrada en la placa. Me da el mismo desplazamiento tanto por la entrada de micrófono como por la de line in.
¿Puede ser un problema de drivers?
Subir
#9 por vagar el 15/06/2015
Todo es posible, pero me imagino que será más bien un problema eléctrico, posiblemente alguno de los elementos estará flotante en vez de a la masa común, habría que revisar los cables y las conexiones. En cualquier caso, usar un micro-previo para entrar a una interfaz integrada es como usar un coche deportivo en una ciudad. Prueba con un micro barato de PC o mira a ver si puedes invertir algo en una interfaz de audio decente PCI o USB.

Ars longa, vita brevis.
Mi colección de enlaces web en diigo.

Subir
#10 por alt486 el 15/06/2015
Gracias por todos los consejos.

Tendré en cuenta lo del interfaz de audio.
Subir
#11 por SG-Bass el 15/06/2015
#8 He editado el post para que la imagen sea visible en el foro. Utiliza la etiquetas IMG que encotrarás en el apartado bbcode para editar tus posts.

No te fíes de las cosas correctas que se hacen por la razón equivocada. El porqué es la base.

Subir
#12 por papitu el 15/06/2015
No se por que te pasa pero en Soundforge tienes el processo DCoffset.. automatico y te lo centra.

Mi canal YouTube
https://www.youtube.com/user/pivotao

Subir
#13 por e_mac el 15/06/2015
Según la imagen parece efectivamente una desviación de corriente continua (DC Offset). En las estadísticas (menú Tools> estadísticas) se puede ver el porcentaje de señal desviada.
O sea, totalmente de acuerdo con SG-Bass e Igarrido (por cierto, un saludo).

papitu escribió:
No se por que te pasa pero en Soundforge tienes el processo DCoffset.. automatico y te lo centra.

A veces, no del todo, pero puede ser reducido en gran parte.

Saludos.

Mirar los manuales de tus aparatos es tu función, no la mía.
Si consideras positiva mi aportación, dale al "me gusta",
justo aquí.

Subir
#14 por papitu el 15/06/2015
e_mac escribió:
A veces, no del todo, pero puede ser reducido en gran parte.


Si en automático no lo reduce del todo, se puede dar el valor manualmente a tu antojo.
Archivos adjuntos:
DC offset.jpg
BBCode:

Mi canal YouTube
https://www.youtube.com/user/pivotao

Subir
#15 por e_mac el 15/06/2015
UGG! Esa versión es "mu modelna pa mí" :paletas: . Yo todavía estoy en SF7 :triston:

Mirar los manuales de tus aparatos es tu función, no la mía.
Si consideras positiva mi aportación, dale al "me gusta",
justo aquí.

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo