Patchage

  • 2
mod
#16 por Irwin J. Cespedes el 26/07/2011
Pablo_F escribió:
Puedes poner una sesión de las que fallan (veo que son cortas y con pocas pistas) en dropbox o ubuntuone o donde quieras. A ver si me la bajo y veo algo raro aquí.


Yo también me ofrezco a probarlo ya que parece un comportamiento muy, muy extraño

Ruta 27, Mi nuevo tema hecho en GNU/Linux: https://soundcloud.com/altiplane/ruta-27

También soy Altiplane, esta es mi música.

Subir
--145306--
#17 por --145306-- el 26/07/2011
¿Guardo el proyecto y lo subo entero?..¿a eso se referis?...Perdon,soy muy torpe.
Pd. Tienes razon Pablo,pero me quedan tres dias para entregar un trabajo y quizas me deje llevar por la intencion de que no me pasara en Ardour3. Sorry.
Subir
#18 por Pablo_F el 26/07/2011
Sí, comprimes la carpeta del proyecto a un archivo tar.gz y la subes.

Otra cosa, te sugiero que pruebes a actualizar la versión de jack. Para ello, en tango studio, añades y activas el repositorio "unstable" como se explica aquí [1] y actualizas jackd.

[1] http://tangostudio.tuxfamily.org/en/apt-repository

Saludos, Pablo
Subir
--145306--
#19 por --145306-- el 27/07/2011
Acabo de actualizar Jackd y el Dsp no sube de 1.6 :shock:

Pruebo de nuevo y subo una captura.
Subir
--145306--
#20 por --145306-- el 27/07/2011
Nada..se sigue quedando pillado,dita sea...te mando el proyecto.

Joder,tengo la extraña sensacion de que os estoy haciendo perder el tiempo :(
¡¡Todo el sistema se me vuelve inestable!!
Y lo peor de todo es este log.

dmesg escribió:
16.575431] end_request: I/O error, dev sr0, sector 0


Me da este error multiples veces al arrancar...¿tendra algo que ver?
Subir
--145306--
#21 por --145306-- el 27/07/2011
Subir
mod
#22 por Irwin J. Cespedes el 27/07/2011
Salomòn escribió:
Sonidos xombies_Ardour


Salomón, creo que pusiste mal el enlace, por que me da directo a la página de inicio de MediaFire.

Ruta 27, Mi nuevo tema hecho en GNU/Linux: https://soundcloud.com/altiplane/ruta-27

También soy Altiplane, esta es mi música.

Subir
#23 por Pablo_F el 27/07/2011
Alguien escribió:
16.575431] end_request: I/O error, dev sr0, sector 0

/dev/sr0 suele ser el lector de CD/DVD.

Alguien escribió:

Salomón, creo que pusiste mal el enlace, por que me da directo a la página de inicio de MediaFire.

Me pasa igual que a Irwin
Subir
--145306--
#24 por --145306-- el 27/07/2011
Pues a mi si me enlaza #-o

Esperar..lo subo a otro sitio
Subir
--145306--
#25 por --145306-- el 28/07/2011
Ostias..se me olvido poner el link.. :(
Os pido disculpas,estoy muy liado ahora...Temas personales...a parte del off-topic..en serio..disculpadme.
Proyecto Ardour.

A ver si este va bien.
Subir
mod
#26 por Irwin J. Cespedes el 28/07/2011
Hey Salomón, luego de bajar los archivos, trate de pasarlos a FLAC, y a mi tampoco me dejo, lo hice en WAV, y tampoco, pero en OGG Vorbis si me dejo. Aun así, da este error extraño:

Ardour2 Console escribió:

[WARNING]: control protocol "Wiimote" is not known. Ignored
[INFO]: Loading session /home/irwin/Desktop/sonidos xombies using snapshot sonidos xombies (1)
Loading history from '/home/irwin/Desktop/sonidos xombies/sonidos xombies.history'.
[ERROR]: could not reconstitute MementoCommand from XMLNode. object type = N6ARDOUR13AudioPlaylistE id = 70
[ERROR]: could not reconstitute MementoCommand from XMLNode. object type = N6ARDOUR13AudioPlaylistE id = 70
[ERROR]: could not reconstitute MementoCommand from XMLNode. object type = N6ARDOUR13AudioPlaylistE id = 70
[ERROR]: could not reconstitute MementoCommand from XMLNode. object type = N6ARDOUR13AudioPlaylistE id = 70
[ERROR]: could not reconstitute MementoCommand from XMLNode. object type = N6ARDOUR13AudioPlaylistE id = 70
[ERROR]: could not reconstitute MementoCommand from XMLNode. object type = N6ARDOUR13AudioPlaylistE id = 70
[ERROR]: could not reconstitute MementoCommand from XMLNode. object type = N6ARDOUR13AudioPlaylistE id = 70
[ERROR]: could not reconstitute MementoCommand from XMLNode. object type = N6ARDOUR13AudioPlaylistE id = 70
[ERROR]: could not reconstitute MementoCommand from XMLNode. object type = N6ARDOUR13AudioPlaylistE id = 70
[ERROR]: could not reconstitute MementoCommand from XMLNode. object type = N6ARDOUR13AudioPlaylistE id = 70
[ERROR]: could not reconstitute MementoCommand from XMLNode. object type = N6ARDOUR13AudioPlaylistE id = 70
[ERROR]: could not reconstitute MementoCommand from XMLNode. object type = N6ARDOUR13AudioPlaylistE id = 70


Después de acomodar los tracks que están en la barra lateral, lo pude convertir, pero a la hora de abrir el proyecto aparece esto. Invoco a Pablo_F ya que nunca había visto este error :-k

Ruta 27, Mi nuevo tema hecho en GNU/Linux: https://soundcloud.com/altiplane/ruta-27

También soy Altiplane, esta es mi música.

Subir
#27 por Pablo_F el 28/07/2011
Hola,

Me da el mismo error que a Irwin. He borrado los archivos .history y deja de dar el error.

Al exportar "sonidos xombies" a flac 8 bit 44100 Hz (como lo tenías) el archivo resultante es inválido. Cambio a 16 bits y ya va bien. Cambio a wav, 16 bit 44100 Hz y también va bien. La otra sesión, "prueba hispasonic" va bien desde el principio (y tampoco da los errores de MementoCommand).

O sea, que quitando estos detalles, aquí funciona.

La propuesta que yo te haría sería no convertir frecuencia o, en su defecto, utilizar un algoritmo de conversión más ligero. Sospecho que es esto lo que hace colgarse el ordenador.

Es decir, si quieres que el resultado final sea wav 16 bit 44100 Hz, entonces lanza jack (y por ende, ardour) a esa frecuencia. Lo malo que como ya tienes los originales a 48.000 Hz, tendrás que convertir frecuencia de antes. Te propongo este script:


#!/bin/bash
#
# conv-frec44
#
mkdir original
for i in *.wav; do
#0 es la mejor calidad, ver "sndfile-resample --help"
sndfile-resample -to 44100 -c 0 "$i" "${i%.wav}44.wav"
mv "$i" original/"${i%.wav}.wav.original"
mv "${i%.wav}44.wav" "${i%.wav}.wav"
done

(Necesitas el paquete "samplerate-programs")

Lo copias a un archivo de texto plano en un directorio que esté en la variable $PATH, por ejemplo ~/.bin, lo llamas conv-frec44 y le das permiso de ejecución (creo que esto ya sabes cómo hacerlo). Dentro de la sesión ardour navegas hasta ...sesion-ardour/interchange/nombre-de-sesion/audiofiles/ (si tienes instalado nautilus-open-terminal, abres la terminal con el botón derecho en esa carpeta, si no, navegas con la misma terminal hasta ahí).

Y entonces lanzas el comando conv-frec44 que convertirá la frecuencia de muestreo a 44100 Hz y guardará los originales en una subcarpeta (si quieres la borras luego o modificas el script para que elimine los originales).

Ahora tendrías que modificar el archivo de sesion.ardour. Lo abres con gedit y en una de las primeras líneas cambias 48000 a 44100 (esto es para que no te de aviso al abrirlo pero tampoco pasa nada si no lo haces). Ahora ardour se abrirá con los archivos de audio a 44100 y ya no habrá que hacer conversión.


Alternativamente, prueba a usar un logaritmo de conversión más ligero al exportar en ardour.

Que yo sepa, ardour y sndfile-resample usan la misma librería de conversión de frecuencia, libsamplerate, también conocida como "Secret rabbit code". En su mejor calidad (excelente en ardour, -c 0 en sndfile-resample) tira más de la CPU. No tengas miedo por la "pérdida de calidad". Un humano no lo va a notar. Para referencia: http://src.infinitewave.ca/

Saludos, Pablo
Subir
--145306--
#28 por --145306-- el 02/08/2011
Tanto a Pablo como a Irwin.
De veras que os agradezco de todo corazon que os involucrarais en mi problema con Ardour.
He tenido ciertos "problemillas" personales y he tenido que dejar aparcado el asunto.
Os pido disculpas.
En breve me pondre a aplicar lo explicado.
Un saludo muy grande.
Salomon.
Subir
--145306--
#29 por --145306-- el 05/08/2011
#27 Bueno,Ahora si me renderiza bien..aunque hace el amago como de quedarse pillado.
Te hare caso e ire con la frcuencia de muestreo desde Jack..
Pd:Copio el Scripts para futuros usos..
Gracias amigos,y perdon la demora.
Un saludo.
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo