Problema con Ardour3, Help!

#1 por pdro74 el 01/02/2012
Pues que tengo una sesión casi acabada, pero no se abre. Al arrancar jack me sale esto:
jackd 0.121.3
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:M2496|hw:M2496|1024|2|44100|0|0|nomon|swmeter|-|32bit
configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback
12:55:14.535 Cambios en las conexiones JACK.
12:55:14.537 Configuración del servidor salvada en "/home/pedro/.jackdrc".
12:55:14.540 Reiniciar estadísticas.
12:55:14.553 Cliente activado.
12:55:14.557 Script de post - inicio...
12:55:14.558 a2jmidid -e&
12:55:14.565 Cambio en el tamaño de buffer (1024).
JACK MIDI <-> ALSA sequencer MIDI bridge, version 7 (b169fb6b8e9e11ce1488d1964649aabedbb89ddf) built on Thu Jan 1 01:00:00 1970
Copyright 2006,2007 Dmitry S. Baikov
Copyright 2007,2008,2009,2011 Nedko Arnaudov
Bridge starting...
Using JACK server 'default'
Hardware ports will be exported.
port created: Midi Through [14] (capture): Midi Through Port-0
port created: Midi Through [14] (playback): Midi Through Port-0
Bridge started
Press ctrl-c to stop the bridge
port created: Q49 [16] (capture): Q49 MIDI 1
port created: Q49 [16] (playback): Q49 MIDI 1
port created: UX16 [20] (capture): UX16 MIDI 1
port created: UX16 [20] (playback): UX16 MIDI 1
port created: M Audio Audiophile 24/96 [28] (capture): M Audio Audiophile 24/96 MIDI
port created: M Audio Audiophile 24/96 [28] (playback): M Audio Audiophile 24/96 MIDI
12:55:14.962 El script de post - inicio finalizó satisfactoriamente.
12:55:14.964 Cambios en las conexiones JACK.

y al intentar cargar la sesión en cuestión en Ardour3:

13:05:55.935 Cambió el gráfico de conexiones de JACK.
13:05:56.004 Cambios en las conexiones JACK.
subgraph starting at a2j timed out (subgraph_wait_fd=16, status = 0, state = Finished, pollret = 0 revents = 0x0)
pp: cannot clean up byte from graph wait fd (Resource temporarily unavailable)
13:06:11.850 XRUN callback (1).
**** alsa_pcm: xrun of at least 0.980 msecs
bad status (-1) for client a2j handling event (type = 8)
13:06:11.904 Cambió el gráfico de conexiones de JACK.
subgraph starting at ardour lost client
bad status (-2) for client ardour handling event (type = 8)
**** alsa_pcm: xrun of at least 10.152 msecs
cannot read server event (Connection reset by peer)
zombified - calling shutdown handler
[33mWARNING: [0mJACK server shutdown notification received.
Bridge stopping...
13:06:12.132 Cambió el gráfico de conexiones ALSA.
13:06:12.134 Cambios en las conexiones JACK.
port deleted: Midi Through [14] (capture): Midi Through Port-0
cannot send request type 2 to server
cannot read result for request type 2 from server (Broken pipe)
port deleted: Q49 [16] (capture): Q49 MIDI 1
cannot send request type 2 to server
cannot read result for request type 2 from server (Broken pipe)
port deleted: UX16 [20] (capture): UX16 MIDI 1
cannot send request type 2 to server
cannot read result for request type 2 from server (Broken pipe)
port deleted: M Audio Audiophile 24/96 [28] (capture): M Audio Audiophile 24/96 MIDI
cannot send request type 2 to server
cannot read result for request type 2 from server (Broken pipe)
port deleted: Midi Through [14] (playback): Midi Through Port-0
cannot send request type 2 to server
cannot read result for request type 2 from server (Broken pipe)
port deleted: Q49 [16] (playback): Q49 MIDI 1
cannot send request type 2 to server
cannot read result for request type 2 from server (Broken pipe)
port deleted: UX16 [20] (playback): UX16 MIDI 1
cannot send request type 2 to server
cannot read result for request type 2 from server (Broken pipe)
port deleted: M Audio Audiophile 24/96 [28] (playback): M Audio Audiophile 24/96 MIDI
cannot send request type 2 to server
cannot read result for request type 2 from server (Broken pipe)
13:06:12.580 Cambió el gráfico de conexiones ALSA.
13:06:12.597 XRUN callback (1 omitidos).
Bridge stopped
13:06:12.644 Cambió el gráfico de conexiones ALSA.

Q49 es un teclado midi, y UX16 un cable midi usb para un sampler externo

¿Porque no se carga? ideas?
Gracias

http://pgfmusic.com/

Subir
#2 por pdro74 el 01/02/2012
otras sesiones si que las abre, por cierto

http://pgfmusic.com/

Subir
#3 por catorze el 01/02/2012
A mi hay sesiones que me las habre al quarto intento o al reiniciar jack ¿ 8-[ ? ni idea, a veces quitando los plugins cuando se habre me funciona bien, tambien creo que las que creé con el beta1 luego con el beta2 me fallaba, esperemos que con el beta3 vaya mejor la cosa ;)
Salut!
Subir
#4 por joanillo el 01/02/2012
Veo que utilizas a2jmidid -e para tener todos los puertos ALSA jackeados. Concretamente tienes el Q49 y el cable UX16, y la interficie M-Audio. Todo ello por USB. La pregunta es: ¿has cambiado las conexiones USB de orden? ¿has añadido o quitado alguna cosa?
Subir
#5 por Pablo_F el 01/02/2012
Complementado lo anterior, yo haría esto antes que nada:

1) Hacer una copia del archivo de sesión de ardour.

cp sesion.ardour sesion.ardour.copia

2) Lanzar ardour desde la línea de comandos a ver de qué se queja el propio ardour.

ardour3 sesion.ardour

3) Probar a quitar la opción -e de ajmidid en qjackctl y volver a lanzar ardour como en el paso anterior.

El archivo de sesión es un xml que, si se descubre el problema, se puede intentar arreglar desde un editor de texto.

De todas formas sería bueno informar del problema en el bug tracker de ardour.

Saludos, Pablo
Subir
#6 por pdro74 el 02/02/2012
Gracias a todos, he probado varias cosas:
-como A3 abre las demás sesiones que tengo, y jack funciona perfectamente, deduzco que el problema está "dentro" de la sesión en cuestión. Quizá era un problema de sobrecarga, 5 minutos con 20 pistas audio y 10 de midi, y con video sincronizado con Xjadeo, en un AMD Athlon x2 (ya estoy ahorrando)
-todas las conexiones y aparatos están igual que siempre, no creo que haya venido por ahi tampoco
-cierto que hay algunos problemillas al abrir con esta beta sesiones de la beta anterior, pero esta sesión era nueva, asi que tampoco
-he probado a abrir otra sesión y entonces, desde el menú, abrir la que da problemas. Es entonces cuando A3 se cierra

Gracias a que Ardour es opensource, he podido echar un vistazo dentro de los archivos de la sesión. No tengo ni idea de como arreglar un archivo .xml, pero en la carpeta "interchange" se guardan todas las regiones tanto de audio como de midi. Al final lo he arreglado importando los archivos midi en Qtractor y los audios en A2, y reconstruyendo el proyecto a partir de ahí. Ya lo he acabado y me ha quedado incluso mejor que antes! Gracias otra vez
Pedro

http://pgfmusic.com/

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo