Problema con cuantización Audiowarp (Cubase 7.5)

#1 por SimónDA el 13/07/2016
Hola, expongo mi situación:

Desde hace años, para cuantizar baterías reales grabadas en multipista he utilizado el método tradicional de fijar los hitpoints en bombo y caja (o las pistas que sean), haces slices, cuantizar, corregir errores, hacer fades, hacer bounce.

Nunca me había tomado el tiempo, por pereza y falta de necesidad, de aprender a hacerlo con la opción del AudioWarp, que parece ser menos engorrosa (sabía en qué consistía pero simplemente nunca le había dedicado un rato a usarla).

Esta mañana, aprovechando que tengo que hacer una mezcla, y que grabé las baterías la semana pasada, decidí cuantizar algunas partes usando el audiowarp,.Me llevó apenas unos minutos "entender" lo que había que hacer, un par de consultas al manual y tutoriales en youtube. A pesar de que el manual aclara que la cuantización multipista con AudioWarp no conserva la coherencia de fases, lo probé y comprobé que tanto auditiva como visualmente no se notaban problemas de fase por ninguna parte entre las distintas pistas de la batería, por lo que supuse que estos problemas serían críticos forzando grandes variaciones de tempo. Estaba maravillado con lo fácil que era, ahorrando mucho tiempo con respecto al método que comenté anteriormente, e incluso permitiéndome cuantizar ritmos bastante rápidos y complejos más facilmente que haciendo slices y fades.

Dediqué varias horas a cuantizar distintas partes de la batería en distintas canciones y, cuando creía que me había ahorrado un montón de tiempo gracias al AudioWarp, probé a exportar y mi primera sorpresa fue comprobar que la versión exportada no era ni igual a las pistas originales, ni igual a las pistas modificadas que yo había hecho (solo unos pocos bombos y cajas seguían perfectamente pegados a la rejilla, la mayoría volvían a estar o bien anticipados o retrasdos). Pensé que era un error mío, lo volví a intentar con el mismo resultado. Lo busqué en internet, y para mi sorpresa me encuentro decenas de hilos en diferentes foros de muchísimas personas reportando el mismo problema: horas de edición, para luego ver que era imposible hacer bounce de esas ediciones hechas con el AudioWarp.... insólito. He probado exportar las pistas, hacer bounce, hacer freeze de las pistas, grabar stems a través de buses de grupo haciendo playback, incluso creando una pista y poniendole el Main Out como entrada, es decir grabando el playback del master, y nada funciona!, es decir, que la herramienta AudioWarp solo sirve para pasar el rato mientras estás en Cubase, pero no sirve realmente para editar el tempo de una canción, ya que nunca lo vas a poder exportar? esto parece no tener sentido, pero increíblemente es así.

Ya por último, comentar que he visto hilos reportando esto desde hace más de 4 años!, desde el Cubase 6 si no me equivoco, me parece totalmente absurdo, no entiendo cómo se puede desarrollar una herramienta tan cojonuda y aparentemente compleja, para que luego sea completamente inútil, ya que solo funciona dentro de la sesión.

He sido incapaz de encontrar solución a esto, y encima he leído que el problema persiste en el Cubase 8 (yo voy por el 7.5)... ¿alguien ha logrado encontrar solución a este problema?¿a alguien más le ocurre?¿a alguien más le parece totalmente absurdo?¿soy el único que piensa que la herramientas es 100% inútil si los cambios que haces no se mantienen al exportar?
Subir
#2 por SimónDA el 13/07/2016
Bueno, he seguido mirando esto (ya que he tirado la mañana, tiro la tarde también, con tal de averiguar un poco más). Me respondo a mí mismo por si alguien se encuentra con este problema más adelante, así tendrá algo más de información.

En el foro oficial de Steinberg leí que el problema es la exactitud del algoritmo, visualmente el Cubase te representa la onda de una manera (como si coincidieran perfectamente con la rejilla (después de cuantizar)) pero en la realidad no es tan exacto (es decir, que lo que ves no es lo que oyes), y falla más gravemente mientras más grande (en longitud de tiempo) sea el archivo en el que estás aplicando el AudioWarp. Sin embargo, dicen que para la versión 7.5.40 y 8 en adelante han mejorado la exactitud del algoritmo (supongo que de todos, porque hay varios, yo estoy usando el Elastique Pro Time).

Comprobé que yo tenía la versión 7.5.00, y antes de actualizar a la 7.5.40 hice una comparativa exacta entre 3 versiones de un mismo track de bombo: original, la versión modificada en tiempo real por el AudioWarp que te muestra el Cubase, y exportado (post audio warp), y las diferencias eran abismales, la pista exportada no era igual ni a la original ni a lo que muestra el AudioWarp en tiempo real, pero no solo es que no fuera "exacto", sino que habían bombos que el AudioWarp dejaba más lejos de la rejilla de lo que estaban originalmente.

Posteriormente he actualizado de la v.7.5.00 a la v.7.5.40. Volví a hacer la comparación y efectivamente, aunque en tiempo real te muestran algo que no es, el algoritmo sí parece estar mejorado, y las inexactitudes son menos graves (al menos no parece estar EMPEORANDO el tempo del track).

Conclusión: la opción de cuantizar con AudioWarp funciona mal, en algunos casos directamente empeora lo que estás haciendo, si quieres arreglar algo tan crítico como una ejecución de batería o instrumento percusivo en general, supongo que para modificar voces, pads, o cosas por el estilo, no será tan importante. Se ve quevan mejorando el algoritmo a medida que van avanzando las versiones, pero aquí mismo podéis ver un vídeo en el que comprueban que sigue funcionando imperfectamente en la versión 8 de Cubase: https://www.youtube.com/watch?v=SmCtljDFR7k&list=UUnav5VgVHpIvqGmdDjdXNAQ

Personalmente prefiero seguir usando el método de slices siempre que me sea posible, ya que lo que ves en la pantalla es lo que estás oyendo, y además te evitas cualquier problema de coherencia de fases, y lo del AudioWarp lo dejo en algún caso extremo en el que el otro método no me solucione lo que quiero hacer,

Saludos
Subir
#3 por Pollobailando el 16/07/2016
Hola!!
El Audiowarp en baterías afecta a la relación de fase, por eso el método mas acertado para cuantizar baterías es el de Hitpoints + panel de cuantizacion.
Respecto al volcado... Has probado la función "Aplanar" en el menú del editor de audio? Según recuerdo, esa función aplica los cambios de warp al audio.
Un saludo!!

Eres mas malo que el plástico de una eLicenser.

Subir
#4 por SimónDA el 16/07/2016
Hola, gracias por la respuesta.

Sí, soy consciente de que afecta la relación de fases, lo aclaran en el manual, aún así lo apliqué y en ciertos puntos y no notaba ni visual ni auditivamente problemas con la fase (eran correcciones ligeras, no cambiar el tempo exageradamente). Aún así el problema que expuse no tiene que ver con la relación de fases, sino con que lo que visualmente se supone que está haciendo el audiowarp (pegar los hitpoints a la rejilla) no es realmente lo que está haciendo. Puedes hacer la prueba tú mismo, aplica audiowarp a un audio y luego exporta, haz el flatten como tu haz dicho, congela la pista, graba un stem, lo que quieras, y luego comprueba donde caen los transientes, y verás que NO corresponde con la referencia visual de la pista que tiene audiowarp, es decir, un timo, el algoritmo no funciona bien, pero la referencia visual te hace creer que sí.

Escribí directamente a Steinberg en un vídeo de youtube, y la respuesta que obtuve es "This is something that used to happen on Cubase 7, was a bug and now with Cubase Pro 8.5 and the Elastic 3 algorithm has been fixed. ", es decir, que AHORA lo han arreglado (en teoría), y si quiero que funcione bien, tengo que gastar casi 200€ en actualizarme de la 7.5 a la 8.5, cuando es una herramienta por la que yo ya pague, y debería funcionar bien en mi versión, si arreglan el algoritmo tienen que sacar un parche gratuito, porque no es una herramienta NUEVA, sino una corrección de un fallo. Pero bueno, así funciona las cosas lamentablemente.

Aquí hay un vídeo de un tío comprobando que el error todavía existe en la versión 8: https://www.youtube.com/watch?v=SmCtljDFR7k&t=0s
así se puede entender mejor lo que yo quiero decir.
Subir
#5 por Pollobailando el 17/07/2016
Pues manda huevos que no solucionen un fallo de una función por la que hemos pagado.

Eres mas malo que el plástico de una eLicenser.

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo