Problema con m-audio radium 61

#1 por veguita el 17/11/2011
Tengo un problema con un teclado m-audio radium 61. Que es un controlador midi usb. En resumen no aparece listado entre los dispositivos al conectarlo.

Esto es lo que aparece cuando lo conecto en las últimas líneas de dmesg

Alguien escribió:
[ 192.770016] usb 3-3: new full speed USB device number 18 using ohci_hcd
[ 192.903342] usb 3-3: device descriptor read/64, error -62
[ 193.140012] usb 3-3: device descriptor read/64, error -62
[ 193.373342] usb 3-3: new full speed USB device number 19 using ohci_hcd
[ 193.506672] usb 3-3: device descriptor read/64, error -62
[ 193.743357] usb 3-3: device descriptor read/64, error -62


al hacer lsusb no me aparece ningún dispositivo listado

Alguien escribió:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


No sé que es lo que ocurre, hasta ayer funcionaba sin problemas.

"tengo una soledad tan concurrida que puedo organizarla como una procesión"
Mario Benedetti

Subir
#2 por veguita el 17/11/2011
Les cuento, en mi computador antiguo (no actualizado) funciona sin problemas. Voy ver que pasa si instalo un kernel más antiguo.

"tengo una soledad tan concurrida que puedo organizarla como una procesión"
Mario Benedetti

Subir
#3 por andriu el 17/11/2011
Y como tarjeta aparece si haces un $ cat /proc/asound/cards

Yo nunca he tenido ningun problema y tengo un M-Audio Keystation 49e y un Keystudio 25

Decibelios Linuxeros

Subir
#4 por veguita el 18/11/2011
Yo también tengo otros m-audio un Prokeys 88 y un oxygen. Ambos me funcionan sin problemas. El Radium requería un firmware especial el midisport-firmware, fue muy complicado hacerlo funcionar, ya que es un modelo antiguo.

Lo peor es que tocamos el sábado y necesito dos teclados. El Prokeys 88 no es una opción por lo pesado que es. Obligatoriamente necesito el el oxygen y el radium

------0-------

Acabo de conectar el teclado

Esto me sale en dmesg:
Alguien escribió:
[17968.558268] usb 3-3: new full speed USB device number 6 using ohci_hcd
[17974.463183] usb 3-3: USB disconnect, device number 6
[17975.446384] usb 3-3: new full speed USB device number 7 using ohci_hcd
[17977.039500] usbcore: registered new interface driver snd-usb-audio


Esto me sale en lsusb:
Alguien escribió:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 006: ID 19d2:0031 ONDA Communication S.p.A. ZTE MF110/MF636
Bus 001 Device 003: ID 174f:5216 Syntek
Bus 003 Device 007: ID 0763:1015 Midiman M-Audio Keystation


Esto me sale en cat /proc/asound/cards :
Alguien escribió:
0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0x52500000 irq 16
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0x52410000 irq 19
2 [Keystation ]: USB-Audio - Keystation
M-Audio Keystation at usb-0000:00:12.0-3, full speed


y funciona :?:

No tengo idea, perdí casi tres desde que me ocurrió el error hasta que hice la pregunta, y ahora me funciona como si el error nunca hubiese existido :-s
Voy a encender un par de velitas a todos los dioses que conozco para que el error no vuelva a ocurrir [-o<

"tengo una soledad tan concurrida que puedo organizarla como una procesión"
Mario Benedetti

Subir
mod
#5 por Irwin J. Cespedes el 18/11/2011
Veguita, estuve investigando el error, y encontré dos posibles soluciones (esta vez no me ha tocado a mi, pero ambos se ven lógicos, mucho más el segundo) Te dejo dos links, para que investigues. Pero te recomiendo que comiences por la segunda opción.

http://ubuntuforums.org/showthread.php?t=797789&page=2

http://www.linuxquestions.org/questions/debian-26/problems-getting-external-usb-hard-drive-to-work-348794/

Y a rezar al Chamuco :satan:

Ruta 27, Mi nuevo tema hecho en GNU/Linux: https://soundcloud.com/altiplane/ruta-27

También soy Altiplane, esta es mi música.

Subir
#6 por veguita el 18/11/2011
Gracias Irwin y Andriu.
Seguí las instrucciones del primer link, y no funcionó :(
Pero luego se me ocurrió apagar el teclado, conectarlo al usb y luego encenderlo y funciona :)

No sé si la respuesta está en las instrucciones del link o que en adelante tendré que conectar el teclado apagado y encenderlo una vez conectado al PC.

También debo decir que es un error aleatorio, como comentaba en el mensaje #4 ayer me funcionó inusitadamente una vez que lo conecté, aunque al reiniciar ya dejó de funcionar.

Lo bonito y lo importante es que el teclado funciona.

PD: El downgrade del kernel no funcionó.

"tengo una soledad tan concurrida que puedo organizarla como una procesión"
Mario Benedetti

Subir
#7 por andriu el 18/11/2011
Tienes tarjeta con midi? por cable midi va?

Decibelios Linuxeros

Subir
#8 por veguita el 20/11/2011
Conecto ambos teclados por el USB, no tengo tarjeta de sonido externa.

"tengo una soledad tan concurrida que puedo organizarla como una procesión"
Mario Benedetti

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo