Problema con MIDI en Motu Ultralite MK3!!

  • 1
#1 por slapbass el 20/06/2012
Hola a tod@s!

Tengo un problema con la MOTU Ultralite Mk3. Al conectarle un teclado por MIDI y tocar unas notas, al poco rato las notas se quedan pulsadas, como si no quitara las manos de las teclas. De hecho, en los instrumentos virtuales que tienen teclado, se ve como se quedan pulsadas. Si pulso, por ejemplo, una nota do, en el teclado virtual se ve como se van quedando pulsadas distintas notas Esto me ha pasado con distintos instrumentos virtuales y en distintos programas como Cubase 6 y Ableton Live 8.

Ya he probado lo siguiente:
* Con dos teclados distintos (uno Roland y un Yamaha)
* Con dos MOTU Ultralite MK3 ( en las dos ocurre lo mismo). Una de las tarjetas tiene el firmware 1.02 y la otra el 1.03)
* Probado con los drivers originales (CD) y otras dos versiones distintas, incluida la ultima versión
* En dos ordenadores (con windows) distintos. Un ordenador con W7 64bits y Xp a 32 bits. El otro PC con w7 a 64 bits.
* Con dos tarjetas Firewire distintas. (Una de ellas con chipset Texas Instruments).
* Distintos cables MIDI.
* Probado en Cubase 6, Cubase 6.5 y Ableton Live 8.1 (Todos originales)
* Si conecto un teclado controlador por USB, puedo reproducir los virtuales sin problemas sacando el audio por la Motu.

Cualquier sugerencia será bien recibida.

Saludos!
Subir
#2 por slapbass el 20/06/2012
* También he probado con alimentación a traves del transformador de corriente.
Subir
#3 por hombreazul el 20/06/2012
Supongo que no tienes funcionando programas en segundo plano, como antivirus y cortafuegos o programas que se instalan como iconos en la barra de tareas en el lado derecho, suelen interferir en los programas que hacen muestreo de datos a tiempo real como los programas secuenciadores.
Mira a ver que tienes funcionando y quitalo.
También las redes wifi interactuan, deshabilita la red mientra haces una prueba.
Subir
#4 por slapbass el 20/06/2012
Gracias, pero no es el problema.
Se siguen agradeciendo todo tipo de sugerencias!
Subir
#5 por slapbass el 21/06/2012
A nadie mas le ocurre? Es una maldición que me perseguirá de por vida?
Subir
#6 por hombreazul el 21/06/2012
Por si te sirve de consuelo puedo decirte que tengo una projectmix conectada a un Imac de ultima generación que ocasionalmente me da el mismo problema, solo que en mi caso es muy ocasional.
Verás los driver controladores de los interfaces que tienen audio y MIDI integrados suelen dar esos problemas con algunas interfaces firewire, es un problema del controlador o driver. He sido vendedor de equipos profesionales durante mas de 20 años y he teneido que afrontar ese problema que mencionas con los clientes, algunos de mis clientes tocaban el parametro de prioridad del audio en el menú de dispositivos de control en Cubase y conseguían que se minimizara el problema. pero repito el problema es del driver controlador.
Subir
#7 por hombreazul el 21/06/2012
Como trabajas con PC es buena idea que entres en los parametros de la placa base y asignes un IRQ determinada al puerto firewire, puedes saber que IRQ está utilizando ese puerto en al administrador de dispositivos del panel de control de windows haciendo doble click en la controladora IEEE 1394 Y PULSANDO LA PESTAÑA RECURSOS.
Cuando reservas una IRQ a un dispositivo este tiene prioridad y funciona más estable.
Subir
#8 por slapbass el 21/06/2012
Por las pruebas que he realizado estoy casi seguro de que son los drivers, como bien dices, ya que el problema es en dos tarjetas y en dos equipos distintos con distintas configuraciones. Aun así me sorprende que una tarjeta de este tipo, que ya lleva un tiempo en el mercado y con varias versiones de drivers desarrollados tenga este problema. Por eso sigo pensando que quizas algo me este pasando por alto.
La verdad que llevo varios años en esto y nunca me habia ocurrido nada igual. Y desgraciadamente, la persona del servicio técnico de Motu en España está de vacaciones. Habrá que tener paciencia.
Si se te ocurre algo, te agradeceré cualquier sugerencia.
Saludos!
Subir
#9 por hombreazul el 21/06/2012
acabo de darte unas indicaciones sobre asignar IRQs, hazlo puede que tengas las IRQ compartidas y eso no es nada bueno amigo.
Subir
#10 por slapbass el 21/06/2012
Hoy mismo haré la prueba. Creo que puede ser interesante probar lo de l IRQ. Si me funciona tienes pagaos un par de cubatas en Sanfermines!
Subir
#11 por slapbass el 21/06/2012
Aun así, al ser dos equipos distintos, me parece extraño que ambos tengan las IRQ´s compartidas, pero todo puede ser.
Al mediodia lo pruebo.
Gracias.
Subir
#12 por hombreazul el 21/06/2012
Espero que se solucione tu problema, es muy posible, en mi caso en los MAC no se puede hacer ese tipo de configuraciones, pero ya te digo me ocurre ocasionalmente.
Subir
#13 por hombreazul el 21/06/2012
Los equipos llevan esa configuración por defecto para que el sistema operativo trate a las IRQ como le parezca conveniente.
Es muy normal tener que entrar y asignar la IRQ a mano cuando tenemos problemas como el que mencionas.
Subir
#14 por slapbass el 21/06/2012
Gracias majo! Lo probaré en cuanto llegue al local. Te comento a la tarde.
Saludos!
Subir
#15 por slapbass el 21/06/2012
Bueno, pues no he modificado las IRQs entra otras cosas porque no parecen ser el problema. Me he documentado al respecto y si en un principio no hay conflictos es mejor dejarlos como están. También parece que las tarjetas pci (la firewire esta en pci) comparten la misma IRQ y con las placas nuevas no suele haber problema. Por otro lado creo que si hubiera conflicto por IRQ, el audio también daría problemas y va como un rayo. Aún así he entrado en la BIOS y por mucho que he buscado, no he encontrado la manera de cambiarlas.

Lo que si que he descubierto respecto al problema de la pulsación de la nota, es que si vuelvo a pulsar las notas que al azar van activandose solas, estas dejan de sonar. Es como si no recibiera el note off y volviendolas a pulsar si. Lo que me lleva a la conclusión de que el problema es con el driver que gestiona el MIDI. Esto probandolo con otro teclado distinto, por si acaso.
En fin, que me parece que va para largo. Aún así, si se te ocurre algo mas, bienvenido sea.

Saludos
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo