Problema Realtek + Sintes VST (FM8, ABSYNTH, Etc.)

  • 1
#1 por zaxxon el 16/12/2010
Hola, nunca me habia pasado lo siguiente.

Me gusta tocar musica a la vez que escucho los originales en mp3 o en video (.avi)

El caso es que cuando enciendo el FM8 para tocar, y despues un video o un mp3 y solo funciona el FM8. Y si invierto el orden de encendido solo funciona el video o el mp3, pero no el FM8

He estado mirando las pestañas de config. de la tarjeta pero no logro que suene todo a la vez

Sabe alguien como conseguirlo?

Gracias :)
Subir
#2 por Tio Harpo Molon el 17/12/2010
Saludos, esto es relativo, para que una interfaz de audio pueda atender a dos o mas programas a la vez, sus driver o controladores deben ser multi cliente. No todas las tarjetas soportan esta característica nativamente, por lo que puede ser este el caso. También puede estar ocurriendo algo mas, pero es difícil evaluarlo con tan poca información.

Para descartar lo primero te aconsejo descargar los driver Asio4all los instales y luego los selecciones como driver por defecto en tu software secuenciador. Ya con esto no debería haber problemas.
Subir
#3 por BORISOV el 17/12/2010
tengo un mac y una rme ff800, y consigo mirar videos de youtube escuchar el itunes y tocar un instrumento en el logic comprado, es cuestion de calidad, una realtek es una tarjeta de sonido preinstalada en el ordenador, y me parece un poco raro que tengas el fm8 y el absynth, los packs estan a 400€ y a mi me da que hay algo de ilegal en tu sistema.

si rulas en windows, no podrás usar la misma salida audio para secuenciador y programa a la vez,

saludos

BORISOV

Subir
#4 por Tio Harpo Molon el 17/12/2010
Fatcap, no tienes absolutamente ningun respaldo para lo que estas diciendo, o tu eres el unico aca que puede darse el lujo de tener un mac y programas originales? y no viene al caso ya que el problema va por otro lado, poca idea tienes ademas, en windows no hay ningun problema para utilizar la misma salida tanto para el secuenciador como otro programa, todo depende de que los driver que utilizas soporten esta opcion. Los Asio4all lo hacen, asi que mejor te ahorras las acusaciones sin respaldo.

Ahora si lo que dices lo dices por algun encuentro previo desafortunado con este usuario, pues por respeto a las normas del foro y otros usuarios resuelvelo en privado.
Subir
#6 por Tio Harpo Molon el 17/12/2010
#5

Ya te dije, los problemas personales en privado, respeta las normas que solicitan expresamente contribuir a un buen ambiente en el foro.

¿Tienes pruebas de que este muchacho está utilizando piratería? yo no las veo en este hilo, lo que veo es una presuncion de tu parte, si es solo una presuncion te vuelvo a reiterar, reserva tu opinion.

¿Ahora todo el que dice tener mas de algun software que es de pago es un pirtata per se? :tasmal:

Los Asio4all funcionan perfectamente con una realtek, no confundas mas a los usuarios.
Subir
mod
#7 por Soyuz el 17/12/2010
FATCAP, un poco de autocrítica, porque es cierto que tu no tienes por qué especular nada sobre la procedencia del software de los demás, y has dado información imprecisa (en Windows sí se puede compartir la salida de audio, depende del driver).

Y los insultos... vaya, eso no queremos ni verlo por aquí. No nos desviemos más del tema propuesto en el hilo por favor.
Subir
#8 por zaxxon el 18/12/2010
Gracias por las respuestas, no he respondido antes porque pensaba que me llegarían avisos de vuestras respuestas por email y no me han llegado.

Voy a ver si arrojo un poco de luz sobre mis especificaciones de sistema, ya que en este mismo pc cuando tenía Windows XP recuerdo que podía hacer lo que expongo y ahora con Windows 7 (64 bits) no puedo, y sigue siendo exactamente el mismo ordenador con los mismos componentes, incluída la Realtek integrada.

Tengo los drivers Asio4All instalados y seleccionados en dichos programas, así que no creo que sea eso, a menos que haya que configurar algo que no sepa.

He estado toqueteando todos los menus habidos y por haber (o casi) relativos a la Realtek y no logro resolverlo. Lo que veo es que tengo 2 solapas independientes dedicadas a la salida de sonido en la configuración de la Realtek. Una de ellas es la de "Digital Output" y la otra es la de "Altavoces", siendo esta última la que está configurada como dispositivo predeterminado y como dispositivo predeterminado de comunicación (ambas cosas) He probado a ir alternando y combinando esto entre ambas solapas buscando una combinación (sin éxito) que hiciera que sonasen los videos o mp3 y los sintes al mismo tiempo que toco, pero nada. Y es curioso el asunto con los mp3, porque si enciendo primero el FM8 y despues pongo un mp3, éste último no se empieza a reproducir hasta que no apago el FM8.

Otro dato mas, aunque no creo que esto afecte porque ya lo tenía así cuando todo funcionaba bien con Win.XP, es que mis altavoces están pinchados en la tarjeta en un único conector (el negro) con un minijack que tiene 2 hembras para recibir los 2 minijacks estéreo agrupándolos en solo uno.

Por ahora no se me ocurren más datos sobre mi estructura del sistema, yo intuyo que es algo que debería ser resuelto mediante manipulación del software, ya que como digo, en éste mismo pc con Windows XP todo iba bien con la Realtek.

También me he fijado en el panel de Asio4All que cuando reproduzco un mp3 y despues abro el FM8, aparece el aspa roja en "Realtek HD Audio output" indicándome que el FM8 no puede usar esta salida ya que está ocupada con el mp3, y cuando apago el mp3, desaparece el aspa y se pone la flechita verde indicando que ya está libre. Veo ahí el conflicto pero no se cómo resolverlo.

Si sigo con mi Realtek integrada es porque nunca había tenido problemas con ella a pesar de lo modesta que es. Hace unos días he comprado un Fatar VMK 88 Plus a la tienda Thomann (está de camino por ups) ya que con mi CME UF7 no puedo funcionar en Windows 7 (64 bit) por desatendimiento de los fabricantes pasando olímpicamente de desarrollar drivers para éste sistema. Y respecto a los sintes, algunas veces existen ofertas como la que yo aproveché en su día:

http://www.futuremusic-es.com/modules/news/article.php?storyid=1106

Dice así:

"NATIVE INSTRUMENTS -SINTES A PRECIO REDUCIDO
26/11/2009 18:42:35
Los magistrales desarrolladores de instrumentos y efectos software, Native Instruments, acaban de presentar una oferta muy especial. Tras el nombre Synthsgiving, se esconde una mega-rebaja por tiempo limitado de algunos de sus productos más poderosos. Así, sólo hasta el 30 de Noviembre, podrás comprar Absynth 5, FM8, Massive o Reaktor 5 en versión descargable por sólo 99 euros (cada uno). ¡Eso implica una rebaja de hasta el 75% sobre el precio de lista! Esta es una oportunidad única para hacerse con algunos de los softsintes más innovadores de la historia."


Si te la perdiste no es mi problema.

Gracias de nuevo al resto :)
Subir
#9 por zaxxon el 18/12/2010
Aquí unas capturas para más detalles:
Archivos adjuntos:
ADMIN-DE-SONIDO-01.jpg
BBCode:
ADMIN-DE-SONIDO-02.jpg
BBCode:
ADMIN-DE-SONIDO-03.jpg
BBCode:
ASIO4ALL.jpg
BBCode:
MIDI-01.jpg
BBCode:
MIDI-02.jpg
BBCode:
MIDI-03.jpg
BBCode:
MIDI-04.jpg
BBCode:
Subir
#10 por Tio Harpo Molon el 20/12/2010
No hace falta tanta foto, si no se solucionó el problema con los Asio4all no hay nada que hacer, solo queda esperar a que te llegue la nueva interfaz.
Subir
#11 por solker el 20/12/2010
Quizás es una chorrada, pero ¿has usado los drivers propios del win o te has descargado los drivers del fabricante actualizados par el w7? ese problema es de gestión del driver, es posible que "el genérico" haga mamonadas de estas.

Visita La construcción de mi estudio
LMDL en Facbook
Move-sound studio

Subir
#12 por zaxxon el 20/12/2010
Disculpad si las fotos molestan, solo queria informar con detalle por si acaso veiais algúna opción mal colocada.

harpocrates666, con nueva interfaz te refieres al nuevo teclado midi? no creo que eso solucione nada. Actualmente tengo el problema usando el ratón, no creo que por enchufar un teclado MIDI al pc se resuelva el problema.

Solker, a qué drivers te refieres exactamente? A los de la tarjeta de sonido Realtek? Si no recuerdo mal se instalaron los genéricos cuando instalé Windows 7, éste detecta la mayoría de componentes y los instala. Voy a ver si encuentro los drivers propios de la Realtek en su web original.

Por mi parte he descubierto que este problema me pasa precisamente por usar los ASIO4All, porque al seleccionar la opción que venia por defecto del driver de Audio del FM8, la WASAPI (Shared Mode), todo suena a la vez pero chisporroteando el FM8 sin posibilidad de arreglo, ya que no me permite ni cambiar el "Sample Rate" (que se fija automáticamente en 192000) ni nada.

Gracias de nuevo.
Subir
#13 por zaxxon el 20/12/2010
He desinstalado los drivers genéricos e instalado los propios de la placa base y el problema persiste.

Es todo por el conflicto que existe entre FM8 y Winamp (u otros programas de musica/video), compitiendo por usar la misma salida de audio. La ocupa el primero que ejecuto y el otro se queda sin sonar.

Lo curioso es que puedo por ejemplo escuchar a la vez un mp3 en winamp y una pelicula en .avi sin que uno silencie al otro, incluso puedo escuchar sonidos del sistema y de páginas web, todo al mismo tiempo. Es cuando incluyo en el saco al FM8 cuando hay conflicto.

Otro dato nuevo es que teniendo el FM8 encendido pongo un mp3 y éste último no suena, pero si abro el panel de ASIO4All y marco la casilla "Siempre remuestrear a 44.1kHz 48kHz" entonces repentinamente el mp3 comienza a reproducir la música dejando al FM8 mudo de nuevo.

Seguiré haciendo pruebas, me jodería bastante tener que comprarme una tarjeta de sonido por esta tontería. Porque si fuera que mi Realtek siempre ha dado este problema, pero no, es que sólo lo da en Windows 7, cuando tenía XP no pasaba esto, y usaba los ASIO4All igualmente sin problemas.

Saludos
Subir
#14 por zaxxon el 20/12/2010
Vale, definitivamente es un problema con el ASIO4All y Windows 7 (o Vista). Se ve que estos sistemas gestionan el sonido de manera diferente a Windows XP, impidiendo que el FM8 o cualquier otro sinte emita sonido a la vez que otros programas de sonido, ya que el ASIO4All toma control total de dicha salida de audio, negándosela por completo al Winamp y cualquier otro programa de audio. Los desactiva hasta que el FM8 es apagado.

Se ve que es un problema irritante y muy extendido, aqui lo debaten, y tambien en el foro de ASIO4All al parecer.

http://www.kvraudio.com/forum/viewtopic.php?p=4185106

Si doy con la solución la pondré aquí.

¿Alguien conoce otros drivers similares que reduzcan la latencia y no hagan que los sintes suenen con chisporroteos? Ya que esta es la razón de que yo instale el ASIO4All.

Saludos.
Subir
#15 por Tio Harpo Molon el 20/12/2010
#12

Hola, lo de las fotos no era por que molesten, solo que bastaba con confirmacion textual de que no se resolvia con los Asio4all, fue el comentario menos serio y sin importancia de este hilo asi que tampoco hacia falta darle importancia.

Lo de la interfaz, mas arriba te lei que habias encargado una nueva interfaz, no es asi? era un teclado? bueno era eso, pense que te habias comprao una interfaz y que te venia en camino.

Intenté hacer una prueba, ya que tambien tengo una realtek y win7, y efectivamente Asio4all no es capaz de dar soporte multicliente en win7, recuerdo que XP si lo habia podiro hacer, pero en win7 me fue imposible, asi que no hay vuelta, si instalas los driver del fabricante no tendras la posibilidad de lograr bajas latencias, si instalas los Asio4all no podras hacer lo que quieres.

Pero bueno, la solucion, pues juntar un poco de dinero y comprarte una interfaz ideada para estos fines, ya que una integrada por un lado o por otro siempre dará problemas.
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo