Problema de sincronizacion entre Midi Editor y vista VIP

  • 1
#1 por fachala el 01/05/2013
Hola amigos, escribo porque hace ya un par de semanas que tengo un problema con mi Samplitude Pro X que me esta complicando bastante las cosas.

Tengo un proyecto en el cual hay 5 temas, cada tema esta separado con un marcador BPM con tempos distintos para cada cancion (ej. el primero en 120 BPM, el segundo en 140, el tercero en 160, etc).

Comencé grabando en audio unas guias de guitarra y voz sobre el click de cada cancion, luego sobre esto grabe baterias en midi. Acto seguido abro el Midi Editor de la bateria del primer tema para corregir algunas cosas y todo de maravilla.

El problema surge cuando quise hacer lo mismo en la segunda cancion y en las subsiguientes: La linea de scroll sobre el VIP va perfectamente sincronizada con los eventos midi, click y grilla de compases, PERO.... en la vista del editor midi no. La linea de scroll va algunos compases atras o adelante del evento que suena. Como si mantuviese el tempo de la primera cancion aunque haya marcadores de cambio de BPM de por medio.

Es algo muy raro y resulta imposible editar en esas condiciones!! Alguien tuvo este problema? O sabe como solucionarlo? Busque por todo el foro, manual, google y no encontre respuesta.

Desde ya muchas gracias!!!
Subir
#2 por fachala el 09/05/2013
Nadie tuvo este problema? Ayuda por favor! Se que debe tener una solucion sencilla pero no aparece por ningun rincon del manual o la red... No quiero migrar a otro DAW.... jejeje
Subir
#3 por ElLoco el 30/05/2013
Me ha pasado lo mismo en un proyecto.
Al decongelar la pista de la bateria para editar in midi veo que se ha movido el ditor con respecto al proyecto...
¿ pudiste solucionarlo?

Comprobé otro proyecto y no había problema pero esto me mosqueado MUUcho
Subir
#4 por fachala el 01/06/2013
Hola! No he podido solucionarlo.... es una pena que tampoco haya foros o respuestas en la net con este mismo problema! Ami me pasa con cualquier proyecto y como ponia en la pregunta, sucede cuando insertas un marker de bpm, a partir de alli se desincroniza, lamentablemente ya desisti en la busqueda de respuestas y me resigne a que en mi samplitude no puedo hacer cambios de bpm y editar midi... si llegas a tener la suerte de dar con la solucion por favor subela aqui. Un abrazo!
Subir
#5 por Fran el 01/06/2013
Pues acabo de probar esto que dices, en un proyecto MIDI a106 BPM's, y en la mitad aproximadamente del proyecto, he puesto un cambio de tempo a 140 BPM's, y el cursor del editor MIDI está sincronizado perfectamente con el cursor del Arrangue.

Luego puse otros 2 cambios de tempo en otros compases del tema, uno a 106 y otro a 90, y todo está sincronizado perfectamente.

Pero estoy hablando de un arrangue donde todas las pistas son MIDI, no hay mezcladas pistas de audio.

Alguien escribió:
Comprobé otro proyecto y no había problema pero esto me mosqueado MUUcho


Lo que si es cierto que SAM, sigue corrompiendo proyectos, cuando le sale de los "eggs", y asimismo abres un proyecto y te salen las barras de herramientas cambiadas totalmente de sitio.

Si tienes backup's anteriores, comprueba si les pasa lo mismo.

Un saludo.

Vale más saber alguna cosa de todo, que saberlo todo de una sola cosa.

Subir
#6 por fachala el 01/06/2013
Hola Fran! Yo no he probado con un proyecto totalmente midi... solo me ha pasado con proyectos audio y midi, voy a probar lo que hiciste para ver si por ahi puede estar la respuesta! Gracias!
Subir
#7 por Fran el 02/06/2013
Hola fachala:

Alguien escribió:
solo me ha pasado con proyectos audio y midi,


Es evidente que si cambias el tempo con marcas, esto solo afectará a las pistas MIDI, las pistas de audio no van a cambiar el tempo al que fueron grabadas (salvo que las cuantizaras a los tempos nuevos, pero esto no creo que lo haga bien).
Por lo tanto, las pistas MIDI al cambiar de tempo, no se van a sincronizar con las de audio.

Un saludo.

Vale más saber alguna cosa de todo, que saberlo todo de una sola cosa.

Subir
#8 por fachala el 02/06/2013
Es que no es ese el caso justamente, quiza no me explique bien en el primer post: No se trata de cambiar el Bpm despues de haber grabado el audio, sino antes! ( y ese es el gran problema).

Supongamos que quiero grabar 5 canciones en un solo proyecto, cada canción tiene Bpms distintos, primero sobre el click grabo una guia de guitarra y voz sobre las 5 canciones, y sobre eso una bateria en midi.
Lo que sucede es que: auditivamente todo esta sincronizado siempre sobre las 5 canciones, visualmente es el problema, en la primera cancion esta sincronizado el scroll tanto del VIP como del editor midi, osea todo a la maravilla y con total normalidad, pero a partir de la segunda es cuando empieza a fallar:

Si sigues el scroll del VIP la linea va perfectamente coincidiendo con cada evento midi que suena y con los picos de la pista de audio, pero si abres el editor midi la linea va por detras o por delante de los eventos que en realidad estan sonando, a veces hasta con muchos compases de diferencia!
Si organizas las ventanas de manera tal que se vea el editor midi y el VIP al mismo tiempo ocurre lo mismo, las lineas de scroll van fuera de sincronía pero la del VIP va bien, la que hace caso omiso es la del editor midi. Hay una opcion dentro de las configuraciones que es "sincronizar VIP y editor" o algo asi, pero la activé, la desactivé y nada...

Imaginate lo dificil que es intentar editar los eventos en esas condiciones... de solo recordarlo me estresa jejeje.

Espero haberme explicado mejor amigos!
Subir
#9 por Fran el 03/06/2013
Hola fachala:

Ahora creo que si entendí tu respuesta, lo del audio es independiente de tu problema y ademas confirmas que los audios estan grabados a los mismos BPM's de cada canción.

Pero creo que crees que esta funcionando mal y no es cierto, tu dices:

Alguien escribió:
Si sigues el scroll del VIP la linea va perfectamente coincidiendo con cada evento midi que suena y con los picos de la pista de audio, pero si abres el editor midi la linea va por detras o por delante de los eventos que en realidad estan sonando, a veces hasta con muchos compases de diferencia!


Esto es normal, por que el nivel de zoom que tengas en el VIP, es diferente al que tienes en el Editor MIDI, y además seguro que el ancho de la ventana del Editor MIDI es menor que la del VIP, y dependiendo de estos niveles de zoom individuales, la linea vertical (cursor de tempo) van a diferentes velocidades, pero esto es una ventaja, no un inconveniente, pero fíjate que cuando ,la linea vertical (cursor de tempo), pasa por el compas 41 del VIP por ejemplo , la linea vertical (cursor de tempo) del Editor MIDI, también esta pasando por el compas 41, independientemente del tempo en BPM's.

Entonces no veo donde está el problema, si tu pones el cursor de tempo en el compas 52 en el cursor de tempo en el VIP, te aseguro que el cursor de tempo del Editor MIDI, también se sitúa en el compás 52, etc.

Y salvo que yo te entienda mal, esto es así, y también es así en todos los Daw's.

Un saludo.

Vale más saber alguna cosa de todo, que saberlo todo de una sola cosa.

Subir
#10 por Poeta el 03/06/2013
:shock:
fachala escribió:
Supongamos que quiero grabar 5 canciones en un solo proyecto, cada canción tiene Bpms distintos,


Una recomendación.. Graba cada tema en un proyecto, y te evitaras muchos problemas, esa manera de trabajar no es muy normal ni muy practica..

:wink: Es solo un comentario...
Subir
#11 por fachala el 04/06/2013
Fran: creo que sigo sin explicarme bien! jejeje Justamente lo que tu dices sería lo que debiera pasar, pero lo que trato de expresar es que en la vista VIP cuando la linea scroll va por el compas 40 (como tu dices) en el editor midi va por el compas 30 o el 45 o el que sea... y tambien pasa si abres en pantalla completa el editor midi solo, es decir, estas escuchando el compas 40 (con audio y midi sincronizados perfectamente en audicion) pero el scroll del editor va por el 30, 45, 60 o el que fuera menos el 40...

Quizá complique la explicacion y podria haber resumido todo en "Problema de linea scroll en editor midi"... ya que alli es donde esta el problema en realidad, olvidemonos del VIP, simplemente la linea scroll del editor midi va por detras o por delante de lo que se escucha (aunque en el VIP todo vaya de maravilla)... pido perdon!

Espero que (ahora si) me haya explicado bien! #-o
Subir
#12 por fachala el 04/06/2013
Poeta: Me interesa mucho tu propuesta... yo trabajo de esa forma cuando todos los temas tienen que sonar iguales, es decir, el mismo sonido, eq, efectos, planos y demas en todos los canales. De esta manera me resulta sencillo ya que si quiero engordar un bombo hago la modificacion en el canal y se hace en todos los temas, lo mismo con el brillo o reverb de la voz, etc.

Se que para ello puedo exportar la configuracion del mixer para que sea la misma en todos los temas dado este caso, pero me parece un poco mas complicado.... tambien me sirve para hacer comparaciones A-B rapidas entre partes de los temas para ver si algo esta mas fuerte o mas escondido y ese tipo de cosas.

Me gustaria mucho saber que tipo de problemas evitaria trabajando con cada tema en un proyecto distinto! Si puedes comentarme me interesa mucho :-)

Gracias por aportar! :ook:
Subir
#13 por Fran el 04/06/2013
Hola fachala:

Alguien escribió:
pero lo que trato de expresar es que en la vista VIP cuando la linea scroll va por el compas 40 (como tu dices) en el editor midi va por el compas 30 o el 45 o el que sea... y tambien pasa si abres en pantalla completa el editor midi solo, es decir, estas escuchando el compas 40 (con audio y midi sincronizados perfectamente en audicion) pero el scroll del editor va por el 30, 45, 60 o el que fuera menos el 40...


Pues esto que dices (que no pongo en duda que te ocurra) es teóricamente imposible, por que no depende de ningún ajuste de configuración, sería un error del código del programa, y lógicamente esto mismo le pasaría a todo el mundo que utilice Sam Prox, y esto no es así.

Pero la única explicación que se me ocurre, es que el proyecto este corrupto.
Si quieres me mandas un privado y contactamos para que me mandaras el proyecto VIP por e-mail ( o puedes subirlo aquí ), y yo lo pruebo para analizar cual es el problema, Es evidente que si yo cargo tu proyecto en mi SAM, las pistas de audio no las va a encontrar, pero eso es irrelevante por que lo que esta fallando es la sincronía MIDI, y también es indiferente que los vsti's que tengas asignados a las pistas MIDI yo los tenga o no, por ejemplo las baterías, por que yo los sustituyo por otros similares, no importa lo raro o mal que suene, por que lo que yo comprobaría sería el problema de entronización de tempo MIDI.

Alguien escribió:
yo trabajo de esa forma cuando todos los temas tienen que sonar iguales, es decir, el mismo sonido, eq, efectos, planos y demas en todos los canales


Y respecto a esto, no conozco ningún disco comercial de éxito, que todos sus temas suenen igual sería, un aburrimiento total escucharlo, cada tema debe llevar el sonido que a juicio del artista le corresponda, ni siquiera tienen que tener las mismas dinámicas, timbres etc, pero para gustos hay colores.

Un saludo.

Vale más saber alguna cosa de todo, que saberlo todo de una sola cosa.

Subir
#14 por fachala el 04/06/2013
Muchas gracias Fran por tu amabilidad, mañana adjunto el proyecto solo con la pista midi y los markers BPM para ver si a ti o a alguien mas le ocurre.. ya estoy sospechando de mi MOTU 896 MK3.... porque por lo que comentas podria ser un problema de sincronia de la interface y eso me preocupa bastante.

Respecto a lo de la organizacion del proyecto quisiera remarcar el "cuando" que puse en la frase... obviamente que cada tema tiene que sonar por su propia identidad, pero hay casos como el Black Album de Metallica en el que al escucharlo de punta a punta la bateria y las voces al menos se mantienen con increible "estabilidad" a lo largo de todos los temas, la misma eq, los mismos planos, mismos efectos, en definitiva el mismo sonido, por no decir "suenan iguales a lo largo del disco" ya que puedo pecar de brusco o exagerado y no es esa mi intencion.

Digo, no te ocurre que al escuchar ese disco de un tema al otro el bombo pierda ataque, o la voz suene mas "flaca", o la caja este mas fuerte o el bajo con mas peso en los subgraves... tu escuchas cualquier tema y dices "es Metallica, es el Black Album".
Da la sensacion que la banda armó su set y grabo todos los temas de corrido, como si tanto en la grabacion como en la mezcla la configuracion del canal de la voz fuese la misma en todos los temas (salvo algunos pasajes con efectos muy puntuales), de hecho cuando cambian de guitarras o bajos entre temas, los planos siguen siendo muy similares (que es lo que busco comparando A-B entre las secciones de los temas).
En cambio esa sensacion no me la da Radiohead por ejemplo, o Depeche Mode, como miles de artistas mas en los que cada cancion (en lo que a audio respecta) es un universo completamente distinto.

Es como si el estilo lo demandase y es solo en esos casos que organizo el proyecto de esa forma, luego te cae Bjork y organizas cada tema en un proyecto independiente jejeje.

Voy a probar organizar este trabajo con cada tema en un proyecto independiente! Para ver que resultado me da.
Subir
#15 por tonibena el 04/06/2013
fachala, copia/pega los ajustes de las pistas de un proyecto a otro, asi tendrás la consistencia entre temas que buscas y al mismo tiempo trabajando con proyectos separados por cada tema

Windows 10 Pro x64 / ASUS P5Q PRO / Intel Core 2 Quad Q6700 @ 2.66GHz 8 Gb Ram DDR2 800Mhz / NVIDIA GeForce 520GT / 2 x WD 500 Mb / CD-DVD RW PLEXTOR / RME FF400

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo