Problemas con ffado y el audio del Firefox

#1 por catorze el 24/03/2011
Hola a todos de nuevo!
Tengo problemas al reproducir qualquier cosa que contenga audio mediante el firefox, se me bloquea cada vez que reproduce algo, tarda como un minuto en "volver en si" estoy con kxstudio, jack2, ffado-svn.
Si alguien sabe algo se agradeceria algo de información.
Gracias!
Subir
#2 por joanillo el 25/03/2011
Esto está relacionado con los problemas de convivencia de Pulseaudio con JACK. Es bastante lioso, y hay varias posibilidades. Como se explica en https://help.ubuntu.com/community/UbuntuStudioPreparation (hacia el final), cuando arranca qjackctl suspende automáticamente pulseaudio. Hay gente que opta por desinstalar el Pulseaudio del todo, y otra posibilidad es suspender pulseaudio en el inicio de sesión y arrancarlo cuando quieras (por ejemplo para ver videos de youtube). Claro que otra posibilidad es que convivan (es como lo tengo yo, aunque a veces también me da quebraderos):

instala sudo apt-get install pulseaudio-module-jack

después de arrancar jackd/qjackctl, haz en el terminal:

pacmd load-module module-jack-source channels=2; pacmd load-module module-jack-sink channels=2;

Esto podría ser útil por ejemplo si quieres grabar lo que suena por el Youtube en el Ardour.
Subir
#3 por catorze el 26/03/2011
Xè Gràcies Joanillo, però:

$ pulse-jack
E: main.c: S'ha produït un error en iniciar el dimoni.
Failed to initialize Pulseaudio!

si hago un "pulseaudio" puedo cargar los módulos:

$ pacmd load-module module-jack-source channels=2; pacmd load-module module-jack-sink channels=2;
Welcome to PulseAudio! Use "help" for usage information.
>>> >>> Welcome to PulseAudio! Use "help" for usage information.

Pero no sale audio ninguno y el firefox se bloquea igualmente, por cierto, al reproducir algo con el firefox me sale un out stereo con nombre jack_P.
Salut!
14
Subir
#4 por Pablo_F el 27/03/2011
¿Has probado a actualizar a firefox 4? Lo puedes hacer desde ppa:mozillateam/firefox-stable. Por probar...

Yo tengo audio sin problemas con el reproductor de flash, que va a través de jack. Eso sí, si jack no está activo cuando lanzo youtube o similar, firefox se me queda un poco colgado pero entonces no espero un minuto, me doy una palmada en la frente, uso xkill, lanzo jack y vuelvo a lanzar firefox. Pero no sé si es el problema tuyo. KXstudio es para valientes :)
Subir
#5 por guitman el 27/03/2011
Yo uso esto para enviar el audio de las aplicaciones flash a jack:

http://repo.or.cz/w/libflashsupport-jack.git

Y de camino hallé esto, por si te puede valer:

http://subversion.ffado.org/wiki/ALSAtoFFADO
Subir
#6 por catorze el 27/03/2011
Conseguido chicos! pero solo una de las soluciones me ha funcionado...

Pulseaudio, de momento ya está desisntalado.

El firefox 4 muy chulo la verdad, pero no me solucionó el problem.

Y efectivaente el libflashsupport-jack es el que pirula perfectamente, la salida que me salia de Jack_P es precisamente de esa libreria, pero la que lleva por defecto el kxstudio está desactualizada, lleva fecha del 2009, he instaldo la del git y a funcionar!

Gracias a todos! de verdad, si no fuera por estas ayudas, esto no seria ni la mitad de divertido ;)

Salut!
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo