Problemas con Hollywood Strings y Brass

mod
#16 por Ludwigvan el 10/09/2014
Hola chicos,

Por casualidades de la vida a mi me empezó a pasar ayer por primera vez. Y no sólo con el Play, sino con Kontakt también.

Y lo he solucionado, después de las correspondientes horas de búsqueda desesperada y probatinas. No es un tema de recursos, por lo que sea no funcionaba bien ni con un cubase vacío con un sólo instrumento, se quedaba colgado el sonido enseguida con cualquier VST

Iros a esta página: http://www.midiox.com/ y descargáis el MIDI yoke y el MIDI OX. Es para hacer un cableado virtual por software, de forma que detecta por ejemplo el 'note off' y cancela el sonido

Para configurarlo, una vez instalados, en el MIDI OX tenéis que ir a 'devides', para configurarlo. En 'midi in' ponéis vuestro teclado y en 'midi out' ponés Midi Yoke 1

En cubase no tenéis que hacer nada, con tener el 'all midi impunts' funciona. ESO SÍ, ANTES DE ARRANCAR EL CUBASE arrancad el Midi OX

Vuelve a funcionar bien, incluso diría que ha mejorado la latencia. Aunque esto no puedo demostrarlo, me da como la sensación de que es más inmediato...

Probadlo y si no os funciona miramos configuraciones

Salu2
Subir
#18 por gerpepla el 10/09/2014
Pues ahora mismo me los bajo a ver si hay suerte. Gracias por la información, ya os contaré.
De momento llevo 2 días esperando respuesta del servicio técnico de Eastwest.
Saludos
Subir
#19 por gerpepla el 10/09/2014
Lo estoy probando. De momento no detecta el teclado en cubase pero en el monitor de MIDI-OX me figuran las Note On y Off de cada pulsación.

Ludwigvan escribió:
Para configurarlo, una vez instalados, en el MIDI OX tenéis que ir a 'devides', para configurarlo. En 'midi in' ponéis vuestro teclado y en 'midi out' ponés Midi Yoke 1

¿Habrá que hacer algo más?
Subir
#20 por gerpepla el 10/09/2014
Este sistema podrá ser bueno (con la configuración adecuada) cuando se toca el teclado pero a la hora de editar un proyecto, que es cuando surge el problema, no actúa.
Seguiremos investigando.
Saludos
Subir
mod
#21 por Ludwigvan el 11/09/2014
Te adjunto un pantallazo...

En midi ox, 'Optinons/Devices, sale esta pantalla.

En midi imput, selecciona el teclado. En output, MIDI Yoke 1.

A mi me funciona...aunque el problema podría ser distinto. En mi caso, me ha sucedido de golpe y con todos los VSTs a la vez
Archivos adjuntos:
midi ox.jpg
BBCode:
Subir
#22 por gerpepla el 11/09/2014
A mí no me funciona y lo tengo igual que tú. Además en Cubase está puesto como All Midi Imputs.
De cualquier forma, como te digo, por lógica eso actuará cuando estás grabando una pista con el controlador MIDI pero editando las pistas ya grabadas (que sería lo interesante pues es cuando se queda la nota "tiesa") no actúa al no ser que hubiese alguna opción de que todas las notas de todas las pistas se pudieran poner en off cuando se detectase que acaba la nota, Si no tiene esa opción el MIDI-OX quizás haya algún otro invento que no sepamos aún.
Seguiremos investigando. Saludos.
Subir
mod
#23 por Ludwigvan el 11/09/2014
Es que lo de que se me quede editando notas no me ha pasado...

Ya te digo, hasta ahora no me había pasado nunca. Bueno, la clásica nota suelta que reinicializas midi una vez cada tres días, pero no de forma continua.

En mi caso con estos dos programas, problema resuelto. Pero joer...¿editando?. Uf, qué lata...
Subir
#24 por gerpepla el 11/09/2014
Así es, mientras estoy escuchando el proyecto y de repente oir de fondo una nota constante que no viene a cuento, o al pararlo. Obliga 1º buscar el instrumento que se ha quedado colgado, 2º ir a Play y 3º pinchar en la luz del micrófono del instrumento para recargarlo.
Lo grave es que hace cosas raras además de cuelgues como desfases cuando detecta el CC11 (Expresión) pero no siempre (eso es lo grave que no exista un error lógico) siendo la Expresión lo que da la humanización al toque del instrumento cuando la Velocidad está deshabilitada. Una lata como bien dices. Así que en esas estoy :estonova: :triston: ](*,)
Subir
mod
#25 por Ludwigvan el 11/09/2014
Joer qué putada.

De todas formas obviamente recursos no es. Te va a tocar revisarlo todo...

Creo que desde el inicio asumes que es el Play. Yo cuando me las pillé tenía mucho miedo (por lo que había oído de las primeras versiones), y joer, es que no he tenido ni medio problema. Mucho menos que con Kontakt. De hecho lo que me ha pasado de quedarse colgado el sonido no es por el Play, pasaba con todos.

Pero es que en esto del audio entran tantas cosa que uf..
Subir
#26 por Javi Arce el 11/09/2014
Gerpepla, te lanzo varias cuestiones al aire, para ver si con alguna de ellas das con la tecla (nunca mejor dicho). Seguro que alguna te parece un poco tonta o una obviedad, pero bueno, por si acaso, allá van:

¿Qué RAM utilizas? Marca, versión de DDR, tasa de transferencia, latencia. ¿No tendrás RAM marca La Cabra con poca velocidad de reloj y alta latencia?

¿Qué procesador tienes? ¿Has monitorizado los cores del procesador mientras utilizas el DAW con PLAY? ¿No tienes picos en la VST Performance (tanto de average load como de real-time peak) de Cubase? ¿Utilizas multicore desde PLAY (supongo que se podrá, te hablo haciendo una semejanza con Kontakt, que es el rompler que conozco)?

¿Qué driver de audio utilizas? ¿No estarás usando los Direct X Full Duplex? :D

¿Cuántas voces levantas con los instrumentos que se quedan colgados? ¿Te has asegurado que no tienes el pedal de sustain activado? ¿No levantas más voces (polifonía) de las que admite tu sistema (el límite del teclado da igual en este caso, es interesante saber que no sobrepasa el límite que tenga PLAY... quizá 128, o 256)? ¿Puedes modificar la política de PLAY a la hora de eliminar voces cuando hay sobrecargas (en Kontakt hay tres variantes, relaxed, medium y strict)?

¿Qué samplerate empleas en tu DAW? ¿Qué profundidad de bits empleas en tu DAW? ¿Has verificado que estos valores coincidan con los valores de los samples que empleas? En teoría pueden hacerse conversiones sin mayores problemas al importar los instrumentos, pero para asegurarte, intenta hacer las pruebas en el mejor de los entornos posibles.

Ésta es mi música:
https://corona-borealis.bandcamp.com/releases
Y ésta es mi aplicación web de teoría musical (beta):
http://codamusica.com/

Subir
#27 por gerpepla el 11/09/2014
Hola,
Ludwigvan:
Ludwigvan escribió:
Creo que desde el inicio asumes que es el Play

Es que sólo me pasa con los instrumentos que ejecuta el Play, y nunca me ha pasado con los que utilizan el Kontakt..
De cualquier forma, aquí pongo unos pantallazos del setting de mi PLAY por si ves algo raro.
Gracias, saludos.
Archivos adjuntos:
pantallazo 1.jpg
BBCode:
pantallazo 2.jpg
BBCode:
pantallazo 3.jpg
BBCode:
Subir
#28 por gerpepla el 11/09/2014
Hola Javi,

Javi Arce escribió:
Gerpepla, te lanzo varias cuestiones al aire

Genial!!!. Vamos manos a la obra...


Javi Arce escribió:
¿Qué RAM utilizas?

RAM: 32 Gbs (4 bancos de 8 GBs)
Marca: Kingstom-HyperX FURY Black 8GB 1600MHz DDR3
Latencia CAS: 10

Javi Arce escribió:
¿Qué procesador tienes?

Intel Core i7-2600 CPU @3,40 GHz

Trabajo con:
- Windows 7 Professional
- Cubase 7.5.30 a 64 bits.


Javi Arce escribió:
¿Has monitorizado los cores del procesador mientras utilizas el DAW con PLAY?

NO

Javi Arce escribió:
¿No tienes picos en la VST Performance (tanto de average load como de real-time peak) de Cubase?

SI a veces

Javi Arce escribió:
¿Utilizas multicore desde PLAY

No lo veo en PLAY

Javi Arce escribió:
¿Qué driver de audio utilizas?

Los de mi tarjeta de sonido: Creative Sound Blaster ASIO que me da latencia entre 2ms y 100ms (Lo tengo a 100ms cuando edito)

Javi Arce escribió:
¿Cuántas voces levantas con los instrumentos que se quedan colgados?

No sé si te he entido bien aquí. Me imagino que te refieres a un punto concreto donde se queda colgada la nota. Si es esto, no meto más de 3 notas tocadas a la vez en todo el proyecto.

Javi Arce escribió:
¿Te has asegurado que no tienes el pedal de sustain activado?

No utilizo pedal

Javi Arce escribió:
¿No levantas más voces (polifonía) de las que admite tu sistema (el límite del teclado da igual en este caso, es interesante saber que no sobrepasa el límite que tenga PLAY... quizá 128, o 256)?

No sé si te refieres al máximo de voces en PLAY, si es esto lo subí al máximo a 2048 voces

Javi Arce escribió:
¿Puedes modificar la política de PLAY a la hora de eliminar voces cuando hay sobrecargas

Si te refieres al "Overload Protection" en PLAY lo tengo desactivado porque lo aconsejan en un video tutorial.
Tambíen hay una opción (Igual que en Kontakt) de purgar las muestras.

Javi Arce escribió:
¿Qué samplerate empleas en tu DAW?

44.100 kHz

Javi Arce escribió:
¿Qué profundidad de bits empleas en tu DAW?

24 Bits

Javi Arce escribió:
¿Has verificado que estos valores coincidan con los valores de los samples que empleas?

Las muestras de sonido en la HS Gold son a 16 bits

Bueno, aquí se acaba el cuestionario. Muy interesante.
De momento veo que tengo que ponerme a probar a bajar los picos del VST Perfomance. Me pondré a congelar algunas pistas que considerer definitivas a ver si baja la carga. También quizás me sirva como solución provisional, y puede que me adapte a ella si no encuentro otra solución... el exportar las pistas de audio de HS y luego importarlas trabajando con el audio.

Muchas gracias por el cuestionario. Ya os seguiré contando.

Saludos
Subir
#29 por Javi Arce el 11/09/2014
A raíz de lo que cuentas, yo destacaría unos cuantos puntos clave:

-Si tienes picos de VST performance poco antes de que se produzca el "cuelgue" de la nota, ahí puedes tener una explicación. Tenemos un equipo casi calcado, salvo que mi procesador es a 3,20 GHzs. Lo normal es que puedas trabajar con varias librerías pesadas y varios plugins exigentes sin producir picos. ¿Sufres picos cuando abres un proyecto nuevo, con una única instancia de PLAY y con un único instrumento cargado? Si es así, quizá tengas el tamaño del buffer de tu tarjeta demasiado bajo (ya has dicho que no es así), o el driver no sea el más óptimo para trabajar con audio.

-Sobre lo último que te comento, desconozco el mundo SoundBlaster, pero tengo entendido que son tarjetas más destinadas a juegos que a cualquier otra cosa. No sé si será un producto profesional, pero... ¿no puedes probar con otra interface que tenga otras E/S MIDI? Con esto matas dos pájaros de un tiro: usas un controlador ASIO mejor para el sistema de audio VST (lo que se traduce en menos problemas de rendimiento VST), y un sistema de E/S MIDI también mejor. Algo tipo RME, Focusrite, Motu,... no hace falta que sea la pera, con mil canales y unos preamps de la leche, con que la interfaz esté diseñada para el trabajo con audio será suficiente.

-Yo creo (es una opinión personal, sin haber usado PLAY) que dejar activada la protección contra sobrecargas (overloads) es importante. No sé qué razones se darán en el tutorial que has visto para quitarla, pero si se producen sobrecargas de procesador vas a tener problemas de uso con cualquier VSTi. Lo normal de estos romplers/samplers es que, ante sobrecargas, se eliminen las voces que sonaron primero para impedir que el problema vaya a más. Un valor de protección que salte al 80% o 90% de carga de CPU creo que puede estar bien, en principio. No le veo el sentido a "trabajar por encima de tus posibilidades", quizá en el tutorial indiquen alguna ventaja que desconozco.

-Voces es el número de samples que levanta el programa al mismo tiempo. No son los eventos simultáneos que el controlador MIDI es capaz de emitir, si no los samples simultáneos que puede manejar PLAY. Tocar tres teclas en tu teclado puede suponer que, dependiendo del instrumento cargado, su tipo de polifonía y la cantidad de posiciones de micro cargadas, tu PLAY emita 3, 10, 20 o 1000 voces. Si tienes el límite en 2048, puede suceder que instrumentos "chupones" comiencen a emitir voces sin límite hasta que, mucho antes de llegar a ese límite de 2048, se sature la CPU y se estrese la RAM (y se produzca lo que los anglos llaman clicks, pops, hang-outs, drops, sustain bugs, etc.). Esto sucede a veces con instrumentos que tienen feedback sobre sí mismos, o que tienen largos eventos con sustain, por eso te preguntaba lo del pedal. Se supone que PLAY debería impedir que esas sobrecargas se produzcan, pero... siendo que ya experimentas ese tipo de problemas, mejor establecer tú el límite de voces e ir probando con la configuración más idónea.

-En resumen, si no te importa hacer pruebas, abre un proyecto a 16 bits, configura el PLAY con un máximo inicial de 128 voces (ves subiendo ese valor a 512, 1024, etc. si experimentas cosas raras, como notas que dejan de sonar), con una protección de sobrecarga de en torno al 80% de CPU, y cuéntanos a ver qué tal te ha ido. Si además puedes cambiar de interface de audio, ya hasta puedes ir a exámen ;)

Ésta es mi música:
https://corona-borealis.bandcamp.com/releases
Y ésta es mi aplicación web de teoría musical (beta):
http://codamusica.com/

Subir
#30 por Emilio Galsán el 11/09/2014
#26 , #27 , #28 , #29
Madre mía...Hay que ser informático para hacer algo que suene medio bien. :-(

Después de leerme todo el debate y de mi desilusión con mis primeros pasos con Cubase, veo que incluso los que saben mucho de esto tienen problemas o con el DAW o con el player de las librerías... #-o

Va a ser que no era tan fácil como parecía.

Salud, coraje y paciencia.
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo