Problemas con M-Audio Fast Track Pro en Kubuntu

--500728--
#1 por --500728-- el 25/05/2013
¡Muy buenas!

¿Qué tal?. Llevo tiempo siguiendo estos foros como mero espectador pero ya tocaba animarse a meterme de lleno. Tengo una tarjeta M-Audio Fast Track Pro y estoy intentando hacerla funcionar en Kubuntu y no hay manera. No me pilla señal ni con Ardour ni con Guitarix, por lo que tiene que ser de la tarjeta. Os dejo la salida de algunos comandos típicos para este tipo de configuraciones:

roberto@roberto-HP-550:~$ cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xe4624000 irq 45
1 [Pro ]: USB-Audio - FastTrack Pro
M-Audio FastTrack Pro at usb-0000:00:1d.1-1, full speed
roberto@roberto-HP-550:~$ ^C
roberto@roberto-HP-550:~$ arecord -l && aplay -l
**** Lista de CAPTURE dispositivos hardware ****
tarjeta 0: Intel [HDA Intel], dispositivo 0: AD198x Analog [AD198x Analog]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 1: Pro [FastTrack Pro], dispositivo 0: USB Audio [USB Audio]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 1: Pro [FastTrack Pro], dispositivo 1: USB Audio [USB Audio #1]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
**** Lista de PLAYBACK dispositivos hardware ****
tarjeta 0: Intel [HDA Intel], dispositivo 0: AD198x Analog [AD198x Analog]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 1: Pro [FastTrack Pro], dispositivo 0: USB Audio [USB Audio]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 1: Pro [FastTrack Pro], dispositivo 1: USB Audio [USB Audio #1]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
roberto@roberto-HP-550:~$ ulimit -r -l
real-time priority (-r) 95
max locked memory (kbytes, -l) unlimited

A priori y por lo que ya he leído en estos foros está todo correcto. Os dejo un pantallazo de la configuración de Jack.

Por favor, ¿me podéis comentar qué puedo estar haciendo mal?. Entiendo que las conexiones físicas no van más allá del cable USB de la tarjeta al PC y el instrumento por una de las entradas Jack.

Muchas gracias por todo.

Un saludo,

Roberto
Archivos adjuntos:
instantánea1.png
BBCode:
Subir
#2 por Pablo_F el 25/05/2013
Lo primero, por si acaso, mira alsamixer, no sea que haya controles accesibles y tengas algún nivel bajado.

alsamixer -c1

Es posible que la tarjeta no tenga controles accesibles desde alsamixer. En este caso, el problema no está aquí.


Más bien sospecho otra cosa. Si te fijas, la tarjeta tiene dos dispositivos el 0 y el 1. Y ambos son dúplex pues los dos aparecen en las lista de captura y reproducción.
Alguien escribió:

**** Lista de CAPTURE dispositivos hardware ****
tarjeta 1: Pro [FastTrack Pro], dispositivo 0: USB Audio [USB Audio]
tarjeta 1: Pro [FastTrack Pro], dispositivo 1: USB Audio [USB Audio #1 ]

**** Lista de PLAYBACK dispositivos hardware ****
tarjeta 1: Pro [FastTrack Pro], dispositivo 0: USB Audio [USB Audio]
tarjeta 1: Pro [FastTrack Pro], dispositivo 1: USB Audio [USB Audio #1 ]


Esto de los dispositivos es importante porque es como si hubieran dos "subtarjetas". Y el caso es que jack no habla a "tarjetas" sino a "dispositivos". Tal y como lo tienes configurado, jack está usando el dispositivo 0 de la tarjeta Pro (como no lo indicas, toma el 0 por defecto). Sin embargo, es posible que tengas que usar el dispositivo 1 para captura/reproducción. O, incluso, el 1 para reproducción y el 0 para captura, o viceversa. No tengo ni idea a qué entradas / salidas corresponde cada dispositivo.

Por ejemplo, si funciona la reproducción (dices que no puedes capturar, pero no tengo claro si puedes reproducir a través de jack?) prueba hw: Pro,1 como dispositivo de entrada y hw: Pro, 0 como dispositivo de salida, dejando interface en (default). Bueno, mejor prueba las 4 combinaciones.
Subir
--500728--
#3 por --500728-- el 26/05/2013
¡Buenas Pablo!

Pues era eso jejeje. Vaya tela. Llevo poco con Linux y todavía hay cosas que se me escapan. Poniendo el interfaz en "default", el dispositivo de entrada el hw:1,1 y el de salida el hw:1,0 ya me pilla la captura y la reproducción. La verdad es que ya me estaba volviendo loco jaja. ¡¡Muchísimas gracias figura!!
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo