Problemas con MIDI y VSTi - ¿Note off?

#1 por AbrahamFA el 06/02/2012
Muy buenas, tengo este problema:



Igualmente lo explico por si no ha quedado claro:

He grabado una pista midi desde mi teclado sin pisar el pedal de sustain. Como he reflejado en el video, si envió al banco midi de windows todo se reproduce con normalidad mientras que si envío esta pista a un instrumento VSTi ocurre lo que habéis visto. Como si el pedal sustain estuviese todo el rato conectado.

He de puntualizar que esto me pasa con todos los instrumentos VSTi que inserto en cubase mientras que con Reason (Rewire) no ocurre esto.

No se que hacer ¿Alguien me aconseja?

Un saludo a todos!

http://www.estudiomalaspulgas.es/

Subir
#2 por AbrahamFA el 06/02/2012
Una cosa que no he comentado, aunque sale reflejado en el video, es que al parar la reproducción el instrumento sigue sonando a no ser que vaya al menú MIDI-Reinicializar

http://www.estudiomalaspulgas.es/

Subir
#3 por AbrahamFA el 06/02/2012
¿Nadie? (Es urgente)

http://www.estudiomalaspulgas.es/

Subir
#4 por teniente_powell el 07/02/2012
No tengo ni idea. Pero hay algo que me resulta chocante: como entrada midi tienes M-16DX. No sé que es eso, pero mira si fuera algo que te está produciendo realimentación. Elige All Midi Inputs, o prueba con No Conectado, a ver si te sigue ocurriendo.

También me llama la atención que estás trabajando en esa pista con el canal Cualquiera. Elige un canal concreto (el 1, ó el 2, ó el 3, ... pero no el Cualquiera), a ver si lo resolviera.

Y, por último, me pregunto por qué cuando trabajas con el banco midi general, no hay programa asignado (lo que hay justo encima del texto Sin Drum Map), mientras que cuando eliges ese banco de cuerdas aparece C:\Program Data\Cakewalk. No había visto yo nunca nada así. Prueba a quitarlo.

Un saludo,
Subir
#5 por AbrahamFA el 07/02/2012
Los dos primeros temas que comentas más o menos los he toqueteado: He cambiado la entrada a No conectado y a All Midi Inputs y no cambia nada y el canal lo mismo.

Lo tercero que comentas lo revisaré.

Una cosa que no he comentado es que estoy utilizando Cubase 5 y no Nuendo. A lo mejor todo lo que comentabas es por la diferencia de interfaces.

http://www.estudiomalaspulgas.es/

Subir
--99435--
#6 por --99435-- el 08/02/2012
Extraído del manual de Cubase 5.

Manual de operaciones. --> Ctrol + F (buscar) = note off


Notas

Cuando pulsa y libera una tecla en su sintetizador o cualquier
otro teclado MIDI, se manda un mensaje de “Note
On” (al pulsar la tecla) y otro de “Note Off” (al liberarla). El
mensaje de nota MIDI también contiene la información sobre
qué canal MIDI ha sido usado. Normalmente, esta información
es sobrescrita por el ajuste de canal MIDI de la
pista, pero si ajusta el canal como “Cualquiera”, las notas
serán reproducidas en sus canales originales.



La función Reinicializar

La función Reinicializar en el menú MIDI envía mensajes
de note off y reinicializa los controladores en todos los canales
MIDI. Esto es a veces necesario si se cuelgan notas,
hay un vibrato constante, etc.
Hay otras dos opciones para realizar una reinicialización:
• Cubase puede realizar automáticamente una reinicialización
MIDI al detenerse.
Puede activar o desactivar esta función en las Preferencias (página MIDI).
• Cubase puede insertar un evento de reinicialización automáticamente
al final de una parte grabada.
Abra las Preferencias (página MIDI) y active la opción “Insertar Evento de
‘Reset’ al final de la Grabación”. El evento Reinicializar insertado reinicializará
los datos del controlador tales como Sustain, Aftertouch, Pitchbend,
Modulación, Breath Control, etc. Esto es útil si una parte MIDI está grabada
y p.ej. el pedal de Sustain todavía está pulsado después de haber
detenido la reproducción. Normalmente, esto haría que todas las partes siguientes
fueran reproducidas con Sustain, ya que el comando Pedal Off
no fue grabado. Para evitar esto, active “Insertar Evento de ‘Reset’ al final
de la Grabación”.



No me quedo claro si usas pedal de sustain o no, en el caso de que sí, esta sería la solución. En realidad, esto que está sucediendo creo que tiene que ver con alguna simple característica que hay que configurar nada más, ya sea de Cubase o de tu controlador MIDI. Te recomiendo en principio darle una ojeada a los manuales de tu controlador y de Cubase (si es que no lo has hecho ya), o esperar a que alguien te pueda decir precisamente cómo resolverlo, saludos.
Subir
#7 por AbrahamFA el 08/02/2012
#6 Puntualizo ante la duda: Todas las pitas midi están grabadas desde un clavinova yamaha, hay pedal sustain pero la pista que muestro en el vídeo no está pulsado en ningún momento.

Lo que me parece raro es que cuando utilizo el banco de sonido de windows no hay ningún problema con el mensaje de Note Off pero si tengo problemas al utilizar el vst (Esto que digo lo he grabado en el vídeo que he posteado). Creo que es lo que más me descoloca del asunto. Igualmente mañana reviso todo lo que comentabas.

#4 He probado a cambiar el número de canal y también el dispositivo de entrada pero nada cambia. Sigue comportándose de la misma forma. Lo que ahora me parece raro es que el tema de comentabas de "C:\Program Data\Cakewalk"... ¡Ahora no aparece! ¡Se queda en blanco! (O mejor dicho, un recuadro negro)

Se que problema del controlador no puede ser porque ya he utilizado dos distintos y pasa lo mismo. En rewire funciona todo el asunto midi con Reason pero con vst se crea el caos.

Ya se me calienta un poco la cabeza porque llevo un par de años así y no me ha hecho falta los vst hasta hora.

Ante todo, muchas gracias a los dos por ayudarme ;)

http://www.estudiomalaspulgas.es/

Subir
#8 por teniente_powell el 08/02/2012
abrahamfa escribió:
Lo que ahora me parece raro es que el tema de comentabas de "C:\Program Data\Cakewalk"... ¡Ahora no aparece! ¡Se queda en blanco! (O mejor dicho, un recuadro negro)
Yo, de siempre, lo tengo en blanco. Nunca tengo seleccionado nada ahí. Yo en Cubase 5 cargo cualquier vst (kontakt, superior drummer, edirol, ....) y nunca tengo nada en ese recuadro.

Saludos,
Subir
#9 por AbrahamFA el 09/02/2012
Me he comprado ( :roll: ) Nuendo 4.3 por si este tema cambiaba y sigue comportándose del mismo modo.

teniente_powell escribió:
Yo, de siempre, lo tengo en blanco. Nunca tengo seleccionado nada ahí. Yo en Cubase 5 cargo cualquier vst (kontakt, superior drummer, edirol, ....) y nunca tengo nada en ese recuadro.

Saludos,


No selecciono nada, me aparece o no me aparece... Ahora por lo menos me ahorro el reinicializar el midi cada vez que paro.

http://www.estudiomalaspulgas.es/

Subir
#10 por AbrahamFA el 09/02/2012
Acabo de darme cuenta que ese recuadro se "rellena" solo cuando selecciono el canal midi en "cualquiera". Si pongo un canal cualquiera desaparece, aun así el sonido no cambia nada.

Esto tiene pinta de tener una solución fácil pero no doy con la tecla... Definitivamente cubase/nuendo me lee "noteoff" cuando la pista midi no está dirigida a ningún vst pero a la hora de dirigirlo no lo lee y me parece rarísimo!

http://www.estudiomalaspulgas.es/

Subir
#11 por teniente_powell el 09/02/2012
Comprueba con el Editor de Lista que no tengas ningún comando extraño o algún CC Midi que esté por ahí dando por saco.
Subir
#12 por AbrahamFA el 09/02/2012
teniente_powell escribió:
Comprueba con el Editor de Lista que no tengas ningún comando extraño o algún CC Midi que esté por ahí dando por saco.


La verdad es que nunca había entrado en el Editor de Lista. Igualmente todos los datos que veo son notas. No hay ni sustain ni nada de nada raro.

Me repito, me parece raro que la pista midi se comporte de manera normal hasta que lo envías a un vst. :tasmal:

http://www.estudiomalaspulgas.es/

Subir
#13 por AbrahamFA el 11/02/2012
He probado ha abrir el proyecto en otro ordenador y se ve que no es problema del PC. Tiene que ser de cubase.

http://www.estudiomalaspulgas.es/

Subir
#14 por teniente_powell el 11/02/2012
Dime cuáles son los VSTi que has probado.
Subir
#15 por AbrahamFA el 11/02/2012
Pues he utilizado dos: Dimension Pro y Studio Instrument, los dos de Cakewalk. Ante la duda por si era la "marca" la que da problemas acabo de probar un vst de DSK de cuerdas y se comporta de la misma forma.

http://www.estudiomalaspulgas.es/

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo