Reducir latencia midi

#1 por Daniel el 26/10/2011
Cual es la mejor forma para reducir total o parcialmente (si es totalmente mejor) la latencia que tiene un teclado midi, no me refiero a la latencia de audio, sino a el retardo desde que el teclado manda la señal hasta que el pc la recibe y ableton la procesa, no es demasiado grande pero si es posible reducirla y desconozco el metodo me gustaria que me informarais.
Subir
#2 por 3ɅƦ WøøD el 27/10/2011
hola daniss1,

¿como haces para reconocer esa latencia midi? Es decir, cuando grabas notas midi por ejemplo ¿ocurre que estas te las graba con retraso o te refieres a que las oyes con retraso?

un saludo

diletante profesional

Subir
#3 por Daniel el 28/10/2011
#2 grabo con retraso, creo que se debe a la interfaz, dado que con un sinte externo conectado via midi suena perfectamente (la latencia de audio lo he comprobado y es practicamente 0, apenas 2ms), no es una latencia demasiado grande ni importante pero ya que por lo visto se puede reducir si es posible me gustaria hacerlo
Subir
#4 por 3ɅƦ WøøD el 28/10/2011
latencia de audio de 2ms?!! pedazo interface!! rme?? (o trabajas a 96KHz o algo asi?)

bueno, por precisar un poco las cosas, supongo que te refieres a que tocando desde el sinte puedes grabas las notas sin latencia. Entonces esta claro que tienes un problema en el teclado MIDI, porque eso no es normal.

No se si el delay de pista podria estar afectando en esto (aunque me imagino que eso tambien lo habras comprobado), a decir verdad nunca lo uso y no se bien como va.

Si tienes un problema con el teclado lo que podrias probar es a reinstalar el driver... A ver si alguien te puede echar un cable con esto, porque a mi al menos no se me ocurre nada. De todas formas, ¿de que teclado hablamos?

diletante profesional

Subir
#5 por Daniel el 28/10/2011
Ear Wood escribió:
latencia de audio de 2ms?!! pedazo interface!! rme?? (o trabajas a 96KHz o algo asi?)

una fireface 400 en concreto, adquirida hace relativamente poco, de todas formas esa latencia la consigo con asio y forzando bastante la latencia.
Ear Wood escribió:

bueno, por precisar un poco las cosas, supongo que te refieres a que tocando desde el sinte puedes grabas las notas sin latencia. Entonces esta claro que tienes un problema en el teclado MIDI, porque eso no es normal.

entonces supongo que sera el teclado, la cosa es que antes no me pasaba, ha empezado hace poco y pense que era por la sobrecarga de cpu, pero al no ser pense en alguna opcion para reducir esa latencia.
tendre que mandar el teclado a la garantia
Ear Wood escribió:

No se si el delay de pista podria estar afectando en esto (aunque me imagino que eso tambien lo habras comprobado), a decir verdad nunca lo uso y no se bien como va.

ya lo he comprobado, de todas formas eso hasta donde yo se solo afecta a la reproduccion de sonido, no a la grabacion.
Ear Wood escribió:
¿de que teclado hablamos?

el teclado ahora mismo es un axiom 49, de maudio, se que es bastante cutre pero como tambien lo uso para live me venian bien todos los knobs y faders. tengo idea de cambiarlo pronto, aunque si no me hubiera dado ningun fallo es un teclado bastante bueno para su gama.
gracias por la ayuda, lo mandare al servicio tecnico, lo curioso es que el problema me lo da desde hace poco y ni siquiera reinstalando el driver..... no se que puede ser..
Subir
#6 por 3ɅƦ WøøD el 28/10/2011
es un buen teclado, creo que no deberia darte esos problemas. Consultales a ver...

pd, no es que me moleste ni un pelo, al contrario. Pero acabo de caer en la cuenta de que con la aparicion de los foros los servicios tecnicos han hecho su gran agosto jajajaj si en verdad son ellos quienes se deberian estrujar los sesos!!!

un saludo!

diletante profesional

Subir
#7 por Daniel el 28/10/2011
acabo de probar y he podido comprobar que conectandolo via cable midi funciona perfectamente, por lo que, o es problema del interfaz usb que tiene integrado o es problema del driver, en cualquier caso voy a hablarlo con el sat de maudio
Subir
#8 por 3ɅƦ WøøD el 28/10/2011
en ese caso, ¿has probado a instalarlo en otro puerto USB? quizas sea ese puerto del ordenador lo que falla (eso es mas tipico, yo tengo un par ya para el arrastre)

diletante profesional

Subir
#9 por Daniel el 29/10/2011
#8 pues no, de todas formas son los integrados en la placa base, probare con uno de los que van pinchados en vez de integrados a ver si lo soluciono
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo