Requisitos para eludir latencias, clicks o saltos.

#1 por beatrancedj el 14/04/2010
Hola a todos.

Bueno, esta creo q es una típica pregunta en el mundo de la producción musical con pc, pero es una pregunta, que a mi, nunca me ha quedado clara, ni nunca he solucionado.

Mi problema es latencia con mi software, y a la hora de cargar muchos vst, o fx, le cuesta mucho tirar al pc, y comienza a tener saltos en el tema, se escucha entrecortado, clicks, etc, algo que seguramente todo el mundo aquí conoce.

Y bueno, mi pc tiene un procesador AMD Athlon 64 x2 Dual Core 4000+ de 2,4 Ghz, y de 4 Gb de Ram actualmente.
Primeramente contaba con 2Gb, pero lo aumenté a 4 Gb, aunque Windows Xp solo es capaz de soportar 3 con algo como máximo por lo que tengo leído por ahí. La aumenté con la idea de que quizás era ese el problema de mi latencia y todo eso, pero nada, ninguna mejora.

Tengo una tarjeta externa la M-audio Fast Track Pro, y la verdad, que lo mismo, todo sigue igual.

Actualmente necesito un equipo en el que pueda trabajar bien, y no tenga esos problemas incómodos que no me permitan trabajar con comodidad y normalidad, pero lo ceirto es, que no conozco cual sería la solución, empiezo a pensar que quizás sea cosa del procesador, que no es capaz de procesar todo lo que sale de mi secuenciador (FL 9)

Os agradecería vustra ayuda, y una respuesta que por fina me solucione todo esto.

Un saludo, y gracias.
Subir
--100617--
#2 por --100617-- el 14/04/2010
cuanto buffer y latencia tienes?
Subir
#3 por Claudio.A el 14/04/2010
aumentar el tamaño del buffer?

yo tengo un pc identico al tuyo. trabajo con ableton y driver asio4all, aumente el tamaño del buffer desde el driver de audio y dejo de clickear. el problema es cuando tengo que usar el controlador :( mucha latencia :(


mas buffer = mas latencia
mas latencia = elimine los click, saltos , etc.

"...La Musica no es buena o mala. Te gusta o no te gusta. si al final de todo....Es musica, y eso es lo q nos hace vivir".

Subir
#4 por beatrancedj el 14/04/2010
De buffer no sabría decirte, pero vamos, que a 512 de buffer o algo asi, q es lo normal si no me equivoco, logicamente con un solo vst, no hay latencia apenas, con 3 o 4 + fx, comienzan los retardos,etc, poniendo el buffer a tope, como es lógico se consigue solucionar un poco ese click, pero la latencia es el cuadruple, con lo cual no me interesa...:S
Subir
#5 por Iban Nieto el 14/04/2010
Hola,

Quizás lo mejor sería desactivar temporalmente antivirus, cerrar programas que no vayas a utilizar (sobre todo los que están en el systray o bandeja del sistema), cerrar navegadores etc y dejar sólo abierto el/los programas musicales que vayas a utilizar.

Por otro lado, tener 4 Gb con XP es inútil, como bien has dicho, no direcciona más de 3Gb, aunque se puede hacer una historia llamada "PAE" para que pueda usar los 4Gb, el escenario ideal sería que actualizaras a Windows Vista o Seven para a)usar toda la memoria b)mejorar la velocidad y reducir latencia.

Tu procesador debería dar de sobra para lo que utilizas, a priori. Puedes saber si estás utilizando toda tu CPU arrancando el administrador de tareas (click con el botón derecho de ratón en la barra de tareas) una vez que te empiece a ir todo lento. Si tienes la CPU al 100% todo el rato, es que algo pasa, o te estás quedando corto de recursos (que no debería) o algún VST y/o algún otro programa te está devorando la CPU. Haz la misma comprobación con el FL9 encendido y apagado a ver si tienes la CPU libre antes de arrancar tu programa de música.

Un saludote

A&H Xone 42 + Technics SL-1210MK5 + NI Audio 4DJ
Traktor Scratch Pro + Kontrol X1 + Ableton Live + AKAI MPK Mini
KRK Rokit 8 GP2 + Technics RP-DJ1200

Subir
#6 por beatrancedj el 14/04/2010
Nada tio, desactivando todo, cerrando todo, ni es mejor, ni es peor. Lo del xp es verdad si, al principio tenía vista, pero tube un problema con él, derrepente, pantallazo negro, q ya le ha pasado a muchisima gente po ahí, formatee, y fui a lo seguro, xp.

Respecto al uso de cpu, en fl, cuando eso ocurre, pues muchisimos picos de 99%, casi todo el tiempo, y en administración de tareas de windows nunca llega al 90% suele estar entre 70 y 85% es una desesperación esto, jaja.

Utilizo muchisimo vst, y fx, pero es algo inevitable. Produzco trance, y delay, reverb, y los vst, son irremediables...
Subir
#7 por klosewaitz el 14/04/2010
Yo he tenido bastante problemas con la latencia para la guitarra eléctrica, que al final he logrado solucionar solo a medias.

Al final lo solucioné con un cable que pillé en Alemania para conectar la guitarra directamente a USB, y tirar de los Asio4all. Y aun así no bajo de lo 10-15 ms.

El problema que tienes de latencia te viene dado por el proceso de VST... yo no tengo muy claro que bajar el buffer te vaya a solucionar los problemas de latencia (por no contar que te va a provocar clicks. Que aunque en la mezcla final no aparezcan, a la hora de tocar ponen de los nervios. A mí al menos).

Yo en tu caso... pasaría del FL, me bajaría el Reaper y congelaría tracks. Es un poco coñazo, pero le vas a quitar mucha carga al procesador.
Subir
#8 por kiket el 14/04/2010
El tema de los 3gb de memoria, no es cuestión de tener xp o vista o seven. Es cuestión de si el so es 32 o 64 bits. Con 32bits solo se puede direccionar 3,2gb aprox. Con 64bits ya puedes direccionar mucho más. De todas maneras, creo que el problema de la latencia viene más por tema de drivers/buffer y procesador que por memoria. A no ser que le cargues mil vsts con 4gb deberías de ir sobrado. Creo que es un problema de ajustar el buffer de la tarjeta de audio, usar los drivers asio correspondientes y tener un buen cableado.

Saludos,

Soy todo lo que me pasa...

Subir
#9 por Iban Nieto el 15/04/2010
Muy cierto, para sacar el máximo partido al sistema, debería ser de 64 bits. Lo que pasa es que ciertos sistemas Vista OEM tienen el PAE habilitado por defecto (suponiendo que el ordenador no es un clónico y/o tiene una licencia original de Vista).

Se podría habilitar el PAE para usar los 4Gb de memoria en un sistema de 32 bits a través del siguiente procedimiento: 1) ejecutando cmd.exe (inicio->Ejecutar) y 2) ejecutando el comando "bcdedit /set PAE forceenable". Después reiniciaríamos y a funcionar.

Por otro lado, coincido con kiket en que el problema podría ser el buffer de la tarjeta de audio. También se podría probar (des)habilitando algunos VSTs para comprobar cuales de ellos gastan más recursos y si podrías hacer lo mismo con otros plugins; todo es cuestión de probar.

Suerte!

Un saludote

A&H Xone 42 + Technics SL-1210MK5 + NI Audio 4DJ
Traktor Scratch Pro + Kontrol X1 + Ableton Live + AKAI MPK Mini
KRK Rokit 8 GP2 + Technics RP-DJ1200

Subir
#10 por beatrancedj el 16/04/2010
Hola de nuevo!

Gracias por las respuestas.

Bueno pues he estado probando mas cosillas, pero ahora tengo un problemilla con el buffer de la tarjeta de sonido, no me permite subir la latencia ni bajarla..:S

Tengo el FL9 y al seleccionar en las opciones de sonido que tarjeta de sonido voy a utilizar, tengo dos opciones con la Fast Track Pro. Me aparecen la propia tarjeta del pc y respecto a la tarjeta me aparece, M-Audio Fast Track Pro, y también, Fast Track Out 1/2.

Con la opción M-audio fast track pro, simplemente no ocurre nada, no suena, pero me permite usar el buffer de los drivers ASIO. Con la otra opción si que me funciona, pero solo me permite cambiar el buffer del directsound, y esto no me permite cambiar el buffer de la tarjeta en el icono de la m-audio que aparecen en la barra de tareas. No entiendo porqué.

Y aprobechando la ocasión, en el portátil, es un poco antiguo respecto al pc, pero lo suficientemente moderno como para soportar la m-audio, pues solo me detecta la tarjeta como m-audio fast track pro, nada de out 1/2 con lo que no puedo usarla...siempre me aparece como NO CONNECTED.

Está la tarjeta mal? O simplemente soy nulo configurandola? jaja

Un saludo, y gracias por todo otra vez.
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo