Retardo 1 compás External instrument Live 8

#1 por jlerin el 10/03/2013
Hola.

Después de leer varios hilos sobre la latencia en Live 8 no he conseguido encontrar el problema que a mí me sucede. Os lo intentare explicar de forma clara.

Tengo un Korg microkorg XL, y lo conecto al ordenador de dos formas. Una por USB y otra por conexión RCA con la tarjeta de sonido. La latencia que me causa problemas no es la referida a la tarjeta de audio –una Ares SC 4- sino un retardo interno de Live que lleva a cabo cuando introduzco en una pista Midi con un “External Instrument” esté conectado o no. Además lo curioso del asunto es que configure la latencia como la configura el retardo interno del programa siempre es de un compás, algo que me resulta muy extraño. Retarda todos los instrumentos un compás.

Esto me causa problemas porque yo no soy un virtuoso del piano, así que compongo las partituras haciendo un borrador previo con un teclado Midi, luego las voy cuadrado con el ratón y lo hago puramente de oído.
Hago la partitura, y luego suelto el set desde Live y lo grabo como audio. Y ya introduzco esta pista de audio en lo que será la composición final.

Así que el problema es que cuando suelto un set en el cual estoy trabajando el sonido va un compás por detrás que la barra negra que indica en el monitor lo que se está reproduciendo. Es decir si tengo en el primer compás un Do y en el segundo un Mi. Cuando la barra negra que indica la progresión de la pista está situada en el Mi suena por los altavoces el Do. Así que es un caos porque no tengo una perspectiva real de los tiempos respecto a lo que ya he compuesto. He de recordar que yo compongo a odio, así que me resulta muy muy complicado componer si todo se retrasa un compás constantemente porque ya no sé si lo que ahora suena bien luego sonora igual, sobre todo cuando meto estructuras complejas.

Este retardo tan solo desaparece cuando elimino la pista Midi que contiene el “External instrument”. Así que la pregunta es cómo trabajar con un instrumento externo mediante “External instrument” sin que se produzca este retardo de un compás.
Uso el External instrument para que Live “toque” las notas en el sintetizador y grabarlas en una pista de audio.
Para hacer cualquier tontería con Korg microkorg XL me tiro un montón de tiempo, ajustando, recuadrando, volviendo a recuadras… Un autentico dolor de cabeza y un despropósito.
Alguien tiene alguna idea con la que solventar este problema.
Subir
#2 por alespardo el 11/03/2013
Lo primero, esa latencia si es de tu tarjeta. Es el tiempo de retardo que tarda en enrutar la señal de entrada hacia ableton live. Si abres el desplegable de delay de la pista y lo ajustas manualmente debería de cuadrarse. Yo cuando tuve un microkorg eran unos 9/12 milisegundos no mas. Y el external instrument ya pintas ahí las notas midi no? Vamos que no necesitas mas q esa pista y ahí pones donde le manda el midi al Korg y de donde entra el audio

Ableton Live 9 Push2 Access Virus Rack Moog Minitaur

https://www.facebook.com/AbletonLiveUserGalicia
https://www.facebook.com/djalespardo
http://soundcloud.com/alespardo

Subir
#3 por jlerin el 11/03/2013
Creo que no me he explicado. No he preguntado si hay alguna forma mágica para eliminar la latencia y sé que mi tarjeta de audio tiene latencia.

Lo que me ocurre es que la barra de progreso de Live pasa por una nota y después suena por los altavoces. Y lo que quiero es precisamente evitar eso. Configurar las latencias y con estas configuradas que cuando la barra de progresos (la negra) pase por la nota La suene La en ese mismo momento y no más tarde.

¿Se me entiende? Es que no se si logro explicar el asunto bien.

Gracias por tu respuesta "alespardo"
Subir
#4 por jlerin el 11/03/2013
Ya lo tengo solucionado.

He aplicado tu configuración "alespardo" funciona de cine, 9/12 milisegundos. Además he descubierto que se puede configurar el retardo por canales y así no afecta a todo el proyecto.

La opción esta en ver/retardo pista y aparecerá una nueva área debajo de cada pista para configurar este parámetro.

Problema solucionado

Gracias "alespardo" :D
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo