SONY VEGAS 11 / Vista previa a tirones

  • 1
#1 por Drive el 03/04/2015
Hola, estoy empezando con el programa Sony Vegas Pro 11.0 y tengo el gran problema de que la vista previa cuando estoy trabajando con un vídeo me da muchos tirones.

Una vez terminado el vídeo, lo renderizo y éste queda perfecto. He buscado varias fórmulas por internet y todo lo que pruebo no me funciona.

SOLUCIONES PROBADAS

Una de las soluciones que he probado, es ir a PREFERENCIAS/VÍDEO y poner la ram dinámica del vídeo a 0.

También estoy jugando con la calidad de la vista previa, probando diferentes posibilidades y nada.

Estoy pensando que a lo mejor puede ser un problema de codecs, alguien sabe cuál es el paquete más idóneo para este programa?

Os dejo las características del portátil con el que trabajo, gracias de antemano!

Windows 7 Ultimate
Service pack 1

Procesador: Intel Core 2 Duo T5450 @ 1.66 GHz 1.67 GHz
Ram: 3 GB
32 bits

-Windows 7 Servi Pack 1. 64 Bits
-Procesador: Intel (R) Core (TM) 2 Duo cpu T5450 @ 1.66 GHz 1.67 GHz
-Ram: 4 GB
-Sonido: Tarjeta Fast Track Pro
-Programas: Cubase 5, Amplitube 3, Addictive Drums.

Subir
#2 por lowpass el 03/04/2015
Hola.

Yo he estado trabajando mucho tiempo de esa manera, hasta que dije: si en otros programas eso no me sucede, no puede ser problema, ni de mi ordenador, ni de Vegas. Ahora mismo no encuentro el enlace donde leí la solución, pero si doy con él, lo pongo. Básicamente lo que tienes que hacer es establecer un framerate y un tamaño de imagen en las propiedades del proyecto, y hacer que todo lo que importes en Vegas tenga ese framerate y ese tamaño. Por ejemplo, imagínate que quieres que tu proyecto sea 1280 x 720 a 25 fps. Entonces, en las propiedades del vídeo estableces 1280 x 720 y 25 fps. Si ahora tienes que importar al proyecto un archivo que sea, por ejemplo, 426 x 240 a 24 fps, deberás convertirlo antes (por ejemplo con mpegstreamclip) a 1280 x 720 a 25 fps. Una vez convertido, es cuando debes importarlo en Vegas. Creo que más o menos eso es lo que hice.

Ya me dirás si te funciona. Un saludo.
Subir
#3 por Drive el 03/04/2015
Gracias por la orientación Lowpass!!

Te haré caso y convertiré los vídeos al formato del proyecto, a ver si me hago con ello.

Otra posible solución que encontrado es activar el administrador de tareas de Windows, voy a procesos y establezco la prioridad del sony vegas en ALTA. Sigo con mi problema de lentitud, pero quizá a alguien le sirva..

Hoy me han hablado bien del programa Adobe after effects. Mis pretensión son montar vídeos con transiciones curradas, rótulos, etc.. para poder promocionar, por ejemplo, el lanzamiento de un nuevo disco del grupo "x". Cositas en plan promo..

-Windows 7 Servi Pack 1. 64 Bits
-Procesador: Intel (R) Core (TM) 2 Duo cpu T5450 @ 1.66 GHz 1.67 GHz
-Ram: 4 GB
-Sonido: Tarjeta Fast Track Pro
-Programas: Cubase 5, Amplitube 3, Addictive Drums.

Subir
#4 por Endre el 12/06/2015
Mira en este enlace los problemas que faltan todavía por solucionar en Sony Vegas.

http://dspcdn.sonycreativesoftware.com/releasenotes/vegaspro13.0.453_readme_esp.htm
Subir
1
#5 por Drive el 18/06/2015
Gracias Endre!!

-Windows 7 Servi Pack 1. 64 Bits
-Procesador: Intel (R) Core (TM) 2 Duo cpu T5450 @ 1.66 GHz 1.67 GHz
-Ram: 4 GB
-Sonido: Tarjeta Fast Track Pro
-Programas: Cubase 5, Amplitube 3, Addictive Drums.

Subir
#6 por tukor el 21/08/2015
Si quieres hacer vídeos complicados, sin dudas con After effects le das mil patadas a sony vegas.
Ojo Sony Vegas tambien lo uso; simplemente cuando necesito algo rápido y facil (pero potente).
Si ya voy a complicarme la vida o meter cosas 3D,Fxs, etc... after effects

En cuanto al problema en sí, ahora mismo sin verlo no se... pero como te dicen mira a ver en que formato estás trabajando.

Pero muchas veces pasa que si metes muchos efectos (o transiciones, o fades o lo que sea) te irá lento, algo que nos pasa a todos. Simplemente el ordenador no puede mostrar todo bien mientras "piensa" en como meter esos efectos a la vez.
Cuando lo renderizas es normal que ya te salga bien, ya que el proceso que sigue el programa no es el de "·mostrar" si no el de pegar todo.
No se si me explico xD

¿Solución a eso? mejorar el ordenador.. ver la preview en menor calidad... o en menos tamaño...
Pero no siempre conseguirás verlo fluído si está muy recargado de efectos. Tampoco en After effects...

NOTA: Si usas after effects has de saber que es mucho más complicado de usar que Sony Vegas... la curva de aprendizaje es mucho mas lenta....
Eso si, After effects + Element 3D (es un plugin) = Flipas!
Subir
#7 por Endre el 21/08/2015
Sony Vegas y Adobe After Effects no son equivalentes. El editor de Adobe es Premiere. After Effects es para añadir efectos (como el nombre indica), Premiere es para montaje de video.

Los precios también son distintos y habría que pensarlo bien antes de decidirse por un producto Adobe si no se tiene por objetivo un futuro profesional o semi-profesional. Es una inversión importante.
Subir
#8 por Drive el 02/11/2015
No hay manera..

Estoy con la versión 13 y ocurre lo mismo. He leído todo lo posible sobre la solución del error y nada.

Hay una solución que funciona, y es que, desde herramientas, das a generar vista previa de ram dinámica.. y el proyecto anda perfecto, eso sí, tarda un rato en generarla. EL problema viene en cuanto haces algún cambio al proyecto, de nuevo falla.. me gusta el sony vegas pero así no hay manera de poder avanzar con él.

He leído a mucha gente que tiene equipos muy potentes y les sucede lo mismo..

Seguiré intentándolo a ver si doy con algún remedio...

-Windows 7 Servi Pack 1. 64 Bits
-Procesador: Intel (R) Core (TM) 2 Duo cpu T5450 @ 1.66 GHz 1.67 GHz
-Ram: 4 GB
-Sonido: Tarjeta Fast Track Pro
-Programas: Cubase 5, Amplitube 3, Addictive Drums.

Subir
#9 por papitu el 02/11/2015
Aqui sucede lo mismo y yo di una solución personal.
http://www.hispasonic.com/foros/edicion-video-relentizada/489264

Mi canal YouTube
https://www.youtube.com/user/pivotao

Subir
#10 por Drive el 03/11/2015
#9

Gracias por el aporte Papitu. Ahora mismo acabo de empezar un proyecto con tan solo una intro de 12 segundos que me he descargado. La cosa está igual, la previa da tirones. No sé si meterme en lo que propones de transformar dos pequeños vídeos que vienen en la intro.

Me da que si una intro de 12 segundos va asi, no sé que podrá ser.. Mi equipo no es muy potente pero en ocasiones sí me ha funcionado la previa.

-Windows 7 Servi Pack 1. 64 Bits
-Procesador: Intel (R) Core (TM) 2 Duo cpu T5450 @ 1.66 GHz 1.67 GHz
-Ram: 4 GB
-Sonido: Tarjeta Fast Track Pro
-Programas: Cubase 5, Amplitube 3, Addictive Drums.

Subir
#11 por mcvadsr1965 el 27/11/2015
Yo trabajo con vegas y puedo decir que con archivos de video MTS o M2TS todo va mejor, con MP4 o AVI va fatal.
Subir
#12 por Antonio Leal el 26/12/2015
Muchos factores pueden influir y algunos ya te los han explicado. Influye el codec del Archivo de video. Influye el hardware de tu ordenador. Influye que tú proyecto tenga una configuración diferente a cómo fueron grabados los vídeos. Influye por supuesto la calidad de la imagen de previo.

Has dado datos de tu pc, el cual me parece el primer problema para esos tirones de los que hablas. De hecho cuando haces un "Build dynamic RAM preview" el problema desaparece. Pero no recuerdo que nos hayas comentado qué vídeos son los que estás editando : resolución, codec (que es diferente que "contenedor"), framerate... Un vídeo avi PAL DV de definición estándar o un MPEG-2 (MPG o Mpeg) de igual definición seguramente te vaya más fluido.

Si te sirve de consuelo yo tengo un cuatro núcleos con 16gb RAM, le meto un vídeo de la GoPro y va a saltos hasta en la peor de las calidades. No he conocido vídeos más exigentes que los codificados con la GoPro.
Subir
#13 por Mazeppa79 el 13/01/2016
Viendo el equipo que pone en tu firma, te falta procesador para tener un buen playback en vídeos HD (y si tuvieras suficiente micro, tal vez te faltase un disco duro rápido o una buena gráfica). Tranqui, que hay solución, es sólo una cuestión de flujo de trabajo.

Primero. Los programas de vídeo prefieren formatos sin compresión o sólo con compresión intra-frame. Para trabajar con vídeo, olvídate de MP4 y similares. Si tu material es tipo MP4 (cosa normal con las cámaras domésticas), siempre es buena idea convertir los clips a AVI, Pro-Res, DNxHD, Cineform y similares para trabajar con ellos. MP4 es un formato de entrega, no de trabajo. En qué formato está tu material?

Segundo. Las resoluciones modernas y los efectos consumen muchísimos recursos del ordenador. Hay 2 soluciones si tu ordenador no puede con eso:

-Proxies: los proxies son versiones a baja resolución de tus clips de vídeo. Con 1 ejemplo se entenderá mejor. Imagina que he grabado varias tomas a 1080p y quiero editar y añadir efectos. En vez de trabajar directamente con esos clips, primero hago una versión a 540p (una cuarta parte de la resolución). Estos nuevos clips son mis proxies. Hago la edición, correción de color y todo lo que quiera con esos proxies. Cuando lo tenga todo ajustado, sustituyo los proxies de baja calidad por los originales de alta calidad y renderizo. Todos los editores de vídeo tienen alguna forma de sustituir unos clips por otros en tu "timeline". Échale un ojo al manual de Sony Vegas o pregunta por su foro cómo se hace.

-Congelar efectos: funciona como congelar pistas en un DAW. Al aplicar muchos efectos, es normal que tu gráfica y tu procesador no puedan hacer todos esos cálculos en tiempo real. En Vegas tiene que haber alguna opción para congelar los efectos que quieras. Lo que hace eso es renderizar el trocito que selecciones con los efectos ya aplicados y colocar este render en tu timeline. Cuando quieras cambiar los ajustes del efecto, descongelas, ajustas y vuelves a congelar. Exactamente igual que en un DAW.

Prueba los de los proxies y congelar efectos y deberías tener un buen playback. Si no se entiende lo que digo, pregunta sin miedo. Cuando empecé a editar, me sonaba todo a chino jejejejejje.
Subir
#14 por Drive el 14/01/2016
Gracias a ambos!! Lo miro detenidamente y volveré a comentar ;)

=D>

-Windows 7 Servi Pack 1. 64 Bits
-Procesador: Intel (R) Core (TM) 2 Duo cpu T5450 @ 1.66 GHz 1.67 GHz
-Ram: 4 GB
-Sonido: Tarjeta Fast Track Pro
-Programas: Cubase 5, Amplitube 3, Addictive Drums.

Subir
#15 por Mazeppa79 el 17/01/2016
Drive escribió:
Gracias a ambos!! Lo miro detenidamente y volveré a comentar


No te compliques mucho para probar los proxies. Simplemente prueba con un vídeo de baja resolución a ver si te va más fluido. Si te funciona, ya buscas después cómo es el proceso para trabajar así (proxy editing).
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo