¿tarjeta para usar con ardour, energyxt?

  • 1
#1 por cpr el 16/04/2010
Hola, antes de meter la pata me gustaría conocer opiniones. Ando buscando una tarjeta de audio compatible con linux (ubuntu 9.10), preferiría que fuese usb y compatible con windows, mac y linux ya que si es usb me la llevaria a distintas plataformas aunque no descarto una interna.

El uso que le daría es para grabar de micrófono y para usarla con programas como energy xt, ardour, lmms, rosegarden... y si fuese compatible la utilizaria con fl studio, garage band...

Actualmente utilizo una integrada y por supuesto, con programas como lmms, energy xt,..va a tirones incluso para reproducir la demo que viene y es imposible hacer nada asi.

El micrófono, de momento tiro con uno de jack barato, mas adelante tengo pensado comprar uno por usb que no se que tal irán, por lo que el numero de entradas que necesito es mínimo. y por ultimo que tenga salida 5.1 (solo salida, de jack o coaxial no optica) y que sea barata para empezar.


he visto es una hercules muse xl que no funciona al 100% y esta otra que es pci y creo que no es compatible http://es.creative.com/products/product ... =0&listby=

tambien vi una de behringer creo que se llama uca 222 que si es compatible pero no tiene entrada de microfono.gracias.
Subir
#2 por Pablo_F el 18/04/2010
Si puedes conseguir una SB Live! de segunda mano, puedes tener muy baratas. Hay muchas no usadas porque llegaron a ser muy populares. No conozco ninguna USB que tenga salida 5.1 pero si es "class compliant" o "plug and play" funcionará. De todas formas, yo intentaría arreglar primero los problemas con la integrada. Igual no es toda la culpa del hardware y puede funcionar mejor.

Eso sí, si quieres buena calidad de grabación, no hagas caso a este post. Lee el foro porque hay varios hilos que tocan este tema.

Saludos, Pablo
Subir
#3 por cpr el 18/04/2010
he mirado la sb live¡ y veo que es un poco antigua (salio en 2001), ¿no sera mejor por poco mas irme a una x-fi? (la xfi que puse en el enlace anterior la consigo barata pero no estoy seguro de su compatibilidad)


Alguien escribió:
De todas formas, yo intentaría arreglar primero los problemas con la integrada. Igual no es toda la culpa del hardware y puede funcionar mejor.


Tambien me interesaba cambiar la tarjeta porque tengo los altavoces z5500 y se nota la calidad de sonido de una tarjeta a otra (hace tiempo probe una audigy) ademas, la integrada solo tiene salida estereo, aun asi, buscare por el foro a ver por donde empiezo a configurar la integrada porque probe el enegy xt en windows y funciona bien al reproducir la demo y en linux no me deja darle al play, puedo reproducir cambiando la configuracion de la tarjeta desde el propio energy xt y al cambiarlo va a tirones y se escucha solo un rato, en cuanto tocas un par de cosas vuelve a no dejar darle al play. gracias.
Subir
#4 por Pablo_F el 18/04/2010
Hablando de la integrada, lo primero que deberías mirar es si el módulo snd-hda-intel (que supongo que es su driver, pero compruébalo con "cat /proc/asound/modules") necesita especificar un modelo para el chip de tu tarjeta (que puedes comprobar lanzando "alsamixer" desde terminal). Mira en en http://www.mjmwired.net/kernel/Document ... Models.txt. Entonces añades esta línea al archivo /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=modelo

donde "modelo" es el que has deducido de la lista.

A veces la siguiente línea da problemas y comentándola (poniendo # delante) se resuelven:

options snd-hda-intel power_save=10 power_save_controller=N

&&
Después de eso, lanza jack con la opción realtime, suponiendo que ya has hecho lo de añadirte al grupo audio y dar a ese grupo prioridad rtprio 99 y memlock unlimited (o al menos el 50% de la RAM) en /etc/security/limits.conf (esto está explicado con detalle en muchos sitios).

Después lanza energyXT con el sistema de audio de Jack. Para esto, es necesario que libamm.so tenga soporte para jack y eso lo haces compilando el archivo jack.cpp que distribuye EnergyXT.

Primero, bajas jack.cpp de aquí:

www.energy-xt.com/download/jack.cpp

Lo colocas en el directorio donde tengas el archivo libamm.so, que en principio está en el mismo sitio que el lanzador del programa y en una terminal situada en ese directorio, compilas con:

g++ -shared -lasound -ljack jack.cpp -o libaam.so

Para esto necesitas las herramientas para compilar y los paquetes de desarrollo de alsa y de jack, o sea, que antes tendrás que hacer, si no tienes ya estos paquetes:

sudo apt-get install build-essential libasound2-dev libjack-dev

Y después eliges jack para el sistema de audio de energyxt.

Con el linux-rt y el script rtirq (ambos en repositorios de ubuntu) podrás conseguir aún mejor latencia sin xruns, en cualquier aplicación cliente de jack que esté bien programada (ardour por supuesto y otras muchas).

Desde &&, vale lo mismo para cualquier otra tarjeta de audio que vayas a usar.

Y volviendo a la pregunta original, supongo que funcionará. En el peor de los casos, parece que creative distribuye drivers para esas tarjetas y sería cosa de compilarlo. No sé si alguien tendrá una de esas por aquí.

Saludos, Pablo
www.semicorchux.blogspot.com
Subir
#5 por cpr el 20/04/2010
muchas gracias, viene todo muy bien explicado.

Alguien escribió:
cat /proc/asound/modules
Alguien escribió:

0 snd_intel8x0
1 snd_mpu401
2 saa7134_alsa




la 3º es una tarjeta de tv, las 2 primeras creo que una es la salida y otra la entrada de audio.


Alguien escribió:
alsamixer
Alguien escribió:

Card: NVidia nForce2
│ Chip: Realtek ALC650E
│ View: [Playback] Capture All
│ Item: Master [dB gain=-19.50, -19.50]


la tarjeta integrada no viene en la lista de la web que me pasaste, la placa base es una asus a7n8x-x ( http://www.asus.es/product.aspx?P_ID=od83seU8RaneL4Cq )

Alguien escribió:
Después de eso, lanza jack con la opción realtime, suponiendo que ya has hecho lo de añadirte al grupo audio y dar a ese grupo prioridad rtprio 99 y memlock unlimited (o al menos el 50% de la RAM) en /etc/security/limits.conf (esto está explicado con detalle en muchos sitios).


Justo aqui ( audio-audiophile-2496-ubuntu-t293407-15.html ) tambien explicado por ti, muy currado.

Alguien escribió:
Y volviendo a la pregunta original, supongo que funcionará. En el peor de los casos, parece que creative distribuye drivers para esas tarjetas y sería cosa de compilarlo. No sé si alguien tendrá una de esas por aquí.



No se si esta bien de precio, me la dejan pelada (solo tarjeta) en 30€ de 2º mano. Si me confirmas que esta bien de precio, antes de liarme a configurar la integrada, me espero y hago todo el proceso que me has enseñado con la creative xtreme music. Muchas gracias de nuevo.
Subir
#6 por Pablo_F el 21/04/2010
Hola,

Sí los dos primeros módulos son los que usa tu tarjeta. El segundo es para señales Joystick/MIDI, el primero para audio.
Sí, la lista que te pasé es sólo para tarjetas integradas que usan el módulo snd-hda-intel, que son muy comunes y las conozco mejor, pero no es tu caso. Tu tarjeta está documentada aquí:

http://www.kernel.org/doc/Documentation ... ration.txt

Pero no sé orientarte mejor.

Sobre la sound-blaster X-FI, según:
http://www.alsa-project.org/main/index. ... ative_Labs
está soportada (excepto dos opciones avanzadas como ves, que no tengo ni idea de lo que son) a partir de la versión
1.0.21., con el módulo emu-20k1 (se supone que el módulo correcto se carga automágicamente al arrancar el ordenador, lo compruebas con el comando que te indiqué, o con "lsmod"). Si estás con karmic tienes la versión 1.0.20, me parece. Entonces o bien compilas las útimas versiones de alsa, o bien actualizas a lucid que sale en unos días y creo que viene con la versión 1.0.22.

No sé si está bien de precio, la verdad. ¿Cuánto cuesta una de esas nueva?

Otra cosa, la configuración de los límites que necesita jack para la opción "realtime" y obtener energyXT con soporte para Jack, es un trabajo que adelantas. No vas a tener que hacerlo otra vez para tu nueva tarjeta, ya lo tendrás hecho.

No siempre es fácil conseguir un jack estable con baja latencia pero aquí estamos para intentar ayudar. Lo bueno de todo esto es que una vez que configuras bien alsa y jack, has hecho lo más importante. Ardour y EnergyXT (y cualquier otra aplicación cliente de jack) no se hablan con la tarjeta, se hablan con Jack, que a su vez utiliza el driver de alsa (u otros para otro tipo de tarjetas, pero en tarjetas integradas, USB, PCI, pcmcia... es alsa en la gran mayoría de los casos).

Saludos, y ánimo! Pablo
Subir
#7 por cpr el 17/05/2010
Se me rompio el equipo y lo tuve que dejar un poco de lado, ahora vuelvo a la carga con placa base nueva, tarjeta de sonido nueva y sistema operativo nuevo (ubuntu 10.04) y con problemas nuevos :oops:


Lo primero, decir que tengo sonido pero no 5.1, si lo pongo en 5.1 solo suenan los delanteros y traseros, el frontal y subwoffer no suena.

Alguien escribió:
cat /proc/asound/modules
Alguien escribió:
0 snd_ctxfi

Alguien escribió:
alsamixer[code]Tarjeta: Creative X-Fi
│ Chip: 20K1
│ Vista: F3:[Reproducir] F4: Captura F5: Todo
│ Elemento: Master [Ganancia en dB: -24,50, -24,50][/code]

[code]sudo gedit /etc/modprobe.d/alsa-base.conf
[code]# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2[/code][/code]


¿que añado y donde? porque con la integrada lo tenia claro, venia en la web que me pusiste, pero de esta (creative xfi xtreme music) no veo nada.

Alguien escribió:
Saludos, y ánimo! Pablo


gracias, confio en tu paciencia :lol:
Subir
#8 por Pablo_F el 18/05/2010
Alguien escribió:
Lo primero, decir que tengo sonido pero no 5.1, si lo pongo en 5.1 solo suenan los delanteros y traseros, el frontal y subwoffer no suena.


Qué interfaz de control estás usando? La que viene en gnome en Sistema->Preferencias? ¿Has revisado todos los niveles y que no tenga ningún canal silenciado? ¿Has revisado los niveles en un ALSA mixer (alsamixer, gamix...)?. Una alternativa a control del sonido de gnome es pavucontrol (Control de volumen de pulseaudio), instálalo a ver si se ve más claro ahí.

Pensaba que para esa tarjeta hacía falta otro módulo pero ya veo que no, supongo que el que se te ha cargado funciona bien y no creo que haya que añadir nada al fichero de configuración. De todas formas, estoy tratando de adivinar y de dar ideas. Nunca he probado esa tarjeta.

Pulseaudio es el sistema de audio que viene por defecto. Intentará asignar los canales automáticamente para el sonido surround. Otra cosa es jack. Jack tratará los canales uno a uno y sin diferenciarlos, no está diseñado para tarjetas de este tipo. Pulseaudio se suspenderá al lanzar Jack Control.

Como ya comentamos, si la vas a usar con ardour y energyXT necesitas jack con el driver alsa. Pero tienes que ir por partes. Pulseaudio y jack son bestias muy diferentes. Entiendo que lo primero es que te funcione el surround para escuchar música y películas. Entonces olvídate de jack, de ardour y de energyXT por el momento. Cuando consigas eso, cambias el chip y te metes con jack.

¿Puedes mostrar la salida de:

[code]$aplay -l [/code]

?

Saludos, Pablo
Subir
#9 por cpr el 18/05/2010
Alguien escribió:
Qué interfaz de control estás usando? La que viene en gnome en Sistema->Preferencias? ¿Has revisado todos los niveles y que no tenga ningún canal silenciado? ¿Has revisado los niveles en un ALSA mixer (alsamixer, gamix...)?. Una alternativa a control del sonido de gnome es pavucontrol (Control de volumen de pulseaudio), instálalo a ver si se ve más claro ahí.


Si, la de preferencias y ahi seleccione 5.1 salida + entrada, hice el test de sonido ( speaker-test -Dplug:surround51 -c6 -l1 -twav ) y solo se escuchaba delante y detrás, instale el pavucontrol y seguia igual, luego el gamix, trastee un poco en el gamix y se empezo a escuchar por los 6 canales pero como un sonido agudo de fondo, desinstale el gamix, se quito el sonido agudo de fondo y se mantuvo el sonido 5.1 asique el 5.1 lo podemos dejar por conseguido.

edito esta parte, añado: el ruido agudo de fondo se oye cuando no tengo el icono de volumen al maximo.

Alguien escribió:
Pulseaudio es el sistema de audio que viene por defecto. Intentará asignar los canales automáticamente para el sonido surround. Otra cosa es jack. Jack tratará los canales uno a uno y sin diferenciarlos, no está diseñado para tarjetas de este tipo. Pulseaudio se suspenderá al lanzar Jack Control.

en añadir y quitar hay muchos programas relacionados con pulseaudio que estan sin instalar.

Alguien escribió:
Como ya comentamos, si la vas a usar con ardour y energyXT necesitas jack con el driver alsa. Pero tienes que ir por partes. Pulseaudio y jack son bestias muy diferentes. Entiendo que lo primero es que te funcione el surround para escuchar música y películas. Entonces olvídate de jack, de ardour y de energyXT por el momento. Cuando consigas eso, cambias el chip y te metes con jack.


chip cambiado, no se si luego sera complicado cambiar de pulseaudio a jack, pero lo principal es que funcione.
Alguien escribió:
¿Puedes mostrar la salida de:

CÓDIGO: SELECCIONAR TODO
$aplay -l


?
Alguien escribió:
**** Lista de PLAYBACK dispositivos hardware ****
tarjeta 0: XFi [Creative X-Fi], dispositivo 0: ctxfi [Front/WaveIn]
Subdispositivos: 8/8
Subdispositivo #0: subdevice #0
Subdispositivo #1 : subdevice #1
Subdispositivo #2 : subdevice #2
Subdispositivo #3 : subdevice #3
Subdispositivo #4 : subdevice #4
Subdispositivo #5 : subdevice #5
Subdispositivo #6 : subdevice #6
Subdispositivo #7 : subdevice #7
tarjeta 0: XFi [Creative X-Fi], dispositivo 1: ctxfi [Surround]
Subdispositivos: 8/8
Subdispositivo #0: subdevice #0
Subdispositivo #1 : subdevice #1
Subdispositivo #2 : subdevice #2
Subdispositivo #3 : subdevice #3
Subdispositivo #4 : subdevice #4
Subdispositivo #5 : subdevice #5
Subdispositivo #6 : subdevice #6
Subdispositivo #7 : subdevice #7
tarjeta 0: XFi [Creative X-Fi], dispositivo 2: ctxfi [Center/LFE]
Subdispositivos: 8/8
Subdispositivo #0: subdevice #0
Subdispositivo #1 : subdevice #1
Subdispositivo #2 : subdevice #2
Subdispositivo #3 : subdevice #3
Subdispositivo #4 : subdevice #4
Subdispositivo #5 : subdevice #5
Subdispositivo #6 : subdevice #6
Subdispositivo #7 : subdevice #7
tarjeta 0: XFi [Creative X-Fi], dispositivo 3: ctxfi [Side]
Subdispositivos: 8/8
Subdispositivo #0: subdevice #0
Subdispositivo #1 : subdevice #1
Subdispositivo #2 : subdevice #2
Subdispositivo #3 : subdevice #3
Subdispositivo #4 : subdevice #4
Subdispositivo #5 : subdevice #5
Subdispositivo #6 : subdevice #6
Subdispositivo #7 : subdevice #7
tarjeta 0: XFi [Creative X-Fi], dispositivo 4: ctxfi [IEC958 Non-audio]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0




No me cansare de darte las gracias :lol:
Subir
#10 por cpr el 18/05/2010
lo bueno dura poco, he reiniciado y se ha ido el 5.1, me vuelve a pasar lo de antes, oigo solo 4 canales de 6, no suenan ni el subwoffer ni el central y esta vez ni tocando la configuracion, tengo todos los niveles al maximo en alsa, gamix, pulseaudio,...¿alguna idea?
Subir
#11 por Pablo_F el 19/05/2010
Prueba a instalar:
linux-backports-modules-alsa-lucid-generic
y reinstalar:
linux-sound-base alsa-base alsa-utils

Reinicia.

En el control de volumen de pulseaudio, revisa los dispositivos de salida. En la pestaña de configuración , prueba otras configuraciones de sonido, si tienes esa opción.

De momento yo no sé si el problema está en el driver de alsa o en pulseaudio, o en la configuración de pulseaudio. No te preocupes por los paquetes que hacen referencia a pulseaudio y no tienes instalados.

Ah, y supongo que estás seguro de que los archivos de audio que intentas reproducir tienen todos esos canales, no?

Saludos, Pablo
Subir
#12 por cpr el 19/05/2010
Alguien escribió:
Prueba a instalar:
linux-backports-modules-alsa-lucid-generic
y reinstalar:
linux-sound-base alsa-base alsa-utils

Reinicia.


hecho


Alguien escribió:
En el control de volumen de pulseaudio, revisa los dispositivos de salida. En la pestaña de configuración , prueba otras configuraciones de sonido, si tienes esa opción.



si, me da la opcion, hay muchas combinaciones posibles. 2.1,5.1+entrada, 5.1 solo salida,....lo tengo puesto en 5.1 salida + 1 entrada mono, probe con 5.1 + entrada stereo, 5.1 solo salida y nada.

Alguien escribió:
Ah, y supongo que estás seguro de que los archivos de audio que intentas reproducir tienen todos esos canales, no?


si, de hecho el poco rato que me llego a funcionar, se escuchaba la voz por el central. Lo que hago para testear el sonido es poner el comando "speaker-test -Dplug:surround51 -c6 -l1 -twav" que tambien funciono un rato pero ahora cuando le toca pasar la voz por el central o el subwoffer no suena, solo el resto. Otra cosa que no se si influira, tengo deshabilitado el la bios la tarjeta de sonido integrada.
Subir
#13 por Pablo_F el 19/05/2010
Para asegurarnos, cual es tu versión de alsa drivers:

$cat /proc/asound/version

¿Quizás tengas que editar el archivo ~/.asoundrc ?
Prueba el paso 4 de http://ubuntuforums.org/showthread.php?t=1254492
Subir
#14 por cpr el 19/05/2010
Alguien escribió:
cat /proc/asound/version
Alguien escribió:
Advanced Linux Sound Architecture Driver Version 1.0.22.1.
Compiled on Apr 29 2010 for kernel 2.6.32-22-generic (SMP).

Alguien escribió:
¿Quizás tengas que editar el archivo ~/.asoundrc ?
Prueba el paso 4 de http://ubuntuforums.org/showthread.php?t=1254492


No, ya lo solucione, no se porque pero en alamixer estaba silenciado el central y en pulseaudio y gamix me aparecian como activados, lo que hice fue:

$alsamixer

situarme en el central y presionar la tecla m para activarlo, tambien he visto que la entrada de microfono esta desactivada.

Ahora si lo podemos dejar por hecho, reinicie y se sigue escuchandose por los 6.

gracias de nuevo, ahora ya podemos pasar a lo interesante, no se si lo comete ya, pero por si acaso, tengo la tarjeta de audio integrada deshabilitada.
Subir
#15 por Pablo_F el 20/05/2010
¡Bien!

Haces bien en deshabilitar la integrada, es lo mejor que puedes hacer si no la vas a usar.

Bueno, pues ahora tienes que encontrar la configuración adecuada para jack. En ubuntu 10.04 va a ser un poco diferente que lo que escribí en el hilo al que haces referencia en el comentario número 5 (que es válido para ubuntu 9.10 y para otras distros). Ahora, el script de post instalación del paquete jackd escribe automáticamente los valores de "rtprio 99" y "memlock unlimited" [1] para el grupo audio en el archivo
/etc/security/limits.d/audio.conf
Por lo tanto, no tienes que hacer nada más que añadir al grupo audio el usuario al que quieras dar esos privilegios. Y reiniciar.

El paquete jackd es una dependencia de ardour, así que sólo tendrías que instalar ardour y añadirte al grupo audio para empezar a usarlo. Super-recomendado que instales qjackctl (Jack Control) para configurar jack. Otra opción es instalar los metapaquetes "ubuntustudio-audio" y "ubuntustudio-audio-plugins". Además de qjackctl, jackd y ardour, te instalarán un montón de otros programas útiles (aunque algunos no tan puestos al día como sería de desear). Lo malo de "ubuntustudio-audio" es que tiene un script que escribe "rtprio 99" para el grupo audio en
/etc/security/limits.conf
cuando eso ya lo ha hecho jackd en un archivo diferente (pero igual de válido) como se indica más arriba. Así que lo mejor es que edites éste último archivo y borres esa línea que ahora ya no pinta nada.

Cuando lanzas qjackctl se suspende pulseaudio y entras en "otra dimensión". alsamixer sigue siendo válido porque jack también usa el driver de alsa pero no va a tratar de mapear las salidas para que puedas reproducir en 5.1, ya que no está diseñado para este tipo de tarjetas. Va a ver los canales de forma independiente. En realidad, ve lo que alsa llama "dispositivos" o "devices". En concreto para tu tarjeta, estos 5, como indica "aplay -l":

hw:0 es tu tarjeta
hw:0,0 -> Front/WaveIn
hw:0,1 -> Surround
hw:0,2 -> Center/LFE
hw:0,3 -> Side
hw:0,4 -> IEC958 Non-audio (salida digital)

Ahora si en la columna derecha del setup de jack control eliges todo default, te va a tomar el dispositivo hw:0,0 que es el que dispone de las entradas analógicas; las salidas analógicas van a ser sólo las frontales (creo, compruébalo). También puedes elegir dispositivos diferentes para entrada y salida, pero para entrada elige el hw:0,0 que es el único que tiene las entradas analógicas. Si es necesario, se puede hacer un dispositivo virtual para que jack te vea todos los canales de salida aunque lo habitual y más sencillo es la salida estéreo frontal.

Una información más detallada (pero bastante incomprensible para mí) de qué es cada dispositivo y subdispositivo la puedes ver con

cat /proc/asound/devices

Como ves la forma en que jack accede al driver de alsa es mucho más manual, especialmente y sobretodo con las tarjetas comerciales como la tuya. Lo cual complica un poco el asunto.

Saludos, Pablo

[1] En lugar de unlimited es más seguro poner un porcentaje alto de la memoria RAM, en kB. Los mensajes de qjackctl me recomiendan 1534989 que corresponde al 75% en mi caso (supongo que hará el cálculo para cada caso) ya que la salida del comando "free" me da 2046652 (2GB de RAM).
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo