¿tarjeta para usar con ardour, energyxt?

  • 2
#16 por cpr el 20/05/2010
parece que esto ya marcha
Alguien escribió:
Bueno, pues ahora tienes que encontrar la configuración adecuada para jack. En ubuntu 10.04 va a ser un poco diferente que lo que escribí en el hilo al que haces referencia en el comentario número 5 (que es válido para ubuntu 9.10 y para otras distros). Ahora, el script de post instalación del paquete jackd escribe automáticamente los valores de "rtprio 99" y "memlock unlimited" [1] para el grupo audio en el archivo
/etc/security/limits.d/audio.conf
Por lo tanto, no tienes que hacer nada más que añadir al grupo audio el usuario al que quieras dar esos privilegios. Y reiniciar.


sudo adduser usuario audio
Alguien escribió:
El paquete jackd es una dependencia de ardour, así que sólo tendrías que instalar ardour y añadirte al grupo audio para empezar a usarlo. Super-recomendado que instales qjackctl (Jack Control) para configurar jack. Otra opción es instalar los metapaquetes "ubuntustudio-audio" y "ubuntustudio-audio-plugins". Además de qjackctl, jackd y ardour, te instalarán un montón de otros programas útiles (aunque algunos no tan puestos al día como sería de desear). Lo malo de "ubuntustudio-audio" es que tiene un script que escribe "rtprio 99" para el grupo audio en
/etc/security/limits.conf


hecho
Alguien escribió:
/etc/security/limits.conf
cuando eso ya lo ha hecho jackd en un archivo diferente (pero igual de válido) como se indica más arriba. Así que lo mejor es que edites éste último archivo y borres esa línea que ahora ya no pinta nada.


linea borrada
Alguien escribió:
Ahora si en la columna derecha del setup de jack control eliges todo default, te va a tomar el dispositivo hw:0,0 que es el que dispone de las entradas analógicas; las salidas analógicas van a ser sólo las frontales (creo, compruébalo). También puedes elegir dispositivos diferentes para entrada y salida, pero para entrada elige el hw:0,0 que es el único que tiene las entradas analógicas. Si es necesario, se puede hacer un dispositivo virtual para que jack te vea todos los canales de salida aunque lo habitual y más sencillo es la salida estéreo frontal.



hecho pero al grabar graba lo mismo que reproduce pero distorsionado, tengo todo default menos en dispositivo de entrada que tengo hw:0,0

gracias de nuevo, ya dentro de nada parece que estará.
Subir
#17 por Pablo_F el 21/05/2010
[code]tengo todo default menos en dispositivo de entrada que tengo hw:0,0[/code]

no me expliqué muy bien. Quería decir, en caso de que elijas dispositivos diferentes para entrada y para salida, en entrada debes elegir hw:0,0 que es el único que cuenta realmente con las entradas de captura. En tu caso, eligiendo el interfaz default, que como no hay otro es el hw:0, tomará hw:0,0 tanto para la entrada como para la salida. De todas formas, tal como lo tienes no es que esté mal, sólo que es innecesario. Sólo por aclararlo.

El tema de la distorsión en principio no tiene nada que ver con jack, más bien con alsa. Tienes a tope los niveles en alsamixer ? Bájalos, entre un 70 y un 80 % debería ir mejor. Con una SBLive me ocurría lo mismo.

Otra cosa: Estas tarjetas suelen tener mezcladores internos que te pueden despistar. La forma más sencilla de monitorizar es "por software" pero entonces tienes que evitar que el audio que metes a la entrada analógica salga por los canales frontales. Si monitorizas por software vas a tener una latencia, esperemos que inapreciable (para bajar la latencia, baja el valor de cuadros por periodo. Si bajas demasiado este valor empezaras a ver xruns. Intenta llegar a un equilibrio aceptable latencia-rendimiento y si no lo consigues, necesitarás ajustar mejor el sistema). Desde ardour por ejemplo, eliges opciones, monitorización, monitorización por ardour. También es posible que puedas aprovechar los canales de sobra para hacer un monitorización por hardware (latencia cero), llevando la señal de entrada a los altavoces laterales, por ejemplo. Ahí tienes que salsear tú con el mezclador hardware de la tarjeta, accesible desde un mezclador de alsa (alsamixer, gamix...).

Y otra cosa más: He leído en la documentación del kernel para el módulo snd-ctxfi que el sample rate por defecto es de 48000 Hz. Te recomiendo ese valor en el setup de jack

Saludos, Pablo
Subir
#18 por cpr el 24/05/2010
Alguien escribió:
no me expliqué muy bien. Quería decir, en caso de que elijas dispositivos diferentes para entrada y para salida, en entrada debes elegir hw:0,0 que es el único que cuenta realmente con las entradas de captura. En tu caso, eligiendo el interfaz default, que como no hay otro es el hw:0, tomará hw:0,0 tanto para la entrada como para la salida. De todas formas, tal como lo tienes no es que esté mal, sólo que es innecesario. Sólo por aclararlo.



Lo que queria decir exactamente es, reproduzco prueba.wav y sobre esa pista grabo, pues la pista que grabo se supone que deberia grabar del microfono pero no es asi, me graba prueba.wav distorsionado en lugar de la voz del microfono, como si la entrada de microfono fuera la salida de audio, he probado con ardour y audacity y ambos hacen lo mismo, reproducen pero graban como comente.

Alguien escribió:
El tema de la distorsión en principio no tiene nada que ver con jack, más bien con alsa. Tienes a tope los niveles en alsamixer ? Bájalos, entre un 70 y un 80 % debería ir mejor. Con una SBLive me ocurría lo mismo.


alsamixer lo tengo asi http://img84.imageshack.us/img84/9883/alsa.png

Alguien escribió:
Otra cosa: Estas tarjetas suelen tener mezcladores internos que te pueden despistar. La forma más sencilla de monitorizar es "por software" pero entonces tienes que evitar que el audio que metes a la entrada analógica salga por los canales frontales. Si monitorizas por software vas a tener una latencia, esperemos que inapreciable (para bajar la latencia, baja el valor de cuadros por periodo. Si bajas demasiado este valor empezaras a ver xruns. Intenta llegar a un equilibrio aceptable latencia-rendimiento y si no lo consigues, necesitarás ajustar mejor el sistema). Desde ardour por ejemplo, eliges opciones, monitorización, monitorización por ardour. También es posible que puedas aprovechar los canales de sobra para hacer un monitorización por hardware (latencia cero), llevando la señal de entrada a los altavoces laterales, por ejemplo. Ahí tienes que salsear tú con el mezclador hardware de la tarjeta, accesible desde un mezclador de alsa (alsamixer, gamix...).


en principio con 2.1 me vale, incluso lo prefiero antes que 5.1 para grabar y producir, cuando consiga que funcione nose si tocare mucho, me lo pensare 2 veces :lol:

Alguien escribió:
Y otra cosa más: He leído en la documentación del kernel para el módulo snd-ctxfi que el sample rate por defecto es de 48000 Hz. Te recomiendo ese valor en el setup de jack


lo acabo de cambiar

saludos y gracias.
Subir
#19 por Pablo_F el 25/05/2010
Alguien escribió:
Lo que queria decir exactamente es, reproduzco prueba.wav y sobre esa pista grabo, pues la pista que grabo se supone que deberia grabar del microfono pero no es asi, me graba prueba.wav distorsionado en lugar de la voz del microfono, como si la entrada de microfono fuera la salida de audio, he probado con ardour y audacity y ambos hacen lo mismo, reproducen pero graban como comente.


Sí, pues esto es (más o menos) a lo que me refería cuando comentaba lo del mezclador interno de la tarjeta, que te puede volver un poco loco.

Tienes que jugar con alsamixer. Supongo que en gamix vendrá más claro a qué corresponde cada canal. En alsamixer se ven dos masters, dos PCM's, varias capturas... Algunos son niveles de mezclas. Algunos (no sé cuáles pero empezaría por los que tienen "captura" en rojo abajo) tendrás que ponerlos a cero, o en fin, deshabilitar de alguna forma esa mezcla por hardware (la hace la propia tarjeta y no tiene nada que ver con jack y menos con ardour o audacity).

Saludos, Pablo
Subir
#20 por cpr el 26/05/2010
he jugado con alsamixer y con pulseaudio (que creo que hacen lo mismo), he deshabilitado pulsando "espacio" pcm captura (el de rojo) y dejaba de capturar audio distorsionado, he ido habilitando poco a poco y no capturaba nada, desde pulseaudio sin habilitar jack he visto que capturaba audio, he dejado toda captura deshabilitada en alsamixer, desde pulseaudio he habilitado el microfono y la entrada de microfono es mic captura (el de rojo), he cerrado pulse audio, inicie jack, abri ardour y ya captura audio pero distorsionado aun al minimo el master y al minimo en mic grabacion desde alsamixer y pulseaudio, asique si consigo que no distorsione, que no este tan sensible la captura yo creo que por fin terminaria la batalla.

un saludo y gracias, espero que te quede un poquito mas de paciencia :oops:
Subir
#21 por Pablo_F el 27/05/2010
Hola,

Tienes que separar pulseaudio y jack en estas pruebas. Pulseaudio es el servidor por defecto y si vas a grabas a través de pulseaudio, está bien que uses pavucontrol (y alsamixer).

Pero cuando lanzas qjackctl se "suspende" pulseaudio y cuando inicias el servidor jack, éste toma el control y habla directamente con el driver de alsa y te olvidas de pavucontrol. Y por supuesto, ardour sólo funciona con jack. En audacity es opcional.

Por otro lado, jack y pulseaudio tienen un pasado bastante conflictivo, así que por si acaso y para estas pruebas, te recomiendo quitarlo del medio, o sea, matar el proceso, para que no haya dudas. Para eso tienes que hacer:

1. Editar (como administrador) el archivo /etc/pulse/client.conf
La línea
; autospawn = yes
debe quedar:
autospawn = no
(SIN punto y coma)

2. Ejecutar el comando
pulseaudio -k

Con lo segundo lo matas, con lo primero te aseguras que no vaya a resucitar.

Y ahora prueba con alsamixer jack ardour (NO pavucontrol!).

Supongo que esas entradas son muy sensibles a la captura porque están pensadas para una señal muy débil, de micro.
Son tarjetas para el Desktop, no para el estudio.
Baja el nivel de captura todo lo que sea necesario para nunca tocar rojo en los vúmetros de ardour.

Ah, si quieres volver a pulseaudio, detén jack desde qjackctl y lánzalo con:
pulseaudio --start
(también arrancará cuando inicies el ordenador)

Saludos, Pablo
Subir
#22 por cpr el 27/05/2010
Me sigue pasando, esta el master y el mic de grabacion al 1 y con tan solo coger el microfono capta el sonido al maximo y distorsiona.

Alguien escribió:
Supongo que esas entradas son muy sensibles a la captura porque están pensadas para una señal muy débil, de micro.
Son tarjetas para el Desktop, no para el estudio.


¿Podria ser que solo este problema le tuviese con jack? porque con pavucontrol en la ventana de entrada nunca llegaba al maximo si lo ponias incluso a mas de la mitad.


saludos
Subir
#23 por Pablo_F el 27/05/2010
No te fíes mucho de los nombres que da alsamixer. Igual el que tienes que bajar es un canal diferente. De todas formas, no sé qué puede pasar y a través del foro menos. Suelo estar en el canal #ubuntustudio-es en el servidor irc.freenode.net
Usa pidgin o xchat .Cuando entres en la ventana principal escribes:
/join #ubuntustudio-es
Y con un poco de suerte me localizas y te intento ayudar mejor
Saludos, Pablo
Subir
#24 por cpr el 02/06/2010
Alguien escribió:
No te fíes mucho de los nombres que da alsamixer. Igual el que tienes que bajar es un canal diferente. De todas formas, no sé qué puede pasar y a través del foro menos. Suelo estar en el canal #ubuntustudio-es en el servidor irc.freenode.net
Usa pidgin o xchat .Cuando entres en la ventana principal escribes:
/join #ubuntustudio-es
Y con un poco de suerte me localizas y te intento ayudar mejor
Saludos, Pablo


a ver si te localizo, si tardo en localizarte no es que se me haya olvidado o lo haya resuelto sin avisar, es porque tengo horarios malos. gracias.
Subir
#25 por Pablo_F el 02/06/2010
Ahora suelo estar más en #musica-linux

Saludos, Pablo
Subir
#26 por cpr el 06/06/2010
he tenido oportunidad y he vendido la tarjeta pero que quede claro que ganamos la batalla :D , voy a mirar una mas compatible y mas enfocada a producción y grabación y para 5.1 utilizo la integrada con este adaptador de 5.1 http://xover.mud.at/~sub/asus_spdif_bracket.jpg imagino que no dará problemas. De momento uso la integrada que la reconoce bien, hasta encontrar una usb, ya que asi la uso tambien en el portatil. Todo un placer haber aprendido todo lo que me enseñaste. gracias de nuevo, te animo a seguir ayudando, asi seguro que mañana somos mas con linux. saludos.
Subir
#27 por cpr el 21/06/2010
revivo el post referente a:

Alguien escribió:
utilizo la integrada con este adaptador de 5.1 http://xover.mud.at/~sub/asus_spdif_bracket.jpg imagino que no dará problemas.


La pregunta es, ¿si reproduzco un video con audio en ac3, es posible sacar 5.1 por coaxial o mandar señal para que el propio decodificador se encarge de convertirla en 5.1?

Las pruebas que he echo, solo me permite sacar stereo por coaxial.
Subir
#28 por Pablo_F el 25/06/2010
Hola,

No sé porque nunca he usado la salida digital y menos con otra tarjeta, pero pulseaudio debería hacerla funcionar. Prueba a instalar pavucontrol (pulse audio volume control) y mira a ver si en la pestaña de configuración tienes un perfil de digital surround o similar. Echa un vistazo antes a la pestaña "dispositivos de salida".

Saludos, Pablo
Subir
#29 por cpr el 26/06/2010
Solo aparece digital stereo y el sonido funciona, pero no en 5.1. Según he leído, si mando la señal ac3 sin decodificar, el propio decodificador se encarga de sacar 5.1, pero no se como mandarla sin decodificar. Lo que quiero hacer se llama pass through ac3 pero no se como activarlo ni donde.
Subir
#30 por Pablo_F el 26/06/2010
Hola,

Pues parece que pulseaudio no lo hace de momento. Ver http://www.pulseaudio.org/ticket/167

Pero igual lo puedes hacer a través de tu reproductor sin usar pulseaudio. Te sugiero mplayer:

$ sudo apt-get install mplayer mplayer-gui

$ mplayer -ao alsa:device=iec958 -ac hwac3 /ruta/a/video

Puede que esto funcione también, en tu caso:

$ mplayer-ao alsa:device=hw#0,4 -ac hwac3 /ruta/a/video

Si funciona, puedes hacer esto permanente escribiendo el archivo de configuración de mplayer:

$ echo '-ao alsa:device=iec958 -ac hwac3' > home/usuario/.mplayer/config

Y a partir de aquí puedes abrir los vídeos con botón derecho, abrir con mplayer.

Para más información:

http://www.mplayerhq.hu/DOCS/HTML/en/ad ... round.html
http://ubuntuforums.org/archive/index.php/t-814285.html
$ man mplayer

Saludos, Pablo
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo