Tarjetas de Sonido Multicanal para Linux

  • 2
#16 por Pablo_F el 31/03/2010
Hola,

No tengo mucha idea de tarjetas de audio USB pero las que usa la gente por aquí que yo sepa, por dar ideas:

Behringer UCA 202
M-audio audiophile usb
M-audio fast track pro
Edirol UA25-Ex
Edirol UA-700

Algunas tascam funcionan. Algunas lexicon también.

En general todas las que son "class compliant" o "plug and play" funcionan. Las que vienen con drivers para Windows y Mac pueden funcionar si alguien ha escrito un driver para ALSA, pero para ello el fabricante ha tenido que colaborar de algún modo. Lo que es muy raro es que el fabricante suministre drivers para linux. Eso no lo vas a encontrar en ningún fabricante que yo sepa. Es el proyecto ALSA el que suministra los drivers, que se integran en el kernel (o ésa es la idea).

Lo que no se puede decir es "las lexicon no están soportadas" o "las m-audio están soportadas", etc... Hay que verlo caso por caso. Algunas sí, otras no, otras sí pero no, otras en camino de...

Si tienes echado el ojo a alguna en concreto, o a un par o tres de ellas, ponlas con el modelo exacto y seguro que habrá quien recomiende.

Saludos, Pablo
Subir
#17 por Pablo_F el 31/03/2010
Por cierto,

Alguien escribió:
draidUn dijo:
Alguien escribió:
Si la M-Audio que comentas en rack es la Fast Track Ultra 8R, yo la tengo y no tiene drivers para Linux.


Buenas noticias para los usuarios de la fast track ultra de m-audio.
http://forums.m-audio.com/showthread.ph ... inux/page5
http://www.mail-archive.com/alsa-user@l ... 26358.html

Por lo que entiendo, en la versión en desarrollo de alsa ya está soportada (sin mezclador y no a 44100 Hz, pero parece que va bien a 48000). A ver si alguien lo prueba y comenta.

Saludos, Pablo
Subir
#18 por involucrado el 31/03/2010
Gracias Pablo!! :D

Por ahora relego este asunto hasta que pueda resolver otros más acuciantes :(

Un saludo!
Subir
mod
#19 por Irwin J. Cespedes el 30/04/2010
@involucrado Mi respuesta es muy tarde, pero en todo lado me han recomendado la Maya 44 para USB

Ruta 27, Mi nuevo tema hecho en GNU/Linux: https://soundcloud.com/altiplane/ruta-27

También soy Altiplane, esta es mi música.

Subir
#20 por jesulines el 17/11/2010
Hola, soy bastante nuevo con linux, me gustaria cambiarme a este sistema operativo, pero tengo una phase 88 rack y no
la logro hacer funcionar en ubuntu, a ver si alguien me puede ayudar.
Muchas gracias
Subir
#21 por Pablo_F el 18/11/2010
Hola,

Tu tarjeta aparece en el sitio de ffado como soportada.

Las tarjetas firewire sólo funcionan a través del driver firewire con jack (no funcionan con el servidor de audio por defecto en ubuntu, que es pulseaudio). Así que lo primero es instalar el paquete jackd y dar privilegios de rtprio y memlock al grupo audio y añadirte al grupo audio. Y también tienes que habilitar acceso a /dev/raw1394, lo cual puedes hacer con ubuntustudio-controls (instala este paquete y accede a través de Sistema-Administración).

Aquí hay una guía: https://help.ubuntu.com/community/FireWire

Pero antes de nada, di: ¿Qué versión de ubuntu?

Saludos, Pablo
Subir
#22 por jesulines el 19/11/2010
Hola, estoy usando ubuntu 10.04 lts.

He cargado los paquetes de ubuntustudio, he configurado el jack pero yo creo que no carga el fireware
y al cargar el jack me sale esto:

00:31:02.503 Script de inicio...
00:31:02.504 artsshell -q terminate
sh: artsshell: not found
00:31:02.905 El script de inicio finalizó con estado 32512.
00:31:02.905 JACK está iniciándose...
00:31:02.905 /usr/bin/jackd -P70 -dfirewire -dhw:0 -r44100 -p128 -n2 -i8 -o8
jackd 0.118.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
Memory locking is unlimited - this is dangerous. You should probably alter the line:
@audio - memlock unlimited
in your /etc/limits.conf to read:
@audio - memlock 3090909
00:31:02.919 JACK se inició con PID=3303.
no message buffer overruns
JACK compiled with System V SHM support.
loading driver ..
libffado 2.0.0 built Mar 31 2010 14:47:42
firewire ERR: Error creating FFADO streaming device
cannot load driver module firewire
no message buffer overruns
00:31:03.042 JACK ha sido detenido satisfactoriamente.
00:31:03.042 Script de post - apagado...
00:31:03.042 killall jackd
jackd: proceso no encontrado
00:31:03.450 El script de post - apagado finalizó con estado 256.
00:31:04.996 No puede conectarse al servidor JACK como cliente. - La operación global falló.

Parece que el ffado no carga.
Muchas gracias por adelantado.
Subir
#23 por Pablo_F el 19/11/2010
Hola,

¿Tienes el paquete ffado-tools instalado, no?

En una terminal, ejecuta estos comandos (para diagnosis y pruebas) y a ver que te da:

ffado-diag

ffado-test Discover

ffado-test ListDevices

Saludos, Pablo
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo