Ubuntu Studio y RME HDSP 9632.

  • 2
#16 por Lamprolog el 22/05/2007
Ah ! Y esas particiones SWAP y en ext3 las dejo, para futuros ensayos...

Este es MySpace

Subir
#17 por neomad el 23/05/2007
Gracias por el aliento (a menta fresca :))

La gente de RME escribe claramente en su pagina que no dan soporte a linux. Con lo cual no creo que haran mucho por mi. El creador del driver paro en 2003/2004.

Lo que no entiendo porque RME no continuo al menos poniendo al dia el driver..;

He encontrado otra solucion: instalar la audigy y la RME. La primera la uso bajo linux. La segunda bajo XP. Pero por el momento, linux quedo en el freezer ;)

Voy a contactar a RME y pegar la respuesta aqui, si es que responden.

Saludos !

Ciao & bacci per tutti - http://www.neomad.net

Subir
#18 por Ismael Valladolid Torres el 23/05/2007
La conversación más completa encontrada en la red sobre tu problema parece ser ésta:

http://www.nabble.com/-RME-HDSP-9632--N ... 81507.html

Primero: RME Hammerfall 9632 y RME HDSP 9632 son tarjetas distintas, así que primero comprueba que el módulo adecuado ha sido cargado para la tuya:

Para la RME Hammerfall 9632, el módulo snd-rme9652 ("classic hammerfall")
Para la RME HDSP 9632, el módulo snd-hdsp ("modern hdsp series")

Segundo: No hay un mezclador convencional ALSA para esta tarjeta, así que hay que usar hdspmixer. De hecho, posiblemente la tarjeta sólo "suena" cuando hdspmixer está ejecutándose.

Tercero: Si con el módulo adecuado cargado y hdspmixer ejecutándose la tarjeta no suena, muy probablemente sea necesario cambiar el firmware. Comprueba con lspci -v la versión del firmware. Algo así:

$ lspci -v
04:00.0 Multimedia audio controller: Xilinx Corporation RME Hammerfall
DSP (rev 98)
Flags: bus master, medium devsel, latency 255, IRQ 16
Memory at dcdd0000 (32-bit, non-prefetchable) [size=64K]

Donde (rev 98) indica la versión del firmware.

Está reportado que hay usuarios que han resuelto el problema rebajando la versión del firmware, desde la 1.52 hasta la 1.51.

La versión 1.51 del firmware es ésta:

http://www.rme-audio.com/download/treib ... in_dsp.zip

Has de hacer la actualización en Windows, no funcionará desde Linux usando WINE.

Sígueme en Twitter

Subir
#19 por Ismael Valladolid Torres el 23/05/2007
: [ ~ ] $; apt-file search /usr/bin/hdspmixer
alsa-tools-gui: usr/bin/hdspmixer

Sígueme en Twitter

Subir
#20 por Rafa1981 el 17/05/2010
Ya es rescatar post viejos ya, pero como dato ahora me acabo de meter un Kubuntu 10.04 para trastear y esta tarjeta medio funciona ya de entrada, si se le pone el hdspmixer y se carga el perfil 2 (que pone todas las salidas en AN1+2) suena el sistema y el navegador, me falta que suene el Spotify, WINE no ve drivers, y falta que Jack me pille las entradas y salidas.

Si alguién sabe como configurarlo lo agradecería, almenos WINE, jack lo puse para ver si JACK veía a ALSA y podía sacar WINE por JAck, no ha colado.
Subir
#21 por neomad el 17/05/2010
Hola Rafa: ya ni ubuntu ni RME ..hace muuucho... no podre ayudarte en esto... :(

Lo que recuerdo es que habia que hacer un downgrade del firmware, y eso era un coñazo ya que perdias muchas ventajas en windows (aunque las ganaras en linux)

Suerte ;)

Ciao & bacci per tutti - http://www.neomad.net

Subir
#22 por Rafa1981 el 17/05/2010
Sin problema al final, ejecutando "winetricks" y marcando el ALSA suena el sonido de test, parece que la cosa va a ser exclusiva de Wine.
Subir
#23 por Rafa1981 el 17/05/2010
neomad escribió:
Hola Rafa: ya ni ubuntu ni RME ..hace muuucho... no podre ayudarte en esto... :(

Lo que recuerdo es que habia que hacer un downgrade del firmware, y eso era un coñazo ya que perdias muchas ventajas en windows (aunque las ganaras en linux)

Suerte ;)


Supongo que había que hacerlo en su momento, yo tengo el último firmware y hoy por hoy chuta, solo ha sido instalar el hdspmixer y configurarlo a la salida analógica para que suene.
Subir
#24 por Rafa1981 el 17/05/2010
Rafa1981 escribió:
Sin problema al final, ejecutando "winetricks" y marcando el ALSA suena el sonido de test, parece que la cosa va a ser exclusiva de Wine.


Y ya para cerrar por si alguien se encuentra en lo mismo alguna vez, todo ha funcionado poniendo OSS.
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo