windows a 64 bits y rendimiento incoherente

#1 por whitebeatk el 03/02/2012
He estado trabajando con XP32 y decidí cambiar a W7 64 bits. Mis problemas eran de consumo de cpu y también de RAM.
He pasado de core duo 2400 a i7 3600, y de 3G de ram a 16G. Supuse que resolvería mi problema de cpu y que posiblemente Studio One a 32 bits sólo podría trabajar con 2 o 3 gigas de RAM, no más. Pues bien, es justo lo contrario lo me ocurre. No tengo problemas de RAM, pero a pesar de que windows registra un rendimiento de cpu de 19%, studio one registra 78%. En cuanto añado o manipulo algún plugin se puede disparar el consumo y bloquearse. Windows sigue diciendo 19-21% de consumo. ¿Alguna explicación/remedio?
Studio One reconoce los ocho nucleos del i7 y estos están activados. El "internal block size" es el que ha salido por defecto en la instalación, 2048. No lo he tocado y todo funciona correctamente.

Gracias

He leido en otro hilo la solución jbrigde. Probaré
Subir
#2 por guichard el 03/02/2012
que version estas ocupando de studio one la de 32 bit o la de 64?
Subir
--111021--
#3 por --111021-- el 03/02/2012
Ocupar una versión? mande? será usar, utilizar, manejar, etc... pero ocupar?? no lo entiendo.
Subir
#4 por Rick Tigrillonic el 03/02/2012
#3 si no lo entendieras no hubieras puesto otras opciones.

#1 que raro que use tanto cpu con la tremenda configuración no debería dar problemas con nada, seguro que tienes la versión 64bits y depende ¿tu proyecto tiene muchos Fx, instrumentos, pistas o pasa con uno sencillo?

Simply Fast, Beauty Different.
---------------------
Desktop Windows 8 Pro 64 Bits | HP Z1 | Reaper 4 64 Bits - Musescore | Behringer UMX610 | Arturia Spark

Subir
--111021--
#5 por --111021-- el 03/02/2012
#4 No hace falta entender una palabra mal usada para más o menos imaginar por donde van las cosas y a que se puede referir, además de que yo quise indicar precisamente eso, que es un mal uso de mi querido idioma.
Subir
#6 por whitebeatk el 04/02/2012
Utilizo la versión de 32 bits, y la carga de cpu es la misma que cuando tenía el WXP a 32 bits. He abierto la versión de studio one a 64, con la misma canción para ver la carga de CPU y veo que se reduce a la mitad más o menos (tampoco veo una disminución proporcional al cambio de dual core 2400 32 bits a i7 (ocho cores reconocidos por studio one) 3600 a 64 bits.

LO curioso sobre todo es la diferencia entre el rendimiento de cpu que muestra windows y el que muestra S1.

Estoy instalando el jbridge y a ver si dejo ya el tema técnico y paso a lo que de verdad importa.

La carga alta de cpu que tenía con el sistema XP a 32 bits era alta pero razonable debido a mi forma de trabajar, sin renderizar nada.
Subir
--111021--
#7 por --111021-- el 04/02/2012
Whitebeatk no sé a que puede ser debido, pero el jbridge es para poder cargar vst 32 bits en un daw de 64 bits, así que ten en cuenta que algo afectará al rendimiento, porque no son realmente a 64, es un puente, además de que tendrás el vst y el puente funcionando dentro del daw... Espero que puedas solucionar el problema y puedas sacarle partido a tu nuevo sistema.
Un saludo.
Subir
#8 por dorremifasol el 04/02/2012
Ayer hice un post en el foro de Cubase sobre mis conclusiones en el uso uso de Windows 7 64 bits, plugins de 32 bits y jBridge.

Resumiendo un poco, ejecutar plugins de 32 bits en un secuenciador de 64 hace perder muchísimo rendimiento. Sale mucho más a cuenta usar un secuenciador de 32 bits con plugins de 32 bits, y jBridge para usar en modo 64 bits los plugins que necesiten mucha memoria. Esto es hasta que todos los plugins sean nativos de 64 bits, claro (cosa poco probable, siempre habrá joyas que no se actualice). jBridge funciona también en sentido inverso, ejecuta plugins de 64 bits en secuenciadores de 32 bits.

El post está aquí por si le queréis echar un vistazo:

http://www.hispasonic.com/foros/funciona-w7-64bit-cubase-51/282362#post3172010

Mi página en YouTube

Subir
#9 por ernestomartinez el 04/02/2012
Pero en mi humilde opinión, esto es problema de Studio one, por mas que utilice una versión 32 bits no debería tener esos problemas, yo trabajo en ableton y ya todos saben que hasta ahora solo hay versión 32 bits, y no tengo esos problemas de ram y rendimiento que el apunta, por favor que no salga ninguno a atacar, no entre para decir que ableton es mejor, sino que sirve de ejemplo, como podría serlo otro secuenciador, llama la atención, tal vez le hace falta un parche, porque esto no se les presento antes?...
Subir
#10 por whitebeatk el 04/02/2012
Primero gracias por vuestras opiniones. Como digo, la carga de ram y cpu en XP 32 estaba justificada ya que el 90% del material con el que trabajo es, de momento, virtual, 5% restante es mi guitarra, y el otro 5% son samples.

Llevo una semana con el tema desde que adquirí el W7 64, y me parece que ya llega el momento de ponerme a lo mio.

Al final me quedo con S1 64, los vst de 32 que ya estaba usando, el jbridge y el tune up utilities turbo mod con el siguiente resultado: de quedarme sin ram y carga de cpu 78-90% del XP 32, paso a eliminar el problema de ram y una carga de cpu de 19-30% con el mismo tema de referencia.

Cuando vuelva a quedarme escaso de algo volveré al tema. Me quedo con la oreja puesta a lo que pueda salir.

Gracias!
Subir
#11 por whitebeatk el 05/02/2012
Parece que esto todavía no se ha acabado. Ahora hay un pequeño detalle que me ha surgido: S1 64 no reconoce mis presets que he ido almacenado con mi versión de 32 bits en "user data folder", donde están las carpetas song, presets, etc. Esto es un gran contratiempo para mi. He intentado varias cosas pero no funcionan. Alguién sabe algo al respecto?

Gracias.
Subir
#12 por Joan Flanegan el 07/02/2012
Imagino que no los reconoce porque studio one de 32 bits, usa plugins también de 32 bits. Al no cargar los plugins de 32 en la versión de 64, pues los presets estarán missing...
El problema no creo que sea de studio one. Supongo que otro secuenciador, cargando la misma cantidad de presets, también iría apretado...
La cuestión es que los programas a 32 bits no aprovechan la capacidad de un ordenador tan cojonudo como el tuyo, y si usas tantos plugins a 32 bits, en parte es lógico que haya problemas. Podrías hacer la prueba de cargar un huevo de plugins, pero de 64 bits, y ver como responde el ordenador. Serviría para comprobar si lo que te aventuro es cierto o no.
Lo que estaría guay sí o sí, para próximas actualizaciones, es que studio one incluyera su propio bridge. Otros secuenciadores sí lo tienen, y S1 no. Y es cierto: poco a poco los plugins llegarán a 64 bits, pero mientras, tenemos por ahí joyitas, que nos costaron un dinero, que tampoco queremos abandonar... Miseria maldita.

Seguiré el hilo. Un abrazo!

¡Menos es nada!

Subir
#13 por whitebeatk el 07/02/2012
El aparato funciona bien a 64. El problema viene cuando a medio camino tienes que cambiar de sistema. En fin, creo que las ventajas superan los inconvenientes. Ahora estoy guardando mis presets nuevos los cuales van en una carpeta que crea S1 y que se llama jbridgepresets. Supongo que cuando trabaje plenamente a 64 (plugins incluidos), tampoco podré usar estos presets nuevos, ja, ja ja, que alegria.

Gracias Joan
Subir
#14 por maikelsolo el 26/02/2012
ningun core i7 tiene 8 nucleos, mas quisieramos, tiene 4 nucleos en Hypertread
Subir
#15 por whitebeatk el 27/02/2012
8. Si resulta que cuatro son virtuales o lo que sea, para S1 hay 8
Archivos adjuntos:
8 cores.jpg
BBCode:
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo