controlador midi envia señal continuamente

#1 el 29/07/2012
Publicidad
Muy buenas a todos compañeros....la verdad es que he estado buscando algun hilo que haga referencia a lo que a mi me ocurre y he encontrado algo parecido pero no igual...y aunque he intentado todo lo que mis pocos conocimientos me permiten...no he dado con ninguna solucion... aqui va mi problema (casi un Poltergeist)

-dispongo de un M-audio oxigen 8 conectado a una targeta de sonido Tascam US-144...el cual mi intencion es hacerlo usar con reason 5...bueno la instalacion ha sido ejecutada con exito...la cuestion es que mi sorpresa viene cuando veo que la lucecita roja,de la tarjeta de sonido, que indica que está recibiendo mensajes midi no para de parpadear...aun asi he abierto un proyecto de reason y cuando selecciono cualquier instrumento(para usar el controlador M-audio) veo como los knobs y faders del instrumento(de reason) se mueven aleatoriamente y sin ningun sentido(haciendo imposible tocar mas de dos segundos seguidos)....pero hay no acaba todo...independientemente tambien dispongo de una groovebox Roland mc-307 y otro controlador M-Audio oxigen 61 conectados entre si....y he pensado sustituir el oxigen 8 por el oxigen 61....me pasa lo mismo...he cambiado cables midi...lo mismo...y por ultimo que ya me ha dejado "todo roto" es que he conectado la roland y me pasa lo mismo cuando le conecto cualquiera de los dos m-audios (que esto ultimo nunca me habia pasado).Estoy desesperadito perdio ya que ahora no puedo hacer musica ni con reason ni con mi tan praciada roland mc-307....disculpad las molestias y muchas gracias por todo.Un cordial saludo a todos.
Subir
#2 el 30/07/2012
Pruba a conectar elteclado por USB, de esa forma e MIDI va directo a tus rogramas sin pasar por las Tascam.
Subir
#3 el 30/07/2012
#2 lo he hecho y me sigue pasando lo mismo....tambien me he dado cuenta de que con el oxigen 61 me pide que ponga el preset 10....pues bien....si el preset no es el 10 puedo tocar a la perfeccion las teclas pero no me reconoce ningun knob ni fader a la hora de asignarlos....y cuando pongo el preset 10 es cuando empiezan a moverse los faders y knobs del instrumento en reason.....gracias por tu rapida respuesta compañero.
Subir
#4 el 30/07/2012
bueno...me he bajado el midi-ox....he vuelto a conectar el oxygen 61 via midi con la tascam y he usado el midi-ox esto es lo que ha pasado en menos de dos segundos (mirar el archivo adjunto)...sigo perdidisimo con el tema...he estado mirando en varios foros aparte de este y nada....incluso en los foros de M-Audio....no se que podrá ser pero me suena muy raro que se me estropeen los dos controladores a la vez y con los mismos sintomas....descarto que es culpa de reason puesto que la lucecilla roja de la tascam se enciende sin abrir Reason.....socorro
Archivos adjuntos:
Subir
#5 el 30/07/2012
Me huele a un problema en la configuracion del controlador, drivers quizas
Subir
#6 el 30/07/2012
Lo que muestra la pantalla es que está reciviendo el mensage de control continuo de MODULACIÓN. Debes bajar la rueda de modulación hasta el tope, porque si la tienes un poco subida envia mensaje de control continuo.
La pantalla no muestra nada más, en principio todo funciona bien, exceptuando el que la rueda de modulación debe estar bajada al mínimo, nada más.
Subir
#7 el 30/07/2012
#5 driver reinstalados recien descargados de la web del fabricante y todo sigue igual.

#6 no hombreazul....la verdad es que es la primera vez que uso el midi-ox y te pido disculpas si con lo que voy a decir meto la pata hasta el fondo (que de esto tengo experiencia)....tengo el midi-ox abierto y me he fijado que en la columna que pone "data-1",cuando muevo la rueda "modulation" el numero que sale es 01 y en la columna "Event" aparece "CC: modulation" en cambio cuando muevo cualquier knob o fader en la columna "data-1" aprecen otros numeros que no son el 01 y en la columna "Event" aparece "control change" igual que en la imagen adjunta anterior....ademas en reason cuando selecciono un knob de un instrumento y hago lo de "edit remote override mapping" y "tildo" la casilla de "learn from control surface input" la barra que indica que detecta que yo estoy moviendo el knob (del oxygen 61) el cual desearia usar para mover el knob del instrumento de reason no para de subir y bajar y en la casilla "control" aparece de manera aleatoria y a toda hostia : fader 01 , knob 03,knob 08, fader 04 etc etc etc....como si yo estubiera moviendo esos faders y knobs...es rarisimo...habra un fantasma DJ en mi choza???? fuera coñas....no se si daremos con la solución pero gracias a vuetras respuestas me dais un poco de esperanza y estoy posponiendo el momento de tirar por la ventana los dos controladores...y yo detras ;) mil gracias
Subir
#8 el 30/07/2012
No estarás ejecutando un antivirus en el ordenador? si lo tienes activo, ya sabes, en la barra de tareas en la parte inferior derecha. desactivalo o salte de él que es lo mejor.

Por si acaso.
Subir
#9 el 30/07/2012
#8 tampoco compañero....voy a llorar
Subir
#10 el 30/07/2012
Qué sistema operativo tienes?
Subir
#11 el 30/07/2012
#10 xp 32 bits
Subir
#12 el 30/07/2012
¿El teclado es nuevo? Lo digo porque yo tuve un Oxygen 8 (lo compré en 2004) y con los años empezó a enviar mensajes de controlador aleatoriamente. En los leds de la superfície del teclado se veía constantemente un baile de dígitos...
Por desgracia era un problema de Hardware, es decir estaba cascado... Era un teclado económico y cumplió su función sobradamente así que tuve que comprarme otro :-(

Yo uso Mac y utílicé un soft para visualizar los datos MIDI, como el que usaste tú. Ese soft tenía la posibilidad de usarse como "filtro", así que entre el teclado y el software Reason, ese pequeño programa inhabilitaba esos mensajes MIDI.. No sé si el MIDI-Ox también lo hace... Podría ser una opción, siempre y cuando no necesites el Controlador problemático.

Saludos
Subir
#13 el 30/07/2012
Lo mejor es que pruebes los teclados en el ordenador de algún amigo, para salir de dudas. Si en ese ordenador funcionan bien, entonces hay que revisar todos los programas que tienes instalados en el ordenador, hay algunos que testean todos los puertos del ordenador y eso provoca esos fallos.
Subir
#14 el 31/07/2012
pues si gente teneis razon.......dejaré el tema aqui hasta que me asegure de que los teclados fallan o no en otros pc´s...y empezaré a hacerme a la idea de que cabe la posibilidad que esten cascaos...muchas gracias y cuando averigüe si funcionan o no ya lo postearé por aqui....mil gracias un saludo
Subir
#15 el 22/11/2012
Exactamente el mismo problema por aqui... Hace poco que nos pillamos uno de segunda mano, seguro que ya tiene unos cuantos años... y trabajando con Ableton y con mac, pasando los datos directamente a traves de un cable Usb to Midi nos ocurre exactamente lo mismo.
El teclado envia datos continuamente, hemos estado toqueteando, cambiando configuraciones etc etc, lo máximo que hemos conseguido, es que envie pocos datos. La unica solución rapida y sencilla que se nos ocurre, es mapear los datos que envia, a algo que no se vaya a usar, para que cuando envie los program change, los cambios se realicen en algún parametro (volumen de una pista que no contiene nada, por ejemplo), que no afecte negativamente al control.

Complicando más el tema, pero solucionandolo menos chapuzeramente se podría crear un patch de max o de pd, para que esas parámetros sean ignorados, tal como DirtyTricks ha comentado que hizo con un software.

Supongo que dejaste correr el tema?

Un saludo
Subir
Respuesta rápida
Identíficate o regístrate para poder responder en este hilo.