Una duda y problema en tango studio

#1 por Kernel/PA el 01/10/2011
hola comunidad linuxera , aqui con una duda y un problema :
duda: desde hace un mes aproximadamente cambie mi distro , de ubuntu 10.10 a tango studio gracias a las recomendaciones de este preciso foro , veo que no esta activado compiz , ¿compiz afecta mucho el rendimento de audio en tiempo real ? o no afecta nada y lo puedo instalar para que se vea mas chulo .
problema :he intentado instalar pure data extended 0.43.1 AMD64 ubuntu lucid , me lo instala sin problemas aparentemente ,pero al tratar de abrirlo , no lo hace .
saludos desde mexico !

gateway nv 53A
amd turion II x2 p520
3 gb ram
320 DD
Subir
#2 por Pablo_F el 02/10/2011
Sobre la duda, depende mucho de tu sistema, sobretodo de tu tarjeta gráfica y el driver que use. Y del uso que hagas del ordenador. Al final, el que mejor lo va a saber eres tú, después de probarlo.

Por el problema, siempre que no te arranque un programa pinchando en un lanzador, lánzalo desde la terminal. En este caso con el comando pd, me parece. Deberían salir mensajes de error.

También nos ayudas a diagnosticar si comentas con más detalle cómo lo has instalado. No sabemos si has seguido el método estándar de apt-get, synaptic o similar, si has añadido algún repositorio no oficial, si has descargado un binario desde internet o si has compilado algo.

No uso pd y no sé si te podré ayudar pero ven otra vez con más información y será más fácil ver qué pasa :)
Subir
#3 por veguita el 02/10/2011
A mi me pasó algo extraño con pure data. Es que pure data trata de detener PulseAudio para iniciarse, pero al no tener PulseAudio instalado no hacía nada. Me parece que Tango Studio no tiene PulseAudio, así que tu problema puede parecerse al mío. Si tiene PulseAudio, ignora mi comentario.

Lo más fácil es lanzarlo desde un terminal como dice Pablo. El comando pd es para Pure Data vainilla. Yo uso Pure Data extendido y el comando es pdextended.

Otro camino es editar el script que genera el lanzadr en el menú. Tienes que editar como root el archivo /usr/share/applications/pd-extended.desktop (El nombre del archivo puede cambiar según la distro)

en un terminal escribe lo siguiente
Alguien escribió:
sudo gedit /usr/share/applications/pd-extended.desktop


Te aparecerá un archivo con estas líneas
Alguien escribió:
[Desktop Entry]
Encoding=UTF-8
Name=Pd-extended
GenericName=Pure Data
Comment=Visual dataflow programming platform for multimedia
Comment[ca]=Plataforma de programaci� visual per aplicacions multimia
Comment[de]=Grafische Datenflussprogrammierung f�r Multimedia
Comment[es]=Plataforma de programaci�n visual para aplicaciones multimedia
Comment[fr]=Plateforme de programmation visuelle pour applications multimia
Comment[it]=Piattaforma di programmazione visuale per applicazioni multimedia
Comment[pt]=Plataforma de programa��o visuais para multimedia
Exec=pasuspender -- /usr/bin/pdextended -alsa %F
Terminal=false
Type=Application
Icon=pd
TryExec=pdextended
Categories=AudioVideo;Audio;Video;Development;SoftSynth;
MimeType=text/x-puredata;application/x-maxmsp;text/x-maxmsp;
StartupNotify=false


vas a la línea que dice Exec al principio, en mi caso
Alguien escribió:
Exec=pasuspender -- /usr/bin/pdextended -alsa %F


y le borras todo lo que no tenga que ver con el ejecutable. Tiene que quedar así
Alguien escribió:
Exec=/usr/bin/pdextended


Te comento lo que sucedió en mi caso y como lo solucioné yo en Arch Linux. Es probable que en Tango sean diferentes las cosas.

"tengo una soledad tan concurrida que puedo organizarla como una procesión"
Mario Benedetti

Subir
#4 por Kernel/PA el 04/10/2011
muchas gracias veguita , intentare lo explicado , la instalacion la hice desde el instalador gdebi, no creo que haya sido la mejor opcion , no tengo pulse audio , asi que creo que que si me va funcionar , muchas gracias por su ayuda !
Subir
#5 por Kernel/PA el 04/10/2011
hola de nuevo ,desistale de nuevo pdextended desde synaptic , lo volvi a instalar desde terminal , pero no me parece en menu . ni desde configuracion de menus , pongo el comando pdextended y me dice orden no encontrada , pero si pude editar el script como dijiste veguita (señal que si estan instalados los paquetes o casi todos )y ni asi puede correrlo , reviso el synaptic y no aparece el paquete instalado .
Subir
#6 por veguita el 06/10/2011
pucha, la solución que te dí era válida para Archlinux, pero la verdad había un 100% de probabilidades que no fuera válida para otras distribuciones.

La nueva situación que describes, probablemente sea que el paquete quedó mal instalado, a lo mejor si escribes pd y luego aprietas el tab dos veces, te van a aparecer todos los comandos que comienzan en pd y uno de esos debiera ser pure data.

"tengo una soledad tan concurrida que puedo organizarla como una procesión"
Mario Benedetti

Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo