Lmms con Jack = problemas!

#1 por Jandokan el 13/09/2011
Hola, pues ya instalé tango studio en un portatil con 4 gigas de ram y con tarjeta MAudio Fast track Pro, actualicé todo el sistema y el kernel a realtime y configuré jack siguiendo el tutorial de Pablo en su blog, me puse a trastear con el software que incluye y, claro, como no!! los primeros problemos!! jejeje

Empecé a jugar algo con lmms y cada poco me salía un mensaje de que se desconectaba de jack, no llegaba a quedarse sin sonido pero se escuchaba un pequeño chasquido, cuando andaba en cualquier cosa de lmms salia este mensaje y ahora al final ya no se escucha nada por la fast track, si cambio la interfaz en jack a la tarjeta interna por los altavoces integrados sí que se escucha. Adjunto una captura de pantalla del mensaje y de la configuración de jack y también el texto que sale en los mensajes cuando lo arranco


pantallazorp.png
pantallazo1bc.png



14:31:45.271 Patchbay desactivada.
14:31:45.328 Reiniciar estadísticas.
14:31:45.343 Cambió el gráfico de conexiones ALSA.
14:31:45.540 Cambios en las conexiones ALSA.
14:31:50.292 Script de inicio...
14:31:50.293 artsshell -q terminate
sh: artsshell: not found
14:31:50.696 El script de inicio finalizó con estado 32512.
14:31:50.696 JACK está iniciándose...
14:31:50.697 /usr/bin/jackd -dalsa -dhw:Pro -r96000 -p1024 -n3
jackd 0.118.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
Memory locking is unlimited - this is dangerous. You should probably alter the line:
@audio - memlock unlimited
in your /etc/limits.conf to read:
@audio - memlock 2300109
no message buffer overruns
JACK compiled with System V SHM support.
14:31:50.739 JACK se inició con PID=2184.
loading driver ..
apparent rate = 96000
creating alsa driver ... hw:Pro|hw:Pro|1024|3|96000|0|0|nomon|swmeter|-|32bit
configuring for 96000Hz, period = 1024 frames (10.7 ms), buffer = 3 periods
ALSA: final selected sample format for capture: 16bit little-endian
ALSA: use 3 periods for capture
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 3 periods for playback
14:31:52.799 Configuración del servidor salvada en "/home/javi/.jackdrc".
14:31:52.802 Reiniciar estadísticas.
14:31:52.878 Cliente activado.
14:31:52.880 Cambios en las conexiones JACK.
14:31:52.883 Cambió el gráfico de conexiones de JACK.
Archivos adjuntos:
Pantallazo.png
BBCode:
Pantallazo-1.png
BBCode:

MurallaMusical NetLabel

Subir
#2 por igny el 13/09/2011
Yo siempre he trabajado sin jack. Así va de perlas. Igual si no lo vas a necesitar puedes trabajar sólo con alsa.

Puedes seguir utilizando tus teclados midi igualmente.

Saludos.
Subir
#3 por Pablo_F el 13/09/2011
Yo no uso LMMS pero sí que he leído muchas veces (y ahora una vez más :) ) que no tiene buen soporte para jack. Como ya viene con sintetizadores y demás integrados, no es tan importante usar jack con este programa. De todas formas, si lo quieres seguir intentando, prueba a subir el límite de tiempo en el setup de Jack Control. Por otro lado, no veo necesario que trabajes a 96000 Hz, aunque se supone que el kernel rt de tango studio da soporte a la fast track pro a esta frecuencia, pero me parece un poco exagerado.

Cambiando de tema, te importa dar la salida del comando "arecord -l && aplay -l". Es para ver una cosa de esa tarjeta. Gracias.

Saludos, Pablo
Subir
#4 por Jandokan el 14/09/2011
Como dijo Jack el destripador: vamos por partes!

Alguien escribió:
Yo siempre he trabajado sin jack. Así va de perlas. Igual si no lo vas a necesitar puedes trabajar sólo con alsa.


Ya lo intenté, no arranco jack y selecciono alsa en interfaz de audio para lmms, pero sigue sonando por los altavoces integrados, es raro no?
Adjunto unas capturas de alsamixer donde dice que la fast track "no tiene controles"


Alguien escribió:
Cambiando de tema, te importa dar la salida del comando "arecord -l && aplay -l". Es para ver una cosa de esa tarjeta.


**** Lista de CAPTURE dispositivos hardware ****
tarjeta 0: Intel [HDA Intel], dispositivo 0: AD198x Analog [AD198x Analog]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 1: Pro [FastTrack Pro], dispositivo 0: USB Audio [USB Audio]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 1: Pro [FastTrack Pro], dispositivo 1: USB Audio [USB Audio #1 ]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
**** Lista de PLAYBACK dispositivos hardware ****
tarjeta 0: Intel [HDA Intel], dispositivo 0: AD198x Analog [AD198x Analog]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 1: Pro [FastTrack Pro], dispositivo 0: USB Audio [USB Audio]
Subdispositivos: 0/1
Subdispositivo #0: subdevice #0
tarjeta 1: Pro [FastTrack Pro], dispositivo 1: USB Audio [USB Audio #1 ]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
Archivos adjuntos:
Pantallazo-2.png
BBCode:
Pantallazo-3.png
BBCode:

MurallaMusical NetLabel

Subir
#5 por Pablo_F el 15/09/2011
Alguien escribió:
selecciono alsa en interfaz de audio para lmms, pero sigue sonando por los altavoces integrados, es raro no?


Más abajo, donde te pide el dispositivo prueba a poner hw:Pro

Alguien escribió:

la fast track "no tiene controles"

Menos complicación :D
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo