No aparece "system" en Jack

#1 por javi72 el 08/11/2010
Hola a todos
Acabo de renovar el equipo y he instalado ubuntustudio 10.10, pués bién no se porque no me aparece en los puertos de entrada de conexiones "system". He toqueteado pero no doy con la tecla. Me dice esto:

12:23:56.785 Patchbay desactivada.
12:23:56.797 Reiniciar estadísticas.
12:23:56.811 Script de inicio...
12:23:56.812 artsshell -q terminate
Cannot connect to server socket err = No existe el archivo o directorio
Cannot connect to server socket
jack server is not running or cannot be started
Cannot connect to server socket err = No existe el archivo o directorio
Cannot connect to server socket
jack server is not running or cannot be started
12:23:56.816 Cambió el gráfico de conexiones ALSA.
sh: artsshell: not found
12:23:57.305 El script de inicio finalizó con estado 32512.
12:23:57.305 JACK está iniciándose...
12:23:57.306 /usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n3 -C
12:23:57.309 JACK se inició con PID=2326.
no message buffer overruns
no message buffer overruns
jackdmp 1.9.6
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2010 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
Cannot lock down memory area (Cannot allocate memory)
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... -|hw:0|1024|3|44100|0|0|nomon|swmeter|-|32bit
Using ALSA driver HDA-Intel running on card 0 - HDA NVidia at 0xfe020000 irq 21
configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 3 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 3 periods for capture
12:23:57.508 Cambios en las conexiones ALSA.
12:23:59.521 Configuración del servidor salvada en "/home/javi/.jackdrc".
12:23:59.521 Reiniciar estadísticas.
12:23:59.543 Cliente activado.
12:23:59.571 Cambios en las conexiones JACK.
12:23:59.574 Cambió el gráfico de conexiones de JACK.
Cannot lock down memory area (No se puede asignar memoria
Subir
#2 por vagar el 08/11/2010
Abre una consola, ejecuta estos comandos y dinos qué te sale:

[code]cat /proc/asound/devices
aplay -L
[/code]

Ars longa, vita brevis.
Mi colección de enlaces web en diigo.

Subir
#3 por javi72 el 08/11/2010
Me sale esto:

javi@equipo:~$ cat /proc/asound/devices
2: : timer
3: : sequencer
4: [ 0- 3]: digital audio playback
5: [ 0- 1]: digital audio playback
6: [ 0- 0]: digital audio playback
7: [ 0- 0]: digital audio capture
8: [ 0- 3]: hardware dependent
9: [ 0- 0]: hardware dependent
10: [ 0] : control
javi@equipo:~$ aplay -L
Subir
#4 por vagar el 08/11/2010
¿Qué tarjeta de sonido tienes?

Y, ya de paso, ¿qué te sale ejecutando esto?

[code]cat /proc/asound/cards
[/code]

Ars longa, vita brevis.
Mi colección de enlaces web en diigo.

Subir
#5 por javi72 el 08/11/2010
00:07.0 Audio device: nVidia Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)
Subir
#6 por vagar el 08/11/2010
Creo que necesitas unos drivers ALSA más actualizados que los que trae Ubuntu 10.04. Mira a ver si estos enlaces te ayudan:

http://newyork.ubuntuforums.org/showthr ... 136&page=7
https://bugs.launchpad.net/ubuntu/+sour ... bug/550655

Ars longa, vita brevis.
Mi colección de enlaces web en diigo.

Subir
#7 por javi72 el 08/11/2010
Muchas gracias Igarrido, voy a investigar y ya os cuento
Subir
#8 por javi72 el 08/11/2010
¡Solucionado!

Después de mucho trastear resulta que la solución era bién sencilla.

Aquí vi la pista
http://www.linuxmusicians.com/viewtopic.php?f=27&t=2842

Resulta que en el apartado "audio" de la configuración de jack, estaba puesto "solo captura", lo cambié por "duplex" y arreglado :lol:

Gracias
Subir
#9 por Pablo_F el 08/11/2010
.
Subir
#10 por vagar el 08/11/2010
O_o

Sin embargo, eso no justifica que aplay -L no te saque ningún dispositivo. ???

Ars longa, vita brevis.
Mi colección de enlaces web en diigo.

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo