Problemas con conexión midi usb.

#1 por Uey Julian el 21/12/2015
Hola, me llamo Julian, soy nuevo usuario de este lugar, aunque ya había leído varios temas en los foros. pero bueno, como no sé que más decir, iré directo al grano.

Tengo un problema al conectar un cable midi que compré, y es que cuando lo conecto, siempre está prendido el foquito verde(IN) que se supone debería prender solo cuando se activa una tecla del teclado, ni si quiera lo conecto al teclado y ya está en verde. Según yo, debería de estar prendido el foco rojo hasta que conectas el cable al teclado, lo que me hace pensar que el problema es de la pc, algo mal configurado o no sé.

Cuando intento usar el teclado en algún programa, se escucha el plugin o instrumentos a lo loco, como si estuviera apretando todas las teclas a lo tonto. Anteriormente había comprado un cable midi, el cual regresé al pensar que el problema era el cable, pero me pasó lo mismo con este.

Conecto el cable IN en el OUTdel teclado y el OUT en el IN. También he intentado conectando el IN con el IN y el OUT con el OUT, ya que algunos cables son así, pero no cambia nada.

En cuanto a la configuración del programa que uso, que es Flstudio, he intentado de todo, pero no da resultados nada.

Mi teclado es un Casio CT-680 y el cable midi que uso lo dejo en imagen. También dejaré una imagen de las opciones que me salen en el programa.

Espero me puedan ayudar. Gracias.
Archivos adjuntos:
capture-20151221-150104.png
BBCode:
USB_midi_interface_cable_1.jpg
BBCode:
tEC.jpg
BBCode:
Subir
#2 por pablofcid el 21/12/2015
Me da que estás haciendo un bonito bucle MIDI, revisa eso. ¿Has usado local off en el teclado o no?
Echa un vistazo a este artículo en el que hablaba del local off
http://www.hispasonic.com/tutoriales/midi-local-control-on-off-modos-midi-mode-change/40665

Lo de que el IN esté permanentemente en verde seguramente sea porque tu teclado envía unos mensajes que hay definidos en MIDI y que se llaman 'active sense'. No tiene porqué ser ningún fallo. Apostaría a que es eso.

Pablo Fdez-Cid

http://www.cicloquintas.es (formación en síntesis y tecnologías para la música)
http://www.hispasonic.com/pablofcid/articulos (artículos sobre música y tecnología)

Subir
1
#3 por Uey Julian el 22/12/2015
Mi teclado tiene la opción midi y creo que no se puede usar local off. Cuando está en verde el IN, es sin haber conectado el cable al teclado, se pone verde en cuanto lo conecto a la pc.

Según lo que leí de active sense, es similar a como se alocan los sonidos, pero se supone que es del teclado a la pc, por lo que no puede ser ese problema, ya que sin conectarlo se pone verde. Es extraño, puede que se el cable, aunque usé uno diferente antes y pasó lo mismo.

Imagino que puede ser mi teclado que ya es viejo, lo tengo desde hace como 10 años, tal vez ya es hora de conseguir otro.

Gracias por contestar.
Subir
#4 por Suvur el 22/12/2015
Uey Julian escribió:
puede que se el cable, aunque usé uno diferente antes y pasó lo mismo.

Esos cables chinos son una porquería, van cuando quieren.

SUVUR

Subir
1
#5 por pablofcid el 22/12/2015
Otra cosa: asegúrate de si tu interfaz etiqueta In y Out pensando en el punto de vista del teclado externo o del ordenador. Eso también podría justificar parte de tus problemas (lo estarías conectando al revés de lo debido).
Siempre que hay problemas tienes que adoptar una metodología de diagnóstico que pase por simplificar el problema e ir creciendo poco a poco.

En vez de conectar los dos sentidos prueba primero uno (p.ej. reproducir un MIDI File desde el ordenador hacia el teclado) y luego el otro (grabar en un secuenciador tocando el teclado y ver que registras las notas). Sólo con ambos funcionando OK separadamente debes plantearte el ir más allá y abordar la conexión en ambas direcciones a la vez (en la que, insisto, el tema de local on/off puede ser un problema).

Pablo Fdez-Cid

http://www.cicloquintas.es (formación en síntesis y tecnologías para la música)
http://www.hispasonic.com/pablofcid/articulos (artículos sobre música y tecnología)

Subir
#6 por Uey Julian el 22/12/2015
El verdadero problema es que soy nuevo intentando esto, nunca había tenido necesidad de conectar mi teclado por conexión midi, por lo que se me complica más, digamos que es mi primera vez.

En cuanto a lo de local off, imagino que está en el teclado, ¿no? Ni leyendo toda tu publicación del link que me pasaste entendí bien como poner local off, aunque sí entendí para qué sirve. Disculpa mi estupidez.

Revisé videos en los que sale el mismo cable midi y al parecer es normal que esté encendido todo el tiempo el foco verde, lo que tiene que prender y apagar dependiendo de la actividad, es el foco rojo.

El problema está en el teclado, tal vez necesito drivers o entender como poner local off.
Subir
#7 por Uey Julian el 22/12/2015
Logré solucionar el problema conectando el cable de OUT en THRU y el de IN en OUT. Por fin funciona esto.

Gracias por todo.
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo