Ayuda:pasar sonidos de instrumento midi externo a audio

#1 por dabile el 11/04/2015
Buenos días,

quería pedirles ayuda, después de intentarlo de todas las formas y colores, viendo y leyendo tutoriales no logro hacerlo. Tengo un trabajo que entregar este martes por lo que entre en la etapa de ''Socorro''.

Tengo mi Yamaha p-105 son sonidos incorporados, he grabado una pista midi con los sonidos de este, pero cuando quiero pasarla a audio me resulta imposible. Renderizando (exportando) audio no sirve. Lo que tengo que hacer creo, es crear una pista audio que luego grabe en tiempo real lo que la pista midi con los sonidos de mi Yamaha está tocando. Pero cuando lo intento simplemente la pista audio no recibe nada, queda en blanco, es decir no le entra información alguna.

Imagino que es un problema de ruta, seteo de las salidas y entradas de las pistas, tengo una fast track pro, probé con ella y luego con el Asio4all pero no está ahí el problema.

P.D: tendrá que ver con que 1ero debo añadir el Yamaha p-105 como dispositivo MDI? Dentro cubase en la pestaña ''Dispositivos'' está esta opción, aunque en realidad en la lista que te da ni siquiera está mi teclad y de todas formas el teclado como controlador funciona correctamente dentro de Cubas así que diría que lo reconoce sin problemas.

Les agradezco y espero que esto le sirva a alguien más.
Subir
#2 por Mordus el 11/04/2015
Hola Dabile,
dabile escribió:
Lo que tengo que hacer creo, es crear una pista audio que luego grabe en tiempo real lo que la pista midi con los sonidos de mi Yamaha está tocando.

Eso es. Correcto.

dabile escribió:
Pero cuando lo intento simplemente la pista audio no recibe nada, queda en blanco, es decir no le entra información alguna.

¿Has grabado pistas de audio alguna vez? El procedimiento es exactamente igual:
Conectar la salida/s de audio del Yamaha a la entrada/s de audio de la Fast Track y, tal como intuyes, verificar que las entradas de audio del software correspondan a las entradas de audio físicas de la Fast Track.

¿Qué software utilizas?

[...]
dabile escribió:
P.D: tendrá que ver con que 1ero debo añadir el Yamaha p-105 como dispositivo MDI? Dentro cubase en la pestaña ''Dispositivos'' está esta opción, aunque en realidad en la lista que te da ni siquiera está mi teclad y de todas formas el teclado como controlador funciona correctamente dentro de Cubas así que diría que lo reconoce sin problemas.

Eso no debe preocuparte. No tiene relación alguna con el problema.

-Que mi avatar se esté descojonando no significa que yo también lo haga...

-Tanto discrepar me va a matar.

Subir
#3 por Mordus el 11/04/2015
mordus escribió:
¿Qué software utilizas?

Perdona, ahora releo que usas Cubase.

Si en 'Conexiones VST' ya tienes configuradas las entradas/salidas de la Fast Track por defecto (ya sea con el driver de la Fast Track o con Asio4All), bastaría con conectar un cable de audio desde el Yamaha a las entradas audio de la Fast Track.

-Que mi avatar se esté descojonando no significa que yo también lo haga...

-Tanto discrepar me va a matar.

Subir
#4 por dabile el 11/04/2015
mordus muchas gracias por tu respuesta,

creo que en el punto 2 está la clave, mi yamaha no está entrando como audio, si no como Midi al computador por cable Usb a Sub. Tengo la fast track pro conectada a otro puerto usb del compu. Es decir, el teclado no está pasando por la interfaz sino que directamente al compu.

En ese sentido mi seteo en mente es el siguiente:

Canal Midi: In= stereo In / Out= Yamaha p105

Canal audio: In= stereo In / Out= stereo out

(probé también con -Canal Midi: In= Yamaha p105 / Out= stereo out) pero es los mismo, al grabar en tiempo real la pista de audio resulta vacía.

Saludos
Subir
#5 por Mordus el 11/04/2015
Buenas de nuevo,

La solución es tan simple que se te está escapando a simple vista, aun habiéndola destacado en negrita en #2 .

mordus escribió:
Conectar la salida/s de audio del Yamaha a la entrada/s de audio de la Fast Track


Olvida el MIDI: Ya está grabado y funcionando. Concéntrate en grabar el sonido, lo que suena, el audio.
Si vas a grabar una pista de audio, necesitarás asignar una entrada de audio a esa pista (ej: estéreo In 1-2). Esa pista grabará entonces toda señal de audio que esté conectada a las correspondientes entradas (de audio) de la interfaz Fast Track... ya sea un micrófono, un walkman, o las salidas de audio de un Yamaha p-105.
Entonces, la pregunta: ¿Qué hay conectado a las entradas de audio de la Interfaz?

La respuesta debería ser:
un cable de audio que conecta las salidas de audio del piano a la entrada de audio de la interfaz.
De cualquier otra forma, si no se conecta nada a la entrada de audio de la Fast Track, difícilmente grabará nada.

El midi es midi, y el audio es audio. Sí, ya sé que es un mantra muy repetido por aquí, pero esa es la cuestión. He aquí el problema al que te enfrentas ;)

Por si la cosa va por ahí, esto es un cable de audio:

9441626-cable-de-audio-de-guitarra.jpg?psid=1

-Que mi avatar se esté descojonando no significa que yo también lo haga...

-Tanto discrepar me va a matar.

Subir
#6 por dabile el 11/04/2015
Perfecto mordus ! tenías toda la razón!, no sabes el peso que me sacaste de encima =0. por fin puedo grabar el sonido del piano. Aunque no lo creas este problema lo vi repetido más de 1 vez en la web y nadie daba con la respuesta. Se enredan resolviendo el seteo de las entradas y salidas dentro de las pistas cuando en realidad no está ahí el problema, ni hablar lo enredado que estaba yo, espero que esto sirva a otros.

Sólo me queda un pequeño ''pero'': Conecté el jack de la salida de audífono a el primer canal de la fast track, osea al izquierdo, el problema es que me suena sólo por el lado izquierdo, en cambio si lo conecto al derecho, suena por el derecho. Supongo que es porque el canal midi está seteado en stereo (?). Entonces cómo le digo, o creo una pista midi en mono?. Fui a conexiones VST y pedí un nuevo bus, tanto un mono-In, como un mono-Out, pero aun así el midi me suena sólo por un lado, obviamente además pierda fuerza, qué seteo debo hacer?.

Es menos terrible el problema, pero así hacemos canasta limpia si se puede :D.

Gracias de nuevo.
Subir
#7 por dabile el 11/04/2015
Ok actualizo porque lo he resuelto, era tan fácil como en la fast track apretar el botón que dice justamente stereo-mono. Lo dejé en mono y ya está. Era esta la solución correcta?.

Saludos:)
Subir
#8 por Mordus el 11/04/2015
Bueno, bueno...

Me alegra que hayas conseguido algo, aunque sea a medias.

No obstante, también tengo la sensación de que deberías leer más atentamente. Tu respuesta #4 invita a pensar en esa dirección, lo siento. Y en #6 sigues confundiendo audio y midi, entre otras cosas más básicas incluso.

En resumen, me veo obligado a enfrentarme a una situación algo paradójica, ya que lo que se plantea al inicio como un problema de lo más sencillo termina convirtiéndose en una "guía paso a paso" o en una explicación detallada e interminable de las nociones más básicas de grabación de audio y/o midi. Ese trabajo te lo dejo a ti, que eres el interesado, y a ti te corresponde.



Aun así, intentaremos resolver el problema concreto del hilo de la forma más elegante que puedo ofrecerte:
Comento un par de cosas sobre lo que has escrito, y luego resolvemos las conexiones y cableado.

dabile escribió:
Aunque no lo creas este problema lo vi repetido más de 1 vez en la web y nadie daba con la respuesta. Se enredan resolviendo el seteo de las entradas y salidas dentro de las pistas cuando en realidad no está ahí el problema

No, no lo creo. Es tu problema el que no está ahí. En otros hilos puede que el problema sea otro, simplemente.
Date cuenta de que tu problema es que pretendías grabar audio sin ningún cable de audio conectado a la grabadora. Algo así como hacer fotografías sin quitar la tapa del objetivo y preguntar porqué no se ve nada en tus fotos. Conectar el cable no siempre es la respuesta para todo.

dabile escribió:
Sólo me queda un pequeño ''pero'': Conecté el jack de la salida de audífono a el primer canal de la fast track, osea al izquierdo, el problema es que me suena sólo por el lado izquierdo, en cambio si lo conecto al derecho, suena por el derecho. Supongo que es porque el canal midi está seteado en stereo (?). Entonces cómo le digo, o creo una pista midi en mono?

Este es un ejemplo del porqué no puedes resolver el problema. Y el botón mono-estéreo de tu interfaz no lo soluciona. Necesitas entender primero qué es el midi y el audio, qué es mono y qué es estéreo, etc. Las salidas de audio del Yamaha están detrás del piano, no es la salida de audífonos; aunque esto último se soluciona leyendo el manual supongo.



Bueno, lo que necesitas para poder entregar el trabajo el martes es lo siguiente (¡ala! paso a paso... :-k ):

1- Necesitas 2 jacks mono (como el de la foto) para grabar el piano en estéreo. Si solo tienes un jack mono, entonces lo grabarás en mono.
2- Los conectas a las salidas de audio traseras (AUX OUT) del Yamaha, L y R. Si sólo tienes un jack mono, conéctalo a la salida L.
3- El otro extremo de los cables los conectas a las entradas 1 y 2 de la interfaz M-Audio. La entrada 1 corresponderá a la izquierda (L) y la 2 a la derecha (R).
4- Vuelve a poner el botón "mono-stereo" de la interfaz en la posición estéreo. Para más información (o información, sin más) sobre este botón consulta el manual de tu interfaz. Sospecho, tal vez, que deberás hacer lo mismo con el resto de botones. Lo aclaro por si acaso, para evitar malentendidos.
5- Ya puedes grabar en una pista de audio estéreo (o mono, si sólo tienes un jack). Asegúrate de que la entrada de la pista estéreo corresponda a las entradas 1 y 2 de tu interfaz.
6- Si algo no funciona como esperas, vuelve a leer éste post. Tantas veces como haga falta.
7- Entrega el trabajo el martes o te enfrentarás a la ira de Satanás.

-Que mi avatar se esté descojonando no significa que yo también lo haga...

-Tanto discrepar me va a matar.

Subir
#9 por dabile el 13/04/2015
Hola Mordus,

bueno es verdad que no soy aun un erudito del audio-midi pero vamos, no sé si se pueden poner links a otros foros pero te aseguro que mi duda no era nueva y la vi en otras partes en la web, sin solución por cierto.

Por otro lado conectar el jack a las salidas de atrás fue lo 1ero que probé pero no funcionó (no descarto que haya hecho algo mal), pero el sonido del yamaha seguía saliendo por los ''parlantes'' del mismo. En cambio cuando lo conecté a la salida de audífonos funcionó enseguida.

He terminado el trabajo ahora puedo disfrutar el martes de la presentación.

Agradezco mucho tu disposición para ayudar ;).
Subir
--447838--
#10 por --447838-- el 13/04/2015
dabile escribió:
mi duda no era nueva y la vi en otras partes en la web, sin solución por cierto.
Tienes toda la razón, en toda la historia de la industria musical solo unos pocos escogidos han sido capaces de hacer una grabación digital de audio procedente de un instrumento externo. Es uno de los secretos mejor guardados, junto con la fórmula secreta de la coca-cola.
Subir
1
#11 por dabile el 13/04/2015
avallesp tu intervención no valdría la pena ni contrargumentarla ni crear más ''polémica'', no sé cuántos años tienes pero ya pasé esa etapa, es más en realidad nunca pasé por esa etapa.
No has sido capaz ni siquiera de entrar a ayudar y apareces sólo al final para decir estas pelotudeces, eres un grande ;). Créeme he grabado cien veces de instrumentos externos pero me confundió el hecho de que esta vez sea un controlador midi y si de audio sé menos de ti, cuál es el problema?. Soy estudiante de música, de música sobre el papel y la partitura sé mucho pero no me irrita ni me vendrían ganas de burlarme de alguno que sepa menos que yo.

Saludos
Subir
#12 por rod_zero el 14/04/2015
dabile escribió:
bueno es verdad que no soy aun un erudito del audio-midi pero vamos, no sé si se pueden poner links a otros foros pero te aseguro que mi duda no era nueva y la vi en otras partes en la web, sin solución por cierto.


Es que nunca ibas a encontrar solución a tu "problema" por que no había ninguno, lo punico que tenías que aprender es la diferencia entre MIDI y audio.
Subir
#13 por kamikase ♕ ♫ el 14/04/2015
#11

Lo que nos preguntamos muchos en este hilo es por que despues de mas de un año aún sigues con la misma duda cuando ya muchos te la han respondido.

"Yo no sé por qué mi Dios le regala con largueza sombrero con tanta cinta a quien no tiene cabeza." Violeta Parra.
http://www.reverbnation.com/marcoantoniocontreras
Grabo aquí: http://hermanoszabaleta.cl/intro.html

Subir
--447301--
#14 por --447301-- el 16/04/2015
:comer:
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo