Problema transposición notas midi

#1 por Álvaro Albarrán el 27/01/2016
Hola

Quería exponer un problema que estoy experimentando desde que actualicé el Logic Pro X a la versión 10.2.1, se trata de las notas que toco en el teclado que no se corresponde con el editor de teclado midi del Logic.

Os adjunto un pantallazo para que veáis que en el momento que abro una nueva instancia con instrumento de software ya por defecto me salta con transposición -1, la verdad que es muy incómodo trabajar así porque las notas no se corresponden con lo que estoy tocando y el correspondiente dibujo de las mismas en el editor de teclado midi del secuenciador.

No sé si el problema radica en mi teclado midi (ALESIS QX61) o en alguna configuración del Logic que tengo que cambiar.

Muchas gracias por vuestro tiempo y por vuestra ayuda.

Un saludo
Archivos adjuntos:
Captura de pantalla 2016-01-27 a las 11.20.55.png
BBCode:

https://soundcloud.com/alvaroalbarrandj

http://www.mixcloud.com/alvaroalbarrandj/

http://www.youtube.com/user/alvarorpm89

Subir
mod
#2 por Jordi Torres el 28/01/2016
Hola,

La versión 10.2.1 incluye unos scripts de configuración MIDI para un buen número de controladores MIDI de distintas marcas que básicamente crean una configuración automática que asigna los controles del controlador MIDI a los Smart Controls de Logic.

Hay gente que está teniendo problemas con esto, pero la verdad no estoy seguro de que esto que te pasa a ti tenga que ver con los scripts.

Antes de seguir con el tema de los scripts, según tu captura de pantalla tienes algo instalado en la ventana de superficies de control...¿qué es?

Saludos,


J.
Subir
#3 por Álvaro Albarrán el 28/01/2016
Hola Jordi

Muchas gracias por tu respuesta. En primer lugar comentarte que no domino muy bien los conceptos que comentas de Smart Controls de Logic ni sé qué son los scripts, agradecería enormemente saber qué son esos parámetros.

En cuanto a lo que tengo instalado en la ventana de superficies de control, esto es lo que me sale en la configuración de superficies de control, espero que sea lo que me preguntas sobre lo que tengo instalado.

Muchas gracias.

Un saludo
Archivos adjuntos:
Captura de pantalla 2016-01-28 a las 10.44.01.png
BBCode:

https://soundcloud.com/alvaroalbarrandj

http://www.mixcloud.com/alvaroalbarrandj/

http://www.youtube.com/user/alvarorpm89

Subir
mod
#4 por Jordi Torres el 28/01/2016
Hola,

Gracias por el nuevo pantallazo. Por lo que veo solo tienes Logic Remote instalado como superficie de control, que supongo nada tendrá que ver con tu problema.

Es probable entonces que el problema tenga que ver con lo que comenté de los scripts que vienen con esta nueva versión de Logic. Sin embargo, por lo que veo no hay un script específico para tu modelo de controlador. Así que para salir de dudas, puedes decir ()o mostrar) qué tienes en la ventana de Asignación de Controladores (menu Logic Pro X > Superficies de Control > Asignación de controladores...)?

Si lo de los scripts aplica para tu controlador, tendrás una zona con el modelo del teclado en la columna Zona de la ventana de Asignación de controladores.

J.
Subir
#5 por Álvaro Albarrán el 28/01/2016
Hola Jordi

Gracias de nuevo por responder, curiosamente estaba ahora mismo asignando los controles de volumen y de la barra de transporte de mi teclado midi (ALESIS QX61) y es curioso porque según bien me explicas me debería aparecer en la columna de la izquierda el nombre de mi modelo de teclado, sin embargo aparece como (ninguna zona), he tratado de modificar el nombre, pero no hay manera.

El tema es que esta mañana he reseteado el teclado a los valores por defecto de fábrica y por ahora ningún problema, esperemos que siga así.

Ya que estamos, por supuesto te adjunto pantallazo. Es un placer

Gracias por tu tiempo y por la ayuda.

Un saludo
Archivos adjuntos:
Captura de pantalla 2016-01-28 a las 14.30.57.png
BBCode:

https://soundcloud.com/alvaroalbarrandj

http://www.mixcloud.com/alvaroalbarrandj/

http://www.youtube.com/user/alvarorpm89

Subir
mod
#6 por Jordi Torres el 28/01/2016
Hola,

Álvaro Albarrán escribió:
y es curioso porque según bien me explicas me debería aparecer en la columna de la izquierda el nombre de mi modelo de teclado


No, solo te aparecería ahí automáticamente si existiese para él un script de estos que he comentado antes. Pero no lo hay. Logic 10.2.1 incluye scripts para el PhotonX25, Q25 y QX49 de Alesis. Para el tuyo no hay.

Alguien escribió:
Sin embargo aparece como (ninguna zona) he tratado de modificar el nombre, pero no hay manera.


Completamente normal. La zona "ninguna zona" no puede cambiársele el nombre. Sin embargo puedes crear tus propias zonas y ponerle el nombre quieras...

Volviendo a tu problema, llegaste a actualizar a la versión de Logic Remote que salió al mismo tiempo que esta versión de Logic?

J.
Subir
#7 por Álvaro Albarrán el 29/01/2016
Jordi Torres escribió:
Volviendo a tu problema, llegaste a actualizar a la versión de Logic Remote que salió al mismo tiempo que esta versión de Logic?
pues la verdad es que no estoy seguro porque cuando abro la app store no me aparece ninguna actualización disponible salvo la última del Logic (que ya lo actualicé). De todos modos me sigue dando problema ahora ya no con la transposición, sino con los comandos que he guardado en superficies de control como los faders para el volumen de cada pista y los knobs para el paneo, he vuelto a abrir el secuenciador y al tocar los faders y los knobs no responden bien, o se mueve un fader que no corresponde o no hace nada, en fin..

También el otro día comenté que estoy teniendo problemas con la actualización nueva del Logic a la hora de trabajar las funciones en el editor de teclado midi como son las de velocidad fija y duración de nota fija, cuando las selecciono y las aplico automáticamente me sale el círculo de colores y el programa se cierra inesperadamente. Alguna idea? Espero que Apple saque una actualización pronto mejorando esto porque vaya tela..

Muchas gracias por tu ayuda Jordi, un saludo

https://soundcloud.com/alvaroalbarrandj

http://www.mixcloud.com/alvaroalbarrandj/

http://www.youtube.com/user/alvarorpm89

Subir
mod
#8 por Jordi Torres el 29/01/2016
Hola,

Álvaro Albarrán escribió:
pues la verdad es que no estoy seguro porque cuando abro la app store no me aparece ninguna actualización disponible


En la App Store que accedes desde el ordenador no verás las actualizaciones para "apps" de iPhone e iPad.

Álvaro Albarrán escribió:
De todos modos me sigue dando problema ahora ya no con la transposición, sino con los comandos que he guardado en superficies de control como los faders para el volumen de cada pista y los knobs para el paneo, he vuelto a abrir el secuenciador y al tocar los faders y los knobs no responden bien, o se mueve un fader que no corresponde o no hace nada, en fin..


Es probable que se haya corrompido algo entonces (el archivo de preferencias de superficies de control, por ejemplo). Aquí hablamos del tema:

http://www.hispasonic.com/foros/problema-entrada-fisica-ventana-entorno/493820#post4219510

Álvaro Albarrán escribió:
También el otro día comenté que estoy teniendo problemas con la actualización nueva del Logic a la hora de trabajar las funciones en el editor de teclado midi como son las de velocidad fija y duración de nota fija, cuando las selecciono y las aplico automáticamente me sale el círculo de colores y el programa se cierra inesperadamente. Alguna idea? Espero que Apple saque una actualización pronto mejorando esto porque vaya tela..


Quizás sea un bug. Incluso no es la primera vez que ha habido bugs con eso, recuerdo que en Logic 9 los hubo. Probaré aquí a ver...

Ok, aquí no puedo reproducir lo que comentas. Quizás esté vinculado a tu versión de OSX, yo estoy en la 10.9.5 aquí.

Saludos,

J.
Subir
#9 por Álvaro Albarrán el 02/02/2016
Jordi Torres escribió:
Quizás sea un bug. Incluso no es la primera vez que ha habido bugs con eso, recuerdo que en Logic 9 los hubo. Probaré aquí a ver...

Ok, aquí no puedo reproducir lo que comentas. Quizás esté vinculado a tu versión de OSX, yo estoy en la 10.9.5 aquí.


Perfecto muchas gracias por todo Jordi, yo estoy trabajando en OS X Yosemite 10.10.5.

Es un placer como siempre

Saludos

https://soundcloud.com/alvaroalbarrandj

http://www.mixcloud.com/alvaroalbarrandj/

http://www.youtube.com/user/alvarorpm89

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo