TASCAM US - 144 MKII en ubuntu

  • 1
#1 por borgaloisenne el 16/01/2011
Amigos!!!
Les cuento que pocoao poco estoy trayendome cosas de windows a linux...
PERO!! el GRAN GRAN problema es que estuve viendo y mi placa de sonido TASCAM US 144 MKII no es soportada por ubuntu!!

Alguien ha tenido un problema similar??
Existe solución???

Saludos!!
Y gracias!
Subir
#2 por DosSantos el 16/01/2011
Hola borgaloisenne, has echado un ojo a...

http://alsa-project.org/main/index.php/Matrix:Module-usb-us122l

dice que funciona con el núcleo 2.6.33, así que, depende de con que versión de Ubuntu estés trabajando. Esto es un principio. Dinos tu distro y que núcleo lleva. En la pagina que te pongo el enlace, te viene como compilar alsa para darle soporte a la tarjeta, si tu núcleo no es el que indica.

Espero que te sea de ayuda


Saludos
Subir
#3 por borgaloisenne el 17/01/2011
gracias dos santos!!
Pero no tengo idea qué núcleo tengo!!! ),O!!
Cómo hago para saberlo

De más está decir que mi experiencia en este sistema operativo es casi nula!

Saludo y disculpas por mi ignorancia!
Subir
#4 por DosSantos el 17/01/2011
No hombre, faltaría mas, todos hemos empezado en algún momento...

Abres un terminal: Aplicaciones>Accesorios>Terminal

y tecleas

uname -r

y nos cuenta lo que te sale, probablemente, si usas ubuntu 10.10 será el 2.6.35, con lo cual no tendrías problemas con la tarjeta. Lo demás es configurar jack y echar a andar. Si te ha sonado a chino esto ultimo echale un ojo a los enlaces de este hilo

http://www.hispasonic.com/foros/grabando-guitarras-ardour/354269

Lo de jack es algo maravilloso una vez le pillas el truco...

Cuenta tus avances


Saludos
Subir
#5 por Pablo_F el 17/01/2011
Hola,

Yo no estaría tan seguro sobre el soporte para esa tarjeta. En la página de alsa habla sobre la US 144 pero no sobre la US 144 MKII. ¿Qué te da el comando lsusb?
Subir
#6 por Pablo_F el 17/01/2011
Si la US 144 MKII es similar a la US 144, puede que estas instrucciones te sirvan:

http://wiki.ubuntuusers.de/Benutzer/BigMc/Tascam_US-144

Si no, tendrás que buscar o preguntar en la lista de usuarios de ALSA.

¡Ánimo!

Saludos, Pablo
Subir
#7 por borgaloisenne el 17/01/2011
Gracias.. voy a probarlo ahora y luego les digo...saludos!!
Subir
#8 por borgaloisenne el 18/01/2011
Erm.. luego de haber ido al link de Pablo:F me doy cuenta de que es el mismo artíuclo que antes tenía, sólo que en otro sitio. La cosa es: Cómo hago para "pegar" los códigos y Dónde lo coloco?

O la mejor: cómo hago para conseguir el mismo artíuclo en castellano? (tengo idea de inglés, pero realmente este idioma con ubuntu, del que soy un novato novato... no entiendo nada!!!

Saludos y espero no complicarla!
Subir
#9 por Pablo_F el 18/01/2011
Hola,

Paciencia. En firefox, herramientas, complementos, obtener complementos, busca un traductor que te pueda ayudar.

Los comandos los pegas a una terminal. Aplicaciones -> Accesorios -> Terminal
Puedes usar el ratón. Destacas el texto arrastrando sobre el mismo con el botón izquierdo y simplemente lo sueltas en la terminal con el botón central. También puedes usar el botón derecho, copiar y luego en la terminal, botón derecho pegar. Lo mismo para copiar aquí desde la terminal, si tienes alguna duda y quieres mostrarnos el texto que saca la terminal.

Yo tengo mis dudas que te vaya a funcionar. Lo peor es que me da que vas a tener que recompilar el kernel con ehci-hcd como módulo. En resumen. puede ser toda una aventura que probablemente acabe mal. Sin embargo, cada vez hay más hardware soportado y la directa sería preguntar en la lista de usuarios de ALSA.

Una cosa antes de nada, que te da la salida de estos comandos (con la TASCAM conectada):

lsusb

lspsci | grep USB

cat /proc/asound/cards

?

Saludos, Pablo
Subir
#10 por borgaloisenne el 21/01/2011
Hola de vuelta!!!
Bueno.. si.. con los siguientes comandos obtengo estos resultados:

lsusb

Bus 002 Device 002: ID 0458:003a KYE Systems Corp. (Mouse Systems)
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 058f:6362 Alcor Micro Corp. Hi-Speed 21-in-1 Flash Card Reader/Writer (Internal/External)
Bus 001 Device 002: ID 03f0:7711 Hewlett-Packard
Bus 001 Device 003: ID 0644:8020 TEAC Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
slowriot77@ubuntu:~$ ^C
slowriot77@ubuntu:~$ ^C
slowriot77@ubuntu:~$


lspsci | grep USB

lspci | grep USB
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
slowriot77@ubuntu:~$ ^C
slowriot77@ubuntu:~$

cat /proc/asound/cards

0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xdfff8000 irq 22

Están bien???

Saludos!
Subir
#11 por Pablo_F el 21/01/2011
Hola,

A ver, que puede que no sea tan complicado. Yo también estoy aprendiendo. Tienes un bus con un controlador USB 1.1 y el otro con 2.0. ¿Lo ves? El bus 002 es USB 1.1.

Según el documento que estamos mirando el driver para la US-144 sólo funciona con el módulo uhci-hcd (USB 1.1). De la salida de lsusb, la TASCAM es el dispositivo ID 0644:8020 TEAC Corp.

(Lo puedes ver aquí: http://www.linux-usb.org/usb.ids El código de producto aún no aparece en la lista pero el de fabricante sí)

Lo más fácil va a ser que lo intentes enchufando la TASCAM en este bus. Por ejemplo, donde tienes ahora mismo el dispositivo "ID 0458:003a KYE Systems Corp. (Mouse Systems)" que supongo que es el ratón. Para asegurarte, puedes mirar la salida del comando dmesg (últimas líneas) después de desenchufar y enchufar la tarjeta.

Entonces estarás siguiendo el método 1 de las instrucciones y entiendo que no es necesario hacer nada para deshabilitar el módulo ehci-hcd.

Lo que tienes que hacer ahora es crear un archivo .asoundrc dentro de tu home. En el navegador de archivos haces que se muestren los archivos ocultos y como supongo que no lo tendrás, lo creas con botón derecho. Le llamas exactamente así, con el punto delante y todo, y le pegas las líneas de las instrucciones. En lugar de "CARDNR" escribes 1. Ahora, enchufas la TASCAM donde corresponda (en el bus 002) y vuelves a comprobar con cat /proc/asound/cards

¿Te aparece?

Si te aparece, genial. Ojo, la tarjeta sólo funciona con jack y no funcionan los canales digitales. Tienes que configurar Jack Control según las instrucciones.

Lo de cambiar /etc/secutiry/limits.conf y añadirte al grupo audio no sé si ya lo hiciste. Es posible que eso ya lo tengas bien. Comprueba con ulimit -r -l ¿Qué distribución y versión has instalado?

Saludos, Pablo
Subir
#12 por borgaloisenne el 22/01/2011
Hola de vuelta pablo...
soy bastante malo te dirè:

Conectè el puerto USB de la placa adonde estaba el mouse.
Luego cree el archivo ".asoundrc" dentro de mi usuario (dentro de la home no podía... no me dejaba hacerlo)

Le coloquè adentro las lìneas que decìan y reemplacè el "CARDNR" por el 1 (sin las comillas)
y luego al colocar cat /proc/asound/cards, me aparece exactamente igual que la otra vez!!

Aparte, la placa tiene un led que indica la conecciòn usb y no se prendiò... (aunque ...deberìa de prenderse)???

Hasta ahí llegué...

Otra cosa::: estoy por formatear y volver a probar, hay una verisón de linux que esté buena para hacer cosas de sonido???
Sé de Ubuntu Studio, aunque realmente no sè si está tan bueno... tendràs alguno para recomendar asì lo bajo y empiezo desde cero?

saludos y de vuelta.. disculpa, la capa gruesa de ignorancia!

salud!
Subir
#13 por Pablo_F el 22/01/2011
Hola,

Sí, cuando dije "dentro de tu home" me refería a "dentro de /home/tu_nombre_de_usuario". Después de crear ese archivo vuelve a enchufar la tarjeta y comprueba que aparece en el bus 002 en la salida de lsusb. Mejor, comprueba que la TASCAM aparece bajo un controlador USB1.1 en la salida de dmesg.

Si vuelve a no aparecer con cat /proc/asound/cards mal asunto. Por cierto, no dijiste que versión del kernel usas, si estás con ubuntu 10.10 supongo que es 2.6.35. Es un kernel bastante reciente. Dudo mucho que funcione cambiando de distribución. Puedes esperar unos meses (o quién sabe si años), puedes preguntar en la lista de usuarios de alsa, comunicar a Tascam lo que te ocurre, o cambiarla por otra que esté bien soportada.

Saludos, Pablo
Subir
#14 por DosSantos el 22/01/2011
Hola de nuevo...

antes de nada, como te dije al principio, estaría bien que nos dijera que distro tienes, parece ser ubuntu pero cual???

en la red hay información un poco contradictoria sobre esta tarjeta, muchos dicen que no funciona, otros (pocos) dicen que la han hecho funcionar, prueba esto


Tascam devices

The firmware loader for the Tascam US-122, US-224, and US-428 is now obsolete; it has been replaced by ALSA's usx2yloader program.

For the latest version, download the alsa-tools and alsa-firmware packages from the ALSA website, but those should alreay come with your Linux distribution.


En cristiano, que instales el alsa-tools y alsa-firmware reinicias y nos cuentas (un tipo dijo que hizo funcionar la us144 mkII con esto)

Cuanto a distros para el tema de audio, hay varias, a mi me gusta Ubuntu. Los repositorios son los mismo tanto para Ubuntu como para Ubuntu Studio, asi que no tienes que formatear, sino instalarte los paquetes que te interesan, pero, vuelvo a lo de antes, dinos que distro tienes y version, ok...


Saludos
Subir
#15 por borgaloisenne el 25/01/2011
Hola... voy a probar esto ultimo a ver si me da resultado...
Espero poder.....

Instalè ubuntu 9.10
Cómo hago para averiguar el kernel?

Saludos!
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo