Kontakt 5 - Mi teclado midi no suena, el interno sí

#16 por cocorico el 26/10/2012
Vamos a ver, por partes:

Interfaz: Digidesign 002 Rack - conectado a una tarjeta firewire del pc (esta es la configuración típica de una interfaz de este tipo)
Teclado externo: Kawai MP5. MIDI Out del teclado -> MIDI In de la 002 Rack

El orden de encendido es correcto: primero la interfaz (002R) y el teclado, luego abro kontakt.

El sistema no me da problemas con Reason, Reaktor y otros programas. Es sólo kontakt standalone el que da este problema. Respecto a la cuestión audio-midi, es cierto que a priori parece un problema midi, porque el teclado interno funciona correctamente. No obstante, el midi del teclado externo pasa de la digi 002 al pc a través del cable firewire, y se recibe en el pc. El sistema operativo "conduce" hacia el programa en cuestión. Así que, aunque remota, existe la posibilidad de que haya algún conflicto con otro dispositivo/tarjeta del pc. En este caso, lo más probable es que sea la tarjeta de audio.
Subir
#17 por Ángel Santana el 26/10/2012
Sí, está claro que es un problema MIDI, pero no creo que sea de la propia interfaz o del sistema hardware, sino de la configuración de Kontakt. Te digo esto porque a veces he conectado un Yamaha PSR-E413 a Kontakt (4 Player) y funciona correctamente, y de pronto deja de hacerlo, y tengo que irme una pestaña de la configuración para volver a activarlo (cuando esté en casa y lo mire te digo cuál es).
Subir
#18 por cocorico el 26/10/2012
Vale, genial. Ya me cuentas.
Subir
#19 por Ángel Santana el 26/10/2012
Hola.

Pues ahora mismo tengo Kontakt delante.

Cuando cargas un instrumento debe aparecerte una ventana a la derecha, como si fuera un módulo de rack. Justo a la derecha del logo de Kontakt en ese módulo aparece Output y Midi Ch ¿Qué te aparece a ti en cada uno de ellos? ¿puedes enviar una captura de esa pantalla?
Subir
#20 por Donethur el 26/10/2012
AngelSPA escribió:
Donethur escribió:
Logico que es MIDI, pero el sonido debe salir por algun lado, ahi entramos a lo que es audio. Si el teclado MIDi esta seteado para controlar un canal X por el driver ASIO instalado, y el driver de la tarjeta integrada esta predominando en la salida de auriculares, no sonara nunca. Creo que deberias intentar desinstalar totalmente tu tarjeta integrada.


Pero en ese caso tampoco podría escuchar el teclado que incluye Kontakt.


No seria asi, porque el problema estaria en la configuracion del driver de la tarjeta externa y no en la integrada. El sonido sale gracias al driver de la integrada. El problema es la comunicacion entre el teclado y el computador a traves de la tarjeta externa. Si funciona en el DAW, es porque la tarjeta integrada esta descartada totalmente dentro de la configuracion del DAW, pero en este caso parece que no es asi.
Subir
#21 por Donethur el 26/10/2012
cocorico escribió:
Tal vez tengas razón. El tema es que prefiero no desinstalar los controladores de la tarjeta, porque luego es un coñazo si más tarde la necesito, así que primero voy a ver si todo va bien conectando el teclado vía usb. Por cierto, desde Native instruments aún no tengo respuesta, les escribí hace tres días.. qué coño pasa con su soporte?


Puedes instalar el driver en cualquier momento nuevamente, descargandolo desde la pagina de tu tarjeta. Pero creo que es necesario realizar esas pruebas o reinstalar el driver de tu tarjeta externa (Asio), desinstalando e instalando nuevamente.

Ps: no esperes respuesta de NI, ellos nunca me solucionaron un problema que tuve y aun tengo... de hecho jamas me respondieron las multiples comunicaciones (pero cuando quieres comprar algo, responden de inmediato).
Subir
#22 por cocorico el 26/10/2012
OK, allá va.

El midi in lo tengo claro (port A, channel 1 - el teclado transmite en el canal 1; también he probado con la opción "omni", y tampoco suena)

Lo que no tengo nada claro es el tema midi out - ¿qué coño significa "st 1"? a lo mejor ahí está el problema...
Archivos adjuntos:
instrumento.jpg
BBCode:
Subir
#23 por Donethur el 26/10/2012
Que opciones aparecen cuando intentas cambiarlo? (sorry, estoy en el trabajo, no puedo comparar con mi PC)
Subir
#24 por Ángel Santana el 26/10/2012
Yo lo tengo exactamente igual que tú y funciona perfectamente.

Voy a releer atentamente todo el hilo de nuevo, sobre todo a mirar las capturas que has enviado. Estoy dispuesto a conectarme desde remoto para intentar solventar el problema.

Saludos.
Subir
#25 por cocorico el 26/10/2012
Donethur escribió:
Que opciones aparecen cuando intentas cambiarlo? (sorry, estoy en el trabajo, no puedo comparar con mi PC)


Aparece "omni" y los canales asociados a las tres entradas midi de la firewire. Selecciono omni y nada, no hay sonido.

AngelSPA escribió:
Estoy dispuesto a conectarme desde remoto para intentar solventar el problema.


Te agradezco de verdad el ofrecimiento, pero prefiero no conectar el pc del estudio a internet. La experiencia me ha demostrado que es mala idea - actualizaciones automáticas, malware, etc

Donethur escribió:
No seria asi, porque el problema estaria en la configuracion del driver de la tarjeta externa y no en la integrada. El sonido sale gracias al driver de la integrada. El problema es la comunicacion entre el teclado y el computador a traves de la tarjeta externa.


No hay ninguna tarjeta de audio externa - el midi out del teclado va al midi in de la digi 002 y de ahí por el cable firewire (y la tarjeta instalada en el pc) entra en el pc. Con el audio pasa lo mismo: el SO envía el audio por la tarjeta firewire a la digi 002, y ésta lo reproduce en sus altavoces. Dicho esto, el posible conflicto con la tarjeta de audio integrada es muy, muy remoto. Sinceramente, no creo que ese sea el problema.
Subir
#26 por Donethur el 26/10/2012
Entiendo... el problema entonces creo que va por que el controlador de la tarjeta integrada se esta superponiendo a Asio, que hace de driver para ocupar MIDI segun entiendo.
Subir
#27 por cocorico el 26/10/2012
Me alegro de haberme hecho entender.

Pues hombre, visto lo visto, que he probado todas las opciones que se nos ocurren, al final hasta vas a tener razón. Pero antes de desinstalar el controlador, voy a probar conectando el teclado vía USB (el lunes me llega el cable). Espero que de este modo (el midi in no tiene nada que ver con ASIO) se solucione el problema. Os iré contando.
Subir
#28 por Donethur el 27/10/2012
Quizas estoy confundiendo las cosas... es que el controlador de mi tarjeta te instala ASIO (ASIO que viene especial para mi tarjeta), y esta no suena sin ASIO.
Subir
#29 por cocorico el 29/10/2012
Hola amigos,

Ya me llegó el cable, lo conecté a un USB del pc, cambié la entrada midi de kontakt y.... funciona!

No tengo ni idea de cual podría ser el problema..

Gracias a todos en cualquier caso por vuestra ayuda. Nos vemos por el foro!
Subir
#30 por Elmer el 29/09/2015
Hola, yo soy nuevo en esto, instale kontakt 5, me suena en los altavoces de la notebook pero no logro que suene en los auriculares y por ende no puedo amplificar.
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo