Mapeo MIDI para pista seleccionada

  • 1
#1 por DeLaRocK el 28/12/2014
Buenas,

Antes de nada aclarar que no he encontrado nada al respecto (o no he sabido entenderlo...) ni en el manual ni en el foro. De ser así, tan solo indicarme el camino y yo ya me espavilo. Sinceramente, llevo días buscando pero no hay manera.

La cuestión es que me gustaría aprovechar un NanoKontrol 2 que tengo para mapear unas macros de efectos que tengo echas a mi gusto, y que me gustaría tener en todas las pistas. Así que, al igual que hace por ejemplo push, quisiera que seleccionando la pista en cuestión, pudiera manipular los parámetros del rack de efectos, ya que si lo mapeo para la pista 1 (por ejemplo) ese maping solo servirá para el rack de la pista 1, y lo que quisiera conseguir es que seleccionando la pista 2, pudiera controlar el rack de la pista 2 con el mismo mapeo. No se si me he explicado bien #-o

Muchiiiiiiisimas gracias

Abrazotes :cascos:

Technics SL 1200MKII x 2
Allen & Heath XONE92
Launchpad
nanoKONTROL 2
Traktor X1
MacBook Pro i5

ICON Icontrols Pro
Novation IMPULSE49
Launchpad
YAMAHA MG102c
KRK RP5 x 2
MacPro Quad-Core Intel Xeon

https://soundcloud.com/poldelarock

Subir
#3 por DeLaRocK el 28/12/2014
Gracias por mostrarme el camino rodzero, me leere el post entero y todo lo relacionado con los remote scripts.
Desde luego me sorprende como se han complicado la vida estos de ableton. Ya podrían haber puesto un solo menu de midi para mapear todo, no? Como Logic o Traktor, por ejemplo...

Technics SL 1200MKII x 2
Allen & Heath XONE92
Launchpad
nanoKONTROL 2
Traktor X1
MacBook Pro i5

ICON Icontrols Pro
Novation IMPULSE49
Launchpad
YAMAHA MG102c
KRK RP5 x 2
MacPro Quad-Core Intel Xeon

https://soundcloud.com/poldelarock

Subir
#4 por rod_zero el 28/12/2014
#3 Es el sistema de scrips el que permite mapeo dinamico y que existan cosas como Push y APC.

Tambien checa nativekontrol.com Tienen mapeos ya hechos para los nanokontrol.
Subir
#5 por DeLaRocK el 29/12/2014
Genial, tengo material de sobras para indagar a tope.
Gracias ora vez

Technics SL 1200MKII x 2
Allen & Heath XONE92
Launchpad
nanoKONTROL 2
Traktor X1
MacBook Pro i5

ICON Icontrols Pro
Novation IMPULSE49
Launchpad
YAMAHA MG102c
KRK RP5 x 2
MacPro Quad-Core Intel Xeon

https://soundcloud.com/poldelarock

Subir
#6 por DeLaRocK el 29/12/2014
Pues por más que pruebo, no me funciona. Tan solo me reconoce los remote script hechos con el lenguaje pyton.
Es normal eso?

Por casualidad no sabrás nada al respecto rodzero? Quiero decir, sabes porqué el userConfiguration no me funciona y en cambio el pyton si?

En youtube le funciona a la gente pero a mi no.... ](*,) ](*,) ](*,) ](*,) ](*,)

Technics SL 1200MKII x 2
Allen & Heath XONE92
Launchpad
nanoKONTROL 2
Traktor X1
MacBook Pro i5

ICON Icontrols Pro
Novation IMPULSE49
Launchpad
YAMAHA MG102c
KRK RP5 x 2
MacPro Quad-Core Intel Xeon

https://soundcloud.com/poldelarock

Subir
#7 por rod_zero el 29/12/2014
#6 Sale en la lista de controladores tu script?
Subir
#8 por DeLaRocK el 29/12/2014
#7

Pues mucho me temo que va a ser eso, ya que con el nanoKontrol 1 si se puede (de echo hay videos por ahí...) pero con el nanoKontrol 2, osea el mío, solo he conseguido información con pyton. Por algo será...

Si es así menuda mierda, con lo sencillo que hubiera sido con el userConfiguration, el pyton me suena a chino...
He conseguido lo que buscaba (un script que emula un APC, aun siendo con pyton), lo malo es que el muy cabroncete solo me deja enviar la información a través del midi channel 1, y mira tu que casualidad que con mi controlador principal, que lo tengo como makie control, también usa por narices el midi chanel 1, así que tengo conflictos... He conseguido evitarlos, pero me fastidia tener tal chapucilla.

En fin, me veo ahorrando para un push, verás como se acaban los problemas :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen:

Technics SL 1200MKII x 2
Allen & Heath XONE92
Launchpad
nanoKONTROL 2
Traktor X1
MacBook Pro i5

ICON Icontrols Pro
Novation IMPULSE49
Launchpad
YAMAHA MG102c
KRK RP5 x 2
MacPro Quad-Core Intel Xeon

https://soundcloud.com/poldelarock

Subir
#9 por rod_zero el 30/12/2014
#8 No eese no es el problema. Tu ya hiciste tu User script? Ya lo pusiste en la carpeta correspondiente? Sólo si lo pones tu va a aparecer.
Subir
#10 por DeLaRocK el 30/12/2014
Si tio, lo hice tal y como explican en un video de youtube, y nada de nada.
Ahora me voy a trabajar pero cuando vuelva escribire un post paso a paso con fotos con el proceso, veras como no me lo pilla. O eso o hay algo que hago mal.

Technics SL 1200MKII x 2
Allen & Heath XONE92
Launchpad
nanoKONTROL 2
Traktor X1
MacBook Pro i5

ICON Icontrols Pro
Novation IMPULSE49
Launchpad
YAMAHA MG102c
KRK RP5 x 2
MacPro Quad-Core Intel Xeon

https://soundcloud.com/poldelarock

Subir
#11 por DeLaRocK el 30/12/2014
Mira te explico el proceso, a ver si es que me dejo algo, pero vamos, he seguido al pie de la letra este video tutorial:

https://www.youtube.com/watch?v=wzvVkGeI_W8

Paso 1: Crear la carpeta y el script y colocarlos en la carpeta de ableton (fotos numero 1 y 2)

Paso 2: Modificar los datos de UserConfiguration (InputName, Output Name y los encoders) (fotos 3 y 4). Veras que las notas MIDI son las que corresponden.

Paso 3: Reiniciar Live poniendo en superficie de control la carpeta cerada por mi (fotos 5 y 6)

Estoy seguro de que sigo bien los pasos, pero está claro que se me puede escapar algo. De todos modos hay algo que no he probado, y es intentarlo con Live 8, que no sea ese el problema... Voy a ver.

Ah, y gracias por escucharme :mrgreen: :besito:
Archivos adjuntos:
1.png
BBCode:
2.png
BBCode:
3.png
BBCode:
4.png
BBCode:
5.png
BBCode:
6.png
BBCode:

Technics SL 1200MKII x 2
Allen & Heath XONE92
Launchpad
nanoKONTROL 2
Traktor X1
MacBook Pro i5

ICON Icontrols Pro
Novation IMPULSE49
Launchpad
YAMAHA MG102c
KRK RP5 x 2
MacPro Quad-Core Intel Xeon

https://soundcloud.com/poldelarock

Subir
#12 por rod_zero el 02/01/2015
Bueno asi en las fotos se ve todo bien, adjunta el script y lo pruebo yo ( no tengo Nanokontrol pero puedo hacer que otra superficie se llame igual)
Subir
#13 por DeLaRocK el 03/01/2015
#12 Ahí lo tienes, como a ti te funcione ya me tiro del balcón...
Tan solo tendrás que cambiar las notas midi, o adecuarlas en tu midi editor de tu controlador.

Gracias de nuevo eh señor!
Archivos adjuntos:

Technics SL 1200MKII x 2
Allen & Heath XONE92
Launchpad
nanoKONTROL 2
Traktor X1
MacBook Pro i5

ICON Icontrols Pro
Novation IMPULSE49
Launchpad
YAMAHA MG102c
KRK RP5 x 2
MacPro Quad-Core Intel Xeon

https://soundcloud.com/poldelarock

Subir
#14 por Pasto el 08/01/2015
Hola Hispasonicos. ¿alguien podría explicarme por qué se prenden las dos señales (KEY Y MIDI) cuando toco una sola tecla del controlador? ..me trae problemas al mapear; coinciden las CC entre dos controladores. AYUDA POR FAVOR!!!
Archivos adjuntos:
error ableton 1.jpg
BBCode:

Pasto

Subir
#15 por DeLaRocK el 08/01/2015
Que controladores utilizas? Lo que tienes que hacer es cambiar los canales midi ya que tendras los dos en el mismo.
Tendras que conseguir el software de tus controladores, entrar en ellos y cambiarlo. Si me dices que controladores son podre ayudarte, normalmente cuando los compras te viene con el software o en las instrucciones te dice donde descargarlos.

Technics SL 1200MKII x 2
Allen & Heath XONE92
Launchpad
nanoKONTROL 2
Traktor X1
MacBook Pro i5

ICON Icontrols Pro
Novation IMPULSE49
Launchpad
YAMAHA MG102c
KRK RP5 x 2
MacPro Quad-Core Intel Xeon

https://soundcloud.com/poldelarock

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo