Cambio de programa en pista ext. instrument.

mod
#31 por Jordi Torres el 19/12/2015
#28 Te dejo un gif animado que muestra como armar las pistas de manera consistente.

Por otro lado, veo que te has salido un poco del tema en tus otros post. Para dejar las cosas claras, yo estoy hablando de cómo hacer que un plug-in Scripter envíe sus ajustes al momento de cargar un proyecto (una vez más, estando Logic ya abierto antes de cargar dicho proyecto).
Obviamente el Scripter estará cargado en canales de instrumentos software donde tengas el plug-in External Instrument. Es a través de éste último que los mensajes del Scripter van a salir.

Saludos,

J.
Archivos adjuntos:
RecEnable.gif
BBCode:
Subir
#32 por clavinord el 19/12/2015
Hola Jordi, muchas gracias...si, así hago para armarlo, armo la pista activa , luego selecciono de ahí hacia arriba el resto de pistas y pincho el botón para armar la de arriba, pero no se arman todas, no se....no,obstante para no salirme del tema, a lo que iba, yo abro Logic, cargo la plantilla con todas las pistas armadas, y no hace nada, tengo que cerrar el proyecto y volver a abrir el mismo para que me mande datos, no es normal. No?

Un abrazo

it´s more fun to compute

Subir
mod
#33 por Jordi Torres el 19/12/2015
#32 No sé que decirte, aquí funciona consistentemente tal como se ve en la foto que puse antes.

Saludos,

J.
Subir
#34 por clavinord el 19/12/2015
Y ni te hace falta cargar dos veces el proyecto, para que envíe el scripter?

it´s more fun to compute

Subir
mod
#35 por Jordi Torres el 19/12/2015
Hmm, lo que veo es que que si cierro Logic del todo y vuelvo a abrirlo, y luego vuelvo a cargar el proyecto, los botones de armado cambian de aspecto (grises con la R en rojo) y entonces ya no se envían los mensajes. Parece que tendrás que buscar otra manera.

Saludos,

J.
Subir
#36 por clavinord el 19/12/2015
A eso me refería yo....no se, no lo hace de forma coherente, verdad?...no sigue una rutina igual siempre, y hay veces que me cambia unas pistas y otras verces otras....y si creo,4 pistas con un instrumento externo, por ejemplo nord lead que tiene 4 partes pero solo tengo dos salidas de audio para ese sinte, lo que hago es que una pista external instrument le asignó las entradas de la mesa, pero las otras tres pistas asignó canales MIDI pero no salidas, y suenan porque la pista 1 está cargada. .bueno, pues esas cuando las armo, se quedan en gris, no en rojo y tampoco manda scripter

Por qué hago todo esto?, te preguntarás ....porque quiero usar arpegiadores que trae en efectos MIDI, ..y la única forma de insertarlos es en external instruments, no en pistas MIDI ....y te para qué quiere script?...pues porque con sintes que tienen más de mil sonidos, quiero ir probando los sonidos que tengo para elegirlos, y la forma que tengo es me sitúo encima el campo preset y voy cambiando con él cursor mientras toco una tecla en el teclado maestro, y así los elijo....y no lo hago en pistas MIDI porque como hablamos en un post que puse en otra ocasión,....no me respeta volúmenes , ni panorámicos ni los programas seleccionados en cada pista al cargar el proyecto, y claro, con tantas pistas y tantos sintes, es un ciñazo tremendo ir pista por pista configurando de nuevo el sonido seleccionado, el volumen inicial etc, cada vez que abra un proyecto....no sé cómo lo hará la gente, la yo desde luego no trabajo con audio excepto las voces, y me es imprescindible tener esa opción de alguna forma.....la solución la vi en scripter, pero lo que no entiendo es que no mande los parámetros al abrir el proyecto de una forma natural, porque se supone que si están ahí, es para que los mande, no?

Un abrazo y muchísimas gracias

it´s more fun to compute

Subir
mod
#37 por Jordi Torres el 19/12/2015
clavinord escribió:
la solución la vi en scripter, pero lo que no entiendo es que no mande los parámetros al abrir el proyecto de una forma natural, porque se supone que si están ahí, es para que los mande, no?


No, no se supone. En la documentación no pone en ningún lado que el Scripter haya sido diseñado para funcionar de la manera que tú quieres que funcione. Siempre puedes mandar tus quejas, sugerencias o peticiones a Apple directamente:

http://www.apple.com/feedback/logic-pro.html

De momento te recomiendo que para enviar los mensajes al cargarse Logic/el proyecto, utilices la otra manera que en su día comentamos y que sí es consistente: Desde el entorno con objetos fader.

Puedes seguir usando el Scripter para enviar lo que quieras mientras estés trabajando en el proyecto y dejar los objetos fader para enviar los mensajes al cargar el proyecto. No se me ocurre otra solución basada únicamente en Logic.

Saludos,

J.
Subir
#38 por Alex el 26/01/2016
.

A.Rodriguez

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo