Problemas con Rosegarden

  • 1
#1 por chino el 28/08/2009
Bueno, aqui voy de nuevo...

Instale Rosegarden, pero cuando le doy click, el programa ni siquiera arranca.
Intente arrancarlo desde la consola y me dice esto:


$ rosegarden
trying to create local folder /home/nicolas/.kde/share: Permission denied
trying to create local folder /home/nicolas/.kde/share: Permission denied
trying to create local folder /home/nicolas/.kde/share: Permission denied
trying to create local folder /home/nicolas/.kde/tmp-nicolas-desktop: Permission denied
trying to create local folder /home/nicolas/.kde/share: Permission denied
trying to create local folder /home/nicolas/.kde/share: Permission denied
trying to create local folder /home/nicolas/.kde/share: Permission denied
trying to create local folder /home/nicolas/.kde/share: Permission denied
trying to create local folder /home/nicolas/.kde/share: Permission denied
trying to create local folder /home/nicolas/.kde/socket-nicolas-desktop: Permission denied
trying to create local folder /home/nicolas/.kde/socket-nicolas-desktop: Permission denied
kdeinit: Aborting. bind() failed: : Permission denied
Could not bind to socket '/home/nicolas/.kde/socket-nicolas-desktop/kdeinit__0'
nicolas@nicolas-desktop:~$

lo habre instalado mal? :roll:
Subir
#2 por vagar el 28/08/2009
Mira los permisos de la carpeta en la que quiere crear los ficheros temporales invocando el siguiente conjuro:

[code]ls -ld /home/nicolas/.kde[/code]

Es posible que si has andado trasteando con sudo la carpeta se haya creado con el usuario root, en vez de nicolas. Para desfacer el entuerto ejecuta:

[code]sudo chown -R nicolas:nicolas /home/nicolas/.kde[/code]

Ars longa, vita brevis.
Mi colección de enlaces web en diigo.

Subir
#3 por chino el 28/08/2009
lgarrido escribió:
Mira los permisos de la carpeta en la que quiere crear los ficheros temporales invocando el siguiente conjuro:

[code]ls -ld /home/nicolas/.kde[/code]

Es posible que si has andado trasteando con sudo la carpeta se haya creado con el usuario root, en vez de nicolas. Para desfacer el entuerto ejecuta:

[code]sudo chown -R nicolas:nicolas /home/nicolas/.kde[/code]



Genial! ahora arranca!

siempre fui de los que saben que pasa en la computadora cuando uno hace una u otra cosa... pero con linux estoy super perdido, espero poder encontrarle la vuelta.

Gracias! :D
Subir
#4 por chino el 28/08/2009
Le cargue el hexter y suena...
Mi pregunta es saber xq cuando habro un demo song, no suena nada...

Por otra parte, estas ventanas me aparecen cuando arranco el programa. Help!



La resolución del temporizador del sistema es muy baja
Rosegarden no ha sido capaz de encontrar una fuente de alta resolución para una temporización de alto rendimiento.
Esto puede significar que usted está usando un sistema Linux con la resolución del temporizador muy baja. Por favor, contacte a su distribuidor para mayor información.
Algunas distribuciones Linux proporcionan núcleos de baja latencia, vea http://rosegarden.wiki.sourceforge.net/ ... cy+kernels para más instrucciones.


Guiones ayudantes no se hallaron
Rosegarden buscó pero no halló uno u más de los guiones ayudantes que se requieren para activar unas características especiales. Las características siguientes no estarán disponibles:
Exportación e importación de archivos de Proyecto de Rosegarden...
Importación y conversión general de archivos de audio
Para arreglar esto, debes instalar los siguientes programas adicionales:
kdialog - para apoyo de archivos de Proyecto de Rosegarden
sox OR sndfile-resample - para importación de archivos de audio
Subir
#5 por Pablo_F el 29/08/2009
Si cargas una demo, las pistas MIDI no tienen por qué estar con un dssi synth plugin de origen (quizás estaban con un General Midi que estaba conectado a sintetizador hardware o cualquier otra cosa) y si lo estaban y no tienes precisamente ese synth plugin, te lo advertirá. Entonces tienes que redefinir el sintetizador a uno que tengas disponible. Si de momento lo único que tienes para que suene Rosegarden es el hexter, lo que tienes que hacer es dar con botón derecho a las pistas y elegir "synth plugin" y luego a la derecha, dar al botón que pone "sin sinte" y elegir el hexter, y luego el instrumento.

Con respecto a las otras advertencias, la primera parece indicar que estás funcionando con el kernel genérico de ubuntu, no con el kernel especial rt que sí tendría que venir configurado con temporizadores de alta resolución (cosas de la configuración del kernel). Yo también me obsesiono en que todo esté lo más perfecto posible pero si eres capaz de hacer música con lo que tienes ahora, sigue adelante. Lee lo que escribio lgarrido acerca del kernel realtime y demás y de mientras, si quieres, da la salida de:

[code]uname -r[/code]

para ver qué kernel estás usando, probablemente el 2.6.28-xx-generic (xx será 13, 14 o por ahí supongo).
Si tienes ubuntustudio supongo que tendrás instalado un kernel rt. Comprueba si está en /boot. Puedes navegar por los archivos gráficamente y comprobarlo. Y si haces:

[code]ls /boot | grep initrd[/code]

te lo decimos seguro.

Si lo tienes instalado y no te sale como opción de arranque es porque no lo tienes registrado en el archivo '/boot/grub/menu.lst'. Es cosa de añadir unas líneas en ese archivo.

Lo de los guiones ayudantes no sé lo que significa, no entiendo bien esa advertencia, pero instalando el paquete kdebase (con sus dependencias) se arregla.

¡Ánimo!
Subir
#6 por chino el 29/08/2009
me sale lo siguiente:

nicolas@nicolas-desktop:~$ uname -r
2.6.28-15-generic

nicolas@nicolas-desktop:~$ ls /boot | grep initrd
initrd.img-2.6.28-11-generic
initrd.img-2.6.28-15-generic
initrd.img-2.6.28-3-rt

He leido el post de lgarrido y me puse al dia con esto de aprender que es el kernel, pero no se como instalar el que correspoden... hay que bajarlo de internet?

Mientras voy a instalar el kdebase.

Gracias!
Subir
#7 por X5000 el 29/08/2009
El kernel ya está instalado.

Cuando cargas tu Ubuntu debería aparecer en GRUB:

Ubuntu (linux-2.6.28-3-rt)
(o algo similar, lo importante es el "rt" al final)

Elegí este kernel y va a cargar el Ubuntu con latencia baja.

salu2
Subir
#8 por chino el 30/08/2009
cargue el kernel linux-2.6.28-3-rt
y ahora, me pasa que cuando inicio no arranca, se queda la pantalla en negro, y no hay forma de salir, tengo q reiniciar...
volvi a iniciar como lo hacia siempre en Ubuntu 2.6.28-15 y funciona, pero se me desactivo los controladores
de hardware de los graficos de la nvidia.
Ya los volvi activar...
no se que como solucionarlo, para poder iniciar con el rt para baja latencia.
Subir
#9 por Pablo_F el 31/08/2009
Hola Cheiro,

¿Qué tarjeta gráfica tienes? Da la salida de 'lspci', pero sólo la línea de la gráfica (o haz 'lspci | grep VGA' para que te salga sólo esa linea).

A mí me pasa algo muy parecido en un ubuntu jaunty que acabo de instalar con un nvidia de la serie 8000 que ahora no recuerdo, no estoy en casa. Sólo me funciona con resolución baja. Vamos a tener que intentar cargar el driver desde línea de comandos. Si no se adelanta nadie, cuando saque un rato y lo consiga, espero que durante esta semana, explicaré cómo lo he conseguido. De mientras sigue con el genérico, que va no va tan mal para el estudio y en mi experiencia va de cine para "todo lo demás".

Hasta pronto, Pablo.
Subir
#10 por Pablo_F el 31/08/2009
Bueno, al final no ha sido para tanto. Voy a explicar cómo he cargado el driver de nvidia contra el kernel rt.

Ojo, las siguientes instrucciones son para instalar el driver privativo de nvidia en el kernel rt de ubuntu jaunty. Tengo una nvidia 8400 GS. Me ha funcionado. . Hay otras alternativas con drivers libres. En mi caso necesito efectos visuales y por eso necesito el privativo y esta es mi elección. Pero no quiero fomentar el uso de software privativo, que conste.

En ubuntu junty genérico ya instalé el driver de nvidia con la utilidad que sale automágicamente al intentar activar los efectos visuales. Así que creo que estoy, más o menos, en tu mismo caso, Cheiro.

1º Arranco con el genérico y en terminal hago:

$cd /etc/X11/
veo con 'ls' que tengo un archivo 'xorg.conf.failsafe', además de un 'xorg.conf', que es donde está la configuración de la parte gráfica. Así que lo primero, pongo a salvo el xorg.conf que me funciona con el kernel genérico, haciendo una copia a un archivo que llamo 'xorg.conf.nvidia.generic' (o como te dé la gana).

$sudo cp xorg.conf xorg.conf.nvidia.generic

Y ahora copio el 'a prueba de fallos' al xorg.conf

$sudo cp xorg.conf.failsafe xorg.conf

Ahora instalo envyng-qt, desde synaptic o con 'sudo apt-get install envyng-qt'. Esto es una herramienta alternativa para cargar los drivers privativos de las tarjetas gráficas.

Ahora reinicio con el kernel rt. Me va a módo gráfico seguro (800x600). Abro una terminal e invoco:

$envyng-qt

Me pide contraseña y procedo a instalar el driver privativo recomendado. Esto, además de instalar el driver me modificará el archivo '/etc/X11/xorg.conf'. Reinicio y ya funciona.

Saludos. Pablo.
Subir
#11 por chino el 01/09/2009
Yo tengo nvidia 8600 GT.
Segui todos tus pasos y ahora esta funcionando de lujo!!! Gracias Pablo
A decir verdad, contento, pero me da un poco de temor, estoy configurando toda mi maquina, pero nada a conciencia jaja... confio plenamente en ustedes, solo q me gustaria saber q es lo que hago con mas conciencia.

Con todo esto, me voy armar un tuto, por si alguna vez tengo que reinstalar todo.

El Ubuntu 9.04 con el Ubuntu estudio instalado, es lo mismo que el jaunty? si es otra cosa, que es el jaunty? ahora voy a googlear un rato con esto, hace dias tengo la duda.
Subir
#12 por marcelo el 18/07/2010
Pablo_F escribió:
Bueno, al final no ha sido para tanto. Voy a explicar cómo he cargado el driver de nvidia contra el kernel rt.

Ojo, las siguientes instrucciones son para instalar el driver privativo de nvidia en el kernel rt de ubuntu jaunty. Tengo una nvidia 8400 GS. Me ha funcionado. . Hay otras alternativas con drivers libres. En mi caso necesito efectos visuales y por eso necesito el privativo y esta es mi elección. Pero no quiero fomentar el uso de software privativo, que conste.

En ubuntu junty genérico ya instalé el driver de nvidia con la utilidad que sale automágicamente al intentar activar los efectos visuales. Así que creo que estoy, más o menos, en tu mismo caso, Cheiro.

1º Arranco con el genérico y en terminal hago:

$cd /etc/X11/
veo con 'ls' que tengo un archivo 'xorg.conf.failsafe', además de un 'xorg.conf', que es donde está la configuración de la parte gráfica. Así que lo primero, pongo a salvo el xorg.conf que me funciona con el kernel genérico, haciendo una copia a un archivo que llamo 'xorg.conf.nvidia.generic' (o como te dé la gana).

$sudo cp xorg.conf xorg.conf.nvidia.generic

Y ahora copio el 'a prueba de fallos' al xorg.conf

$sudo cp xorg.conf.failsafe xorg.conf

Ahora instalo envyng-qt, desde synaptic o con 'sudo apt-get install envyng-qt'. Esto es una herramienta alternativa para cargar los drivers privativos de las tarjetas gráficas.

Ahora reinicio con el kernel rt. Me va a módo gráfico seguro (800x600). Abro una terminal e invoco:

$envyng-qt

Me pide contraseña y procedo a instalar el driver privativo recomendado. Esto, además de instalar el driver me modificará el archivo '/etc/X11/xorg.conf'. Reinicio y ya funciona.

Saludos. Pablo.


hola Pablo

1) alguna vez charlé con vos y rvchila por chat y uds. dos me recomendaron migrar a ubuntu en la versión lucid, así lo hice (instale desde cero ubuntu studio lucid 10.04) y la verdad que les agradezco la sugerencia en su momento, ya que camina 10 pts.

2) tengo estas dudas y si me lo permitís -por favor- quisiera pedir tu opinión
2A) cuando inicio qjackctl, en la ventana del mismo parpadea RT (modo servidor Jack) pero cuando inicio Rosegarden muestra un mensaje diciendo que no hay un kernel de baja latencia: quien dice lo mas parecido a la verdad, Jack o Rosegarden?

* la salida de uname -r es: 2.6.32-23-generic
* instale (via synaptic) linux-image-rt y linux-image-2.6.32-11-rt -> esta ultima aparece como opción de arranque en el grub pero cuando la selecciono para arrancar con este kernel, me pasa lo mismo que al compañero cheiro, se queda la pantalla en negro y tengo que reiniciar (el ubuntu studio lucid 10.04 instala por defecto el grub2), te cuento también que instale el driver de nvidia que baje de la pagina misma de nvidia (ya que envyng-qt no es usado en esta distribución) y lo instale compilando con la ayuda que se ofrece en http://ubuntu-guia.blogspot.com/

3) linuxsampler que pude instalar con la ayuda que me diste via "Semicorchux" camina como los dioses

gracias de antemano Pablo, saludos.

Marcelo

Subir
#13 por Pablo_F el 18/07/2010
¡Hola Marce!

Alguien escribió:
2A) cuando inicio qjackctl, en la ventana del mismo parpadea RT (modo servidor Jack) pero cuando inicio Rosegarden muestra un mensaje diciendo que no hay un kernel de baja latencia: quien dice lo mas parecido a la verdad, Jack o Rosegarden?


Los dos dicen la verdad. Jack está en modo realtime (tienes activada la opción realtime en el setup) y has arrancado con un kernel genérico, como confirmas con la salida de uname -r. El modo realtime de jack no implica el kernel rt y sólo es posible si el usuario que ejecuta jackd tiene cierto "privilegio" de prioridad realtime (rtprio) que es necesario para trabajar con audio a baja latencia.

Este límite se comprueba con el comando "ulimit -r" y tú lo tienes bien seguro porque si no, no podrías arrancar jack en rt.

Si estás interesado, ver:
http://www.kernel.org/pub/linux/libs/pa ... imits.html
http://jackaudio.org/faq (segunda faq)

Hoy en día, el kernel genérico es "bastante" realtime. Espero que Luis me corrija si digo algo mal pero hace años era impensable trabajar con un kernel genérico y esperar baja latencia pero eso ha cambiado hoy en día. Es más, desde ubuntu lucid, el paquete ubuntustudio-audio no incorpora el kernel rt porque se considera que el genérico es válido como punto de partida.

Además, ubuntu y algunos ppa's ofrecen variaciones sobre el kernel. Por ejemplo hay un kernel no parcheado (el código fuente es el mismo que el genérico) pero considerado de baja latencia porque al compilarlo se marcó alguna opción especial que el kernel genérico de ubuntu no tiene (no estoy muy puesto en este tema y nunca he compilado mi propio kernel por eso no soy más específico, además que creo que lo importante es la idea general para empezar). En ubuntu, los kernels marcados como "rt" están parcheados, es decir, que el código fuente del kernel no es el mismo que el que se emplea para compilar el "genérico" ni el de "baja latencia". Parece que esto permite mayor granularidad para gestionar las tareas y el acceso al hardware, aunque en este caso, se deben gestionar las prioridades intencionadamente. Hay un script que permite hacerlo automáticamente al arrancar el ordenador; sólo hay que configurarlo adecuadamente. Ver:

http://semicorchux.blogspot.com/2010/05 ... tudio.html
Alguien escribió:

* instale (via synaptic) linux-image-rt y linux-image-2.6.32-11-rt -> esta ultima aparece como opción de arranque en el grub pero cuando la selecciono para arrancar con este kernel, me pasa lo mismo que al compañero cheiro, se queda la pantalla en negro y tengo que reiniciar (el ubuntu studio lucid 10.04 instala por defecto el grub2), te cuento también que instale el driver de nvidia que baje de la pagina misma de nvidia (ya que envyng-qt no es usado en esta distribución) y lo instale compilando con la ayuda que se ofrece en http://ubuntu-guia.blogspot.com/


Perfecto, y va bien?

Yo tengo una buena experiencia reciente con el 2.6.31-xx-rt
Pero también estuve un tiempo con el genérico e iba muy bien, aunque no podía poner la latencia de jack tan baja sin recibir xruns como ahora con el rt y el script rtirq-init.
Alguien escribió:

3) linuxsampler que pude instalar con la ayuda que me diste via "Semicorchux" camina como los dioses


:)

Saludos, Pablo
Subir
#14 por marcelo el 21/07/2010
hola Pablo

me llevó un tiempito de concentración y estudio seguir el hilo de la información que agradezco

Los dos dicen la verdad. Jack está en modo realtime (tienes activada la opción realtime en el setup) y has arrancado con un kernel genérico, como confirmas con la salida de uname -r. El modo realtime de jack no implica el kernel rt y sólo es posible si el usuario que ejecuta jackd tiene cierto "privilegio" de prioridad realtime (rtprio) que es necesario para trabajar con audio a baja latencia.

Este límite se comprueba con el comando "ulimit -r" y tú lo tienes bien seguro porque si no, no podrías arrancar jack en rt.

ahora entiendo el concepto de las dos situaciones

Si estás interesado, ver:
http://www.kernel.org/pub/linux/libs/pa ... imits.html
http://jackaudio.org/faq (segunda faq)

gracias por informarme de la existencia de estas dos páginas aunque no poseo un ingles lo suficientemente fluido (lectura) igual pude sacar provecho


http://semicorchux.blogspot.com/2010/05 ... tudio.html

seguí las instrucciones de "Semicorchux" para confeccionar el script pero hay ciertos datos que no puedo extraer de htop, hay unas leves diferencias en la salida de tu pantalla y lo que muestra la mia, estoy potabilizando las dudas para confeccionar una consulta concisa con vos en el blog -por favor-

* instale (via synaptic) linux-image-rt y linux-image-2.6.32-11-rt -> esta ultima aparece como opción de arranque en el grub pero cuando la selecciono para arrancar con este kernel, me pasa lo mismo que al compañero cheiro, se queda la pantalla en negro y tengo que reiniciar (el ubuntu studio lucid 10.04 instala por defecto el grub2), te cuento también que instale el driver de nvidia que baje de la pagina misma de nvidia (ya que envyng-qt no es usado en esta distribución) y lo instale compilando con la ayuda que se ofrece en http://ubuntu-guia.blogspot.com/[/quote]

Perfecto, y va bien?
el driver nativo de nvidia va bien, aunque con ciertos detalles (al pulsar ALT+CTrL+F1 no "veo nada", lo mismo durante el inicio {carga del S.O.} pero no es algo que me quite el sueño, por ahora sigo buscando datos para solucionarlo)

lo que si Pablo, me gustaría tener una orientación de tu parte -por favor- respecto a poder iniciar con el kernel-rt, te vuelvo a repetir mi situación (creo no haber sido claro): cuando selecciono la opcion kernel-rt en el grub, arranca la carga del sistema pero la pantalla se queda en negro, cualquier información sera bienvenida

gracias por tu tiempo Pablo

Atte.

Marcelo

Subir
#15 por Pablo_F el 21/07/2010
Alguien escribió:
seguí las instrucciones de "Semicorchux" para confeccionar el script pero hay ciertos datos que no puedo extraer de htop, hay unas leves diferencias en la salida de tu pantalla y lo que muestra la mia, estoy potabilizando las dudas para confeccionar una consulta concisa con vos en el blog -por favor-


Ese script sólo funciona con un kernel rt. Creo que lo estás intentando con el genérico (porque según comentas, con el rt no puedes arrancar de momento, pero no estoy seguro si es lo que te pasa).
Alguien escribió:

cuando selecciono la opcion kernel-rt en el grub, arranca la carga del sistema pero la pantalla se queda en negro, cualquier información sera bienvenida


O sea, ¿Tienes que reiniciar con el kernel genérico? ¿O llegas al entorno gráfico la segunda vez que arrancas con el rt? No entiendo del todo.

Saludos, Pablo
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo