Problemas con Rosegarden

  • 2
#16 por marcelo el 22/07/2010
Pablo_F escribió:
Alguien escribió:
seguí las instrucciones de "Semicorchux" para confeccionar el script pero hay ciertos datos que no puedo extraer de htop, hay unas leves diferencias en la salida de tu pantalla y lo que muestra la mia, estoy potabilizando las dudas para confeccionar una consulta concisa con vos en el blog -por favor-


Ese script sólo funciona con un kernel rt. Creo que lo estás intentando con el genérico (porque según comentas, con el rt no puedes arrancar de momento, pero no estoy seguro si es lo que te pasa).
Alguien escribió:


-> no habia pensado en esa posibilidad, o mejor dicho, no lei lo suficientemente en detalle la información dada en el blog "Semicorchux", esperaré a poder arrancar con el kernel-rt y sigo la confección del script

cuando selecciono la opcion kernel-rt en el grub, arranca la carga del sistema pero la pantalla se queda en negro, cualquier información sera bienvenida


O sea, ¿Tienes que reiniciar con el kernel genérico? ¿O llegas al entorno gráfico la segunda vez que arrancas con el rt? No entiendo del todo.

-> no Pablo, no puedo llegar al entorno gráfico de ninguna manera si arranco con el kernel-rt, debo reiniciar la pc y arrancar con el kernel-generico

gracias y saludos.

Atte.

Marcelo

Subir
#17 por marcelo el 22/07/2010
Pablo dijo: " Ese script sólo funciona con un kernel rt. Creo que lo estás intentando con el genérico (porque según comentas, con el rt no puedes arrancar de momento, pero no estoy seguro si es lo que te pasa)".

marce_rega dijo: ->ok, espero a poder arrancar con el kernel-rt para llevar a cabo la confección del script, gracias Pablo.

Pablo_F dijo:O sea, ¿Tienes que reiniciar con el kernel genérico? ¿O llegas al entorno gráfico la segunda vez que arrancas con el rt? No entiendo del todo.

marce_rega dijo: -> no Pablo, con el kernel-rt no puedo llegar al entorno gráfico de ninguna manera, debo reiniciar la pc seleccionando el kernel genérico, gracias, saludos.

Marcelo

Subir
#18 por Pablo_F el 22/07/2010
Hola Marce,

Por curiosidad, ¿Qué tarjeta gráfica tienes?

Da la salida de:

lspci | grep -i vga

Antes te entendí mal, disculpa. Si ni siquiera te arranca en resolución gráfica lo debes hacer desde línea de comandos, arrancando en recovery mode y con el modo texto del envyng. Antes de esto, desde el kernel genérico instala los paquetes:

envyng-core
linux-headers-rt
build-essential

Reinicia y arranca con el recovery mode del rt. Elige la opción de ir a línea de comandos de root. Y haces:

[code]cd /etc/X11/[/code]
[code]
cp xorg.conf xorg.conf.generic[/code] (copia de seguridad del xorg.conf actual que funciona con el kernel generic)
[code]
envyng -t [/code]

Seguir instrucciones y reiniciar con el kernel rt.

Espero que funcione. Saludos, Pablo
Subir
#19 por marcelo el 24/07/2010
hola Pablo

la salida es:

marce@sempron-lucid:~$ lspci | grep -i vga
00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 6150SE nForce 430] (rev a2)

1) te cuento que el paquete envyng no aparece en los repositorios (sino estoy hablando de mas en esta versión de lucid {10.04} en lugar de envyng se ha usado nouveau)

2) tampoco puedo arrancar con recovery mode del kernel-rt, pasa lo mismo, no tengo señal en el monitor, nada, totalmente negro

3) te acordas que te conté que había instalado el driver nativo que baje de la página de nvidia? (para poder usar dos efectos compiz que me gustan, esto no lo podía lograr con el driver que trae por defecto ubuntu studio lucid 10.04) y, para poder instalar el driver tuver que deshabilitar nouveau, te paso este dato por si te resulta de importancia.

gracias por tu dedicación y tiempo Pablo, saludos.

Atte.

Marcelo

Subir
#20 por Pablo_F el 24/07/2010
Hola Marce,

Mira a ver si te vale el kernel realtime del ppa de Abogani.

sudo add-apt repository ppa:abogani/ppa
sudo apt-get update
sudo apt-get install linux-realtime
sudo update-grub

Es un 2.6.33, a ver si te funciona.

Saludos, Pablo
Subir
#21 por marcelo el 29/07/2010
hola Pablo

1) agregué el repositorio de Abogani y bajé e instalé el kernel 2.6.33.26 realtime pero no arrancaba, luego instalé el kernel 2.6.31.11-rt y tampoco arrancó, luego instalé el kernel 2.6.31.10-rt y arrancó tirando fuego por el caño de escape !!!!! hasta incluyó como modulo al ultimo driver de nvidia (256_35) que había instalado con anterioridad !!! -> mas no puedo pedir

2) esto no termina aquí: pude modificar el script rtirq siguiendo los pasos que indicas en "Semicorchux". Resultado: el trio divino (jack-Rosegarden-Qsynth) suena como los dioses sin xruns a la vista (uno solo que es el que se hace notorio cuando se abre Qsynth) no sabes que alegría ver-oír guapear a Rosegarden arpegios en semifusas (piano) / 3 violines en semicorcheas /corno ingles y trompeta SIN UN SOLO XRUN !!!!! -> por supuesto que cuando termine lo que estoy haciendo te lo mando con dedicatoria y todo (mira que la vengo yutando hace tiempo y no daba pie con bola)

3) muchas gracias por tu ayuda desinteresada Pablo, sinceramente muchas gracias.

Marcelo

Subir
#22 por Pablo_F el 01/08/2010
:)
Subir
#23 por fernaess el 09/10/2012
Hola amigos, necesito que me ayuden con Rosegarden. Mi roblema es que debido a que no tengo Linux, me descargué una versión especial para windows y el conector Jack también. Cuando instalé el Jack para windows 32 bits, en vez de mostrarse una ventana visual de la aplicación, algo amigable, con solapas o menues, se presentó una ventana en sistema DOS. Tal vez alguien que haya instalado Rosegarden para Windows haya solucionado este problema y me pueda ayudar al respecto. Si alguien tiene una idea, tambien se lo agradecería..
Subir
#24 por Pablo_F el 09/10/2012
¿No se ha instalado un archivo "qjackctl.exe"?
qjackctl es el interface gráfico de usuario para el control y puesta en marcha de jack.

Tienes que leer las instrucciones del archivo README para configurar jack desde el "Setup" de qjackctl.
En concreto, lo que pone bajo: QJACKCTL on Windows
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo