Configurar sonido en Ubuntu Studio 8.04

#1 por t3chnofilo el 28/04/2008
Bueno, abro este post para aquellas personas que se instalen la nueva versión y tengan problemas con el sonido. Sé perfectamente que bueno, esta sección está más dedicada al enterno de la producción y que estos problemas técnicos se deberian resolver en otros foros. Espero que no les moleste a aquellas personas.

Mi problema fue que al instalar los paquetes linux-restricted-modules y linux-headers de la versión del kernel nuevo me he quedado sin sonido.

Según he leído el nuevo kernel se carga los drivers de audio.

Así que los que estén configurando su sonido, vamos escribiendo aquí de lo que nos enteremos para poder configurarlo bien.

Un saludo a todos
Subir
#2 por Blask el 17/05/2008
Bueno, pues yo me lo instalé el miércoles, y tengo que decir que mi placa base es una Asus P5B Plus, cuya tarjeta de sonido integrada no funciona en Ubuntu. La utilizaba básicamente para el 5.1, supongo que pillaré alguna Sound Blaster X-Fi baratilla para eso.

Por otra parte, he conseguido reproducir audio (a grabar voy a probar ahora) con la Presonus Inspire, cosa que no sé si había conseguido en otras versiones anteriores, o recuerdo que me costó mucho más (lo único que me falta es decirle que cargue el módulo 'raw1394' al arranque para que la pille).

También me queda intentar instalar el teclado controlador MIDI M-Audio Radium 49 USB, y si lo consigo seré casi feliz :mrgreen:
Subir
#3 por Gaboni el 17/05/2008
Blask escribió:
También me queda intentar instalar el teclado controlador MIDI M-Audio Radium 49 USB, y si lo consigo seré casi feliz :mrgreen:


Yo tengo el M-Audio oxygen de 49 teclas... y bueno, fue conectarlo.. ¡Y tocar! :lol:
Subir
#4 por Blask el 17/05/2008
Pues qué suerte... Yo no soy capaz, a ver si alguien me echa una manita, explico lo que tengo hasta ahora:

- hago lsusb y veo que el sistema me reconoce el teclado:
[code]Bus 007 Device 001: ID 0000:0000
Bus 006 Device 001: ID 0000:0000
Bus 005 Device 002: ID 0763:1014 Midiman
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 002: ID 04fc:0538 Sunplus Technology Co., Ltd
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 002: ID 058f:6362 Alcor Micro Corp. Hi-Speed 21-in-1 Flash Card Reader/Writer (Internal/External)
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
[/code]

- he instalado el cargador de firmware para M-Audio, de ésta página: http://usb-midi-fw.sourceforge.net/

- sudo alsa reload devuelve lo siguiente:

[code]lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/eme/.gvfs
Output information may be incomplete.
Unloading ALSA sound driver modules: snd-seq-oss snd-seq-dummy snd-usb-lib snd-seq-midi snd-seq-midi-event snd-rawmidi snd-pcm-oss snd-pcm snd-page-alloc snd-mixer-oss snd-hwdep snd-seq snd-timer snd-seq-device.
Loading ALSA sound driver modules: snd-seq-oss snd-seq-dummy snd-usb-lib snd-seq-midi snd-seq-midi-event snd-rawmidi snd-pcm-oss snd-pcm snd-page-alloc snd-mixer-oss snd-hwdep snd-seq snd-timer snd-seq-device.
[/code]
Veo que se carga snd-usb-lib, que entiendo que será el sucesor de snd-usb-audio (módulo que no me deja instalar porque está "deprecated"). ¿Hay alguna manera de configurar ése módulo?

Estoy un poco perdido, como véis...
Subir
#5 por Blask el 20/05/2008
Sigo prácticamente igual en el tema del teclado... Si alguien me puede echar una mano se lo agradecería. La verdad es que no entiendo por qué no sale en las conexiones de JACK, porque todo lo demás lo hace bien:

dmesg:

[code][ 728.372280] usb 5-1: new full speed USB device using uhci_hcd and address 2
[ 728.508240] usb 5-1: configuration #1 chosen from 1 choice
[/code]

La cosa es la siguiente, el driver de audio que cargo para JACK es Freebob, para la Inspire. Por lo tanto en las conexiones del JackControl, en la pestaña MIDI no sale nada. Eso lo veo casi normal, porque la Inspire no tiene posibilidad de MIDI, pero supongo que en la pestaña ALSA me debería salir y lo único que aparece es el MIDI-Through, no tengo entradas ni salidas.

Supongo que me explico muy mal, pero son las 8 de la mañana y me acabo de despertar :mrgreen:
Subir
#6 por Blask el 20/05/2008
Continúo y doy más datos por si a alguien se le ocurre algo que pueda probar (aunque no estoy en casa ahora). Mi equipo:

- Asus P5B Plus
- Intel Core2Duo E6350
- 4Gb de RAM DDR2 800 (5 5 5 18)
- 400 Gb HD SATA + 160 Gb Hd IDE (que va a desaparecer en breve)
- NVidia GeForce 8600 GTS

He instalado Ubuntu Studio 8.04 en su versión AMD64, ¿puede que sea éste el origen de todos mis males?. Estoy pensando en instalar una versión de 32 bits para probar, lo que pasa es que no lo quiero sólo para audio, también para gráficos 3D con Blender, GiMP, etc... y ahí el rendimiento en 64 bits parece ser superior. Lo que podría hacer también es tener dos kernels, uno de 32 bits y otro de 64, si veo que el audio tira mejor en 32.
Subir
#7 por Blask el 21/05/2008
Os parecerá increíble... pero me he instalado el Ubuntu de 32 bits y tampoco me tira el Radium... :oops:
Subir
#8 por Blask el 23/05/2008
Bueno, pues al final lo he conseguido yo solito (cosa que no está mal, pero se echa de menos un poquito de feedback en éste sub-foro... :roll: )

Lo que ocurre es que ha sido mediante el fxload, que no viene con ubuntu, así que:
[code]sudo apt-get install fxload[/code]

Y después, con lsusb, podemos saber dónde se ha montado el teclado:

[code]...
Bus 006 Device 001: ID 0000:0000
Bus 005 Device 002: ID 0763:1014 Midiman
Bus 005 Device 001: ID 0000:0000
...[/code]

Ésto quiere decir que el M-Audio "está" en /dev/bus/usb/005/002, y nuestra instrucción fxload quedaría así:

[code]sudo fxload -D /dev/bus/usb/005/002 -I /ruta/donde/tengamos/archivo/MidiSportKS.ihx[/code]

Éste archivo viene con el cargador de firmware de http://usb-midi-fw.sourceforge.net/ (supongo que para otros fabricantes, habrá un archivo .ihx equivalente).

Lo malo es que cada vez que se conecta el teclado, le asigna una ruta /dev/bus... diferente, y hay que escribir el comando fxload. Creo que tendré que hacer una regla udev para ello.
Subir
#9 por Ismael Valladolid Torres el 23/05/2008
Blask, has quedado como un auténtico crack y mereces toda nuestra admiración.

Esta comunidad funciona así. Gente que simplemente protesta porque las cosas no funcionan la hay a patadas. Gente que se toma la molestia de investigar para resolver el problema y que después comparte la solución hay pocos.

¡Gracias!
Subir
#10 por Blask el 23/05/2008
Muchas gracias, ivalladt.

Creo que es lo que hay que hacer, compartir la solución, ya que si lo he conseguido no ha sido por inspiración divina, sino buscando mucho en foros, blogs, etc... Por lo tanto, si mi experiencia puede servirle a alguien como a mi me sirvió la de otros, pues ahí la dejo. Ojalá que sí :wink:
Subir
#11 por Ismael Valladolid Torres el 25/05/2008
Si no les vale tu solución en concreto, al menos tú ejemplo seguro que sí.
Subir
#12 por pirator el 03/06/2008
hola
no quiero crear un hilo con mi pregunta, asi que decidi hacerla acá, a ver si alguien me puede contestar
tengo el dvd de ubuntu studio, y quisiera saber si se puede ejecutar directamente del dvd, para probarlo, ya que soy nuevo con linux y no quiero dejarlo instalado en la pc por ahora, sino simplemente usarlo un poco para ver qué tal es.
si alguien me enseña cómo hacerlo, se lo agradecería.

saludos
Subir
#13 por Blask el 03/06/2008
Pues hasta donde yo sé, en el DVD de UbuntuStudio no se incluye un Live CD, por lo que creo que no podrías hacerlo. Lo que sí que podrías hacer, según creo, es bajarte un Live CD de Ubuntu Hardy 8.04 e instalar los paquetes de Ubuntu Studio mediante apt-get (hay un montón de info en la Red sobre cómo usar apt-get).

Eso sí, si eres nuevo en Linux, te recomiendo un par de cosas, en base a mi propia experiencia. Lo primero es que seas paciente, porque con toda probabilidad no te va a funcionar todo a la primera, y con algunas cosas te volverás bastante loco. Sobre todo si estás acostumbrado a un entorno Windows, cuyo funcionamiento en cosas muy básicas es totalmente diferente.

Lo siguiente que te recomendaría es que te prepares para leer un montón de documentación, manuales, tutoriales, etc, si quieres Ubuntu para algo más que navegar, ver el correo y utilizar el Pidgin (MSN). Ten siempre el Firefox abierto y acostúmbrate a buscar en Google, porque seguramente la mayoría de los problemas que tengas, los ha tenido otro antes, y quizá se le hayan solucionado.

Una vez que tengas un sistema que funcione bien, HAZTE UNA IMAGEN (un backup), o tendrás que recorrer de nuevo el mismo camino :wink: Y cuando tengas un backup, no tengas miedo de probar, enredar e investigar, que para eso tienes backup. Realmente, joder algo de manera irreversible, tampoco es tan fácil.
Subir
#14 por amando el 04/06/2008
Tengo un midisport 2x2 y me costo un poco hacerlo funcionar en el portatil, con Ubuntu HH y eso que en synaptic esta el paquete que lo hace funcionar, el caso es que de buenas a primeras se puso a funcionar sin problemas.
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo