Construir footswitch swr J202

cantabron
#1 por cantabron el 02/03/2019
Hola, estoy intentando hacerme un pedal de control para el amplificador SWR Workingpro 400 y, despues de conseguir los esquemas del ampli y las conexiones para el Din 5 solo he conseguido que funciones el on/off del intensificador, pero ni siquiera enciende el led. Ahora los he conectado en paralelo, asi que probare a poner el led en serie. De todos modos el mute no va, no se si sera porque el switch debe ser pdt, en vez de dpdt. Si alguien sabe orientarme lo agradeceria. Y si alguien tiene el pedal y puede enviarme una foto del interior seria MUY de agradecer. :)
Archivos adjuntos ( para descargar)
WorkingPro 400 & 700.pdf
Subir
pedrodeni
#2 por pedrodeni el 02/03/2019
De los 2 pines donde funciona el interruptor del BASS INT, uno de ellos es común a todas las otras funciones casi seguro, tenemos que averiguar cuál es. Así que yo probaría a activar en el frontal el MUTE y BASS INT (para que estén encendidos los leds) y probar con un led entre uno de los pines del interruptor que te funcionó y todos los demás que no sabes que son (mejor el led en serie con una resistencia de 330 o 470 para limitar la corriente por si acaso). Es posible que no sepas que los leds tienen polaridad, sólo encienden en un sentido, así que has de probar todos los pines con el led en un sentido y en otro.

Desde el momento en que el led te encienda, el lado común con el interruptor de bass int que te funcionaba ese es el pin común para todos (casi seguro).
Para encontrar el interruptor de mute, una vez que tengas los leds encontrados, prueba entre los pocos pin que quedan y el común.
Mejor encontrar los leds primero para que no hagas un corto con los interruptores en las salidas de leds (no sé si se podría joder algo)

PIN común.
PIN interruptor de MUTE
PIN led de MUTE
PIN interruptor de BASS INT
PIN led de BASS INT

Bueno, con esto puedes ir probando, suerte.
No me hago responsable si te cargas algo ;)
Subir
cantabron
#3 por cantabron el 02/03/2019
Gracias Pedrodeni. Efectivamente si que sabia que los led tienen polaridad, y tenia bastante claro que hay que meterle una resistencia si los pongo en serie, aunque no sabia de cuanto. Voy a ir haciendo pruebas, aunque la cosa es que el interruptor del intensificador si lo enciende y lo apaga, pero el de mute no, y son iguales y estan bien conectados (en teoria) por el esquema.
Archivos adjuntos ( para descargar)
din5conection.PNG
Subir
pedrodeni
#4 por pedrodeni el 02/03/2019
No había visto esa parte del esquema, gracias. La patilla 2 es G (ground/tierra) ese es el negativo, así que el cátodo del led va a ese pin.
¿Tienes claro si son pulsadores o interruptores?¿Puede ser eso?¿En el frontal tienen que estar activados los botones o desactivados para que se pueda activar/desactivar en el pedal?

Pulsador mantiene el cable unido mientras pulsas el botón.
Interruptor, cada vez que das cambia de estado, cable unido o separado.

Por lo que veo, tienes el interruptor o pulsador de BASS INT entre 3 y 2.

Lo demás debería estar así:
Debería funcionar un Pulsador/interruptor de mute entre 1 y 2.
LED MUTE debería conectarse el pin 2 (masa), a la resistencia, que va en serie con el cátodo del led y el ánodo del led al pin 4.
LED BASS INT debería conectarse el pin 2 (masa), a la resistencia, que va en serie con el cátodo del led y el ánodo del led al pin 5.

Seguro que ahora encuentras lo que falla, un saludo.

Pedro.
Subir
cantabron
#5 por cantabron el 02/03/2019
Hola otra vez Pedro. No, en el frontal no tienen que estar activados los botones para que el pedal funcione. Estoy usando dos pulsadores momentaneos, y solo funciona el intensificador, asi que igual es necesario usar interruptor para el mute.
Lo he conectado de la siguiente manera: 1 y 3 cada uno al positivo de los pulsadores, y en el comun el negativo de ambos y los catodos de los diodos led. El anodo de los led a 4 y 5 respectivamente, pero sin resistencias. Son led 9-12v, asi que supongo que aguantan los teoricos 15 volt que tiene el circuito.
Subir
pedrodeni
#6 por pedrodeni el 02/03/2019
los led normales rojos de toda la vida son de aprox 1,8v. Se pone una resistencia en serie para limitar la corriente y que no se queme (20mA creo que era la corriente típica).
https://www.inventable.eu/paginas/LedResCalculatorSp/LedResCalculatorSp.html
http://www.educachip.com/resistencia-led/

Con un pulsador momentáneo pulsado un rato puedes simular un interruptor.
Subir
cantabron
#7 por cantabron el 02/03/2019
Muchisimas gracias Pedro. Creo que ya solo queda hacer pruebas sin romper nada. Jejeje. A ver que sale
Subir
1
cantabron
#8 por cantabron el 05/03/2019
Bueno, al final he podido hacerme con un pedal swr original, asi que no tendre que terminar el que me estaba haciendo. Pero por si alguien llega aqui buscando lo mismo voy a subir fotos del original, para que lo tengan mas facil.
Archivos adjuntos ( para descargar)
IMG_20190305_171250.jpg
IMG_20190305_171349.jpg
IMG_20190305_171803.jpg
IMG_20190305_172041.jpg
IMG_20190305_172120.jpg
IMG_20190305_172150.jpg
Subir
1
Hilos similares
Respuesta rápida

Regístrate o para poder postear en este hilo