Jack y edirol ua 25

musikocabron
#1 por musikocabron el 28/12/2007
Hola, no consigo hacer funcionar jack con mi ua 25 alguien de aquí podría tomarse la molestia, de decir como hay que tener configurado la pestaña "Settings" en la configuración del jack.

En Alsa lo tengo bien configurado, pero no consigo arrankar jack.

Gracias
Subir
TheFlowerKing
#2 por TheFlowerKing el 01/01/2008
musikocabron escribió:
Hola, no consigo hacer funcionar jack con mi ua 25 alguien de aquí podría tomarse la molestia, de decir como hay que tener configurado la pestaña "Settings" en la configuración del jack.

En Alsa lo tengo bien configurado, pero no consigo arrankar jack.

Gracias


Qué traza te devuelve la ventana de log del qjackctl?

Yo tengo la ua25 configurada con un frames/period de 512, una frecuencia de muestreo de 48k y 3 periodos por buffer.

De todas maneras si nos dices que trazas devuelve jack al iniciar podremos afinar más

salud.
Subir
musikocabron
#3 por musikocabron el 05/01/2008
hola, te respondo.

El problema, son dos: que me saltan xrun y tengo latencia.

y lo chungo, es que, si configuro el servidor jack para que tenga mucha latencia,entonces no aparecen xrun y cuando configuro de tal modo que en la ventana de setting se ve un numero muy pequeño de latencia o en su defecto un numero suficientemente bajo como para no notar la latencia, salta un xrun de vez en cuando.

Te pediría lo siguiente: Si tu has conseguido tener el punto de configuración ajustado para no tener ni latencia ni xrun's al menos en un largo periodo de tiempo, te agradecería que, o bien me pones una captura de pantalla con el settings para ver como lo tienes configurado o bien me pones la configuración que tienes puesta:

Alsa lo tengo bien configurado, y se que si configure bien la pantalla de settings del servidor jack, el resto chutara, es decir el ardour y demás.

Gracias y me harías un favor si me pusieras tu configuración.
Subir
TheFlowerKing
#4 por TheFlowerKing el 05/01/2008
musikocabron escribió:
hola, te respondo.

El problema, son dos: que me saltan xrun y tengo latencia.

y lo chungo, es que, si configuro el servidor jack para que tenga mucha latencia,entonces no aparecen xrun y cuando configuro de tal modo que en la ventana de setting se ve un numero muy pequeño de latencia o en su defecto un numero suficientemente bajo como para no notar la latencia, salta un xrun de vez en cuando.

Te pediría lo siguiente: Si tu has conseguido tener el punto de configuración ajustado para no tener ni latencia ni xrun's al menos en un largo periodo de tiempo, te agradecería que, o bien me pones una captura de pantalla con el settings para ver como lo tienes configurado o bien me pones la configuración que tienes puesta:

Alsa lo tengo bien configurado, y se que si configure bien la pantalla de settings del servidor jack, el resto chutara, es decir el ardour y demás.

Gracias y me harías un favor si me pusieras tu configuración.


Perdona por no contestarte el privado pero estaba en el trabajo.

No puedo poner la captura porque no tengo donde subirla (ni photobuckets ni nada de eso), pero se me hace extraño que tengas tantos xrun's...

Te has asegurado de seleccionar la UA25 en input device y output device en lugar de la integrada que lleve tu máquina? En mi caso el portátil lleva una realtek que si la selecciono en vez de la UA25 me da un carro de XRUN's...

Segunda... qué kernel y distribución tienes? soporta realtime? Tienes el checkbox de Realtime marcado?

seguimos para bingo...

salud
Subir
musikocabron
#5 por musikocabron el 08/01/2008
Hola, te explico, tengo el kernel linux-image-2.6.22-3-686 tengo debian, tengo la opción de Realtime marcada pero mi kernel no es real time, pero no me da error ni nada, toque el archivo limits, me interesaría saber lo siguiente: ¿Tu no tienes ningún xrun y tampoco latencia? si fuera así, te pediria de forma amable que si me pusieses que opciones y valores tienes puestos en el settings de jack me harias un favor.

A la pregunta de ¿Tu no tienes ningun xrun y tampoco latencia?: haber si salta un xrun a la hora o a la media hora, o en un intervalo de 15 minutos, pues no pasa nada, pero el tema es que no me salte cada minuto por ejemplo y no tener latencia, gracias
Subir
TheFlowerKing
#6 por TheFlowerKing el 11/01/2008
Perdona por no haberte contestado...

Si tu kernel no es realtime no va a servir de nada que pongas esa opción al arrancar jack
Quizá lo primero que deberías hacer es mudarte a un kernel realtime...

Yo, por darte una cifra, igual tengo un xrun cada 15 minutos.

El resto de opciones, a parte de las que te dije, no van a tener un efecto determinante en que tengas más o menos xruns, ya que los parámetros fundamentales son el número de frames por periodo y el número de periodos por buffer.

de todas maneras te pongo mi configuración...

Priority:0
Frames/period: 512
Periods/buffer:3
Port maximum: 256
Timeout: 500
Dither: none
Audio: Duplex
Start delay:2
Input y Output latency:0

Todas las checkboxes de la izquierda demarcadas excepto la de realtime, que en tu caso no funcionará.

salut
Subir
musikocabron
#7 por musikocabron el 13/01/2008
Muchas gracias, probare la configuración mañana, haber que tal rula.
Subir
Hilos similares
Respuesta rápida

Regístrate o para poder postear en este hilo