Logic 7 en G3 beige

herrhafen
#1 por herrhafen el 28/04/2006
Hola a todos. Por todo el esfuerzo que me ha costado conseguirlo, considero que quizás mi experiencia pueda ser de utilidad para otros incautos que lo intenten a partir de ahora.

El reto era instalar el Logic 7 que uso en mi imac G5 en un G3 beige de 233 Mhz que he comprado en ebay por 10 €.

El ordenador venía con 128 mb de ram y un disco duro de 4 Gb.

El primer paso fue intentar configurar OS X. Tenía unos Cds del 10.3, que los intenté instalar a pelo varias veces con el resultado de que todo dejaba de funcionar. Al arrancar se quedaba la manzana gris sobre el fondo blanco y el cd dejaba de reconocer los discos. La única manera de salir de ahí era arrancando dede un disco externo conectado por SCSI. Este paso recomiendo no probarlo.

Investigando las causas leí que para hacer lo que yo intentaba era necesario utilizar un programa que se llama XPostFacto.

Lo que hice a continuación fue probar a instalar el 10.2, con los cds de un emac G4 que tenía por aquí. Esto sí que funcionó. Iba relativamente lento, pero mejor de lo que esperaba cuando lo instalé, la verdad. Una vez con el 10.2, actualicé desde el menú a 10.2.8, y a partir de entonces, todo dejó de funcionar de nuevo. En esta ocasión, tras el mínimo esfuerzo exigido a la máquina, el monitor se ponía en reposo y la única manera de volverlo a encender era reiniciando el ordenador. Repetí esta operación, borrando el disco duro, e instalando el 9.1 antes del OS X, y nada, lo mismo.

En uno de estos días, me hice con otro G3 de características parecidas, pero con 288 mb de ram y HD de 1Gb. Combiné las placas de memoria en el primer ordenador, sumando en total 320 (dos módulos de 128 y uno de 64), y monté los dos discos duros en el mismo.

Resultó que con 320 Mb de RAM todo cambió. El 10.2.8 iba perfectamente, y ya no se colgaba nunca. Pero...... Logic 7 necesita OS X 10.3!

Bien, pues empecé de nuevo:
- Borré el disco duro.
- Instalé OS 8.6
- Después 9.1
- Actualicé, primero a 9.2.1 y después a 9.2.2, con las actualizaciones de la página de Apple.
- Me bajé XPostFacto4, y lo ejecuté desde el disco duro, escogiendo como instalador el Cd1 del 10.3 que había intentado instalar anteriormente.

Hasta aquí todo bien, el instalador comienza, se elige el tipo de instalación y la aplicación comienza a funcionar. Terminó con el primer disco y me pidió el segundo. A mitad del proceso, de nuevo, el monitor se apagaba y había que reiniciar, así que no podía terminar. Lo intenté otra vez y lo mismo.

Finalmente, hice esta misma operación, pero configurando a medida mi propia instalación. Por ejemplo, no puse los drivers de las impresoras, los idiomas asiáticos, ni unas cuantas cosas. Prácticamente dejé la instalación mínima más el iTunes, QuickTime y poco más.

Pues no sé por qué, pero esto funcionó. La verdad es que al finalizar la instalación también se quedó negra la pantalla, pero después de reiniciar ya aparecía el asistente de configuración y todo iba bien. Por cierto, el 10.3 va más ágil incluso que el 10.2.

El último paso era instalar Logic 7, lo que ya no me ha supuesto ningún problema, y funciona perfectamente.

Fin de la historia.
No hay moraleja.
Subir
CLom
#2 por CLom el 06/06/2006
Hola, estaba pensando en hacer algo parecido. Yo tengo un G3 233Mhz 4Gigas en un Imac de los antiguos(esos de solo monitor verde)
Crees q podria hacer algo parecido? Es que parece muy poco ampliable el Imac, ya que tengo la posiblidad de quitarle la Ram a otro igual, crees q seria posible hacer algo parecido?
Eso si, tu paciencia me ha dejado de piedra tio....
Subir
herrhafen
#3 por herrhafen el 06/06/2006
Jajaja :lol:

Por eso, después de tanto esfuerzo pensé que valía la pena escribirlo... :wink:

Bueno, pues lo que comentas, supongo que no tendrás problema en hacerlo (bueno... como mucho los problemas que he tenido yo, jeje...). Lo que sí te recomiendo en cualquier caso es que lo tengas a tope de ram para meterle OSX. No entiendo muy bien las especificaciones que da Apple sobre el tema (http://support.apple.com/specs/imac/iMac.html), pero me imagino que al menos 256 podrás meterle.

Si quieres hacer funcionar el Logic 7, ten en cuenta que tendrás que instalar 10.3; mientras que por ejemplo, si pones el 6 te valdrá con el 10.2.8. En realidad no sé qué recomendarte, porque aunque el 10.3 gaste más ram, tengo la impresión de que anda algo más suelto el ordenador, y desde luego, creo que es un sistema más completo.

Bueno, ánimo y suerte con el asunto, y si puedo ayudarte en algo lo haré encantado.
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo