X

Hoy a las 19:00 No te pierdas el estreno de la nueva entrega de Conectados con Suso Ramallo

Me Ayudais a Instalar M-audio Midisport Uno Usb (1x1)

nukitron
#1 por nukitron el 05/08/2009
Saludos:

He utilizado durante años el cable MIDI/USB M-Audio MIDISPORT UNO USB (1x1) en Windows, pero ahora que me paso a linux quisiera hacerlo funcionar para conectar mi teclado al PC.

El cable en cuestión es éste:

Imagen no disponible

En esta página me indican la forma de cómo utilizarlo en linux :?

http://usb-midi-fw.sourceforge.net/

Según creo entender hay que actualizar el firmware del interface :!:

El cargador de firmware es éste: http://sourceforge.net/project/showfile ... e_id=92666
(Me he bajado la versión 1.2)

En el léame que trae indica los prerrequisitos:

- Linux kernel 2.6.x
- udev version 057 or later
- fxload (release dated 2002_04_11 or later)
(you can get fxload from )

El kernel OK
El fxload, lo he bajado con synaptic 0.020020411
udev, descargado también versión 141-1.2

Hasta ahora más o menos lo sigo. pero en la instalación me pierdo:

[code]Installing
----------

1) Run './configure'.
2) Run 'make'.
3) As root, run 'make install'.[/code]

Lo he intentado en el terminal pero no me funciona

Hago doble click en el archvio configure que viene en el paquete, pero tras indicarme que es un archivo de texto ejecutable y hacerlo ejecutar en el terminal no ocurre nada

La verdad es que estoy bastante perdido y sigo las instrucciones a ciegas...algún consejo?

Gracias y un saludo
Subir
monon
#2 por monon el 06/08/2009
Como compilar lo que sea??
(el simbolo de dolar es el de usuario normal)
Abres una terminal y ejecutas...
[code]
$ cd /ruta/al/directorio/con/el/codigo
$ ./configure[/code]
eso configurará para poder realizar el make con los parametros indicados o por defecto.

Despues ejecutas
[code]$ make[/code]
La salida será texto de lo que está construyendo en ese momento.
Tras el vómito, lo instalas con...
[code]$ sudo make install [/code]
Te pedirá la contraseña.
Subir
nukitron
#3 por nukitron el 05/09/2009
ok, mono...estoy ahora en el portátil...pero cuando me ponga en el Pc de sobremesa lo miro.

Gracias por tu ayuda.

Un saludo
Subir
Pablo_F
#4 por Pablo_F el 06/09/2009
Hola nuki, también necesitas el paquete 'build-essentials', que te instalará las herramientas básicas para compilar.
Si "./configure" te da algún error y make no funciona, pon aquí las últimas líneas de la salida de './configure'. "No funciona" es desesperante tanto para tí como para los que intentamos ayudar.

Si usas gnome como entorno gráfico de escritorio, 'nautilus-open-terminal' será mucho más cómodo para abrir terminales con el botón derecho y ya estás en el directorio donde lo has abierto (creo que necesitas reiniciar la sesión para que funcione la primera vez).

Hola monon :) ./configure, make, sudo make install no funciona para compilar cualquier cosa. Para la mayoría sí, pero para muchos programas no vale. Si se necesita compilar algo, se debería leer siempre el archivo README y normalmente también el archivo INSTALL que suele venir con el código fuente.

Saludos, Pablo.
Subir
guitman
#5 por guitman el 06/09/2009
nukitron

¿Qué distro estás usando? En ubuntu hago :

[code]apt-cache search midisport[/code]

y me devuelve

[code]midisport-firmware - Firmware loader for M-Audio's MidiSport devices[/code]

Así que un simple

[code]sudo apt-get -u install midisport-firmware[/code]

Dice esto:

[code]Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes extras:
fxload
Se instalarán los siguientes paquetes NUEVOS:
fxload midisport-firmware
0 actualizados, 2 se instalarán, 0 para eliminar y 2 no actualizados.
Necesito descargar 39,6kB de archivos.
Se utilizarán 242kB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? [/code]

Con decirle que sí ya está instalado.

Si todo esto te resulta complicado puedes buscar "midisport" en Synaptic , y si lo tienes no tendrías por qué comerte la olla con compilaciones (aumiendo que tienes ubuntu instalado)


Luego tendrás que aprender a cargar el firmware con el comando "fxload"
Si haces

[code]man fxload[/code]

Verás información de cómo usarlo y algunas cosas más.

Por otro lado, si lees el archivo "README", del paquete que te bajaste de sf.net , dice que al conectar el dispositivo se carga el firmware automáticamente, así que teóricamente no debería presentar más problemas.


A ver si te vale.
Subir
Hilos similares
Responder

Regístrate o para poder postear en este hilo