Salidas Midi multiples (problema)

Tecladista
#1 por Tecladista el 06/04/2008
Hola. Estoy tratando de solucionar algo en Logic Pro 8. Necesito asignar 3 intrumentos MIDI diferentes por medio de una Motu Micro lite. Con otros programas va bien, pero en logic se cambian todos los puertos al cambiar uno. Como decía necesito usar tres puertos de salida simultáneos y no me explico por qué se cambia todo.

Tiene que ver con el Enviornment ?

De antemano agradezco la ayuda.

Saludos desde El Salvador.
Subir
Javia
#2 por Javia el 13/04/2008
Saludos, eso te debe ocurrir porque debes de estar monitorizando las pistas midi hacia el objeto "general midi" (es un estandar que tienen todos los sintetizadores) en vez de a un "instrumento midi" y logic_amente al cambiar el canal midi de una pista se cambian todas. No necesitas usar tres puertos necesitas usar un puerto solo, el cual tiene 16 canales, el puerto midi equivale a la salida fisica de tu tarjeta o interface, por el cual salen 16 canales midi.
Subir
Miguel Lo Sasso
#3 por Miguel Lo Sasso el 26/01/2019
Hola! Estoy teniendo el mismo problema en logic pro x. Utilizo más de 16 canales y ocupo por tanto más de un puerto de mi interfaz midi..empleo canales MIDI EXTERNO. Sucede en ocasiones q al cambiarle el puerto a un canal se cambia automaticamente en otro..pero no es siempre así y no encuentro el patrón del fallo..no sé si es un bug de logic o un asunto de configuración. Has encontrado solución para esto? Saludos!
Subir
Jordi Torres mod
#4 por Jordi Torres el 26/01/2019
Hola,

Miguel Lo Sasso escribió:
Sucede en ocasiones q al cambiarle el puerto a un canal se cambia automaticamente en otro


Eso ocurre porque tus pistas están asignadas al mismo objeto multi-instrumento en el entorno. Al cambiar el puerto en los parámetros de pista del inspector, se lo estás cambiando al objeto directamente, y por eso afecta a todas las pistas asignadas a él.

Si quieres evitar que esto ocurra, asigna los puertos y canales desde la Librería.

Saludos,

J.
Subir
Miguel Lo Sasso
#5 por Miguel Lo Sasso el 27/01/2019
#4

Genio Jordi. Muchas gracias por tu respuesta! Entiendo, cuando asignás puerto y canal desde la librería crea un nuevo objeto en el entorno, ¿me equivoco? Voy a probar asignar de esta manera los canales y reporto resultados..

Saludos!
Subir
Jordi Torres mod
#6 por Jordi Torres el 27/01/2019
Hola,

Miguel Lo Sasso escribió:
Entiendo, cuando asignás puerto y canal desde la librería crea un nuevo objeto en el entorno,


Así es, a menos que el objeto ya esté creado claro.

Puedes ver lo que pasa si abres la ventana del Entorno MIDI y vas a la capa "MIDI Instr.".

Saludos,

J.
Subir
Hilos similares
Respuesta rápida

Regístrate o para poder postear en este hilo